Bitcoin Forum

Bitcoin => Bitcoin Technical Support => Topic started by: ender_x on April 13, 2010, 05:26:08 PM

Title: Crashing (solved)
Post by: ender_x on April 13, 2010, 05:26:08 PM
Unfortunately I've experienced crashing while I send transfers.. its happened twice so far.. both times it was after having been idle for many hours.. then I attempted to use the client to transfer. The first transfer was for 0.01.. it failed. but has removed from my total.  and sits in a perpetual state of 0/unconfirmed.
After it had crashed.. I brought the cilent back up.. and it showed -0.01.. and the recipient had not received it. so I immediately sent a second transfer just to make sure it was reproducible.. The second I made for 0.02 as to make it easily identifiable.. it succeeded.  I left the client alone for a day or so.. and had it "generating".
Then I made another transfer.. unfortunately I tried to transfer all of the funds.. and now they're all lost :-) awesome huh. It crashed in the same mannor. it Does display a message.. but I have not captured it. sorry.. When I get more funds I'll try and reproduce it, and capture the dialog.

I'm running Mandriva 2010.0 x86_64. all other transfers have gone great.. both offline recipients vs online.

$ ldd bitcoin
./bitcoin: /usr/lib/ no version information available (required by ./bitcoin)                                                                    =>  (0xffffe000)                                          => /usr/lib/ (0xf7585000)            => /usr/lib/ (0xf7177000)          => /usr/lib/ (0xf7171000)          => /usr/lib/ (0xf7167000)                            => /usr/lib/ (0xf7076000)                    => /lib/ (0xf704e000)                                  => /lib/ (0xf7031000)                          => /lib/ (0xf6ed0000)                                  => /lib/ (0xf6ecb000)                                => /usr/lib/ (0xf6e29000)          => /usr/lib/ (0xf6e24000)                => /usr/lib/ (0xf6e09000)    => /usr/lib/ (0xf6cd7000)                          => /usr/lib/ (0xf6c8f000)              => /usr/lib/ (0xf6c4d000)          => /usr/lib/ (0xf6b88000)                => /lib/ (0xf6b6e000)                      => /usr/lib/ (0xf6b43000) => /usr/lib/ (0xf6b37000) => /usr/lib/ (0xf6b31000) => /usr/lib/ (0xf6b13000) => /usr/lib/ (0xf6a93000) => /usr/lib/ (0xf69eb000) => /usr/lib/ (0xf69c1000) => /usr/lib/ (0xf698d000) => /usr/lib/ (0xf6988000) => /lib/ (0xf697d000) => /usr/lib/ (0xf6963000)
        /lib/ (0xf7738000) => /usr/lib/ (0xf6958000) => /usr/lib/ (0xf694f000) => /usr/lib/ (0xf6944000) => /usr/lib/ (0xf693f000) => /usr/lib/ (0xf692d000) => /usr/lib/ (0xf6929000) => /usr/lib/ (0xf691f000) => /usr/lib/ (0xf6901000) => /lib/ (0xf68d1000) => /lib/ (0xf68be000) => /usr/lib/ (0xf683c000) => /usr/lib/ (0xf67d3000) => /lib/ (0xf67bd000) => /usr/lib/ (0xf667b000) => /usr/lib/ (0xf6677000) => /usr/lib/ (0xf6670000)

Any ideas on capturing my limbo coins? Also ideas on preventing failed transfers in the future?

Title: Re: Crashing
Post by: Link2VoIP on April 13, 2010, 06:11:58 PM
Which version are you running? 0.2 or a snapshot?

Oh, and " no version information available (required by ./bitcoin)" is worrisome.

Title: Re: Crashing
Post by: ender_x on April 13, 2010, 07:03:51 PM
I'm running 0.2.0 binarys.
I was unable to compile svn trunk with my distro.

Anyways looks like I didnt search for my question in the forums.. Sorry!!

For those who are interested: