Bitcoin Forum

Bitcoin => Bitcoin Technical Support => Topic started by: Karmicads on June 02, 2011, 10:24:49 AM

Title: HELP!! what a mess (Need help recovering/restoring my wallet).
Post by: Karmicads on June 02, 2011, 10:24:49 AM

Hi all, Well I have gotten myself into a bit of a mess, and a bit of a catch 22 situation.

I started playing with bitcoin about a year ago (back in v. 0.2. days). I've been caught up in other worlds since, but until the GPU miners started to take hold, I managed to mine 450 BTC on my CPU over a bit over a month on my CPU alone. I think I had a problem with my OS after a power outage and never got bitcoin set up again for one reason or another, until a few months ago. Unfortunately by then there was no joy to be had, mining with a measly CPU. I spent some of my coins though, on a months worth of VPN connection (which I never really made good use of) Anyhow I checked back again a couple of weeks ago only to find the price of bitcoins going through the roof. Seems that my months worth of CPU mining is growing toward $4,000 USD WOW!  :o

Anyhow I no sooner learned of this and had intended to do a full (and careful) upgrade to the latest client, before my mother board gave up the digital ghost. That's were the real problem begins. As Linux users may be aware, it can be very forgiving on some hardware problems even changing drives to a completely different machine can work, but not for me. Not this time. Grub wouldn't take to the new (slightly downgraded board) To complicate this, I had two drives with the root partition on one, and the /home directory on another. I just couldn't boot into my old distro. I chose to make some space on a new partition and set about installing something else.

I had a super security packed Fedora distro, which I tried out and a futzy cloud based consumer oriented Ubuntu distro called Joli. I have both of these installed. The beauty of the Joli distro is that it finds all your other grub installs and includes them automatically on it's boot menu. The down side is that it makes it like hell to get proper administrative privileges and access to you own machine for say copying files as root (if it's actually possible at all). But at least I can try different parameters at the grub prompt. The fedora one is better to administer but I found that after installing the latest bitcoin client, it is giving me a segmentation fault error when I try to load it with the the wallet.dat file which (I believe) is the one from my old distro. I did try clearing out the whole lot except the wallet.dat, starting with restore etc...etc.. I've spent over a week pouring over the docs and problems here on the forum, but I'm getting nowhere fast. I cant start the old client on a new system and the new wont take my old wallet.

I have that many copies of various wallets and have tried that many things now, I am loosing track of where I am and what I've done. So I will offer 20 BTC bounty to the linux guru who can help me fix this mess and get access to the wallet which (I believe) is the one that has my BTC booty stored in it, as I need to do a transaction to cement a business deal and those coins will come in very handy. Thanks in advance for any advice/help too.


Title: Re: HELP!! what a mess (Need help recovering/restoring my wallet).
Post by: SomeoneWeird on June 02, 2011, 10:34:24 AM
PM me, I can help.