Bitcoin Forum

Other => Beginners & Help => Topic started by: zhangweiwu on April 13, 2013, 02:41:22 PM



Title: poclbm "failed to subscribe", mining solo
Post by: zhangweiwu on April 13, 2013, 02:41:22 PM
Hello

When I run poclbm, I get

localhost:8332 07/04/2013 19:45:02, Failed to subscribe                        
localhost:8332 07/04/2013 19:45:04, IO errors - 1, tolerance 2

Full commandline and output is at the end of this message.

What I have checked

- bitcoin-qt is running in server-mode (version 4.8.3)
- device is supported. poclbm can identify my Radeon HD5800 as "AMD Phenom(tm) II X4 945 Processor"
- netstat(8) shows bitcoin-qt is listening to localhost:8332 (it's apparent, because if it doesn't, I should get 'Connection refused' insteead of 'Failed to subscribe')
- all python components are installed, including opencl, serial, numpy ...
- poclbm is the latest, in fact, git cloned from https://github.com/Kiv/poclbm just a few hours ago.
- fglrx and AMDAPP-sdk installed. poclbm didn't complain about them.
- also tried using bitcoind instead of bitcoin-qt (version 0.8.1)
- password and username are of course checked for correctness, verified by accessing http://localhost:8332/ with a web browser, which says
Code:
{"result":null,"error":{"code":-32700,"message":"Parse error"},"id":null}

So is there anything I missed to check? What could be the problem?
Code:
$ python2.7 poclbm.py -d 1 un:pw@localhost:8332

WARNING: no adl3 module found (github.com/mjmvisser/adl3), temperature control is disabled

 13/04/2013 22:30:55, started OpenCL miner on platform 0, device 1 (AMD Phenom(tm) II X4 945 Processor)
 13/04/2013 22:30:55, Setting server (un @ localhost:8332)                      
localhost:8332 13/04/2013 22:31:05, Failed to subscribe                        
localhost:8332 13/04/2013 22:31:07, IO errors - 1, tolerance 2                  
localhost:8332 13/04/2013 22:31:17, Failed to subscribe                        
localhost:8332 13/04/2013 22:31:19, IO errors - 2, tolerance 2                  
localhost:8332 13/04/2013 22:31:29, Failed to subscribe                        
localhost:8332 13/04/2013 22:31:31, IO errors - 3, tolerance 2                  
localhost:8332 13/04/2013 22:31:31, No more backup servers left. Using primary and starting over.
localhost:8332 13/04/2013 22:31:31, Setting server (un @ localhost:8332)        
localhost:8332 13/04/2013 22:31:41, Failed to subscribe                        
localhost:8332 13/04/2013 22:31:43, IO errors - 1, tolerance 2                  
localhost:8332 13/04/2013 22:31:53, Failed to subscribe                        
localhost:8332 13/04/2013 22:31:55, IO errors - 2, tolerance 2                  
localhost:8332 13/04/2013 22:32:05, Failed to subscribe                        
localhost:8332 13/04/2013 22:32:07, IO errors - 3, tolerance 2                  
localhost:8332 13/04/2013 22:32:07, No more backup servers left. Using primary and starting over.
localhost:8332 13/04/2013 22:32:07, Setting server (un @ localhost:8332)        
localhost:8332 13/04/2013 22:32:17, Failed to subscribe                        
localhost:8332 13/04/2013 22:32:19, IO errors - 1, tolerance 2                  
localhost:8332 13/04/2013 22:32:29, Failed to subscribe                        
localhost:8332 13/04/2013 22:32:31, IO errors - 2, tolerance 2                  
localhost:8332 13/04/2013 22:32:41, Failed to subscribe                        
localhost:8332 13/04/2013 22:32:43, IO errors - 3, tolerance 2


Title: Re: poclbm "failed to subscribe", mining solo
Post by: tim_s_uk on June 07, 2013, 07:03:39 AM
I was getting this behaviour when running poclbm without "http://" before the server, i.e.
Code:
python.exe poclbm.py user:password@server:8332

Adding the "http://" prefix fixed things:
Code:
python.exe poclbm.py http://user:password@server:8332