Bitcoin Forum

Other => CPU/GPU Bitcoin mining hardware => Topic started by: BTC_Junkie on July 12, 2011, 05:35:25 PM

Title: Bricked 5870
Post by: BTC_Junkie on July 12, 2011, 05:35:25 PM
So, I accidentally loaded my 6970's Bios onto my 5870.  I never backed up the 5870 (Diamond reference) Bios, and I spent hours trying to reflash it.  I use Ubuntu 11.04, and was using a DOS booting USB drive to atiflash the bios.  Atiflash no longer recognizes the 5870 when another card is plugged in as the main.  Using -i it only shows the 1 working card, and using -p 1 it says there is nothing available.  I tried blind flashing the ati stock bios, as well as Diamond and Asus versions with no luck (I couldn't see but I suspect I'm getting the same error using -p0 when blind that shows up with -p 1, no card available).

Is there another way I can get the system to at least acknowledge that the 5870 is plugged into the PCI-e port?  The fan is spinning, and there wasn't a burning smell or anything so I suspect the hardware is undamaged.  Definitely never making this mistake again.

Title: Re: Bricked 5870
Post by: KKAtan on July 12, 2011, 06:42:29 PM
If I recall, I seem to have bumped into a similar issue, although not exactly the same as you. But I solved it by booting into a windows installation with no AMD drivers installed at all, maybe it will work in linux too.

Title: Re: Bricked 5870
Post by: Jen4538 on July 14, 2011, 01:35:05 AM
i used a matx board with onboard video to save a video card that was a bad bios flash


Title: Re: Bricked 5870
Post by: badfrog on July 14, 2011, 08:01:55 PM
You can Download 5870 Bioses in the Internet.
Have a Look Here :

Good Luck in finding the right one.

Greetings, Frog

Title: Re: Bricked 5870
Post by: steelhouse on July 17, 2011, 07:56:32 AM

Title: Re: Bricked 5870
Post by: haploid23 on July 18, 2011, 08:50:47 AM
like Jen said, try using a mobo with onboard video, and only put that bricked 5870 in there to flash it.