Bitcoin Forum
September 27, 2022, 05:22:08 PM *
News: Latest Bitcoin Core release: 23.0 [Torrent]
  Home Help Search Login Register More  
  Show Posts
Pages: [1]
1  Alternate cryptocurrencies / Mining (Altcoins) / Bitmain Antminer E3 (SD Card Flashing / Firmware Upgrade Details) on: February 03, 2019, 12:54:12 AM
After hours & hours of trying to get the SD card flash to work on the E3 I finally found a solution that worked (for me). This may work on non-E3 Bitmain asics, but YMMV

Original Instructions:

Note: These aren't the steps to perform, this is just more details & specifics about what's going on that Bitmain's instructions left out.

1. The Antminer E3 is super picky on which SD card you are using (2/3 of my 8gb cards were no good - Samsung worked). If you turn the power on with the SD card in (and jumper moved) and the front green & red LED lights are solid, most likely it doesn't like your card - try a different one.

2. Windows 7 / 10 was a problem (again for me - I'm sure people have got this to work in Windows). After countless formats between Windows 7 & Windows 10, I fired up a live CD of Fedora Linux, installed & ran gparted (you could just download a live cd of ( to do the same), removed all partitions and formatted to fat32.

3. Inside the you need to copy the contents to the root of the SD card.

4. Once you have a supported card and files in the right place, once you power on the miner the green & red LEDs on the front of your control board (by the Ethernet port) will be off for about 10 seconds. They will blink once, then go back off. After another 10 ~ 20 seconds they will continuously blink to tell you the copy process to the main board has completed. At this point, power the miner down, take out the SD card and move the jumper back.

Let me know if this helps, I wasted a ton of time with their shoddy ass instructions. Their support just sends you in circles.
2  Other / Beginners & Help / Xubuntu Headless Miner *unable to open display* SOLVED on: May 10, 2013, 05:08:20 PM
Are you stuck with the dreaded
xhost:  unable to open display ":0"
when trying to run cgminer / bfgminer on a headless machine?

After banging my head against the wall for a few hours I figured this out and decided to try and pass the knowledge onto anyone else that may be having a difficult time.

My goal was to have a completely headless setup which means:
Start the pc with no monitor, keyboard, or mouse plugged in whatsoever and be able to mine.

I followed both Xubuntu guides to get bfgminer and the ati drivers installed & enabled (more from the 12.10 one because that had the bfgminer instructions):

"Installed - Xubuntu 13.04, Raring Ringtail"


The instructions assume you aren't headless. The command that makes it all possible is 'xhost +'. The problem is 'xhost +' from a headless machine gives you something similar to the following (even as root):

    miner@rig:~$ export DISPLAY=:0
    miner@rig:~$ xhost +
    xhost:  unable to open display ":0"
    miner@rig:~$ sudo aticonfig --adapter=all --odgt
    ERROR - X needs to be running to perform AMD Overdrive(TM) commands

    miner@rig:~$ cgminer -n
     [2013-04-18 14:16:18] CL Platform 0 vendor: Advanced Micro Devices, Inc.                    
     [2013-04-18 14:16:18] CL Platform 0 name: AMD Accelerated Parallel Processing                    
     [2013-04-18 14:16:18] CL Platform 0 version: OpenCL 1.2 AMD-APP (1016.4)                    
     [2013-04-18 14:16:18] Error -1: Getting Device IDs (num)                    
     [2013-04-18 14:16:18] clDevicesNum returned error, no GPUs usable                    
     [2013-04-18 14:16:18] 0 GPU devices max detected

But if you run
netstat -l
you can clearly see that X is running.

What you will need to do is:

1. Install x11vnc
sudo apt-get install x11vnc

2. Create a password to connect
sudo x11vnc -storepasswd /etc/x11vnc.pass

3. Start it on ":0" referencing your magic cookie
sudo /usr/bin/x11vnc -auth /var/run/lightdm/root/:0 -noxrecord -noxfixes -noxdamage -rfbauth /etc/x11vnc.pass -forever -bg -rfbport 5900 -o /tmp/x11vnc.log -display :0

4. Connect to your headless machine via VNC on port 5900 (example using realvnc:

5. Open a terminal via the VNC session and type:
xhost +

6. Either connect via ssh and try to run your miner or try to start it via the VNC session.


If the x11vnc password is giving your problems you can skip step 2 and run this in step 3 (to connect insecurely with no password)
sudo /usr/bin/x11vnc -auth /var/run/lightdm/root/:0 -noxrecord -noxfixes -noxdamage -forever -bg -rfbport 5900 -o /tmp/x11vnc.log -display :0

If you are having issues connecting via VNC, you can try the following (although I only used it with tightvncserver):

Edit using vi or pico, etc:


Comment out:

Add the following to the end of the file:

exec startxfce4

Close & save the file, then issue the following command:

sudo coldreboot

Please donate LTC if this helped :-) @ LTgWjHtzgkLiXSDDBFdh8XwWJw3x6Hv5qu
Pages: [1]
Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2006-2009, Simple Machines Valid XHTML 1.0! Valid CSS!