Bitcoin Forum
July 02, 2022, 10:39:43 PM *
News: Latest Bitcoin Core release: 23.0 [Torrent]
 
  Home Help Search Login Register More  
  Show Posts
Pages: [1]
1  Bitcoin / Bitcoin Discussion / Reddit story - upvotes needed! on: January 22, 2011, 06:20:50 PM
A reddit submission was made for the recent EFF article, it needs upvotes to get more eyes.

http://www.reddit.com/r/reddit.com/comments/f67zd/eff_deeplinks_blog_bitcoin_a_step_toward

If you don't have a reddit account, it is very easy to get one, you don't even need to email confirm.
2  Bitcoin / Development & Technical Discussion / Needed: calling db4.8 testers! on: January 07, 2011, 05:33:09 PM
The distributed binary of bitcoin is compiled against libdb4.7++. However, compiling it against libdb4.8++ seems to work fine,  at least in my tests on Debian. It seems that the FreeBSD people are also compiling against 4.8 (at least according to http://bitcointalk.org/index.php?topic=379.0), and I think it would be a worthwhile pursuit to find out if others are able to use this newer format.

If you are willing to test, I'm interested in hearing what your results are. If you are, you should be *very careful* with your wallet, because hey that is your money. Backup your wallet before you mess around. If you don't know how to backup your wallet, you shouldn't be testing. Verify your wallet is backed up, if you don't know how to verify your wallet is backed up, you shouldn't be testing.

Now that you have verified your wallet is backed up, stop bitcoind, install libdb4.8++ and compile the bitcoin binary against it instead of 4.7. Make sure you aren't linking against 4.7 in the process. Then launch bitcoind and verify that things are working. The upgrade to 4.8 will automatically upgrade your database files to the new format and you should notice no difference in operation.

One issue with moving to 4.8 is that although going back to 4.7 is possible, it may be risky, so making sure you have a backup is important. To go back to 4.7, you just need to stop bitcoind and then delete .bitcoin/database/* and then start up the version compiled against 4.7.

Maybe you are using libdb4.8 already? If so, please post here which operatingsystem you are using.
Pages: [1]
Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2006-2009, Simple Machines Valid XHTML 1.0! Valid CSS!