Bitcoin Forum
March 22, 2023, 03:34:52 AM *
News: Latest Bitcoin Core release: 24.0.1 [Torrent]
 
  Home Help Search Login Register More  
  Show Posts
Pages: [1] 2 »
1  Alternate cryptocurrencies / Mining (Altcoins) / Re: [ANN] TeamRedMiner 0.5.1 - Cryptonight Thread - High hashrate, Low Power on: June 11, 2019, 11:24:23 AM
What tool are you using to set compute mode?
It's not recent, but still works
https://bitcointalk.org/index.php?topic=2815803.0

(this doesn't apply to cards with HBM2)

Thank you for the link! I can't believe it never came up before.
2  Alternate cryptocurrencies / Mining (Altcoins) / Re: [ANN] TeamRedMiner 0.5.1 - Cryptonight Thread - High hashrate, Low Power on: June 10, 2019, 08:07:36 PM
What tool are you using to set compute mode?
3  Alternate cryptocurrencies / Mining (Altcoins) / Re: AMD Mem Tweak - Read/modify mem timings on the fly - [Vega Friendly] [Win/Linux] on: May 25, 2019, 05:30:08 PM
Hello, thanks for great app!
I use gui version.
I created profile with timings and overclock settings and I want to load and apply this profile at system startup. But I not find command line for it.
I would be very grateful if you could add this feature to the next release.

Why not use the command line version for that?
4  Alternate cryptocurrencies / Mining (Altcoins) / Re: AMD Mem Tweak - Read/modify mem timings on the fly - [Vega Friendly] [Win/Linux] on: May 23, 2019, 07:41:40 PM
Anyone has any idea about what could be causing this?

I have already verified it isn't driver related and most of the times I get zeros from all cards. Some times it will work normally, some times I will only get readings from some cards, as in the log below.

Needless to say I can't set any timings for the cards not giving proper readings.

Code:
GPU 1:  Vega 10 XL/XT [Radeon RX Vega 56/64]    Memory state: 0x0 (unknown)
Timing 1          CL: 0   RAS: 0          RCDRD: 0        RCDWR: 0
Timing 2          RCAb (RC): 0    RCPb (RC): 0    RPAb (RP): 0    RPPb (RP): 0
Timing 3          RRDS: 0         RRDL: 0         RTP: 0
Timing 4          FAW: 0
Timing 5          CWL: 0          WTRS: 0         WTRL: 0
Timing 6          WR: 0
Timing 7          RREFD: 0
Timing 8          RDRDDD: 0       RDRDSD: 0       RDRDSC: 0       RDRDSCL: 0
Timing 9          WRWRDD: 0       WRWRSD: 0       WRWRSC: 0       WRWRSCL: 0
Timing 10         WRRD: 0         RDWR: 0
Timing 12         REF: 0
Timing 13         MRD: 0          MOD: 0
Timing 14         XS: 0
Timing 16         XSMRS: 0
Timing 17         PD: 0   CKSRE: 0        CKSRX: 0
Timing 20         RFCPB: 0        STAG: 0
Timing 21         XP: 0   CPDED: 0        CKE: 0
Timing 22         RDDATA: 0       WRLAT: 0        RDLAT: 0        WRDATA: 0
Timing 23         CKESTAG: 0
RFC Timing        RFC: 0

GPU 2:  Vega 10 XL/XT [Radeon RX Vega 56/64]    Memory state: 0x0 (unknown)
Timing 1          CL: 0   RAS: 0          RCDRD: 0        RCDWR: 0
Timing 2          RCAb (RC): 0    RCPb (RC): 0    RPAb (RP): 0    RPPb (RP): 0
Timing 3          RRDS: 0         RRDL: 0         RTP: 0
Timing 4          FAW: 0
Timing 5          CWL: 0          WTRS: 0         WTRL: 0
Timing 6          WR: 0
Timing 7          RREFD: 0
Timing 8          RDRDDD: 0       RDRDSD: 0       RDRDSC: 0       RDRDSCL: 0
Timing 9          WRWRDD: 0       WRWRSD: 0       WRWRSC: 0       WRWRSCL: 0
Timing 10         WRRD: 0         RDWR: 0
Timing 12         REF: 0
Timing 13         MRD: 0          MOD: 0
Timing 14         XS: 0
Timing 16         XSMRS: 0
Timing 17         PD: 0   CKSRE: 0        CKSRX: 0
Timing 20         RFCPB: 0        STAG: 0
Timing 21         XP: 0   CPDED: 0        CKE: 0
Timing 22         RDDATA: 0       WRLAT: 0        RDLAT: 0        WRDATA: 0
Timing 23         CKESTAG: 0
RFC Timing        RFC: 0

GPU 3:  Vega 10 XL/XT [Radeon RX Vega 56/64]    Memory state: 0x118 (800MHz)
Timing 1          CL: 17          RAS: 27         RCDRD: 13       RCDWR: 8
Timing 2          RCAb (RC): 39   RCPb (RC): 39   RPAb (RP): 12   RPPb (RP): 12
Timing 3          RRDS: 4         RRDL: 5         RTP: 5
Timing 4          FAW: 13
Timing 5          CWL: 6          WTRS: 3         WTRL: 7
Timing 6          WR: 13
Timing 7          RREFD: 7
Timing 8          RDRDDD: 3       RDRDSD: 2       RDRDSC: 1       RDRDSCL: 3
Timing 9          WRWRDD: 3       WRWRSD: 2       WRWRSC: 1       WRWRSCL: 3
Timing 10         WRRD: 1         RDWR: 17
Timing 12         REF: 3120
Timing 13         MRD: 8          MOD: 12
Timing 14         XS: 216
Timing 16         XSMRS: 6
Timing 17         PD: 6   CKSRE: 8        CKSRX: 8
Timing 20         RFCPB: 128      STAG: 7
Timing 21         XP: 6   CPDED: 2        CKE: 6
Timing 22         RDDATA: 16      WRLAT: 4        RDLAT: 14       WRDATA: 1
Timing 23         CKESTAG: 2
RFC Timing        RFC: 208

GPU 4:  Vega 10 XL/XT [Radeon RX Vega 56/64]    Memory state: 0x118 (800MHz)
Timing 1          CL: 17          RAS: 27         RCDRD: 13       RCDWR: 8
Timing 2          RCAb (RC): 39   RCPb (RC): 39   RPAb (RP): 12   RPPb (RP): 12
Timing 3          RRDS: 4         RRDL: 5         RTP: 5
Timing 4          FAW: 13
Timing 5          CWL: 6          WTRS: 3         WTRL: 7
Timing 6          WR: 13
Timing 7          RREFD: 7
Timing 8          RDRDDD: 3       RDRDSD: 2       RDRDSC: 1       RDRDSCL: 3
Timing 9          WRWRDD: 3       WRWRSD: 2       WRWRSC: 1       WRWRSCL: 3
Timing 10         WRRD: 1         RDWR: 17
Timing 12         REF: 3120
Timing 13         MRD: 8          MOD: 12
Timing 14         XS: 216
Timing 16         XSMRS: 6
Timing 17         PD: 6   CKSRE: 8        CKSRX: 8
Timing 20         RFCPB: 128      STAG: 7
Timing 21         XP: 6   CPDED: 2        CKE: 6
Timing 22         RDDATA: 16      WRLAT: 4        RDLAT: 14       WRDATA: 1
Timing 23         CKESTAG: 2
RFC Timing        RFC: 208

No change on that front, not sure if it should make any difference but I did try beta 5 and 6 and the latest cli. Beta 5 did seem to make a difference at first but went back to same behavior after a restart.
5  Alternate cryptocurrencies / Mining (Altcoins) / Re: AMD Mem Tweak - Read/modify mem timings on the fly - [Vega Friendly] [Win/Linux] on: May 22, 2019, 12:50:05 AM
Hello, is anyone having an issue where the last GPU of a multi-GPU rig does not get the mem tweak applied? On 3 out of my 4 rigs (6 Vega64s per rig), the last GPU does not get the tweak applied to it. Iím using CLI (last version) on Win10.

Double-check you enumerate your GPUs correctly. I know it sounds like a silly suggestion, but you know... been there, done that.

If the onboard GPU is anything AMD, it gets listed too (usually GPU0).  

I hear ya, made plenty of stupid mistakes myself. But yeah, TRM miner shows the bus number and changes I make to the other GPUs do take effect. Iím wondering if itís because Iím using CLI and the - -i parameter and itís not reading the last GPU in the parameter setting?

You don't happen to start TRM with a -d in config?
6  Alternate cryptocurrencies / Mining (Altcoins) / Re: AMD Mem Tweak - Read/modify mem timings on the fly - [Vega Friendly] [Win/Linux] on: May 21, 2019, 09:52:21 PM
Hello, is anyone having an issue where the last GPU of a multi-GPU rig does not get the mem tweak applied? On 3 out of my 4 rigs (6 Vega64s per rig), the last GPU does not get the tweak applied to it. Iím using CLI (last version) on Win10.

Double-check you enumerate your GPUs correctly. I know it sounds like a silly suggestion, but you know... been there, done that.

If the onboard GPU is anything AMD, it gets listed too (usually GPU0).  
7  Alternate cryptocurrencies / Mining (Altcoins) / Re: AMD Mem Tweak - Read/modify mem timings on the fly - [Vega Friendly] [Win/Linux] on: May 15, 2019, 10:44:10 AM
Hello all,

I noted in an earlier post issue running the CLI via a batch file, sadly I have the same issue - has anyone come across this (seemingly basic Windows/Authentication issue) before? in that post the admin rights were applied to a batch file that would then run the batch file with correct access privs.

Batch File Usage Issue
Problem - unable to launch the CLI via batch file via a simple batch file in the start-up folder (current up to date patched Win 10 build)
Workaround - manually launching the batch file works, settings applied and CLI/GUI work as expected. I am able to use CMD to edit/tweak/test and run the batch file manually but not the start-up - all other miners/use of start-up has never failed until now Sad

Straps Issue
Straps when viewed from a Polaris BIOS are displayed correctly/setup and strap working correctly it would seem but less 200 H/s  GUI displays the default settings (even under load/running the miner) stumped by this as when I manually re-apply the same settings on the strap and re-run the CLI/GUI tool the correct settings are applied (over the BIOS strap defaults) - very strange - strap when viewed in R_ encoded and re-added - again same issue. (straps on the bios have the edited tweaks but are not working unless the GUI tool/CLI tool re-adds them - stumped lol

So GUI not reporting the settings as they are on the strap on the modded BIOS (just the default) not on all Polaris, but on a mining 470 (tried all 4 BIOS switches - same) otherwise when I edit the strap, apply - they work / as expected


Thanks all

For your first issue, right click the .exe, go to properties, compatibility, tick the "always run as admin". You still need to disable UAC I guess, alternatively you could use task scheduler to run as admin at logon or each boot.

Can't help much with your second issue I'm afraid, hopefully someone else will though.
8  Alternate cryptocurrencies / Mining (Altcoins) / Re: AMD Mem Tweak - Read/modify mem timings on the fly - [Vega Friendly] [Win/Linux] on: May 14, 2019, 08:39:05 PM
Thank you both for the suggestions.

Zorg33, I checked the files and they seemed alright (date, size, everything). I still went ahead and copied the file from C:\AMD just to make sure, still no change I'm afraid. I also uninstalled everything w/DDU, double-checked the files were deleted and installed the driver again. Again, no change.

naska21, could you elaborate a bit? The system is running fine, mining for days non-stop, I just can't make AMD Memory Tweak work for whatever reason. I could be missing something of course.

edit: forgot to mention, no conflicts in device manager.

Oh, I thought you have faced  the spontaneous loss of working cards in your rig but if they all  are non-stop running then everything is OK  with IRQ sharing. Sorry for misunderstanding. As to memory tweaks, I've never known such a situation. Arguably you have quite a bunch of cards attached to motherboard.

No worries, thank you for the input regardless. It's a weird issue really, and way too random to try and make any sense of it. One day I think it must be hardware related, next day I wonder how can it work when it does. It's only four cards BTW, maybe I still need to try and remove them one by one when I get a chance, just to make sure. An option to ignore the onboard GPU would be nice too.. Eliovp Wink
9  Alternate cryptocurrencies / Mining (Altcoins) / Re: AMD Mem Tweak - Read/modify mem timings on the fly - [Vega Friendly] [Win/Linux] on: May 13, 2019, 11:39:54 AM
Is there any solution for the non ref 56 cards that have a default of 800 mem and canít go past 900-950?


I got four of these crap cards any thoughts ? Three are red devil 56 power colors and one is a sapphire pulse

Memory tweak isn't exactly working for me so this isn't fully optimized yet as I can only experiment in the rare cases when it happens to work after a reboot. However, the following seems to be working great for me with such cards (assuming samsung mem).

Doesn't affect stability at all, no errors, adds 200 h/s give or take per card on XMR. It is just a variation of the stock. I hope it helps.

Code:
--RAS 20 --RCDRD 13 --RCDWR 6  --RC 37 --RP 12 --RRDS 4 --RRDL 5 --RFC 208 --REF 15600

10  Alternate cryptocurrencies / Mining (Altcoins) / Re: AMD Mem Tweak - Read/modify mem timings on the fly - [Vega Friendly] [Win/Linux] on: May 11, 2019, 02:01:50 PM
Can somebody shares some good settings for Radeon VII, please?

I need too. but people keeping silent. But disput about oldest cards - 290x and 470.  Grin
We are needing support for new card. Navi is coming!  Cheesy but we don't have normal settings for vega 20 (radeon VII )

You can't mess things too much it seems if you are a bit conservative with any values you try. Start with the stock settings and try a few changes here and there, see what makes a difference and what not. There is a link in the first post to get you started too. Share your findings afterwards, compare notes with others. There are way way more 290s and 470s out there than there are VIIs.
11  Alternate cryptocurrencies / Mining (Altcoins) / Re: AMD Mem Tweak - Read/modify mem timings on the fly - [Vega Friendly] [Win/Linux] on: May 11, 2019, 12:42:06 PM

thanks for your great tool!

I have one rig it cannot change the any values by your tool

C:\Users\G4560\Desktop\AMT\CLI>WinAMDTweak.exe --i 0 --rfc 175
Successfully applied new RFC settings to GPU 0.

C:\Users\G4560\Desktop\AMT\CLI>WinAMDTweak.exe --i 0 --current
GPU 0:  Baffin [Radeon RX 550 640SP / RX 560/560X]
PMG:      CKSRE: 2        CKSRX: 2        CKE_PULSE: 10   CKE: 10         SEQ_IDLE: 7
CAS:      CL: 22          W2R: 16         R2R: 5          CCLD: 2         R2W: 27         NOPR: 0         NOPW: 0
RAS:      RC: 65          RRD: 6          RCDRA: 24       RCDR: 24        RCDWA: 19       RCDW: 19
MISC:     RFC: 178        TRP: 24         RP_RDA: 27      RP_WRA: 58
MISC2:    WDATATR: 0      T32AW: 0        CRCWL: 25       CRCRL: 3        FAW: 0          PA2WDATA: 0     PA2RDATA: 0
M3(MR4):          RAS: 41
DRAM1:    RASMACTWR: 9    RASMACTRD: 5    ACTWR: 0        ACTRD: 4
DRAM2:    RAS2RAS: 21     RP: 7   WRPLUSRP: 13    BUS_TURN: 9

both cli and gui version have the same problem, the cards was 8 rx 550 4gb micron memory

win10 64, 1607, change several drivers 18.6.1 19.4.X 19.3.X, default or mod bios are the same,

all the same, just can not change any value, when i apply, they just restore to default value, any ideas?

of course, I did it when the rig was mining. I found the bios only have 1500 strap, nothing above the 1500, is it the reason? how to fix it?

That sounds very similar to the issue I'm having, only difference is I usually get no readings from the cards, that's on vegas though. Any value I try to change resets to zero the moment I hit apply too.

The other thing is sometimes it works sometimes it doesn't in my case. I have also noticed it may work at first, enough to set my timings, but if I close the GUI and reopen it I'm back to zero readings and not being able to change anything. Previously set timings stick of course, unless I reboot.

I'm not sure what I'm looking for as this is apparently a rare issue (assuming it is the same issue), but do you see any similarities in our systems? Mine is an older AMD 4 core CPU with an on-board HD 8330, single 4GB stick of DDR3, Win10x64 updated to latest a few days ago. I only use PPT, OverdriveNTool and HWinfo64 to monitor and control the cards and I always install AMD drivers without Wattman/AMD settings or anything. This is a dedicated miner so not much else is installed in terms of software.

12  Alternate cryptocurrencies / Mining (Altcoins) / Re: AMD Mem Tweak - Read/modify mem timings on the fly - [Vega Friendly] [Win/Linux] on: May 10, 2019, 10:24:04 PM
Yes, I have the same issue with both versions. Only difference is CLI isn't giving any errors, doesn't apply the timings either though.

It turns out the "ADL2_OverdriveN_SettingsExt_Set" error I mentioned earlier may be unrelated after all. I just realized I'm only getting it trying to import previously saved .xml files, but if I manually change any value and hit apply it works. After a lucky boot that is, if any of my cards happens to show any readings in GUI.

I thought it was just xml files saved with different drivers that caused it at first, but I didn't see any reference to driver version in any of my xml files. I used to import no problem before the driver reinstall, come to think of it, I reinstalled the same driver first time around. I'm on 19.4.1 currently.
13  Alternate cryptocurrencies / Mining (Altcoins) / Re: AMD Mem Tweak - Read/modify mem timings on the fly - [Vega Friendly] [Win/Linux] on: May 10, 2019, 04:04:43 PM
Thank you both for the suggestions.

Zorg33, I checked the files and they seemed alright (date, size, everything). I still went ahead and copied the file from C:\AMD just to make sure, still no change I'm afraid. I also uninstalled everything w/DDU, double-checked the files were deleted and installed the driver again. Again, no change.

naska21, could you elaborate a bit? The system is running fine, mining for days non-stop, I just can't make AMD Memory Tweak work for whatever reason. I could be missing something of course.

edit: forgot to mention, no conflicts in device manager.
14  Alternate cryptocurrencies / Mining (Altcoins) / Re: AMD Mem Tweak - Read/modify mem timings on the fly - [Vega Friendly] [Win/Linux] on: May 09, 2019, 10:06:20 PM
Anyone has any idea about what could be causing this?

I have already verified it isn't driver related and most of the times I get zeros from all cards. Some times it will work normally, some times I will only get readings from some cards, as in the log below.

Needless to say I can't set any timings for the cards not giving proper readings.

Code:
GPU 1:  Vega 10 XL/XT [Radeon RX Vega 56/64]    Memory state: 0x0 (unknown)
Timing 1          CL: 0   RAS: 0          RCDRD: 0        RCDWR: 0
Timing 2          RCAb (RC): 0    RCPb (RC): 0    RPAb (RP): 0    RPPb (RP): 0
Timing 3          RRDS: 0         RRDL: 0         RTP: 0
Timing 4          FAW: 0
Timing 5          CWL: 0          WTRS: 0         WTRL: 0
Timing 6          WR: 0
Timing 7          RREFD: 0
Timing 8          RDRDDD: 0       RDRDSD: 0       RDRDSC: 0       RDRDSCL: 0
Timing 9          WRWRDD: 0       WRWRSD: 0       WRWRSC: 0       WRWRSCL: 0
Timing 10         WRRD: 0         RDWR: 0
Timing 12         REF: 0
Timing 13         MRD: 0          MOD: 0
Timing 14         XS: 0
Timing 16         XSMRS: 0
Timing 17         PD: 0   CKSRE: 0        CKSRX: 0
Timing 20         RFCPB: 0        STAG: 0
Timing 21         XP: 0   CPDED: 0        CKE: 0
Timing 22         RDDATA: 0       WRLAT: 0        RDLAT: 0        WRDATA: 0
Timing 23         CKESTAG: 0
RFC Timing        RFC: 0

GPU 2:  Vega 10 XL/XT [Radeon RX Vega 56/64]    Memory state: 0x0 (unknown)
Timing 1          CL: 0   RAS: 0          RCDRD: 0        RCDWR: 0
Timing 2          RCAb (RC): 0    RCPb (RC): 0    RPAb (RP): 0    RPPb (RP): 0
Timing 3          RRDS: 0         RRDL: 0         RTP: 0
Timing 4          FAW: 0
Timing 5          CWL: 0          WTRS: 0         WTRL: 0
Timing 6          WR: 0
Timing 7          RREFD: 0
Timing 8          RDRDDD: 0       RDRDSD: 0       RDRDSC: 0       RDRDSCL: 0
Timing 9          WRWRDD: 0       WRWRSD: 0       WRWRSC: 0       WRWRSCL: 0
Timing 10         WRRD: 0         RDWR: 0
Timing 12         REF: 0
Timing 13         MRD: 0          MOD: 0
Timing 14         XS: 0
Timing 16         XSMRS: 0
Timing 17         PD: 0   CKSRE: 0        CKSRX: 0
Timing 20         RFCPB: 0        STAG: 0
Timing 21         XP: 0   CPDED: 0        CKE: 0
Timing 22         RDDATA: 0       WRLAT: 0        RDLAT: 0        WRDATA: 0
Timing 23         CKESTAG: 0
RFC Timing        RFC: 0

GPU 3:  Vega 10 XL/XT [Radeon RX Vega 56/64]    Memory state: 0x118 (800MHz)
Timing 1          CL: 17          RAS: 27         RCDRD: 13       RCDWR: 8
Timing 2          RCAb (RC): 39   RCPb (RC): 39   RPAb (RP): 12   RPPb (RP): 12
Timing 3          RRDS: 4         RRDL: 5         RTP: 5
Timing 4          FAW: 13
Timing 5          CWL: 6          WTRS: 3         WTRL: 7
Timing 6          WR: 13
Timing 7          RREFD: 7
Timing 8          RDRDDD: 3       RDRDSD: 2       RDRDSC: 1       RDRDSCL: 3
Timing 9          WRWRDD: 3       WRWRSD: 2       WRWRSC: 1       WRWRSCL: 3
Timing 10         WRRD: 1         RDWR: 17
Timing 12         REF: 3120
Timing 13         MRD: 8          MOD: 12
Timing 14         XS: 216
Timing 16         XSMRS: 6
Timing 17         PD: 6   CKSRE: 8        CKSRX: 8
Timing 20         RFCPB: 128      STAG: 7
Timing 21         XP: 6   CPDED: 2        CKE: 6
Timing 22         RDDATA: 16      WRLAT: 4        RDLAT: 14       WRDATA: 1
Timing 23         CKESTAG: 2
RFC Timing        RFC: 208

GPU 4:  Vega 10 XL/XT [Radeon RX Vega 56/64]    Memory state: 0x118 (800MHz)
Timing 1          CL: 17          RAS: 27         RCDRD: 13       RCDWR: 8
Timing 2          RCAb (RC): 39   RCPb (RC): 39   RPAb (RP): 12   RPPb (RP): 12
Timing 3          RRDS: 4         RRDL: 5         RTP: 5
Timing 4          FAW: 13
Timing 5          CWL: 6          WTRS: 3         WTRL: 7
Timing 6          WR: 13
Timing 7          RREFD: 7
Timing 8          RDRDDD: 3       RDRDSD: 2       RDRDSC: 1       RDRDSCL: 3
Timing 9          WRWRDD: 3       WRWRSD: 2       WRWRSC: 1       WRWRSCL: 3
Timing 10         WRRD: 1         RDWR: 17
Timing 12         REF: 3120
Timing 13         MRD: 8          MOD: 12
Timing 14         XS: 216
Timing 16         XSMRS: 6
Timing 17         PD: 6   CKSRE: 8        CKSRX: 8
Timing 20         RFCPB: 128      STAG: 7
Timing 21         XP: 6   CPDED: 2        CKE: 6
Timing 22         RDDATA: 16      WRLAT: 4        RDLAT: 14       WRDATA: 1
Timing 23         CKESTAG: 2
RFC Timing        RFC: 208

A quick update on that issue, still unresolved unfortunately. I'm back on 19.4.3 currently, played a bit more with the GUI, still getting zeros and memory status 0x0 most of the times, had a couple of lucky runs after numerous restarts and managed to export some working .xml files.

Now, importing the .xml file obviously doesn't do much and everything resets to zero the moment I hit "apply", but again in some cases, I get this error and I thought maybe (hopefully) it isn't unrelated?
Code:
ADL2_OverdriveN_SettingsExt_Set : Generic Error. Most likely one or more of the Escape calls to the driver failed!
 

I have also spent quite a bit of time comparing (software-wise) this with another perfectly working test system I have, made a few changes just in case, nothing seems to be helping and the systems were very similar to begin with anyway. In terms of hardware though, they are day and night so it could be anything. The most relevant difference I can think of obviously is the on-board GPU of each system? Intel on the working one, HD 8330 on the other.

Eliovp, can you think of any way that 8330 could be interfering? I have nothing else to try at the moment, next step is disable the 8330 from the BIOS but I won't be near that system for another couple of weeks and I only have remote access for now. I already tried disabling from device manager but it stops the GUI from running altogether. I can't remember the exact error but I can give it another try if it could be of any help.

edit: HD 8330 disabled in device manager, no change for CLI, GUI gives the following errors.
Code:
---------------------------
ADLException
---------------------------
ADL2_OverdriveN_MemoryTimingLevel_Get : Generic Error. Most likely one or more of the Escape calls to the driver failed!

   at WinFormsGUI.ADL.GetTimingLevels(UInt16 adapterIndex, Int32& defaultValue, Int32& currentValue, Int32[]& levels)

   at WinFormsGUI.GDDR5Control.RefreshADL()

   at WinFormsGUI.GDDR5Control.RefreshTimings()

   at WinFormsGUI.GDDR5Control.ReadAndDisplay(VGAChip chip, UInt16 adapterIndex, ToolTip toolTip)

   at WinFormsGUI.MainForm..ctor()

   at WinFormsGUI.Program.Main()
---------------------------
OK   
---------------------------
Code:
---------------------------
ADLException
---------------------------
ADL2_OverdriveN_Temperature_Get : Generic Error. Most likely one or more of the Escape calls to the driver failed!

   at WinFormsGUI.ADL.GetTemperature(UInt16 adapterIndex, Int32& temperature)

   at WinFormsGUI.GDDR5Control.Timer_Tick(Object sender, EventArgs e)

   at System.Windows.Forms.Timer.OnTick(EventArgs e)

   at System.Windows.Forms.Timer.TimerNativeWindow.WndProc(Message& m)

   at System.Windows.Forms.NativeWindow.Callback(IntPtr hWnd, Int32 msg, IntPtr wparam, IntPtr lparam)
---------------------------
OK   
---------------------------
15  Alternate cryptocurrencies / Mining (Altcoins) / Re: AMD Mem Tweak - Read/modify mem timings on the fly - [Vega Friendly] [Win/Linux] on: May 03, 2019, 09:24:32 AM
Anyone has any idea about what could be causing this?

I have already verified it isn't driver related and most of the times I get zeros from all cards. Some times it will work normally, some times I will only get readings from some cards, as in the log below.

Needless to say I can't set any timings for the cards not giving proper readings.

Code:
GPU 1:  Vega 10 XL/XT [Radeon RX Vega 56/64]    Memory state: 0x0 (unknown)
Timing 1          CL: 0   RAS: 0          RCDRD: 0        RCDWR: 0
Timing 2          RCAb (RC): 0    RCPb (RC): 0    RPAb (RP): 0    RPPb (RP): 0
Timing 3          RRDS: 0         RRDL: 0         RTP: 0
Timing 4          FAW: 0
Timing 5          CWL: 0          WTRS: 0         WTRL: 0
Timing 6          WR: 0
Timing 7          RREFD: 0
Timing 8          RDRDDD: 0       RDRDSD: 0       RDRDSC: 0       RDRDSCL: 0
Timing 9          WRWRDD: 0       WRWRSD: 0       WRWRSC: 0       WRWRSCL: 0
Timing 10         WRRD: 0         RDWR: 0
Timing 12         REF: 0
Timing 13         MRD: 0          MOD: 0
Timing 14         XS: 0
Timing 16         XSMRS: 0
Timing 17         PD: 0   CKSRE: 0        CKSRX: 0
Timing 20         RFCPB: 0        STAG: 0
Timing 21         XP: 0   CPDED: 0        CKE: 0
Timing 22         RDDATA: 0       WRLAT: 0        RDLAT: 0        WRDATA: 0
Timing 23         CKESTAG: 0
RFC Timing        RFC: 0

GPU 2:  Vega 10 XL/XT [Radeon RX Vega 56/64]    Memory state: 0x0 (unknown)
Timing 1          CL: 0   RAS: 0          RCDRD: 0        RCDWR: 0
Timing 2          RCAb (RC): 0    RCPb (RC): 0    RPAb (RP): 0    RPPb (RP): 0
Timing 3          RRDS: 0         RRDL: 0         RTP: 0
Timing 4          FAW: 0
Timing 5          CWL: 0          WTRS: 0         WTRL: 0
Timing 6          WR: 0
Timing 7          RREFD: 0
Timing 8          RDRDDD: 0       RDRDSD: 0       RDRDSC: 0       RDRDSCL: 0
Timing 9          WRWRDD: 0       WRWRSD: 0       WRWRSC: 0       WRWRSCL: 0
Timing 10         WRRD: 0         RDWR: 0
Timing 12         REF: 0
Timing 13         MRD: 0          MOD: 0
Timing 14         XS: 0
Timing 16         XSMRS: 0
Timing 17         PD: 0   CKSRE: 0        CKSRX: 0
Timing 20         RFCPB: 0        STAG: 0
Timing 21         XP: 0   CPDED: 0        CKE: 0
Timing 22         RDDATA: 0       WRLAT: 0        RDLAT: 0        WRDATA: 0
Timing 23         CKESTAG: 0
RFC Timing        RFC: 0

GPU 3:  Vega 10 XL/XT [Radeon RX Vega 56/64]    Memory state: 0x118 (800MHz)
Timing 1          CL: 17          RAS: 27         RCDRD: 13       RCDWR: 8
Timing 2          RCAb (RC): 39   RCPb (RC): 39   RPAb (RP): 12   RPPb (RP): 12
Timing 3          RRDS: 4         RRDL: 5         RTP: 5
Timing 4          FAW: 13
Timing 5          CWL: 6          WTRS: 3         WTRL: 7
Timing 6          WR: 13
Timing 7          RREFD: 7
Timing 8          RDRDDD: 3       RDRDSD: 2       RDRDSC: 1       RDRDSCL: 3
Timing 9          WRWRDD: 3       WRWRSD: 2       WRWRSC: 1       WRWRSCL: 3
Timing 10         WRRD: 1         RDWR: 17
Timing 12         REF: 3120
Timing 13         MRD: 8          MOD: 12
Timing 14         XS: 216
Timing 16         XSMRS: 6
Timing 17         PD: 6   CKSRE: 8        CKSRX: 8
Timing 20         RFCPB: 128      STAG: 7
Timing 21         XP: 6   CPDED: 2        CKE: 6
Timing 22         RDDATA: 16      WRLAT: 4        RDLAT: 14       WRDATA: 1
Timing 23         CKESTAG: 2
RFC Timing        RFC: 208

GPU 4:  Vega 10 XL/XT [Radeon RX Vega 56/64]    Memory state: 0x118 (800MHz)
Timing 1          CL: 17          RAS: 27         RCDRD: 13       RCDWR: 8
Timing 2          RCAb (RC): 39   RCPb (RC): 39   RPAb (RP): 12   RPPb (RP): 12
Timing 3          RRDS: 4         RRDL: 5         RTP: 5
Timing 4          FAW: 13
Timing 5          CWL: 6          WTRS: 3         WTRL: 7
Timing 6          WR: 13
Timing 7          RREFD: 7
Timing 8          RDRDDD: 3       RDRDSD: 2       RDRDSC: 1       RDRDSCL: 3
Timing 9          WRWRDD: 3       WRWRSD: 2       WRWRSC: 1       WRWRSCL: 3
Timing 10         WRRD: 1         RDWR: 17
Timing 12         REF: 3120
Timing 13         MRD: 8          MOD: 12
Timing 14         XS: 216
Timing 16         XSMRS: 6
Timing 17         PD: 6   CKSRE: 8        CKSRX: 8
Timing 20         RFCPB: 128      STAG: 7
Timing 21         XP: 6   CPDED: 2        CKE: 6
Timing 22         RDDATA: 16      WRLAT: 4        RDLAT: 14       WRDATA: 1
Timing 23         CKESTAG: 2
RFC Timing        RFC: 208
16  Alternate cryptocurrencies / Mining (Altcoins) / Re: AMD Mem Tweak - Read/modify mem timings on the fly - [Vega Friendly] [Win/Linux] on: April 25, 2019, 08:15:19 AM
Hey all!

Just to let you know that i've released a new GUI version with muchos improvements and options.
A few of those..

  • Bug Fixes
  • Clock Control (Both Core and Memory)
  • Fan Control (Curve)
  • Export/Import values
  • Reset option
  • Removed EIO requirement
  • ....

Link

Some shots




Not working for me either. No errors, just nothing happens. On two different windows systems, 18.5.1.
17  Alternate cryptocurrencies / Mining (Altcoins) / Re: AMD Mem Tweak - Read/modify mem timings on the fly - [Vega Friendly] [Win/Linux] on: April 24, 2019, 07:10:00 PM
Seems to be working on 18.5.1 too if anyone is interested!

very interesting. if you can please share your results. rx580 gddr5 interesting. All internet timings is cool of course. but when timings I can tweak myself - that is cool. Please share your playing to start for noobies.. Thanks for early.

I have very little to share atm I'm afraid. That was just a few quick runs on a single vega 56 test system, just trying to understand why WinAMDTweak isn't working at all in one of my systems, and I needed to make sure 18.5.1 wasn't the source of the problem.

This is on a very un-optimized system and all but the last run, were only about an hour long. So please take everything with a grain of salt. All on the same system (vega 56 hynix), same ODNT settings (1350 core, 980 mem), CNR only.

XMRig w/o memtweak 1650 h/s, with memtweak 1930 h/s
TRM w/o 1935 h/s, with 2072 h/s (still running after 9 hours)

Power consumption seemed about the same on all runs but I can't really tell from such short runs, and timings used were anwil's from a few pages back (thank you anwil!).
18  Alternate cryptocurrencies / Mining (Altcoins) / Re: AMD Mem Tweak - Read/modify mem timings on the fly - [Vega Friendly] [Win/Linux] on: April 24, 2019, 07:59:49 AM
Seems to be working on 18.5.1 too if anyone is interested!
19  Alternate cryptocurrencies / Mining (Altcoins) / Re: [ANN] TeamRedMiner 0.4.4 - Cryptonight Thread - High hashrate, Low Power on: April 23, 2019, 10:01:38 AM
Since later drivers (>= 19.2.x or so) are using a different approach with a fan curve instead of a single target temp, I'm guessing they don't care about the old classic target temp in the PPT. It's not by random chance that the target temp is missing in the ODNT beta that supports these drivers. The implementation of the fan curve is also f-ing horrible, there is no interpolation with smooth fan rpm increase, it's like they only switch hard between two adjacent points on the curve. This is for 19.2.2 though, might have improved in later versions?

Sorry - was thinking more of older versions.  Donít have much exp w/ windows since 19.2. Based on what @kerney666 said, it sounds to me like fan support is actually broken in later drivers.  Like you, Iíve always found target temp to work perfectly in the past, but wattman still provided working fan curve support for those inclined.

Seems like the new fan curve impl has borked a number of things.

Thank you both, the only reason I thought about updating was an issue with AMDMemoryTweak that seems unrelated now anyway so I'll be sticking with what works best. I still have a system where it works and one where it doesn't, both on 18.6.1. I know 18.6.1 is confirmed working but I thought it could be driver related because I don't even get any readings with --current. I read there is an update coming though so... fingers crossed!
20  Alternate cryptocurrencies / Mining (Altcoins) / Re: [ANN] TeamRedMiner 0.4.4 - Cryptonight Thread - High hashrate, Low Power on: April 22, 2019, 10:26:32 AM
FYI, I completed an evaluation between win10 driver 18.6.1 vs 19.4.2. Found no hashrate/power draw difference with TRM 0.4.4 miner. Evaluated on CNR algo only.

Still using ODNT? How do you set your fan speeds? IIRC there is no target temp in the beta version.

I tested a few 19.x drivers recently, on a 3x vega 56 rig, TRM 0.4.2 (also CNR only) and came to the same conclusion. Didn't have enough time to play with ODNT, but it felt weird having to spend time tweaking fan speeds. Target temp has been a set and forget kind of thing for me so...      

You can set your target temp in PPT...

Vega (hex short, byteswapped -- e.g. "1c,00" => 0x001c => 0d28):



Polaris (hex char -- e.g. "28" => 0x28 => 0d40):



Thank you for that!! It seems to be working! Your posts have always been immensely helpful.

I can't try the beta ODNT right now as I'm currently on old drivers and it's crashing so, am I right to assume the fan speed section can still be disabled in beta?

Np - happy to help.  I don't know about disabling, but ODNT just reads the value from PPT, so you shouldnt need to worry about it, unless you want to change it.

It doesn't seem to be reading it from PPT, I just double checked to make sure. Apparently it just defaults to 75 no matter what value I set in PPT. So unless the fan section can still be disabled in newer ODNT versions, it will just override whatever is set in PPT apparently.
Pages: [1] 2 »
Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2006-2009, Simple Machines Valid XHTML 1.0! Valid CSS!