Bitcoin Forum
September 18, 2019, 05:16:06 PM *
News: If you like a topic and you see an orange "bump" link, click it. More info.
 
  Home Help Search Login Register More  
  Show Posts
Pages: « 1 2 [3] 4 »
41  Other / CPU/GPU Bitcoin mining hardware / Re: SmartCoin - A simple, robust mining system for Linux. [NOW WITH FAILOVER!] on: July 19, 2011, 05:06:01 AM
Update r456(Experimental) available
- Fixes false lockup detection on failovers.  What was happening, is when a failover event happens, all previous failed profiles continue to run along with the new ones that fall into the list.  On the failed profiles, every now and then the miner would output a message such as "Could not connect, will retry...". After a while, the entire screen would be filled with this message, and even though the message is pushed out again at regular intervals, the screen appears to never change, and triggers the lockup detection.  This fix works by enabling lockup detection only on instances that are not part of a down profile (lockup detection will still work however, as there will still be a failover profile that is working running at the bottom of the list)

Thanks plantucha for finding this bug!

I was about to describe it better.
But you think and coding faster than I can write.
Thanx
42  Other / CPU/GPU Bitcoin mining hardware / Re: SmartCoin - A simple, robust mining system for Linux. [NOW WITH FAILOVER!] on: July 19, 2011, 01:37:37 AM
Update r455(experimental) available:
- grep errors are suppressed
- Fixed a small bug that resets the failover counters on smartcoin restart



sensitivity still too high for me.
I have to mine on manual profile with failover every 2-3 hours miners killed => loosing more with failover

it looks like everybody has different threshold, can we set some number in settings or turn it off?
or use different algorithm?
for example:
if it detect locked GPU check again in 5 minutes and again in another 5 minutes
if all 3 checks are positive reboot PC.

also option - just kill smartcoin or reboot PC will be nice.
Because just kill smartcoin only stops not locked GPUs working.
while reboot will unlock locked GPU and autostart mining again.


I can't reproduce anything locally...
Can you give me more information on whats happening?  You mention both the failover system and the lockup detection, but I'm not sure which one you are talking about.  They are 2 separate independent systems (I.e. the lockup system runs no matter which profile is selected, and the failover system only runs when the failover profile is active).  Are you sure you don't have a locked up GPU?  I couldn't imagine a miner running with absolutely no change in its output for 5 minutes straight. 
Also, the new failover will trip a fail condition if stales go over 10% - do you know if this may be the case also?
Is there anything in the logs that may also give a clue?
Perhaps watching the miner output directly (screen -r miner) will give a clue as well - if the miner output sits there with absolutely no change, that pretty much means a locked GPU

manual profile= smartcoin off , running own script
failover was working fine
lockup detection killing miners 2-3 hours    (too sensitive)
rejection rate 0.4%
nothing in logs: just generic   . kiling miners....overclocking...
GPU not locked. it was only once, now I'm making sure it is not.


 I couldn't imagine a miner running with absolutely no change in its output for 5 minutes straight. 

better example what I mean: 

(now - don't LOL yourself to death, this is my first pseudo-code in my life)

start
A=0
detect lockup routine                                 (whatewer formula you are using)
if lockup detected A=A+1                         
If lockup NOT detected go to start             
wait 5 min
detect lockup routine
if lockup detected A=A+1
If lockup NOT detected go to start
wait 5 min
detect lockup routine
if lockup detected A=A+1
If lockup NOT detected go to start
if A=3  then reboot PC                          (lockup is 3x positive in 15 min = it is probably really GPU locked) 
end


testing just once: there will be higher chance false positive or negatives even your formula will be supersmart
only what can happend if it is really GPU locked then will be locked 15 minutes before pc reboots

(5 min is just example, but in case of failover GPUs down, higher rejection..etc) it take 2-3min to system stabilize, so Failover will be not interfering with Lockup detection.

or now maybe even better easier version :
 if is failover starts, turn off lockup detection for 5 min









43  Other / CPU/GPU Bitcoin mining hardware / Re: SmartCoin - A simple, robust mining system for Linux. [NOW WITH FAILOVER!] on: July 18, 2011, 11:20:44 PM
Update r455(experimental) available:
- grep errors are suppressed
- Fixed a small bug that resets the failover counters on smartcoin restart



sensitivity still too high for me.
I have to mine on manual profile with failover every 2-3 hours miners killed => loosing more with failover

it looks like everybody has different threshold, can we set some number in settings or turn it off?
or use different algorithm?
for example:
if it detect locked GPU check again in 5 minutes and again in another 5 minutes
if all 3 checks are positive reboot PC.

also option - just kill smartcoin or reboot PC will be nice.
Because just kill smartcoin only stops not locked GPUs working.
while reboot will unlock locked GPU and autostart mining again.

44  Other / CPU/GPU Bitcoin mining hardware / Re: SmartCoin - A simple, robust mining system for Linux. [NOW WITH FAILOVER!] on: July 18, 2011, 12:26:08 PM
I started using smartcoin (r451 ex) recently and ran into an interesting bug: instead of failing over to a backup profile, smartcoin terminates with the following message:

07/18/11 14:05:06       ERROR: It appears that one or more of your devices have locked up.  This is most likely the result of extreme overclocking!
07/18/11 14:05:06              It is recommended that you reduce your overclocking until you regain stability of the system
07/18/11 14:05:06       Killing Miners....

The thing is that it app fails at the very beginning when trying to connect to BTCguild using phoenix r111 while BTCguild is unaccessible. Perhaps this is because the meter doesn't show up until a connection is established? I'm running r451 experimental. Overclocking is not an issue here as everything is pretty much stock, with just my fans cranked up to keep everything as cool as possible.

Love your the work! Smiley

Yes me too.
around 5am EST   BTCguild has problem with connectivity
=> failover switched to profile 1 and 2

all GPUs was already working on profile2 ( I have seen accepted work, so No GPU locked)
while profile 1 (BTCguild) was trying to connect and some GPUs had work, some GPUs was down.

then Anti-locking kicked in and killed all miners
before total switch to profile 2
and again 5 times after i start manually smartcoin

I have to set profile 2 without Failover to keep mining.

Overclocking is not a problem because my issues before I'm already on stock clock. using phoenix r108 + smartcoin r451ex

We need lower sensitivity overclock anti-lock.
or even better make anti-lock optional.


45  Other / CPU/GPU Bitcoin mining hardware / Re: SmartCoin - A simple, robust mining system for Linux. [NOW WITH FAILOVER!] on: July 18, 2011, 03:51:58 AM
Update r450 experimental available
- Failovers can  happen now in the case where you get unusually high rejected shares (over 10%)
- Dead GPU detection - detects locked up GPU (most likely cause is too aggressive of an overclock).
- AutoDonate bug fixed.  I was finally able to reproduce it locally after a user PM'd me some good info.  It only effected a few, and it took a specific combination of start time and donation minutes.  
- The autodonate countdown timer is now displayed while donating again, and its accurate.  I ran it through a battery of tests manually to ensure accuracy (tests included start/stop times within the same hour, start/stop times that crossed over an hour, and start/stop times that crossed over midnight)


elrock - do another update,  you must have ran the  update right inbetween my commits!

Update r450
- Dead GPU detection
I got false detection. 3+ hours stable running and smartcoin shutdown.
10min after I find out about it and just start smartcoin again.
Previous.log says shutdown because too much overclocking and GPU locked.
But GPUs are not locked all GPUs happily mining again without PC restart.

I'm overclocking GPU just about 6% over, my mem  is factory set .
Temperatures 70C, 70C, 71C, 72C
All fans 100%
And it is tested stable for many days.

Now I'm on r451.

edit: when I wanna set back to factory speed
       GPU 0  was showing error.
       So it was locked.
       Stats showing GPU in work confused me.  Huh Usually after smartcoin restart it shows DOWN.
       MY BAD. Sorry for useless report.  Cry




46  Other / CPU/GPU Bitcoin mining hardware / Re: SmartCoin - A simple, robust mining system for Linux. [NOW WITH FAILOVER!] on: July 17, 2011, 10:56:35 PM
if I don't use AMDOverdriveCtrl - I get the following message after passing `aticonfig --od-setclocks=985,285 --adapter=all`:

Code:
ERROR - Set clocks failed for Adapter 1 - ATI Radeon HD 5800 Series  
        Please check that input values were valid

So AMDOverdriveCtrl must be doing something...And it's not `aticonfig --od-enable --adapter=all` ... that didn't change anything.

It would be good to know how to script Screen anyway - for general Linux education.

yes, ubuntu an other distros are using catalyst 11.5 -
yes you need AMDOverdriveCtrl if is your driver not up to date.
yes I did same , I was assuming I have 11.6.

just update catalyst to 11.6 it is easy copy/paste job, 10 min max:

http://wiki.cchtml.com/index.php/Main_Page

for ubuntu:
http://wiki.cchtml.com/index.php/Ubuntu_Natty_Installation_Guide

47  Other / CPU/GPU Bitcoin mining hardware / Re: SmartCoin - A simple, robust mining system for Linux. [NOW WITH FAILOVER!] on: July 17, 2011, 10:22:05 PM
If there are any commands that you want to have run automatically when smartcoin starts, create a file "init.sh" in the smartcoin directory.  Then you can add your commands that you want run on startup.

Admittedly undereducated about exactly what AMDOverdriveCtrl is doing to my overclock settings/performance - but I have to start it for both cards everytime I reboot my rig. How can I script this with a detached screen? I'm trying:

Code:
#!/bin/bash
screen -dmS ctl0 "AMDOverdriveCtrl -i 0"
screen -dmS ctl1 "AMDOverdriveCtrl -i 3"

why are you using AMDOverdriveCtrl
is there anything what can't be done just by  catalyst 11.6?

like:
aticonfig --od-setclocks=900,1000 --adapter=all
or
export DISPLAY=:0.1; aticonfig --pplib-cmd "get fanspeed 0"
export DISPLAY=:0.1; aticonfig --pplib-cmd "set fanspeed 0 100"

unless AMDOverdriveCtrl can finally overvolt
but I bet 11.7 will do it too or atitweak http://forum.bitcoin.org/index.php?topic=25750.msg371068#msg371068 (overvolt bypass bios in next version)
48  Other / CPU/GPU Bitcoin mining hardware / Re: SmartCoin - A simple, robust mining system for Linux. [NOW WITH FAILOVER!] on: July 17, 2011, 10:00:34 PM
I want to gather suggestions on the preferred cli email program to be used by smartcoin.  I'll go with the most requested.

I finished a new routine which monitors for GPU lockups (the kind common when pushing overclocking a bit too far)
All of my tests so far indicate that a full reboot is needed to recover from locked card conditions.  Currently, the routine will monitor for this  kind of hard lock condition,  and if found it will Log and error, shut down smartcoin and fire off an email.  I'm going to do some tests to see if its possible to revive a locked card, but until then this is about as elegant as I can come up with.

Any further suggestions on this?

Why would you kill smartcoin and kill the other working devices? Let's say I go to bed and sleep 7 hours. After 1 hour one GPU locks. Then you kill smartcoin and 6 hours idle time for 3 other GPUs. That doesn't make sense to me. The current state is even better, because when getting up I can easily detect the the lockup by looking at the stats and I wouldn't waste 6 hours x3 GPUs hashing time.

Email, wonderful. Shutdown smartcoin, very bad idea imo.

most people don't wanna checking rig daily when they wake up.
maybe not shutdown,
restart (email about restart)
with smartcoin autostart after restart. (email about recovery)
then if restart 5x in 1hour (too hot outside or something)  let it hang and send email every x hours about lockup.


also emails about configurable events will be awsome:
like
temperature threshold
failover - profile name
fan threshold
stats every X minutes
Mhash/s threshold
etc.

49  Other / CPU/GPU Bitcoin mining hardware / Re: SmartCoin - A simple, robust mining system for Linux. [NOW WITH FAILOVER!] on: July 17, 2011, 08:57:21 PM
plantucha -

I'm just testing the cgminer and poclbm support.
So far for me, cgminer has been the slowest of the bunch for me (about 1040 MHash/sec vs about 1150 MHash/sec in phoenix). Here is the launch string that I have been testing with:
Code:
./cgminer -a 4way -t 2 -g 2 -o http://pit.x8s.de:8337 -u <#user#> -p <#pass#> -I 14


Also, I don't get much more than 0.7MHash out of my GPU no matter what I do (though, it is an older P4)

Let me know if you have any suggestions!  I'll update this post once I can confirm that the cgminer support in smartcoin is complete


Maybe because cgminer has implemented
- Dynamic intensity that keeps desktop interactive under load and maximises throughput when deskop idle
so if you fiddling with PC intensity going down

or it can be just Intel/AMD sensitive

but anyway, I'm using CGminer for CPU only, Phoenix for GPUs

 
Code:
smartcoin Management System r442(experimental) Sun Jul 17 16:19:33 EDT 2011
--------------------------------------------------------------------------------
Host: localhost
GPU[0]: Temp: 69.00 load: 99%
GPU[1]: Temp: 70.00 load: 99%
GPU[2]: Temp: 71.00 load: 99%
GPU[3]: Temp: 72.00 load: 99%
CPU Load : 0.88%

Profile: Failover
--------BTCGuild--------
GPU[0]: [207.52 Mhash/sec] [132 Accepted] [1 Rejected] [RPC (+LP)]
GPU[1]: [207.48 Mhash/sec] [113 Accepted] [0 Rejected] [RPC (+LP)]
GPU[2]: [207.58 Mhash/sec] [132 Accepted] [1 Rejected] [RPC (+LP)]
GPU[3]: [207.51 Mhash/sec] [132 Accepted] [1 Rejected] [RPC (+LP)]
CPU:    [20.3 MHash/sec] [8 Accepted] [0 Rejected]
Total : [850.39 MHash/sec] [517 Accepted] [3 Rejected] [.580% Rejected]

Grand Total: [850.39 MHash/sec] [517 Accepted] [3 Rejected] [.580% Rejected]



Please note: for some reason after CPU mining is each GPU 2Mhash/s faster than without CPU mining.


now just tiny things like CPU load is 0.88% for GPU mining.
most likely 100% for CPU mining.

I'm getting CPU temperature from "lm-sensors", some people don't have lm-sensors installed.



also I personally do not understand, why people pushing sqlite.
This will be big project and i can see people using it in mining farms with 50+ computers.
Mysql is perfect solution and for mailing postfix.
Think BIG.
People don't cry for 50MB on your 1TB HDD.
Safety first and what is better an more often maintained than Mysql or Postfix?
Some shady project without security upgrades?


jondecker76 Thank you for your super fast development speed.

_______________________________________________________________________________ __________

P.S.:
I'm thinking about writing some documentation, soon it will be too complex for people who starting from this point.
But maybe after some front page simplification.
For example:
Pool configuration on front page
 - it is already pre-configured, but users will try to do something just because they see it...like jen
I think first page have to be just this:

1) Reboot Computer
2) Kill smartcoin (exit)
3) Disconnect from smartcoin (leave running)
4) Select Profile
5) Configure   
6) Update Smartcoin


and most important info:
Ctrl + a      =  switch to rigs live streaming
Ctrl + a +d =  disconnect from smartcoin (leave running)


Submenu 5.

Mandatory basic Configure:
1) Configure Workers

Advacend configure:
2) Edit Settings
3) Remote computers: (yes/no) , address conf. etc

Profile configure:
3) Configure Profiles
4) Set Profile Failover Order

Pre-configured for basic use (tune for your own hardware):
5) Configure Miners
6) Configure Devices
7) Configure Pools

Now, I can see I have to more think about it. Because I'm not sure if is it much easier or more clear than before.
hmmm
....But at least now you do have idea what I mean. Smiley

50  Other / CPU/GPU Bitcoin mining hardware / Re: SmartCoin - A simple, robust mining system for Linux. [NOW WITH FAILOVER!] on: July 17, 2011, 03:29:35 AM
Code:
Can't add correct device number. For some reason it is taking only opencl devices.
actually, you can enter any number you wish, it doesn't have to be an opencl device number, its just what it is normally used for (you can enter 1000 here, if you wanted to).  In the miner setup, if the <#device#> tag is used, this is where that number comes from.  In a miner launchstring that doesn't use the <#device#> tag, its irrelevant anyways.

As far as profiles go,  a device still has to be used in cases like what you are trying to do. It keeps the logic of the program together. The device table its self is abstract - a device is simply something capable of doing hashes as far as bitcoin is concerned so it isn't locked to openCL devices  (I'm also confused as to why you named the cpu 'GPU[0]'?  You can give it any nickname you want - 'AMD6400' for example - this is also true for GPU devices, they just happened to be named 'GPU[X]' by the autodetection code.  You can rename one of your GPU devices 'AMD 5850' if you want even.)

I'm committing changes shortly that let you specify a device type ('gpu' or 'cpu'). This has always existed in the database, but was  hard coded until now to always be 'gpu'.  By marking a device as a non-gpu type, it will keep the aticonfig commands from trying to get information from the non-gpu device.

Can you post sample output from minerd and cgminer?  As well as the command usually used to launch them?    I can add support to show their hashrate along with everything else, if I have this information.


I didn't named CPU  'GPU[0]' , since it was not needed by miner, I didn't set new device .

Then I picked just one of GPUs  'GPU[0]' because it was not going to fill out any variable in miners formula


Cgminer page: http://forum.bitcoin.org/index.php?topic=28402.0

Btw:
Cgminer has newest phat kernel support => faster than phoenix for GPU

Here is output from cgminer:
with GPU support is just listed GPU 0 ...X
similar like CPUs just X more rows

Code:
cgminer version 1.2.7 - Started: [2011-07-16 23:05:55]
--------------------------------------------------------------------------------
 [(5s):21.1  (avg):20.1 Mh/s] [Q:48  A:4  R:0  HW:0  E:8%  U:0.60/m]
 TQ: 0  ST: 0  LS: 0  SS: 0  DW: 0  NB: 1  LW: 0  LO: 0  RF: 0  I: 0
 Connected to http://btcguild.com:8332/ as user plantucha_cpu
 Block 0001733e6f81123485248db025826449  started: [2011-07-16 23:09:20]
--------------------------------------------------------------------------------
 CPU 0: [3.3 Mh/s] [Q:8  A:0  R:0  HW:0  E:0%  U:0.00/m]
 CPU 1: [3.3 Mh/s] [Q:8  A:2  R:0  HW:0  E:29%  U:0.34/m]
 CPU 2: [3.3 Mh/s] [Q:8  A:0  R:0  HW:0  E:0%  U:0.00/m]
 CPU 3: [3.5 Mh/s] [Q:8  A:2  R:0  HW:0  E:29%  U:0.33/m]
 CPU 4: [3.3 Mh/s] [Q:8  A:0  R:0  HW:0  E:0%  U:0.00/m]
 CPU 5: [3.3 Mh/s] [Q:8  A:0  R:0  HW:0  E:0%  U:0.00/m]
--------------------------------------------------------------------------------

[2011-07-16 23:07:09] Share b245ba02 accepted from CPU 3 thread 3
[2011-07-16 23:09:17] LONGPOLL detected new block on network, waiting on fresh work
[2011-07-16 23:09:18] Share 87576403 accepted from CPU 1 thread 1
[2011-07-16 23:11:47] Share cf2be405 accepted from CPU 1 thread 1
[2011-07-16 23:12:05] Share 2859a209 accepted from CPU 3 thread 3


launching code
Code:
./cgminer -a 4way -t 6 -o http://btcguild.com:8332/ -u <#user#> -p <#pass#>

-t <arg>  Number of miner CPU threads

-a <arg>     Specify sha256 implementation:
        c               Linux kernel sha256, implemented in C
        4way            tcatm's 4-way SSE2 implementation
        via             VIA padlock implementation
        cryptopp        Crypto++ C/C++ implementation
        sse2_64         SSE2 implementation for x86_64 machines (default: sse2_64)
51  Other / CPU/GPU Bitcoin mining hardware / Re: SmartCoin - A simple, robust mining system for Linux. [NOW WITH FAILOVER!] on: July 17, 2011, 12:19:05 AM
Quote
Can you please add support for CPU mining?

In theory, CPU mining should work.  Give this a try:
1) Configure Miners -> Add
then add an identical copy of the default phoenix miner, but with a reasonable aggression (5?)
2) Configure Devices -> Add
enter the details of your CPU (name it something like CPU[0]), and make sure the device number is correct.

I don't see why it wouldn't work.  I purposely try to detect only GPU's at install, as most people wont' want to run CPU mining.  I think it may even pound the CPU so much, that you may have problems even handling the incoming SSH connection (which Is why I suggested using a lower aggression in phonix) - but feel free to give it a try and let us know if it works!


Can't add correct device number. For some reason it is taking only opencl devices.

also i want to use cgminer or minerd because implemented -aclu 4way and -aclu sse2_64

phoenix is runnig my CPU only 3mhash/s   , minerd = 25mhash/s

so mayby in future..

Code:
GPU[0]: [204.97 Mhash/sec] [1 Accepted] [0 Rejected] [RPC (+LP)]
GPU[1]: [204.91 Mhash/sec] [2 Accepted] [0 Rejected] [RPC (+LP)]
GPU[2]: [205.03 Mhash/sec] [1 Accepted] [0 Rejected] [RPC (+LP)]
GPU[3]: [205.00 Mhash/sec] [0 Accepted] [0 Rejected] [RPC (+LP)]
GPU[0]: <<<DOWN>>>                                                                                  <<< here is  CPU cgminer                     
Total : [819.91 MHash/sec] [4 Accepted] [0 Rejected] [0% Rejected]

cgminer (compiled without GPU support) or minerd doesn't require any device number
however in profile I MUST choose defined device GPU[X] although it is not necessary for CPU miner
=>
miner is actually working, but showing <<<DOWN>>>    ==> failover changing profile


52  Other / CPU/GPU Bitcoin mining hardware / Re: SmartCoin - A simple, robust mining system for Linux. [NOW WITH FAILOVER!] on: July 16, 2011, 11:43:18 PM
Quote
Can you please add support for CPU mining?

In theory, CPU mining should work.  Give this a try:
1) Configure Miners -> Add
then add an identical copy of the default phoenix miner, but with a reasonable aggression (5?)
2) Configure Devices -> Add
enter the details of your CPU (name it something like CPU[0]), and make sure the device number is correct.

I don't see why it wouldn't work.  I purposely try to detect only GPU's at install, as most people wont' want to run CPU mining.  I think it may even pound the CPU so much, that you may have problems even handling the incoming SSH connection (which Is why I suggested using a lower aggression in phonix) - but feel free to give it a try and let us know if it works!


Can't add correct device number. For some reason it is taking only opencl devices.

also i want to use cgminer or minerd because implemented -aclu 4way and -aclu sse2_64

phoenix is runnig my CPU only 3mhash/s   , minerd = 25mhash/s

so mayby in future..
53  Other / CPU/GPU Bitcoin mining hardware / Re: New command-line tool for overclocking ATI cards (Linux) on: July 16, 2011, 11:27:02 PM
As far as im aware, the original AMDOverdriveCtrl cant actually raise the voltage above the default? Can this?

NO

Code:
michal@rig:~/adl3$ atitweak -v 1.19 -P 2 --adapter=all
Setting performance level 2 on adapter 0: core voltage 1.19VDC
Setting performance level 2 on adapter 1: core voltage 1.19VDC
Setting performance level 2 on adapter 2: core voltage 1.19VDC
Setting performance level 2 on adapter 3: core voltage 1.19VDC

Code:
michal@rig:~/adl3$ atitweak -v 1.20 -P 2 --adapter=all
Setting performance level 2 on adapter 0: core voltage 1.2VDC
ADL_Overdrive5_ODPerformanceLevels_Set failed.
54  Other / CPU/GPU Bitcoin mining hardware / Re: SmartCoin - A simple, robust mining system for Linux. [NOW WITH FAILOVER!] on: July 12, 2011, 07:29:03 AM
Can you please add support for CPU mining?
My CPU just idle, so why not to add some more Mhash?
with CPUminerd i can get 25Mhash/s now,
with sse3 in the new version it will be even more.

I can add CPU miner to miners, but cant add CPU device
i offers just opencl GPUs.

Now I just starting script outside Smartcoin,
of course if pool is broken, GPU happily redirecting
CPU working to no avail.

thanks

55  Bitcoin / Mining / Re: Linux vs Windows for Dedicated Mining on: July 11, 2011, 04:49:17 AM
Now, our measurements aren't exact...  we took a network power switch/battery backup, and pulled snmp power usage every 15 seconds for a 15 minute period.  Then we wrote a script that would move the core and memory settings up and down until it found a sweet spot in MH/j for a specific card.  We ran this test on 8 different cards from 2 different vendors in the 5770 line, the results are similar for all the cards in that test.  We ran the same test on a smaller batch of 5850's and 6950's again with similar results.

can i get this script somewhere?
or do you have already HD6790 measured?
56  Other / CPU/GPU Bitcoin mining hardware / Re: SmartCoin - A simple, robust mining system for Linux. [BETA RELEASED!] on: July 11, 2011, 03:47:43 AM
Quote

On my 6970's 950/300 if I set my worksize to 256 my Mhash/s goes down. I have to run at 128.

how do you underclock 950/300?

1)  Are you running Catalyst 11.6?  If not, then you can't over/under clock outside of the BIOS ranges without flashing.
2)  Did you enable over/underclocking with:

Code:
aticonfig --od-enable --adapter=all

3)  What is the output of:

Code:
aticonfig --odgc --adapter=all


1: a)  yes 11.6.
    b)  Flashing? where I can get alternative BIOS?

2: yes

3:
Code:
aticonfig --odgc --adapter=all

Adapter 0 - AMD Radeon HD 6700 Series
                            Core (MHz)    Memory (MHz)
           Current Clocks :    900           1050
             Current Peak :    900           1050
  Configurable Peak Range : [775-1000]     [1050-1250]
                 GPU load :    99%

Adapter 1 - AMD Radeon HD 6700 Series
                            Core (MHz)    Memory (MHz)
           Current Clocks :    900           1050
             Current Peak :    900           1050
  Configurable Peak Range : [775-1000]     [1050-1250]
                 GPU load :    99%

Adapter 2 - AMD Radeon HD 6700 Series
                            Core (MHz)    Memory (MHz)
           Current Clocks :    900           1050
             Current Peak :    900           1050
  Configurable Peak Range : [775-1000]     [1050-1250]
                 GPU load :    99%

Adapter 3 - AMD Radeon HD 6700 Series
                            Core (MHz)    Memory (MHz)
           Current Clocks :    900           1050
             Current Peak :    900           1050
  Configurable Peak Range : [775-1000]     [1050-1250]
                 GPU load :    99%
57  Other / CPU/GPU Bitcoin mining hardware / Re: SmartCoin - A simple, robust mining system for Linux. [BETA RELEASED!] on: July 10, 2011, 10:46:47 PM
Quote

On my 6970's 950/300 if I set my worksize to 256 my Mhash/s goes down. I have to run at 128.

how do you underclock 950/300?

in my case:

Code:
aticonfig --od-setclocks=900,300 --adapter=all

ERROR - Set clocks failed for Adapter 0 - AMD Radeon HD 6700 Series
        Please check that input values were valid
ERROR - Set clocks failed for Adapter 1 - AMD Radeon HD 6700 Series
        Please check that input values were valid
ERROR - Set clocks failed for Adapter 2 - AMD Radeon HD 6700 Series
        Please check that input values were valid
ERROR - Set clocks failed for Adapter 3 - AMD Radeon HD 6700 Series
        Please check that input values were valid

Code:
aticonfig --od-setclocks=900,1050 --adapter=all

Adapter 0 - AMD Radeon HD 6700 Series
            New Core Peak   : 900
            New Memory Peak : 1050

Adapter 1 - AMD Radeon HD 6700 Series
            New Core Peak   : 900
            New Memory Peak : 1050

Adapter 2 - AMD Radeon HD 6700 Series
            New Core Peak   : 900
            New Memory Peak : 1050

Adapter 3 - AMD Radeon HD 6700 Series
            New Core Peak   : 900
            New Memory Peak : 1050
58  Other / CPU/GPU Bitcoin mining hardware / Re: SmartCoin - A simple, robust mining system for Linux. [BETA RELEASED!] on: July 10, 2011, 10:40:37 PM
Quote
The worksize will affect performance depending on your memory clock generally speaking a worksize of 256 will be best with a memory clock around 300Mhz. I actually run that way because you don't need your GPU memory for much while hashing and this keeps the power consumption and heat lower.
Quote
On my 6970's 950/300 if I set my worksize to 256 my Mhash/s goes down. I have to run at 128.


GPU ATI 6790  

900/1050  best worksize is 64.
  
it is about 1,5 Mhash/s better than 128
and 4 Mhash/s better than 256
worksize 32 is hashrate 50% down
59  Other / CPU/GPU Bitcoin mining hardware / Re: SmartCoin - A simple, robust mining system for Linux. [BETA RELEASED!] on: July 10, 2011, 07:53:30 AM

Quote

On my 6970's 950/300 if I set my worksize to 256 my Mhash/s goes down. I have to run at 128.


how you did 950/300 ?
950 I can set any time, but memory is 1050 and I cant change it. how you did it?
60  Other / CPU/GPU Bitcoin mining hardware / Re: SmartCoin - A simple, robust mining system for Linux. [BETA RELEASED!] on: July 09, 2011, 08:52:00 PM
Code:
smartcoin Management System r383(stable) Sat Jul 9 16:32:58 EDT 2011
--------------------------------------------------------------------------------
Host: localhost
GPU[0]: Temp: 74.00 load: 99%
GPU[1]: Temp: 79.00 load: 99%
GPU[2]: Temp: 69.00 load: 99%
GPU[3]: Temp: 73.00 load: 99%
CPU Load : 2.64%

Profile: Failover
--------BTCGuild--------
GPU[0]: [204.83 Mhash/sec] [16 Accepted] [0 Rejected] [RPC (+LP)]
GPU[1]: [204.56 Mhash/sec] [10 Accepted] [0 Rejected] [RPC (+LP)]
GPU[2]: [204.66 Mhash/sec] [22 Accepted] [0 Rejected] [RPC (+LP)]
GPU[3]: [204.64 Mhash/sec] [11 Accepted] [0 Rejected] [RPC (+LP)]
Total : [818.69 MHash/sec] [59 Accepted] [0 Rejected]

Grand Total: [818.69 Mhash/sec] [59 Accepted] [0 Rejected] [0% Rejected]

Code:
Profile: Automatic
smartcoin Management System r383(stable) Sat Jul 9 16:47:00 EDT 2011
--------------------------------------------------------------------------------
Host: localhost
GPU[0]: Temp: 75.00 load: 99%
GPU[1]: Temp: 80.00 load: 99%
GPU[2]: Temp: 69.00 load: 99%
GPU[3]: Temp: 72.00 load: 99%
CPU Load : 2.79%

Profile: Automatic
--------BTCGuild--------
GPU[0]: [67.89 Mhash/sec] [17 Accepted] [0 Rejected] [RPC (+LP)]
GPU[1]: [71.79 Mhash/sec] [12 Accepted] [0 Rejected] [RPC (+LP)]
GPU[2]: [75.36 Mhash/sec] [15 Accepted] [0 Rejected] [RPC (+LP)]
GPU[3]: [70.68 Mhash/sec] [10 Accepted] [1 Rejected] [RPC (+LP)]
Total : [285.72 Mhash/sec] [54 Accepted] [1 Rejected]
--------Bitcoins.lc--------
GPU[0]: [71.89 Mhash/sec] [8 Accepted] [3 Rejected] [RPC (+LP)]
GPU[1]: [67.77 Mhash/sec] [13 Accepted] [1 Rejected] [RPC (+LP)]
GPU[2]: [68.14 Mhash/sec] [13 Accepted] [1 Rejected] [RPC (+LP)]
GPU[3]: [71.26 Mhash/sec] [12 Accepted] [1 Rejected] [RPC (+LP)]
Total : [279.06 Mhash/sec] [46 Accepted] [6 Rejected]
--------MineCo--------
GPU[0]: [68.51 Mhash/sec] [5 Accepted] [0 Rejected] [RPC (+LP)]
GPU[1]: [68.38 Mhash/sec] [11 Accepted] [3 Rejected] [RPC (+LP)]
GPU[2]: [67.90 Mhash/sec] [14 Accepted] [1 Rejected] [RPC (+LP)]
GPU[3]: [68.52 Mhash/sec] [8 Accepted] [0 Rejected] [RPC (+LP)]
Total : [273.31 MHash/sec] [38 Accepted] [4 Rejected]

Grand Total: [838.09 Mhash/sec] [138 Accepted] [11 Rejected] [7.971% Rejected]

Is here any reason why Automatic profile mining 20 Mhash/sec more?
is it just rounding in formula or dbase distributing load better?
Rejection rate with automatic profile is horrible, more workers, more rejections,
maybe it is compensation for higher hashrate.


Also I added another GPU and CPU load go from 0.8% to 2.6%, is it normal?
Pages: « 1 2 [3] 4 »
Sponsored by , a Bitcoin-accepting VPN.
Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2006-2009, Simple Machines Valid XHTML 1.0! Valid CSS!