Bitcoin Forum
April 23, 2014, 02:22:58 PM *
News: Due to the OpenSSL heartbleed bug, changing your forum password is recommended.
 
  Home Help Search Donate Login Register  
  Show Posts
Pages: [1]
1  Bitcoin / Pools / Re: [1437 GH/s] Slush's Pool (mining.bitcoin.cz); supporting p2sh! on: February 14, 2012, 09:32:15 PM
Odd, my miner was idle for a few rounds and its average hash rate of the last 10 rounds dropped and then it became active again and a few hours later the average mhash of the last 10 rounds has dropped even more... Huh

Its 100 mhash/s lower then the miner. Shocked
2  Other / Beginners & Help / Re: further improved phatk_dia kernel for Phoenix + SDK 2.6 - 2012-01-13 on: January 19, 2012, 01:48:53 PM
Just a hint, this kernel is for SDK 2.6+, it doesn't work well with earlier versions / runtimes!

Dia
Yes I know, I tried the one from sdk 2.6 and also those that ship with the newest (leaked) drivers, and I tried them all to find which one is best but it didn't make a difference.

Update: just updated to phoenix 1.7.5

pahtk and phatk2 perform at about 416 mhash/s
 -k phatk(2) DEVICE=0 VECTORS AGGRESSION=16 WORKSIZE=64 FASTLOOP=false

your build 2011-12-21 performs at 418 mhash/s
 -k phatk DEVICE=0 VECTORS2 AGGRESSION=16 WORKSIZE=64 FASTLOOP=false

your build from 2012-01-13 at 417 mhash/s
 -k phatk DEVICE=0 VECTORS2 AGGRESSION=14 WORKSIZE=64 FASTLOOP=false

If I put aggression higher then the statistics like mhash/s won't appear or they disappear and come back every few seconds.
also it states that the miner is idle sometimes.

so for now ill stick with:
your build 2011-12-21 and -k phatk DEVICE=0 VECTORS2 AGGRESSION=16 WORKSIZE=64 FASTLOOP=false

Using these drivers: AMD Cat 8.95 ( January 17th)  http://forums.guru3d.com/showthread.php?t=357581
with an AMD 6950 (unlocked to a 6970 and running at 930/1430)
3  Bitcoin / Pools / Re: [1296 GH/s] Slush's Pool (mining.bitcoin.cz); Pool back in action! on: January 18, 2012, 11:44:33 PM
Hmm I'm having issues again, using phoenix and phatk modified kernel: https://bitcointalk.org/index.php?topic=25135.0
 -k phatk DEVICE=0 VECTORS2 AGGRESSION=16 WORKSIZE=64 FASTLOOP=false
On a unlocked 6950, running at 930 mhz core and 1430 mhz memory.

It was working perfectly but yesterday my isp did some maintenance and now the program will only mine 9 shares and after that it "hangs"
I tried disabling long polling, went back to phoenix 1.7.2 and tried 2 different modified kernels.

If you are running the latest phatk, try removing the 'FASTLOOP=FALSE' from your arguments.
If that does not change anything try with the normal vectors, aggr, etc. i.e, 'VECTORS AGGRESSION=8 WORKSIZE=256'
That memory sounds awfully high for running vectors2 as well. Though if it worked for you in the past then it may not be the issue. I would try lowering it to about 800 if using vectors2
I rebooted my pc, got a bsod, rebooted again and now its working fine again... odd Huh
4  Bitcoin / Pools / Re: [1296 GH/s] Slush's Pool (mining.bitcoin.cz); Pool back in action! on: January 17, 2012, 06:55:04 PM
Hmm I'm having issues again, using phoenix and phatk modified kernel: https://bitcointalk.org/index.php?topic=25135.0
 -k phatk DEVICE=0 VECTORS2 AGGRESSION=16 WORKSIZE=64 FASTLOOP=false
On a unlocked 6950, running at 930 mhz core and 1430 mhz memory.

It was working perfectly but yesterday my isp did some maintenance and now the program will only mine 9 shares and after that it "hangs"
I tried disabling long polling, went back to phoenix 1.7.2 and tried 2 different modified kernels.
5  Bitcoin / Pools / Re: [1296 GH/s] Slush's Pool (mining.bitcoin.cz); Pool back in action! on: January 15, 2012, 05:03:58 PM

I few days ago my reject ratio was 0.3% and now its 2-3%, and I'm getting a lot of miner idle warnings in phoenix, is this causes by my own settings/system/upgraded phoenix + kernel or is slush getting ddosed again?

What version of phoenix are you running? I used to have the same problem as you until I upgraded to 1.7.3. Also do you have a manually set "ask rate" (in the phoenix command line argument) ?


I don't have a manual set ask rate, I'm using 1.7.3 and this kernel: https://bitcointalk.org/index.php?topic=25135.0

Ah that explains it. There is some bug in the latest phoenix version when running with that kernel (checkout the phoenix thread for details). I would suggest going back to phatk2 to see if it makes a difference.
Nope, I tried 1.7.2 again with that kernel and its still having issues.
6  Bitcoin / Pools / Re: [1296 GH/s] Slush's Pool (mining.bitcoin.cz); Pool back in action! on: January 15, 2012, 02:08:57 PM

I few days ago my reject ratio was 0.3% and now its 2-3%, and I'm getting a lot of miner idle warnings in phoenix, is this causes by my own settings/system/upgraded phoenix + kernel or is slush getting ddosed again?

What version of phoenix are you running? I used to have the same problem as you until I upgraded to 1.7.3. Also do you have a manually set "ask rate" (in the phoenix command line argument) ?


I don't have a manual set ask rate, I'm using 1.7.3 and this kernel: https://bitcointalk.org/index.php?topic=25135.0
7  Bitcoin / Pools / Re: [1296 GH/s] Slush's Pool (mining.bitcoin.cz); Pool back in action! on: January 15, 2012, 12:14:14 PM

I few days ago my reject ratio was 0.3% and now its 2-3%, and I'm getting a lot of miner idle warnings in phoenix, is this causes by my own settings/system/upgraded phoenix + kernel or is slush getting ddosed again?
8  Other / Beginners & Help / Re: further improved phatk OpenCL kernel (> 4% increase) for Phoenix - 2012-01-13 on: January 15, 2012, 12:04:05 PM
Well the performance is about 0.5 mhash/s lower as with the old phoenix and your old kernel from 2011 because with this one I cant make aggression higher, duo to that "bug".
however at the same aggression it performs better.

I noticed that my minder is idle a lot and I have a 2-3% reject ratio, but that might be because my pool is under a ddos.
I tried a different pool, same issue.

I also tried a few opencl builds: 2.6 ,1.2 c++ and one that came with my driver.
They all perform the same.

Note: your build still performs better then normal pathk or pathk2, so I'm happy with it and donated 0.34 btc, might take up to 3 days before it arrives though.

Update: I just went back to your last kernel from 2011 and I no longer get any miner idle/stall errors any more.
+ Its slightly faster cause I can use a higher suppression setting.
9  Other / Beginners & Help / Re: further improved phatk OpenCL kernel (> 4% increase) for Phoenix - 2012-01-13 on: January 14, 2012, 02:30:33 PM

its cause of the aggresion at 16, when I put it on 15 it shows again but the miner is idle a lot according to the log and the khash/s are at 0 however its still mining and getting hashes accepted.
with 14 its working fine but slightly lower mhash/s then with the older one kernel at aggression 17. (417 compared to 418 mhash/s.)
This is because above 12 or 13 is insane aggression - the miner hogs the GPU so much that the Windows GUI can't even draw stuff like the status line on the screen.
It was fine with the older kernel.
Does that mean anything?
I think this kernel is slightly faster then the older one.
10  Other / Beginners & Help / Re: further improved phatk OpenCL kernel (> 4% increase) for Phoenix - 2012-01-13 on: January 14, 2012, 01:25:34 PM
Uploaded a fixed version, which corrects an error with FASTLOOP=True:
Download version 2012-01-13: http://www.mediafire.com/?xzk6b1yvb24r4dg

There are no other changes in this version!

Dia
I no longer see the mhash/s. also I don't see the shares and other statistics.(basically the entire button line)

I do see the log which says at which time a share was accepted and that says other things.

That's not a helpful bug report ... sorry. What OS? Can you paste an output of the Phoenix window.
What's your command line? Was this introduced with the FASTLOOP fix or before?

Dia
Didn't try the one before only the 2011-12-21.

OS is server 2008 R2 sp1 64 bit.

[/quote]
I no longer see the mhash/s. also I don't see the shares and other statistics.(basically the entire bottom line)

I do see the log which says at which time a share was accepted and that says other things like miner is idle, etc.

its cause of the aggresion at 16, when I put it on 15 it shows again but the miner is idle a lot according to the log and the khash/s are at 0 however its still mining and getting hashes accepted.
with 14 its working fine but slightly lower mhash/s then with the older one kernel at aggression 17. (417 compared to 418 mhash/s.)
[/quote]

Also with 14 and lower settings the stats sometimes disappear for a few seconds before they come back.

I made a screenshot, the part marked with red is the part that is having issues.
http://xgclan.com/miner.png
11  Other / Beginners & Help / Re: further improved phatk OpenCL kernel (> 4% increase) for Phoenix - 2012-01-13 on: January 14, 2012, 12:57:31 PM
Uploaded a fixed version, which corrects an error with FASTLOOP=True:
Download version 2012-01-13: http://www.mediafire.com/?xzk6b1yvb24r4dg

There are no other changes in this version!

Dia
I no longer see the mhash/s. also I don't see the shares and other statistics.(basically the entire button line)

I do see the log which says at which time a share was accepted and that says other things.

Hmm its cause of the aggresion at 16, when I put it on 15 it shows again but the miner is idle a lot according to the log and the khash/s are at 0.
with 15 its working fine but slightly lower mhash/s then with the older one.

417 compared to 418.
12  Other / Beginners & Help / Re: further improved phatk OpenCL kernel (> 4% increase) for Phoenix - 2011-12-21 on: January 09, 2012, 05:13:24 PM
Hmm I made some calculations and I saw that the Mhash/s is incorrect.
it indicates I get around 418Mh/s
my pool indicates I get 403 Mh/s

7610 9-1-2012 17:18

7879  9-1-2012 18:01

time=2580 sec
shares=269

269 x 2^32 =1 155 346 202 624 / 2580 =447 808 606
447 808 606 / 1 000 000 = 447,808606 Mh/s

or am I doing something wrong here, why are they all reporting different speeds Huh

13  Other / Beginners & Help / Re: Introduce yourself :) on: January 08, 2012, 02:02:05 PM
Hi I'm new here, although I have some experience with gui miner but I recently switched over the phoenix Tongue
I hope to find some tips and tricks here to get my mining performance up and also share my settings with others Cheesy.
14  Other / Beginners & Help / Re: further improved phatk OpenCL kernel (> 4% increase) for Phoenix - 2011-12-21 on: January 08, 2012, 01:59:39 PM
Thanks for your infos.

The higher the AGRESSION, the more Desktop lag you observe, that's normal.

Dia
No problem, so aggression doesn't affect the speed of shares?

btw I'm having some connection issues every now and then duo to my isp and sometimes I get a warning that my work queue is empty for a few seconds although this only happens once a hour or so.
Could I prevent this from happening by using -q 2 or -q 5, or is this not a good idea?
15  Other / Beginners & Help / Re: further improved phatk OpenCL kernel (> 4% increase) for Phoenix - 2011-12-21 on: January 08, 2012, 01:32:15 PM
Hi, I'm new to bitcoin mining and I'm not sure if I'm posting this in the correct forum (I can't post in the phoenix thread), I've used guiminer for a few months now and decided to give phoenix a try.
And its great, phoenix is slightly faster and has a stable hashrate.
However I noticed that phatk2 is much slower(50-60Mhashes/s) then pathk, and I believe this optimized kernel is supposed to replace the original pathk2 kernel, because when I overwrite the original pathk kernel with this one my hash rate is almost the same as with pathk2.

Am I using incorrect settings? I have an unlocked 6950 card with 910 mhz core and 1440 mhz memory.

The settings I use are: -k phatk DEVICE=0 VECTORS BFI_INT AGGRESSION=11 worksize=128  FASTLOOP=false

or if I want to run on phatk2:  -k phatk2 DEVICE=0 VECTORS BFI_INT AGGRESSION=11 worksize=128  FASTLOOP=false

I will only comment on my kernel here, which has to be used with:
Code:
-k phatk DEVICE=0 VECTORS2 AGGRESSION=11 WORKSIZE=128 FASTLOOP=false

The normal Phoenix kernel, which is in the default Phoenix download package doesn't have VECTORS2 and needs BFI_INT switch supplied (I activate this by myself if cl_amd_media_ops extension is available).

Dia
Thanks,I replaced the normal pathk kernel with yours, the performance is now the same in Mh/s although shares seem to come slightly quicker.
Hmm with a worksize of 64 I get slightly better performance(0.5 Mh/s more).
I'm now at ~408 MH/s drops to 407.91 sometimes, and with aggression on 12 I get 408+ Mh/s
Fine tuned aggression to 16 and I get 409+ Mh/s nearly 410.

What's your setup? Driver, OS, card?
I mine at bitcoin.cz which support long polling and uses rpc.
cpu: Intel core I7 2600K at 4.7 ghz (phoenix is using 11-13% cpu)
gpu amd 6970(unlocked 6950) at 910mhz but now got it running at 930mhz, memory at 1430 mhz
os: Windows server 2008 R2 sp1 64 bit
Driver: marthand leaked driver from guru 3d 20th december: http://forums.guru3d.com/showthread.php?t=356146
opencl: Unknown I tried a few versions from different catalyst builds to see which one performs better but I'm not sure which version this is.
I have put it on my own website if you want to try it: http://www.xgclan.com/opencl.msi

I'm now using the following settings: -k phatk DEVICE=0 VECTORS2 AGGRESSION=16 WORKSIZE=64 FASTLOOP=false  
and I overclocked my gpu to 930 mhz I get about 418 mhash/s

I just have one question, I see that the higher aggression setting causes for my pc to be a bit slower, and in the console the shares seem to get confirmed later.
at first it did 1 or 2 share every 5-6 seconds but now it only does one or multiple ones every ~30 sec, can this be affected by my (aggression) settings?
Note: I just got a new block from the pool and now the shares take 10 sec to get confirmed, so I guess its not related to my settings?
16  Other / Beginners & Help / Re: further improved phatk OpenCL kernel (> 4% increase) for Phoenix - 2011-12-21 on: January 08, 2012, 12:02:50 PM
Hi, I'm new to bitcoin mining and I'm not sure if I'm posting this in the correct forum (I can't post in the phoenix thread), I've used guiminer for a few months now and decided to give phoenix a try.
And its great, phoenix is slightly faster and has a stable hashrate.
However I noticed that phatk2 is much slower(50-60Mhashes/s) then pathk, and I believe this optimized kernel is supposed to replace the original pathk2 kernel, because when I overwrite the original pathk kernel with this one my hash rate is almost the same as with pathk2.

Am I using incorrect settings? I have an unlocked 6950 card with 910 mhz core and 1440 mhz memory.

The settings I use are: -k phatk DEVICE=0 VECTORS BFI_INT AGGRESSION=11 worksize=128  FASTLOOP=false

or if I want to run on phatk2:  -k phatk2 DEVICE=0 VECTORS BFI_INT AGGRESSION=11 worksize=128  FASTLOOP=false

I will only comment on my kernel here, which has to be used with:
Code:
-k phatk DEVICE=0 VECTORS2 AGGRESSION=11 WORKSIZE=128 FASTLOOP=false

The normal Phoenix kernel, which is in the default Phoenix download package doesn't have VECTORS2 and needs BFI_INT switch supplied (I activate this by myself if cl_amd_media_ops extension is available).

Dia
Thanks,I replaced the normal pathk kernel with yours, the performance is now the same in Mh/s although shares seem to come slightly quicker.
Hmm with a worksize of 64 I get slightly better performance(0.5 Mh/s more).
I'm now at ~408 MH/s drops to 407.91 sometimes, and with aggression on 12 I get 408+ Mh/s
Fine tuned aggression to 16 and I get 409+ Mh/s nearly 410.
17  Other / Beginners & Help / Re: further improved phatk OpenCL kernel (> 4% increase) for Phoenix - 2011-12-21 on: January 08, 2012, 10:26:05 AM
Hi, I'm new to bitcoin mining and I'm not sure if I'm posting this in the correct forum (I can't post in the phoenix thread), I've used guiminer for a few months now and decided to give phoenix a try.
And its great, phoenix is slightly faster and has a stable hashrate.
However I noticed that phatk2 is much slower(50-60Mhashes/s) then pathk, and I believe this optimized kernel is supposed to replace the original pathk2 kernel, because when I overwrite the original pathk kernel with this one my hash rate is almost the same as with pathk2.

Am I using incorrect settings? I have an unlocked 6950 card with 910 mhz core and 1440 mhz memory.

The settings I use are: -k phatk DEVICE=0 VECTORS BFI_INT AGGRESSION=11 worksize=128  FASTLOOP=false

or if I want to run on phatk2:  -k phatk2 DEVICE=0 VECTORS BFI_INT AGGRESSION=11 worksize=128  FASTLOOP=false
Pages: [1]
Sponsored by , a Bitcoin-accepting VPN.
Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2006-2009, Simple Machines Valid XHTML 1.0! Valid CSS!