Bitcoin Forum
February 24, 2017, 01:50:01 AM *
News: Latest stable version of Bitcoin Core: 0.13.2  [Torrent]. (New!)
 
   Home   Help Search Donate Login Register  
Pages: « 1 2 3 4 5 6 7 8 [9] 10 11 12 13 14 »  All
  Print  
Author Topic: v5.6.0 ][ Open-Source Pooling Web Software ( MiningFarm )  (Read 54558 times)
Xenland
Legendary
*
Offline Offline

Activity: 980


I'm not just any shaman, I'm a Sha256man


View Profile
June 24, 2011, 07:28:50 AM
 #161

Can you update the changelog ?

Added serverFeePercentage mysql.

And fixed the accounts not being rewarded bug

Sorry cant have more detailed changelog, but its just me and i cant rememeber every change
"Accounts not being rewarded bug" - I thought it was just me running on testnet that broke things, I solved 14 blocks and all balances were 0, so I have a private pool going now on the real blockchain.  Because I have modified your v4.0.1 release *heavily*, do you mind posting a diff or describing how this bug was fixed?

Honestly i dont remeber, i get so many fix/suggestion requests i just cant remeber changes in the code it self. the top half of blockUpdater.php was wierd i keptd hacking at it until i worked correctly.

I honestly think it was a misspelling somewere and on top of that the if statements didnt work.

When i upload 4.2.2 the stats will get purged after a certain amount of time to save memory.
1487901001
Hero Member
*
Offline Offline

Posts: 1487901001

View Profile Personal Message (Offline)

Ignore
1487901001
Reply with quote  #2

1487901001
Report to moderator
1487901001
Hero Member
*
Offline Offline

Posts: 1487901001

View Profile Personal Message (Offline)

Ignore
1487901001
Reply with quote  #2

1487901001
Report to moderator
Advertised sites are not endorsed by the Bitcoin Forum. They may be unsafe, untrustworthy, or illegal in your jurisdiction. Advertise here.
1487901001
Hero Member
*
Offline Offline

Posts: 1487901001

View Profile Personal Message (Offline)

Ignore
1487901001
Reply with quote  #2

1487901001
Report to moderator
1487901001
Hero Member
*
Offline Offline

Posts: 1487901001

View Profile Personal Message (Offline)

Ignore
1487901001
Reply with quote  #2

1487901001
Report to moderator
kr105
Sr. Member
****
Offline Offline

Activity: 406


View Profile WWW
June 24, 2011, 02:21:40 PM
 #162

Hey Xenland, you should move to SVN or GIT to track your changes better  Wink
phorensic
Hero Member
*****
Offline Offline

Activity: 630



View Profile
June 24, 2011, 03:54:41 PM
 #163

I agree, but he used Github already and abandoned it!  We want github again!   Grin
frizzl
Newbie
*
Offline Offline

Activity: 28


View Profile
June 24, 2011, 04:31:51 PM
 #164

/justdoeeet

1NtLm3jrRK2keDBMiBbTUvNetrkNuBV8hY
peedee
Newbie
*
Offline Offline

Activity: 28


View Profile
June 24, 2011, 08:00:11 PM
 #165

Xenland : in the 4.1.2 version the serverFeepercentage column was removed from the SQL script, is that on purpose ?

sakkaku
Member
**
Offline Offline

Activity: 70



View Profile WWW
June 24, 2011, 08:01:03 PM
 #166

I agree, but he used Github already and abandoned it!  We want github again!   Grin

Github is <3

13NiQcetcioQj3YwHL1ZWvgQg8eAjkzUdt
Blog/Projects: zxlu.com | syn-multiminer
openrune
Member
**
Offline Offline

Activity: 62


View Profile WWW
June 24, 2011, 08:14:41 PM
 #167

Hi all, i just installed the actual Farm 4.1.2 everything works good exept this:

When i should type in the auth code i get wired errors above the code field but to add the code provided in the mail works

then when i login i see in on top left, aswelll on the statistics page and in the percentage field in the administrator section

Warning: mysql_fetch_object(): supplied argument is not a valid MySQL result resource in .../req/functions.php on line 340

guess there is a little mess in the sql file

Smiley

0 Fee TENOBIS MINE
http://mine.tenobis.com
Dnt mind any donation!
19gD6ZNxSReeNf18A2ftYeDK5uuJ5VDKnu
peedee
Newbie
*
Offline Offline

Activity: 28


View Profile
June 24, 2011, 08:25:24 PM
 #168

Hi all, i just installed the actual Farm 4.1.2 everything works good exept this:

When i should type in the auth code i get wired errors above the code field but to add the code provided in the mail works

then when i login i see in on top left, aswelll on the statistics page and in the percentage field in the administrator section

Warning: mysql_fetch_object(): supplied argument is not a valid MySQL result resource in .../req/functions.php on line 340

guess there is a little mess in the sql file

Smiley


Lol. thats the missing column I just pointed out. It tries to get the serverfeepercentage Smiley

Try :

ALTER TABLE websiteSettings ADD  serverFeePercentage varchar(20) NOT NULL AFTER browserTitle;

Then add a percentage and see if it works.


phorensic
Hero Member
*****
Offline Offline

Activity: 630



View Profile
June 24, 2011, 08:31:15 PM
 #169

It is supposed to be a varchar and 'x%' or an int and 'x'?
openrune
Member
**
Offline Offline

Activity: 62


View Profile WWW
June 24, 2011, 09:14:35 PM
 #170

thanks peedee that solved the problem

0 Fee TENOBIS MINE
http://mine.tenobis.com
Dnt mind any donation!
19gD6ZNxSReeNf18A2ftYeDK5uuJ5VDKnu
Xenland
Legendary
*
Offline Offline

Activity: 980


I'm not just any shaman, I'm a Sha256man


View Profile
June 24, 2011, 09:21:24 PM
 #171

I'll find something that tracks changes better, last time github ruined everything it appended old code with my new code for some reason and it took me 6 hours to clean up the code.
Xenland
Legendary
*
Offline Offline

Activity: 980


I'm not just any shaman, I'm a Sha256man


View Profile
June 24, 2011, 09:22:02 PM
 #172

Xenland : in the 4.1.2 version the serverFeepercentage column was removed from the SQL script, is that on purpose ?



No please add serverFeePercentage back this was a regression.
sakkaku
Member
**
Offline Offline

Activity: 70



View Profile WWW
June 24, 2011, 09:22:56 PM
 #173

I'll find something that tracks changes better, last time github ruined everything it appended old code with my new code for some reason and it took me 6 hours to clean up the code.

You probably f*cked something up when you committed your changes to git.  I have never had that issue.

13NiQcetcioQj3YwHL1ZWvgQg8eAjkzUdt
Blog/Projects: zxlu.com | syn-multiminer
openrune
Member
**
Offline Offline

Activity: 62


View Profile WWW
June 24, 2011, 10:28:01 PM
 #174

Wow the Frontpage looks great when a worker is active Wink

but i have an other error on the stats page aswell as in the blocksUpdater.php:

Uncaught BitcoinClientException:
  • : Didn't receive 200 OK from remote server. (HTTP/1.0 401 Authorization Required) thrown in on line 0


0 Fee TENOBIS MINE
http://mine.tenobis.com
Dnt mind any donation!
19gD6ZNxSReeNf18A2ftYeDK5uuJ5VDKnu
Xenland
Legendary
*
Offline Offline

Activity: 980


I'm not just any shaman, I'm a Sha256man


View Profile
June 24, 2011, 10:38:07 PM
 #175

Wow the Frontpage looks great when a worker is active Wink

but i have an other error on the stats page aswell as in the blocksUpdater.php:

Uncaught BitcoinClientException:
  • : Didn't receive 200 OK from remote server. (HTTP/1.0 401 Authorization Required) thrown in on line 0

i allso have a lot rpc upstream erros in the miner, but he allready was abot to find valid and rejected blocks,

thats a bit wired Wink

Yes im receving this too it started happening around 12-2am my time(when i wasnt playing with code)
Looking for a fix could be a bitcoin-php problem or bitcoimd problem possibly.

Im trying github again and ill just keep backups before updating to prevent this problem
peedee
Newbie
*
Offline Offline

Activity: 28


View Profile
June 24, 2011, 10:58:26 PM
 #176

There are two other stats that have been broken with 4.1.2 :

accountDetails.php :

Estimated Reward this Round

header.php :

Estimated
 

Huh


...
Xenland
Legendary
*
Offline Offline

Activity: 980


I'm not just any shaman, I'm a Sha256man


View Profile
June 24, 2011, 11:39:53 PM
 #177

Sorry everyone, I technically have 3 different versions on my computer, all on different partitions/servers. I'm just going to download the 4.1.2 version again and start over. This may take a bit longer for another daily update, to prevent this from happening again I'll try using github so I can stop fussing with all these regressions I keep finding. Hopefully github will play nice this time. Again sorry for the inconvenience.
phorensic
Hero Member
*****
Offline Offline

Activity: 630



View Profile
June 25, 2011, 03:31:13 AM
 #178

My github fork has been updated with some quick initial changes.  I hope to contribute as much as I can to this project while I test my private pool and try to make it public.  Currently I am only editing the fork with bits and pieces of what I like, it's not a clone of my current pool code which would change everything and break things.  "inset_into_database.sql" needs some major editing.  The version on github is horrible, while the version in your released tarballs is pretty close.  I suggest deleting the original in your master branch and pasting in a copy from your tarballs.  Cheers!
openrune
Member
**
Offline Offline

Activity: 62


View Profile WWW
June 25, 2011, 01:10:17 PM
 #179

Hello All

My mine works good now on http://mine.tenobis.com !
But there is still a little bug and i cant find why that is its on the stats page and in the block cronjobs aswell:

Uncaught BitcoinClientException:
  • : Didn't receive 200 OK from remote server. (HTTP/1.0 401 Authorization Required) thrown in on line 0

Does anyone have an idea why that happens??

0 Fee TENOBIS MINE
http://mine.tenobis.com
Dnt mind any donation!
19gD6ZNxSReeNf18A2ftYeDK5uuJ5VDKnu
drontus
Jr. Member
*
Offline Offline

Activity: 42



View Profile
June 25, 2011, 10:45:20 PM
 #180

Fatal error: Call to undefined function bindtextdomain() in Z:\home\localhost\www\req\functions.php on line 36
Pages: « 1 2 3 4 5 6 7 8 [9] 10 11 12 13 14 »  All
  Print  
 
Jump to:  

Sponsored by , a Bitcoin-accepting VPN.
Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2006-2009, Simple Machines Valid XHTML 1.0! Valid CSS!