Bitcoin Forum
December 02, 2016, 08:28:02 PM *
News: Latest stable version of Bitcoin Core: 0.13.1  [Torrent].
 
   Home   Help Search Donate Login Register  
Pages: [1]
  Print  
Author Topic: 0 connections  (Read 2840 times)
trout
Sr. Member
****
Offline Offline

Activity: 326


View Profile
June 03, 2011, 12:57:43 PM
 #1

I posted this questions here a while ago, and basically my conclusion was that it
is normal to have 0 connections for about an hour after starting the bitcoin client.

but the situation has got worse since.

now my client can run for hours without getting a single connection.

does anybody else have this problem?
can it be due to some kind of throttling of the network?

i must add that the problem is not permanent- 
sometimes it runs normally, gets connectons, downloads the chain and operates perfectly.

running bitcoin 0.3.21 on ubuntu

Advertised sites are not endorsed by the Bitcoin Forum. They may be unsafe, untrustworthy, or illegal in your jurisdiction. Advertise here.
1480710482
Hero Member
*
Offline Offline

Posts: 1480710482

View Profile Personal Message (Offline)

Ignore
1480710482
Reply with quote  #2

1480710482
Report to moderator
1480710482
Hero Member
*
Offline Offline

Posts: 1480710482

View Profile Personal Message (Offline)

Ignore
1480710482
Reply with quote  #2

1480710482
Report to moderator
1480710482
Hero Member
*
Offline Offline

Posts: 1480710482

View Profile Personal Message (Offline)

Ignore
1480710482
Reply with quote  #2

1480710482
Report to moderator
mewantsbitcoins
Full Member
***
Offline Offline

Activity: 126


View Profile
June 03, 2011, 01:12:10 PM
 #2

Open up terminal and navigate to where your bitcoin binary is then type

Code:
bitcoin -addnode=69.164.218.197 -addnode=64.22.103.150 -addnode=173.242.112.53 -addnode=178.79.147.99 -addnode=184.106.111.41 -addnode=91.85.220.84 -addnode=173.224.125.222 -addnode=86.5.50.90 -addnode=178.255.199.86

It is a quick fix. To properly resolve this problem try enabling "Map port using UPnP" in Settings->Options. If that doesn't work you'll need to manually open/forward port 8333 from your router to your computer
trout
Sr. Member
****
Offline Offline

Activity: 326


View Profile
June 03, 2011, 01:13:23 PM
 #3

ok, i tried running the client with -addnode option, with an ip of a belgian guy (kinda close),
and it got me connected.

still it seems to be smth wrong with  the p2p network.
i mean, it usually takes much less time to connect to other p2p networks,
like torrents and the like.
trout
Sr. Member
****
Offline Offline

Activity: 326


View Profile
June 03, 2011, 01:16:24 PM
 #4

Quote
To properly resolve this problem try enabling "Map port using UPnP" in Settings->Options. If that doesn't work you'll need to manually open/forward port 8333 from your router to your computer

wouldn't I only need to do something like that if could never get any connections?
i mean, sometimes the thing just works fine.
mewantsbitcoins
Full Member
***
Offline Offline

Activity: 126


View Profile
June 03, 2011, 01:18:45 PM
 #5

This connection problem is due to a slight change in how the client uses IRC to connect. The problem is worsened by a lot of people joining the network but not opening port 8333 so there are more and more nodes wanting to connect, but not enough letting to connect to.

It will be fixed in the near future
trout
Sr. Member
****
Offline Offline

Activity: 326


View Profile
June 03, 2011, 01:23:17 PM
 #6

This connection problem is due to a slight change in how the client uses IRC to connect. The problem is worsened by a lot of people joining the network but not opening port 8333 so there are more and more nodes wanting to connect, but not enough letting to connect to.

It will be fixed in the near future

cool! great to know that the problem is known and being fixed.
trout
Sr. Member
****
Offline Offline

Activity: 326


View Profile
June 03, 2011, 02:30:06 PM
 #7


I enabled that UPnP mapping and suddenly there are over 100 connections.
cool. It even seems bitcoin is throttling my connection a bit now 0.o
genjix
Legendary
*
Offline Offline

Activity: 1232


View Profile
June 03, 2011, 02:33:52 PM
 #8

Try this,

http://forum.bitcoin.org/index.php?topic=11441
Undie
Newbie
*
Offline Offline

Activity: 5


View Profile
June 04, 2011, 06:01:21 AM
 #9

This problem happened to me too. Solved it by opening port 8333.
Then what happened was that I had another computer in the same network I wanted to open another wallet on.

And this computer just remained idle with 0 connections. And I didn't want to use UPnP.


How I solved it:
My network structure is as follows:

10.0.0.1 NAT
10.0.0.2 Computer 1 running bitcoin
10.0.0.3 Computer 2 running bitcoin

Forward port 8333 from NAT to 10.0.0.2 and connections get through.

On Computer 2 launch bitcoin with:   bitcoin -addnode 10.0.0.2  and it recieves blocks from the other computer.

If you want to add additional computers with bitcoin just launch them as well with -addnode 10.0.0.2

I use 10.0.0.X for ease, this might be 192.168.0.X or similar for you.


Hope this helped someone!
carbonpenguin
Full Member
***
Offline Offline

Activity: 157



View Profile
June 04, 2011, 02:44:50 PM
 #10

How does one manually open port 8333 in Ubuntu (11.04)?
mewantsbitcoins
Full Member
***
Offline Offline

Activity: 126


View Profile
June 04, 2011, 08:01:31 PM
 #11

It's your router that you should open/forward port 8333.
Pages: [1]
  Print  
 
Jump to:  

Sponsored by , a Bitcoin-accepting VPN.
Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2006-2009, Simple Machines Valid XHTML 1.0! Valid CSS!