Bitcoin Forum
April 18, 2015, 08:48:54 PM *
News: Latest stable version of Bitcoin Core: 0.10.0 [Torrent]
 
   Home   Help Search Donate Login Register  
Pages: [1] 2 »  All
  Print  
Author Topic: How to Install BFG Miner on your new Raspberry Pi - A Step by Step Guide  (Read 33894 times)
DrGuns4Hands
Jr. Member
*
Offline Offline

Activity: 36


View Profile

Ignore
October 30, 2012, 04:05:54 AM
 #1

These are the instructions for installing BFG Miner on the Raspberry Pi OS (Raspbian “wheezy”)

I would first like to thank the people who in various places have helped with laying out the steps for CGMiner, which with some tweaks worked for BFG
The link to CGMiner's steps can be found here http://techblog.sethleedy.name/?p=24276


You will need to first download the Linux Zip Archive from https://bitcointalk.org/index.php?topic=78192.0. This thread is always updated with both the newest test, and newest stable versions(I would recommend sticking with the stable version unless you are very experienced.


Now that you have the zip file lets get started with the fun stuff Open the Terminal and get ready to punch some code. this isn't the quickest equipment so wait until the next open terminal line appears before continuing through the steps.

1 sudo aptitude update
2 sudo aptitude install autoconf libtool libncurses-dev yasm curl libcurl4-openssl-dev libjansson-dev pkg-config libudev-dev

3a sudo aptitude install libusb-dev      (needed in BFG Miner for ZTEX & X6500 FPGAs board support)(Skip if you don't have/won't be getting one of these boards)

Additional package required for bfgminer-3.3.0:

3b apt-get install uthash-dev

To enable opencl:sensors, apt-get install libsensors4-dev
To enable getwork proxy, apt-get instal libmicrohttpd-dev
To enable stratum proxy, apt-get instal libevent-dev
To enable ztex / x6500, apt-get install libusb-1.0-0-dev

Navigate to where you saved the zip file (I will use the current BFGminer stable version for an example)

4 unzip bfgminer-2.8.3
5 cd bfgminer-2.8.3
6 ./autogen.sh unnecessary
7 ./configure
8 make

If you have not yet hooked up your FPGA to the Pi, now is the time. If you are planning on hooking up multiple FPGA's it is highly recommended to use an externally powered USB Hub.

Step 9 is to determine if the OS recognizes your FPGA and needs to be done from the home location

8 cd (to return to home)
9 ls -l /dev/ttyUSB*

your FPGA's should show up as ttyUSB0, ttyUSB1, etc. Any number is fine as long as there are as many of them as you have units.

If they do not show up here is a link to a thread about that issue. https://bitcointalk.org/index.php?topic=65879.msg915045#msg915045

run BFGMiner the usual way.(sudo ./bfgminer from the bfgminer installed directory) If you do not use sudo it won't save your configuration properly when you go to settings and write config.

Editted: corrections, Stream-Lined, & Tested on Raspberry Pi, all to save you time. ENJOY!

Final Note: I have had 2 Raspberry Pi's burn out with BFL ASIC's. It seems the USB ports just can't handle the I/O. First I had crashes of the mining software, so I forced the Pi to reset itself twice daily which worked as a stop gap, but eventually they fell apart under the weight of the problem. Got a low powered amd apu and motherboard and have been running for months with it just sitting on a table, no maintenance required. At this time I would not recommend purchasing a Raspberry Pi as a control device for ASIC's.

How do you know if someone uses Arch Linux?
They'll tell you.
1429390134
Hero Member
*
Offline Offline

Posts: 1429390134

View Profile Personal Message (Offline)

Ignore
1429390134
Reply with quote  #2

1429390134
Report to moderator
NO BITCOIN? NO PROBLEM! GET $6,888 FREE BONUS! BetCoin™
Advertised sites are not endorsed by the Bitcoin Forum. They may be unsafe, untrustworthy, or illegal in your jurisdiction. Advertise here.
1429390134
Hero Member
*
Offline Offline

Posts: 1429390134

View Profile Personal Message (Offline)

Ignore
1429390134
Reply with quote  #2

1429390134
Report to moderator
Luke-Jr
Legendary
*
Offline Offline

Activity: 1582



View Profile

Ignore
October 30, 2012, 04:23:50 AM
 #2

For normal usage, Debian has replaced apt-get with aptitude a few releases ago. Also, both tools can take any number of packages on the same command. So,
Code:
sudo aptitude update
sudo aptitude install autoconf libtool libncurses-dev yasm curl libcurl4-openssl-dev libjansson-dev libudev-dev libusb-dev

Note that libusb-dev is required for not just Ztex, but also X6500 FPGAs.

Steps 13-17 are all performed by the autogen.sh script, so just run that to automate it Smiley

You don't need to use "make install" (and I'm not sure it actually installs the bitstreams sensible) if you want to run BFGMiner from the source code directory; you can just do:
Code:
./bfgminer

vitruvio
Sr. Member
****
Offline Offline

Activity: 464



View Profile

Ignore
October 31, 2012, 06:17:49 PM
 #3

Thank you, stored in Bookmarks, I own the Rpi, just need the ASIC.

Regards
Phraust
Full Member
***
Offline Offline

Activity: 205


Mostly Harmless...


View Profile WWW

Ignore
November 01, 2012, 12:08:46 AM
 #4

Just wanted to say this is an awesome little bit of help.

I'm not running a Pi, I'm using a DockStar, but it's very similar and it's been so long since I've installed a clean OS it really came in handy.

Some notes:

I am using ArchLinux, so most of the steps are very similar.  However, when I tried running autogen.sh, I was getting errors that were fixed by installing pkg-config (which is in the base-devel package, which I believe this is in build-essential in other distros).

Thanks a ton for putting this together for us!
bitcoindaddy
Sr. Member
****
Offline Offline

Activity: 477


View Profile

Ignore
November 03, 2012, 12:53:50 PM
 #5

Thanks for the guide, it was very helpful.  Can you tell me if you had to snip the 5V line on the USB cable from the powered USB hub to keep the power from flowing back into the Raspberry Pi?

I tried connecting a powered up to the pi but without power and the pi instantly reset, but is fine after booting with it connected. I haven't tried running it powered yet as I've heard bad things about that.
DrGuns4Hands
Jr. Member
*
Offline Offline

Activity: 36


View Profile

Ignore
November 05, 2012, 04:49:01 AM
 #6

I'm using a powered USB hub and the only thing I noticed is that power will flow backwards from the hub so to do a restart you give the sudo halt command to shut down the Pi. Then you disconnect the Power and unplug the USB Hub then re-plugging them in will let it boot right up. I don't believe mine will start up with the USB plugged in without the additional Power line feeding the hub. The raspberry pi was a minimalist design and wasn't made to handle much power draw by peripherals. This is the USB Hub I am using and I've had 0 issues http://www.amazon.com/10-Port-USB-2-0-Hub/dp/B00475WJEY/ref=sr_1_13?s=electronics&ie=UTF8&qid=1352091861&sr=1-13&keywords=usb+hub

How do you know if someone uses Arch Linux?
They'll tell you.
mightycount
Member
**
Offline Offline

Activity: 101



View Profile

Ignore
November 20, 2012, 11:41:14 PM
 #7

Awesome stuff, thanks!

Personal Bitcoin Black List - Companies and people to avoid!
````` Butterfly Labs...MtGox...ragingazn628...(reserved)...  `````
kidgorgeous
Member
**
Offline Offline

Activity: 75


View Profile

Ignore
November 21, 2012, 02:10:54 AM
 #8

I was having trouble getting my raspberry pi to recognize my BFL's. After some fiddling and alot of reading, it came down to running:
Code:
$sudo usermod <username> -a -G dialout
.

1KHxCRniFNmS7ChiPqaewmokuCABk2PRQn
zxyzxy
Full Member
***
Offline Offline

Activity: 132


View Profile

Ignore
November 21, 2012, 08:04:06 AM
 #9

will this work on hackberry or other similar  alternatives?
Martin666
Jr. Member
*
Offline Offline

Activity: 49



View Profile

Ignore
November 23, 2012, 01:37:49 AM
 #10

Did you get it to work on your hackberry ?
Berni
Full Member
***
Offline Offline

Activity: 125


View Profile

Ignore
November 24, 2012, 09:26:02 PM
 #11

Did you get it to work on your hackberry ?

I installed Debian Wheezy on my hackberry with cgminer 2.9.4.
cpu-mining is successfull, USB-Miner i can't test, because i'm waiting for my bASICs. Sad
I hope it works fine  Sad
techman05
Hero Member
*****
Offline Offline

Activity: 546


View Profile WWW

Ignore
August 26, 2013, 09:45:57 PM
 #12

For this do I have to designate the devices if I have multiple or will bfg miner see them and use them as needed for mining? Right now I'm planning to install an eroupter if I can get my hands on one after my coins settle and hopefully be able to run it alongside a butterfly labs asic device once I get it. I'm hoping I can run both on startup with whatever pools I want.

Both will be on a powered hub

Thanks

Like the info address for potential tips Wink
BTC 1CL5BnNhdL2wDVmSDwMbW1cNhZew87CAPV
* http://www.miningrigrentals.com/register?ref=563
TheSpiral
Full Member
***
Offline Offline

Activity: 182



View Profile WWW

Ignore
August 26, 2013, 10:52:40 PM
 #13

For this do I have to designate the devices if I have multiple or will bfg miner see them and use them as needed for mining? Right now I'm planning to install an eroupter if I can get my hands on one after my coins settle and hopefully be able to run it alongside a butterfly labs asic device once I get it. I'm hoping I can run both on startup with whatever pools I want.

Both will be on a powered hub

Thanks
It should recognize them. I got a few erupters and they run just fine. From the readme:
Quote
ASIC/FPGA mining boards (BitForce, Icarus, ModMiner, X6500, ZTEX) only options:

--scan-serial|-S <arg> Serial port to probe for mining devices

To use ASICs or FPGAs, you will need to be sure the user BFGMiner is running as
has appropriate permissions. This varies by operating system.
On Gentoo: sudo usermod <username> -a -G uucp
On Ubuntu: sudo usermod <username> -a -G dialout
Note that on GNU/Linux systems, you will usually need to login again before
group changes take effect.

By default, BFGMiner will scan for autodetected devices unless at least one -S
is specified for that driver. If you specify -S and still want BFGMiner to scan,
you must also use "-S auto". If you want to prevent BFGMiner from scanning
without specifying a device, you can use "-S noauto". Note that presently,
autodetection only works on Linux, and might only detect one device depending
on the version of udev being used. If you want to scan all serial ports, you
can use "-S all"; note that this may write data to non-mining devices which may
then behave in unexpected ways!

On Linux, <arg> is usually of the format /dev/ttyUSBn
On Mac OS X, <arg> is usually of the format /dev/cu.usb*
On Windows, <arg> is usually of the format \\.\COMn
(where n = the correct device number for the device)

The official supplied binaries are compiled with support for all ASICs/FPGAs.
To force the code to only attempt detection with a specific driver,
prepend the argument with the driver name followed by a colon.
For example, "icarus:/dev/ttyUSB0" or "bitforce:\\.\COM5"
or using the short name: "ica:/dev/ttyUSB0" or "bfl:\\.\COM5"

Some FPGAs do not have non-volatile storage for their bitstreams and must be
programmed every power cycle, including first use. To use these devices, you
must download the BFGMiner source archive (bfgminer-x.y.z.zip) and copy the
"bitstreams" directory into your BFGMiner application directory.

See README.ASIC and README.FPGA for more information regarding these.
I just ran bfgminer with "-S all" and it was just fine.

[Cex.io] - Cheap virtual mining.
village.idiot
Sr. Member
****
Offline Offline

Activity: 271


View Profile

Ignore
September 22, 2013, 12:40:24 AM
 #14

I'm hoping this will get me mining on the Pi with my ASIC.
I really appreciate the well written Guide.  Even I could follow it.
With an exception...
I got to 6 ./autogen.sh
and got back...
Getting submodules...
fatal: Not a git repository (or any of the parent directories): .git

I did see the post from Phraust,
but don't understand what it means I should do.
Unfortunately, I don't speak Linux.

Someone please guide me a little.

Edit: forgot to mention - I'm using 2013-09-10-wheezy-raspbian and bfgminer-3.2.1
Luke-Jr
Legendary
*
Offline Offline

Activity: 1582



View Profile

Ignore
September 22, 2013, 01:08:56 AM
 #15

I'm hoping this will get me mining on the Pi with my ASIC.
I really appreciate the well written Guide.  Even I could follow it.
With an exception...
I got to 6 ./autogen.sh
and got back...
Getting submodules...
fatal: Not a git repository (or any of the parent directories): .git

I did see the post from Phraust,
but don't understand what it means I should do.
Unfortunately, I don't speak Linux.

Someone please guide me a little.

Edit: forgot to mention - I'm using 2013-09-10-wheezy-raspbian and bfgminer-3.2.1
Skip autogen, it's not supposed to be used with zips.

village.idiot
Sr. Member
****
Offline Offline

Activity: 271


View Profile

Ignore
September 22, 2013, 01:20:31 AM
 #16

Thanks Luke.
That go me a step farther.
Now I got
configure: error: Could not find HASH_ITER - please install uthash-dev 1.9.2+

tried
install uthash-dev 1.9.2+
but, of course, that didn't work.

Don'cha just hate newbies
Luke-Jr
Legendary
*
Offline Offline

Activity: 1582



View Profile

Ignore
September 22, 2013, 01:40:12 AM
 #17

Thanks Luke.
That go me a step farther.
Now I got
configure: error: Could not find HASH_ITER - please install uthash-dev 1.9.2+

tried
install uthash-dev 1.9.2+
but, of course, that didn't work.

Don'cha just hate newbies
sudo aptitude install uthash-dev

village.idiot
Sr. Member
****
Offline Offline

Activity: 271


View Profile

Ignore
September 22, 2013, 03:11:51 AM
 #18

IT'S WORKING!!

Luke, you're my hero!  I wanna have your baby. Uh, wait.  Think I'll just send you some bitcoin.
Thank you
Thank you
Thank you
Thank you
birkomester
Full Member
***
Offline Offline

Activity: 168


View Profile WWW

Ignore
November 07, 2013, 06:03:48 PM
 #19

Ty for the guide, it worked!!!c

▄▄▄▄▄▄▄▄▄▄▄▄▄▄▄▄▄▄▄▄▄▄▄▄▄▄▄▄▄▄▄▄▄▄▄▄▄▄▄▄▄
PRIMEDICE
The Premier Bitcoin Gambling Experience @PrimeDice
▀▀▀▀▀▀▀▀▀▀▀▀▀▀▀▀▀▀▀▀▀▀▀▀▀▀▀▀▀▀▀▀▀▀▀▀▀▀▀▀▀
rallasnackbar
Full Member
***
Offline Offline

Activity: 196


View Profile

Ignore
January 24, 2014, 02:35:58 PM
 #20

I know this is an old post. But i just cant get this to work, and searching googe dosnt help me either.

at 9 ls -l /dev/ttyUSB*

i get this return

ls: cannot access /dev/ttyUSB*: No such file or directory
Pages: [1] 2 »  All
  Print  
 
Jump to:  

Sponsored by , a Bitcoin-accepting VPN.
Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2006-2009, Simple Machines Valid XHTML 1.0! Valid CSS!