Bitcoin Forum
June 19, 2018, 01:10:36 PM *
News: Latest stable version of Bitcoin Core: 0.16.1  [Torrent]. (New!)
 
   Home   Help Search Donate Login Register  
Pages: « 1 [2] 3 »  All
  Print  
Author Topic: How to Install BFG Miner on your new Raspberry Pi - A Step by Step Guide  (Read 62620 times)
Cactusizer
Jr. Member
*
Offline Offline

Activity: 51
Merit: 0


View Profile
March 06, 2014, 10:08:04 AM
 #21

I had problems with cgminer on my rasp pi so I will be looking forward to testing bfgminer on my rasp pi.

1529413836
Hero Member
*
Offline Offline

Posts: 1529413836

View Profile Personal Message (Offline)

Ignore
1529413836
Reply with quote  #2

1529413836
Report to moderator
1529413836
Hero Member
*
Offline Offline

Posts: 1529413836

View Profile Personal Message (Offline)

Ignore
1529413836
Reply with quote  #2

1529413836
Report to moderator
The World's Betting Exchange

Bet with play money. Win real Bitcoin. 5BTC Prize Fund for World Cup 2018.

Advertised sites are not endorsed by the Bitcoin Forum. They may be unsafe, untrustworthy, or illegal in your jurisdiction. Advertise here.
village.idiot
Sr. Member
****
Offline Offline

Activity: 270
Merit: 250


View Profile
March 06, 2014, 12:33:04 PM
 #22

I'm still using bfgminer-3.2.1 and it's working just fine.
Not producing much at 30Gh/s, but still running.
Cassey
Sr. Member
****
Offline Offline

Activity: 470
Merit: 250

Better to have 100 friends than 100 rubles


View Profile
May 08, 2014, 04:51:52 PM
 #23

For what its worth, I just placed my 16GB Gentoo Raspberry PI with 3.99.0 of bfgminer installed up on Vuze (torrent).  It compresses down to a bit over 1gb, can be unzipped and dd'ed directly to a 16gb sdhc card.

Search for "GentooPIimage080514.gz" - with luck you will find it.

Cassey
Buchi-88
Legendary
*
Offline Offline

Activity: 1638
Merit: 1021


ELYSIAN | Pre-TGE 5.21.2018 | TGE 6.04.2018


View Profile
June 17, 2014, 09:32:23 PM
 #24

Thanks Luke.
That go me a step farther.
Now I got
configure: error: Could not find HASH_ITER - please install uthash-dev 1.9.2+

tried
install uthash-dev 1.9.2+
but, of course, that didn't work.

Don'cha just hate newbies

but

Quote
root@sunwatch:~# sudo aptitude install uthash-dev
No packages will be installed, upgraded, or removed.
0 packages upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
Need to get 0 B of archives. After unpacking 0 B will be used.

and than
Quote
cd /usr/src

wget http://luke.dashjr.org/programs/bitcoin/files/bfgminer/4.2.0/bfgminer-4.2.0.zip

unzip bfgminer-4.2.0.zip && mv bfgminer-4.2.0 bfgminer

cd bfgminer

sudo ./configure

sudo make

always the same and I don't know?Huh
Code:
checking whether HASH_ITER is declared... no
configure: error: Could not find HASH_ITER - please install uthash-dev 1.9.4+

On my Pi is the newest Kernel!?

greets








████████████████     ██                ██              ██    ▄████████████████      ████████████████     ▄████████████████▄    █████████████████▄
                     ██                ██              ██                                                                ██                    ██
                     ██                ██              ██                                                                ██                    ██
                     ██                ▀████████████████▀    ▄████████████████▄            ██             █████████████████     ██             ██
█████████████        ██                        ██                            ██            ██             ██             ██     ██             ██
██                   ██                        ██                            ██            ██             ██             ██     ██             ██
██                   ██                        ██                            ██            ██             ██             ██     ██             ██
██                   ██                        ██                            ██            ██             ██             ██     ██             ██
████████████████     ████████████████          ██             ████████████████▀     ████████████████      ██             ██     ██             ██
 
█     █
█    █
█    █
█    █
█    █
█    █
█    █
  
█    █
█    █
█    █
█    █
█    █
█    █
█     █

█     █
█    █
█    █
█    █
█    █
█    █
█    █
  
█    █
█    █
█    █
█    █
█    █
█    █
█     █
▄▄█████████▄▄
▄█████████████████▄
▄█████████████████████▄
████████████████▀▀  █████
█████████████▀▀      ██████
██████████▀▀    ▄     ███████
███████▀▀     ▄█▀     █████████
███▀▀      ▄██▀       █████████
█████▄    ██▀        ██████████
████████ █          █████████
███████ █ ▄███▄▄   ████████
████████████████▄▄███████
▀█████████████████████▀
▀█████████████████▀
▀▀█████████▀▀
TOKEN GENERATION EVENT
JUNE 4 UNTIL JUNE 24  [ WHITEPAPER ]
[TWITTER] [FACEBOOK] [REDDIT] [STEEMIT]
dmz241
Hero Member
*****
Offline Offline

Activity: 506
Merit: 502

http://www.certify.pk


View Profile WWW
June 23, 2014, 05:20:35 AM
 #25

Hey all. I am completely new to linux and pretty much asics. I picked up a pi and have 2 usb dualminer sticks that I want to run in scrypt only mode.
I have latest Raspbein OS installed.
I did the first 2 steps.
As I know I need bfgminer 4.0+ as thats the one that supports it I believe. Can anyone tell me how to proceed from here. I am connected to the pi through putty.

Cassey
Sr. Member
****
Offline Offline

Activity: 470
Merit: 250

Better to have 100 friends than 100 rubles


View Profile
June 23, 2014, 02:44:54 PM
 #26

Hey all. I am completely new to linux and pretty much asics. I picked up a pi and have 2 usb dualminer sticks that I want to run in scrypt only mode.
I have latest Raspbein OS installed.
I did the first 2 steps.
As I know I need bfgminer 4.0+ as thats the one that supports it I believe. Can anyone tell me how to proceed from here. I am connected to the pi through putty.

Suggest popping over to http://asic.usertalk.info/index.php?topic=66.0 and reading the 2nd post in that thread.  It should get you started.

Cassey
Sysop @ asic.usertalk.info

Cassey
dmz241
Hero Member
*****
Offline Offline

Activity: 506
Merit: 502

http://www.certify.pk


View Profile WWW
June 27, 2014, 07:31:44 AM
 #27

Hey all. I am completely new to linux and pretty much asics. I picked up a pi and have 2 usb dualminer sticks that I want to run in scrypt only mode.
I have latest Raspbein OS installed.
I did the first 2 steps.
As I know I need bfgminer 4.0+ as thats the one that supports it I believe. Can anyone tell me how to proceed from here. I am connected to the pi through putty.

Suggest popping over to http://asic.usertalk.info/index.php?topic=66.0 and reading the 2nd post in that thread.  It should get you started.

Cassey
Sysop @ asic.usertalk.info

Thanks for the time being I am running the antminer u2s on the pie dualminers on pc thats always on.

rumjar86
Newbie
*
Offline Offline

Activity: 15
Merit: 0


View Profile
July 11, 2015, 12:15:24 AM
 #28

hey guys, I know this is an older thread but I just have finally got off my but and started getting into the mining again. I just picked up a Pi, a Bitfury M-card (v3.0) and a bunch of H-cards v2.2, I was just wondering if anyone would have any info on how to get bfgminer to detect the cards? or if I should go to another mining software.
please the info on these kinds of cards is rare as but there are so many of these cards floating around on ebay and all over the forum. cheers
Josh
Luke-Jr
Legendary
*
Offline Offline

Activity: 2366
Merit: 1001



View Profile
July 11, 2015, 12:25:16 AM
 #29

hey guys, I know this is an older thread but I just have finally got off my but and started getting into the mining again. I just picked up a Pi, a Bitfury M-card (v3.0) and a bunch of H-cards v2.2, I was just wondering if anyone would have any info on how to get bfgminer to detect the cards? or if I should go to another mining software.
please the info on these kinds of cards is rare as but there are so many of these cards floating around on ebay and all over the forum. cheers
Josh
I'm not sure you can mix cards of different versions like that.
IF it works, it would be using ./configure --enable-bfsb and then at runtime bfgminer -S bfsb:auto

amrulshare
Hero Member
*****
Offline Offline

Activity: 686
Merit: 505



View Profile WWW
July 11, 2015, 10:23:21 AM
 #30

Thank You for Sharing , I now understand how to install it , it is very helpful for beginners like me  Wink

▄███▄
███████▄
██████▀██▄
█████▄  ▀██▄
████▀  ▄  ▀██▄
███▄ ▄██▀   ▀
██████▀  ▄█▄
███████▄█████▄
███████████████▄
████████████████▀
█████████▀
███████▀
 ▀███▀
Safein     
.M A K E   I S I M P L E.
A   R E V O L U T I O N A R Y   W A Y   T O   P A Y   O N L I N E
.
[WHITEPAPER]
▬▬▬▬▬▬▬▬▬▬▬▬▬▬

██
██
██
██
██
██
██
██
██
██
██
▄█████████████████████████▄
███████████████████████████
████████████████▀░░░░░▐████
███████████████░░░░░░░▐████
██████████████▌░░░▐████████
██████████████▌░░░▐████████
███████████░░░░░░░░░░░█████
███████████░░░░░░░░░░▐█████
██████████████▌░░░▐████████
██████████████▌░░░▐████████
██████████████▌░░░▐████████
██████████████▌░░░▐████████
▀█████████████▌░░░▐███████▀

██
██
██
██
██
██
██
██
██
██
██
▄█████████████████████████▄
███████████████████████████
███████████████████████████
██████▀███████▀░░░▀▀▀▄█████
█████▌░░▀▀███▌░░░░░░░▄█████
█████▀░░░░░░░░░░░░░░░██████
█████▄░░░░░░░░░░░░░░███████
██████▄░░░░░░░░░░░░████████
███████▄▄░░░░░░░░▄█████████
██████▄░░░░░░░▄████████████
███████████████████████████
███████████████████████████
▀█████████████████████████▀

██
██
██
██
██
██
██
██
██
██
██
▄█████████████████████████▄
███████████████████████████
███████████████████████████
██████████████████▀▀███████
█████████████▀▀▀░░░░███████
████████▀▀▀░░░▄▀░░░████████
█████▄░░░░░▄█▀░░░░░████████
████████▄░█▀░░░░░░█████████
█████████▌▐░░░░░░░█████████
██████████░▄██▄░░██████████
████████████████▄██████████
███████████████████████████
▀█████████████████████████▀

██
██
██
██
██
██
██
██
██
██
██
A
▬▬

█▄▄
██████▄▄
██████████▄▄
██████████████▄▄
██████████████████▄▄
█████████████████████
██████████████████▀▀
██████████████▀▀
██████████▀▀
██████▀▀
█▀▀
.GET IT ON               
Google Play
work2coin
Newbie
*
Offline Offline

Activity: 4
Merit: 0


View Profile
January 04, 2016, 12:13:05 PM
 #31

sudo apt-get install bfminer

And enjoy!  Wink
Ahkmar
Newbie
*
Offline Offline

Activity: 1
Merit: 0


View Profile
March 21, 2016, 01:22:25 PM
 #32

Could we get updated instructions for the newer hardware & software?

I'm using the newer Jessie on a Pi 2 and I'm having some difficulty. For me, step 5 comes back with something about bfgminer not being a valid directory. I'm not sure what I'm doing wrong, but this learning process has been frustrating. Could somebody help me out?
deltalima
Jr. Member
*
Offline Offline

Activity: 43
Merit: 0


View Profile
March 29, 2016, 08:08:24 PM
 #33

For me, step 5 comes back with something about bfgminer not being a valid directory.
Could somebody help me out?

Please post the exact error message and someone will be able to help.

1BitCoinLSc864UEc3qE5E7iV3BXd6M4Xk
toptek
Legendary
*
Offline Offline

Activity: 1274
Merit: 1000


View Profile
March 31, 2016, 03:36:54 PM
 #34

sudo apt-get install bfminer

And enjoy!  Wink


as far as i know
Code:
sudo apt-get install bfminer
  only work with ubuntu but yea it's that easy just do
Code:
sudo apt-get install bfminer
at a ssh command if your using ssh with ubuntu and your set .

For security, your account has been locked. Email acctcomp15@theymos.e4ward.com
toptek
Legendary
*
Offline Offline

Activity: 1274
Merit: 1000


View Profile
March 31, 2016, 03:40:03 PM
 #35

Code:
cd /home

sudo apt-get install -y build-essential autoconf automake libtool pkg-config libcurl4-gnutls-dev libjansson-dev uthash-dev libncursesw5-dev libudev-dev libusb-1.0-0-dev libevent-dev libmicrohttpd-dev


sudo git clone https://github.com/luke-jr/bfgminer.git

cd /bfgminer

sudo ./autogen.sh
sudo chmod +x ./configure  
sudo ./configure CFLAGS="-O2" --enable-scrypt --enable-broad-udevrules
or use
sudo ./configure  (defaults are used)
make
sudo ldconfig
lsusb
sudo chmod 777 bfgminer

sudo ./bfgminer --version
 
sudo bfgminer or sudo ./bfgminer or sudo /bfgminer --scrypt -o stratum+tcp://your pool:port -u user id  -p x  your miners setting.

or for sha256 coin mining aka btc

sudo bfgminer or sudo ./bfgminer or sudo /bfgminer -o stratum+tcp://your pool:port -u user id  -p x  your miners setting.


For security, your account has been locked. Email acctcomp15@theymos.e4ward.com
xchakg
Newbie
*
Offline Offline

Activity: 10
Merit: 0


View Profile
April 07, 2016, 09:48:30 AM
 #36

hi, I have a pi-2 and the newest bfgminer, + the pi is recognizing my usb hub, but its not
recognizing the avalon-2 sticks.

any suggestions?

i've tried many + still trying. Smiley

thank you
toptek
Legendary
*
Offline Offline

Activity: 1274
Merit: 1000


View Profile
April 07, 2016, 09:37:29 PM
 #37

hi, I have a pi-2 and the newest bfgminer, + the pi is recognizing my usb hub, but its not
recognizing the avalon-2 sticks.

any suggestions?

i've tried many + still trying. Smiley

thank you


make sure if you compiled your own BFG  it has  --enable-avalon the readme says it is on by default but it might be wise to compile it on any way

in the bfg folder do a version check it tells, if the --enable-avalon driver is on .

Code:
sudo ./bfgminer --version or bfgminer --version or sudo bfgminer --version or sudo /bfgminer --version

if it is, do a hub check

Code:
sudo ldconfig
lsusb

lsusb should list all the hubs plugged in to that pi .


if all that checks out try in the BFG folder


Code:
cd to your bfgminer

sudo apt-get remove libblkmaker-0.1-dev
sudo apt-get purge libblkmaker-0.1-dev
sudo apt-get install build-essential autoconf automake libtool pkg-config libcurl4-gnutls-dev libjansson-dev uthash-dev libncurses5-dev libudev-dev libusb-1.0-0-dev libevent-dev libgcrypt20-dev

sudo ./autogen.sh -rpath-link
sudo chmod +x ./configure  
sudo ./configure CFLAGS="-O2" --enable-avalon --enable-broad-udevrules
make
sudo make install
sudo ldconfig
then try the miner .


beyond that

check power to hub , does the pi really support it, Ive had a few hubs not work with RPI and BFG but do with other PI type PC'c even after i did a hub check .


For security, your account has been locked. Email acctcomp15@theymos.e4ward.com
xchakg
Newbie
*
Offline Offline

Activity: 10
Merit: 0


View Profile
April 08, 2016, 01:33:12 AM
 #38

hi, I have a pi-2 and the newest bfgminer, + the pi is recognizing my usb hub, but its not
recognizing the avalon-2 sticks.

any suggestions?

i've tried many + still trying. Smiley

thank you


make sure if you compiled your own BFG  it has  --enable-avalon the readme says it is on by default but it might be wise to compile it on any way

in the bfg folder do a version check it tells, if the --enable-avalon driver is on .

Code:
sudo ./bfgminer --version or bfgminer --version or sudo bfgminer --version or sudo /bfgminer --version

if it is, do a hub check

Code:
sudo ldconfig
lsusb

lsusb should list all the hubs plugged in to that pi .


if all that checks out try in the BFG folder


Code:
cd to your bfgminer

sudo apt-get remove libblkmaker-0.1-dev
sudo apt-get purge libblkmaker-0.1-dev
sudo apt-get install build-essential autoconf automake libtool pkg-config libcurl4-gnutls-dev libjansson-dev uthash-dev libncurses5-dev libudev-dev libusb-1.0-0-dev libevent-dev libgcrypt20-dev

sudo ./autogen.sh -rpath-link
sudo chmod +x ./configure  
sudo ./configure CFLAGS="-O2" --enable-avalon --enable-broad-udevrules
make
sudo make install
sudo ldconfig
then try the miner .


beyond that

check power to hub , does the pi really support it, Ive had a few hubs not work with RPI and BFG but do with other PI type PC'c even after i did a hub check .



thank you = i'm going to go give this a try Smiley

looks like theres a few new commands that i see here from what i've tried so far.


thank you
hashgoalPool
Full Member
***
Offline Offline

Activity: 170
Merit: 100



View Profile
October 24, 2016, 02:11:21 PM
 #39

i am having asic mining technology scrypt 256Mh . how can i install bfgminer on Raspberry Pi ?

toptek
Legendary
*
Offline Offline

Activity: 1274
Merit: 1000


View Profile
October 24, 2016, 05:36:50 PM
 #40

What miner ? . yup  it's a MAT MINER  Smiley.  Mining ASICs Technologies follow below


for the latest BFG to work you have to flash each board with a flasher you can only get here https://litecointalk.org/index.php?topic=27370.0 you have to ask

jstefanop

 to send it hell probable want to sell it , then follow https://litecointalk.org/index.php?topic=27370.0 his post, it tells you how to flash it.

Then follow my post here https://bitcointalk.org/index.php?topic=1468120.0  it will tell you how to hook  up a AlcheMiner/MAT miner to use any PI type PC or PC you want  , they are the same miner with different names.


if the boards are all ready flashed then compile bfg like my post said, your set . why i said my post is   BFG doesn't have all the fixes pulled or  not  all the fixes jstefanop did are in the master bfg  yet once it is you can just install/compile BFG the normal way by  following this post but make sure to use this when you do compile it

Code:
chmod +x ./configure
./configure CFLAGS="-O2" --enable-scrypt --enable-alchemist
mainly this
Code:
--enable-alchemist
it is off in BFG by default and that works with Mat miners  remember they are  the same miner AlcheMiner or MAT aka Mining ASICs Technologies .


 BFG is free, the Flasher is not, unless jstefanop gives it a way freely .The flasher is a paid for updated firmware that lets you use the free updated BFG drivers ( jstefanop did also) with those miners that fixed all  most every issue those miners had.


thanks top

For security, your account has been locked. Email acctcomp15@theymos.e4ward.com
Pages: « 1 [2] 3 »  All
  Print  
 
Jump to:  

Sponsored by , a Bitcoin-accepting VPN.
Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2006-2009, Simple Machines Valid XHTML 1.0! Valid CSS!