Bitcoin Forum
June 24, 2018, 04:42:01 PM *
News: Latest stable version of Bitcoin Core: 0.16.1  [Torrent]. (New!)
 
   Home   Help Search Donate Login Register  
Pages: [1]
  Print  
Author Topic: Connect Client Over Internet  (Read 813 times)
Mobotek
Newbie
*
Offline Offline

Activity: 18
Merit: 0


View Profile
June 06, 2011, 05:52:41 PM
 #1

So I am trying to connect my client which is running at work to my home Bitcoin node. My Firewall is off, AV is turned off and I have port forwarding setup on my router to port 8332. I have a username and password setup on my Bitcoin node along with allowip = *. When I try to connect I get error that I cant connect to the RPC Server. I did some port scanning and on port 8332 it says connection rejected. Any one have any ideas why I cant connect the client back home from work? P.S. I am the network Admin here so i know I am on a unfiltered/ no firewall connection.
1529858521
Hero Member
*
Offline Offline

Posts: 1529858521

View Profile Personal Message (Offline)

Ignore
1529858521
Reply with quote  #2

1529858521
Report to moderator
1529858521
Hero Member
*
Offline Offline

Posts: 1529858521

View Profile Personal Message (Offline)

Ignore
1529858521
Reply with quote  #2

1529858521
Report to moderator
The World's Betting Exchange

Bet with play money. Win real Bitcoin. 5BTC Prize Fund for World Cup 2018.

Advertised sites are not endorsed by the Bitcoin Forum. They may be unsafe, untrustworthy, or illegal in your jurisdiction. Advertise here.
1529858521
Hero Member
*
Offline Offline

Posts: 1529858521

View Profile Personal Message (Offline)

Ignore
1529858521
Reply with quote  #2

1529858521
Report to moderator
1529858521
Hero Member
*
Offline Offline

Posts: 1529858521

View Profile Personal Message (Offline)

Ignore
1529858521
Reply with quote  #2

1529858521
Report to moderator
mewantsbitcoins
Full Member
***
Offline Offline

Activity: 126
Merit: 100


View Profile
June 06, 2011, 06:05:09 PM
 #2

Did you start your node with -server
Mobotek
Newbie
*
Offline Offline

Activity: 18
Merit: 0


View Profile
June 06, 2011, 06:19:51 PM
 #3

Yup. I have a localhost GUIMiner running as well and that connects fine.
mewantsbitcoins
Full Member
***
Offline Offline

Activity: 126
Merit: 100


View Profile
June 06, 2011, 06:26:23 PM
 #4

Wrong syntax. It should be rpcallowip=
https://en.bitcoin.it/wiki/Running_Bitcoin

# By default, only RPC connections from localhost are allowed.  Specify
 # as many rpcallowip= settings as you like to allow connections from
 # other hosts (and you may use * as a wildcard character):
 #rpcallowip=10.1.1.34
 #rpcallowip=192.168.1.*
Mobotek
Newbie
*
Offline Offline

Activity: 18
Merit: 0


View Profile
June 06, 2011, 06:45:35 PM
 #5

Worked that time! Thanks man!
Pages: [1]
  Print  
 
Jump to:  

Sponsored by , a Bitcoin-accepting VPN.
Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2006-2009, Simple Machines Valid XHTML 1.0! Valid CSS!