Bitcoin Forum
December 14, 2017, 07:01:39 AM *
News: Latest stable version of Bitcoin Core: 0.15.1  [Torrent].
 
   Home   Help Search Donate Login Register  
Pages: « 1 2 3 [4]  All
  Print  
Author Topic: Warning about portable versions  (Read 122933 times)
Alex456789
Newbie
*
Offline Offline

Activity: 2


View Profile
November 06, 2017, 08:07:13 AM
 #61

Having downloaded the 3.0.0 portable version of Electrum, I found the mistake while installing. My Windows XP Professional SP3 said that the program electrum-3.0.0-portable.exe is not the Win32 application. What must I do with it?

The version electrum-2.9.3-portable.exe works well.

Thank you for your answers beforehand.
Advertised sites are not endorsed by the Bitcoin Forum. They may be unsafe, untrustworthy, or illegal in your jurisdiction. Advertise here.
1513234899
Hero Member
*
Offline Offline

Posts: 1513234899

View Profile Personal Message (Offline)

Ignore
1513234899
Reply with quote  #2

1513234899
Report to moderator
1513234899
Hero Member
*
Offline Offline

Posts: 1513234899

View Profile Personal Message (Offline)

Ignore
1513234899
Reply with quote  #2

1513234899
Report to moderator
1513234899
Hero Member
*
Offline Offline

Posts: 1513234899

View Profile Personal Message (Offline)

Ignore
1513234899
Reply with quote  #2

1513234899
Report to moderator
HCP
Sr. Member
****
Online Online

Activity: 448

<insert witty quote here>


View Profile
November 07, 2017, 11:43:56 AM
 #62

You have several options:

1. Upgrade your operating system... it is horribly outdated Tongue
2. Downgrade to v2.9.3... v3.0.0 has issues with older versions of windows (it only runs on Windows 10)
3. Try and use the newly released v3.0.1... it had some fixes to try and fix the issues v3.x is having on older windows, but you might need to install some windows updates:

Note: Some old versions of Windows might need to install the KB2999226 Windows update.

EDIT: I've tested v3.0.1 on Windows 7... got the Python35.dll error... then I installed the latest VC++ redist package (I used Visual Studio 2017 package from here: https://support.microsoft.com/en-us/help/2977003/the-latest-supported-visual-c-downloads) and that fixed the error! Wink

Sauaba
Newbie
*
Offline Offline

Activity: 3


View Profile
November 07, 2017, 06:42:33 PM
 #63

Hi guys.
I´m using the portable version just on my computer. But I want to know how do I update the portable version? ATM I´m using v2.9.3. Some portable Software I just download a new version, extract and copy it to my current version overwriting the old files. Does it work with Electrum portable too?
Thanks
HCP
Sr. Member
****
Online Online

Activity: 448

<insert witty quote here>


View Profile
November 08, 2017, 01:24:36 AM
 #64

That is exactly how Electrum Portable works. You can just download the new version of Electrum portable from here (https://electrum.org/#download) and away you go...

NOTE: there are some issues with v3.0.1 on older versions of Windows like Win7/8, (you'll get a Python35.dll error)... If this occurs, you need to install the latest VC++ redist package (I used Visual Studio 2017 package from here: https://support.microsoft.com/en-us/help/2977003/the-latest-supported-visual-c-downloads) which should fix the error.

Thirdspace
Sr. Member
****
Offline Offline

Activity: 462


Mixing reinvented for your privacy | chipmixer.com


View Profile
November 08, 2017, 03:52:01 AM
 #65

Having downloaded the 3.0.0 portable version of Electrum, I found the mistake while installing. My Windows XP Professional SP3 said that the program electrum-3.0.0-portable.exe is not the Win32 application. What must I do with it?

The version electrum-2.9.3-portable.exe works well.

Thank you for your answers beforehand.

How did you manage to get it running on your WinXP SP3? I got "python27.dll (error code 14001)"
I checked the reddit discussion electrum_fatal_error_fix_re_python27dll but still couldn't figure out how to solve it

Note: Some old versions of Windows might need to install the KB2999226 Windows update.
I searched on KB2999226 and found it only applies to Win Vista up to 8.1 2999226/update-for-universal-c-runtime-in-windows
any tips on how to get it working on XP (I know I should buy new pc & windows or other OS linux etc)  Grin Tongue

HCP
Sr. Member
****
Online Online

Activity: 448

<insert witty quote here>


View Profile
November 08, 2017, 09:43:06 AM
 #66

The simple answer is that you don't get it working on WinXP... Unfortunately that OS is just way to old and outdated to have any sort of support and the chances of any "modern" working on XP get less and less as time goes by Undecided

So, you either need to continue using v2.9.3 or you update your OS... pretty simple really

Thirdspace
Sr. Member
****
Offline Offline

Activity: 462


Mixing reinvented for your privacy | chipmixer.com


View Profile
November 08, 2017, 10:18:22 AM
 #67

I was trying with earlier version v2.9.2 when I get python27.dll error
that's why I asked him, Alex456789, on how he gets it running
I never actually get any electrum version running successfully
I'm considering running linux OS live on USB stick for linux electrum
if that is too much hassle or I have trouble, I probably go with easiest way android electrum

Alex456789
Newbie
*
Offline Offline

Activity: 2


View Profile
November 08, 2017, 11:50:08 AM
 #68

The KB2999226 Windows update is used for Windows Vista as minimum. As I understand it cannot be used for Windows XP.

I want to ask.

If I continue using the 2.9.3 version of portable Electrum, can I receive coins after hard fork of Bitcoin SegWit2x in this November?

How did you manage to get it running on your WinXP SP3?

The version 2.9.3 runs on WinXP if it is portable only. The full version of Electrum is not running. In order to install it, I have used the following site:
http://hyiphunter.org/bitkoin-koshelek-electrum-otzyvy-kak-polzovatsya/

It is in Russian. If you know this language, you may read the dialogues after the article. If not, you may watch the screenshots in the article which show the way of installing.

Some thoughts from the dialogues after the article:

a) Do not use the spaces in the folder of installing the Electrum. For example, do not install it in C:/Program Files/Electrum, because there is a space between the word "Program" and the word "Files".

b) Do not rename the file which you downloaded from the site electrum.org

c) Install the wallet in the same folder where the installing file is located only. For examle. If you download the 2.9.3 portable file from the site electrum.org into the folder C:/Electrum, you need to install the program in the same folder C:/Electrum.
HCP
Sr. Member
****
Online Online

Activity: 448

<insert witty quote here>


View Profile
November 08, 2017, 07:57:56 PM
 #69

If I continue using the 2.9.3 version of portable Electrum, can I receive coins after hard fork of Bitcoin SegWit2x in this November?
Well, that's no longer an issue now... the hard fork has been cancelled!

https://medium.com/@OneMorePeter/onwards-all-in-on-segwit-9e7cb3faa73d
https://techcrunch.com/2017/11/08/segwit2x-backers-cancel-plans-for-bitcoin-hard-fork/

Sanity has prevailed.

forensick
Sr. Member
****
Offline Offline

Activity: 260



View Profile
November 10, 2017, 05:13:19 PM
 #70

I don't understand if I can update my portable version simply saving the data folder or I have to enter again the seed?
I have never updated so maybe you can link me a guide.

██
█║█
║║║
║║║
█║█
██
'BTC MULTI-WALLET SOON'
▬▬▬ Download WHITEPAPER ▬▬▬

                    ▄██▄
                  ▄██████▄
                ▄██████████
              ▄██████████▀   ▄▄
            ▄██████████▀   ▄████▄
          ▄██████████▀    ████████▄
         ██████████▀      ▀████████
         ▀███████▀   ▄███▄  ▀████▀   ▄█▄
    ▄███▄  ▀███▀   ▄███████▄  ▀▀   ▄█████▄
  ▄███████▄      ▄██████████     ▄█████████
  █████████    ▄██████████▀    ▄██████████▀
   ▀█████▀   ▄██████████▀    ▄██████████▀
     ▀▀▀   ▄██████████▀    ▄██████████▀
          ██████████▀    ▄██████████▀
          ▀███████▀      █████████▀
            ▀███▀   ▄██▄  ▀█████▀
                  ▄██████▄  ▀▀▀
                  █████████
                   ▀█████▀
                     ▀▀▀
e i d o o
██

███▀▀
▐▐▌
▐▌
▐▌
▐▐▌
███▄▄
▀▀███
▐▌▌
▐▌
▐▌
▐▌▌
▄▄███
HCP
Sr. Member
****
Online Online

Activity: 448

<insert witty quote here>


View Profile
November 10, 2017, 08:11:15 PM
 #71

I don't understand if I can update my portable version simply saving the data folder or I have to enter again the seed?
Personally, I would make a copy of the data folder... It isn't strictly required, but it's always better to have a backup and not need it, than needing a backup and not having one! Wink

Then you just put the new portable .exe in the same folder as the old portable .exe (Note: You don't even need to delete the old portable .exe at this point, it is OK to just leave there). Then double click the new portable .exe to check that it is all OK... that's all there is to it.

Once you have confirmed that everything is running ok with the new portable .exe, you can safely remove the old portable .exe.

forensick
Sr. Member
****
Offline Offline

Activity: 260



View Profile
November 15, 2017, 10:00:35 PM
 #72

I don't understand if I can update my portable version simply saving the data folder or I have to enter again the seed?
Personally, I would make a copy of the data folder... It isn't strictly required, but it's always better to have a backup and not need it, than needing a backup and not having one! Wink

Then you just put the new portable .exe in the same folder as the old portable .exe (Note: You don't even need to delete the old portable .exe at this point, it is OK to just leave there). Then double click the new portable .exe to check that it is all OK... that's all there is to it.

Once you have confirmed that everything is running ok with the new portable .exe, you can safely remove the old portable .exe.

Thank you very much! I updated my portable version with your procedure although I read this thread and I am now worried about dangerous behaviour because it very easy to the wallet on infected computers.

██
█║█
║║║
║║║
█║█
██
'BTC MULTI-WALLET SOON'
▬▬▬ Download WHITEPAPER ▬▬▬

                    ▄██▄
                  ▄██████▄
                ▄██████████
              ▄██████████▀   ▄▄
            ▄██████████▀   ▄████▄
          ▄██████████▀    ████████▄
         ██████████▀      ▀████████
         ▀███████▀   ▄███▄  ▀████▀   ▄█▄
    ▄███▄  ▀███▀   ▄███████▄  ▀▀   ▄█████▄
  ▄███████▄      ▄██████████     ▄█████████
  █████████    ▄██████████▀    ▄██████████▀
   ▀█████▀   ▄██████████▀    ▄██████████▀
     ▀▀▀   ▄██████████▀    ▄██████████▀
          ██████████▀    ▄██████████▀
          ▀███████▀      █████████▀
            ▀███▀   ▄██▄  ▀█████▀
                  ▄██████▄  ▀▀▀
                  █████████
                   ▀█████▀
                     ▀▀▀
e i d o o
██

███▀▀
▐▐▌
▐▌
▐▌
▐▐▌
███▄▄
▀▀███
▐▌▌
▐▌
▐▌
▐▌▌
▄▄███
HCP
Sr. Member
****
Online Online

Activity: 448

<insert witty quote here>


View Profile
November 16, 2017, 04:39:23 AM
 #73

Thank you very much! I updated my portable version with your procedure although I read this thread and I am now worried about dangerous behaviour because it very easy to the wallet on infected computers.
The thing is, the only person in control of the "dangerous behaviour" is YOU.

Portable versions are only dangerous if you engage in risky activity and don't take adequate precautions... it's a bit like sex... if you sleep with random people and don't use condoms/birth control, there can be serious consequences (STDs/STIs... unwanted pregnancy etc)

Likewise with using a portable bitcoin wallet, you put your USB key into random computers without properly assessing the risks and making sure those computers are not infected with viruses/malware/keyloggers, there can be serious consequnces (loss of coins)

cynical
Full Member
***
Offline Offline

Activity: 126


View Profile
November 16, 2017, 12:07:06 PM
 #74

I am looking to install and/or create a wallet on an encrypted USB drive so that I can access that wallet on the go,
rather than relying on a 'mobile wallet' on my phone.
From the website i can see the download option is mobile, https://electrum.org/#download
i assume this is the way to go
any thoughts from current users?



Marcus07
Newbie
*
Offline Offline

Activity: 1


View Profile
November 20, 2017, 11:08:53 AM
 #75

Since we now have a subforum for Electrum, I am rewriting here what I already said in other threads. I hope it's more visible in its own thread.

It is not safe to use a portable version of Electrum on an insecure computer!

Don't get me wrong: I am not saying that a portable build is by itself more dangerous than a non-portable version.
However, a portable version does not bring anything more in terms of security. It does not protect you from the computer you are using.
In addition, portable builds encourage dangerous behaviour, because they make it very easy to use your wallet on third party computers, that might be infected with viruses and keyloggers.

I was never enthusiastic about distributing portable versions of Electrum.
I did it because the demand for portable versions was so high that portable builds distributed by third parties were getting popular.
That's the only reason why I accepted to distribute portable builds: I do this in order to avoid an even worse situation.




its right
Casperko
Newbie
*
Offline Offline

Activity: 3


View Profile WWW
December 13, 2017, 09:28:37 PM
 #76

I will repeat the request in this thread:
The problem with Electrum, version 2.5.2 portable. Essence: included after a couple of weeks, and writes "Synchronization" .. and already 2 days, changed the download server. It does not help, even on the contrary - the red circle glows. In what there can be a problem and how it to correct ??
p.s have Win 7 and recently updated all the drivers, after that Electrum stopped switching on

█ DECENT FOUNDATION █ ICO ⏰ 10th of September
HCP
Sr. Member
****
Online Online

Activity: 448

<insert witty quote here>


View Profile
December 13, 2017, 10:47:01 PM
 #77

I will repeat the request in this thread:
The problem with Electrum, version 2.5.2 portable.
2.5.2??!? Shocked Shocked

That version is far too old... you need to use something like 2.9.3 portable which you can get here: https://download.electrum.org/2.9.3/

Don't try and use v3.x... it doesn't play nicely with Windows 7/8... Undecided

Pages: « 1 2 3 [4]  All
  Print  
 
Jump to:  

Sponsored by , a Bitcoin-accepting VPN.
Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2006-2009, Simple Machines Valid XHTML 1.0! Valid CSS!