Bitcoin Forum
December 11, 2017, 10:20:34 AM *
News: Latest stable version of Bitcoin Core: 0.15.1  [Torrent].
 
   Home   Help Search Donate Login Register  
Pages: « 1 [2]  All
  Print  
Author Topic: Armoury 0.95 - "Building database" forever  (Read 3065 times)
M4rt1n
Newbie
*
Offline Offline

Activity: 14


View Profile
October 24, 2016, 01:38:35 AM
 #21

For all Windowsuser getting the same error like me and getting this error in ArmoryQT.exe.log:

Quote
(ERROR) SDM.pyc:376 - Could not find guardian script: .\guardian.exe
(ERROR) ArmoryQt.py:2247 - Failed to setup SDM
Traceback (most recent call last):
  File "ArmoryQt.py", line 2243, in startBitcoindIfNecessary
  File "SDM.pyc", line 468, in startBitcoind
  File "SDM.pyc", line 577, in launchBitcoindAndGuardian
  File "SDM.pyc", line 377, in getGuardianPath
FileExistsError

Download this File (guardian.exe 109 KB) :

Zippyshare
Mega.nz
G-Drive

if you dont trust me (this files) download 0.94.1 and install it to another directory. Then continue with your own guardian.exe

place this file in the installationdirectory (standard is C:\Program Files (x86)\Armory)

If you now got this error by running ArmoryDB.exe:

Quote
-INFO  - 1477273626: (..\main.cpp:22) Running on 8 threads
-INFO  - 1477273626: (..\main.cpp:23) Ram usage level: 4
-INFO  - 1477273626: (..\BlockUtils.cpp:1325) blkfile dir: C:\Users\***\AppData\Roaming/Bitcoin/blocks
-INFO  - 1477273626: (..\BlockUtils.cpp:1326) lmdb dir: C:\Users\***\AppData\Roaming/Armory/databases
-INFO  - 1477273626: (..\lmdb_wrapper.cpp:388) Opening databases...
-INFO  - 1477273627: (..\BlockUtils.cpp:1508) Executing: doInitialSyncOnLoad
-INFO  - 1477273628: (..\DatabaseBuilder.cpp:162) Reading headers from db
-ERROR - 1477273629: (..\StoredBlockObj.cpp:538) buffer is too small: 80 bytes. expected: 106
-ERROR - 1477273629: (..\BDM_mainthread.cpp:255) BDM thread failed: buffer is too small: 80 bytes. expected: 106


Close and exit Armory (even in the tray)
Go to %appdata%\Armory\ and delete the folder called databases then start ArmoryDB.exe again.
After it finished start ArmoryQT.exe and wait (on HDD maybe about 5min) now ArmoryDB.exe starts itself and does everything what is necessary.

Have fun.


Proof of work -->

http://i.imgur.com/p1Ghh0H.png
http://i.imgur.com/atQBm62.png


I guess there will be a 0.95.0.1 with including guardian.exe

@goatpig: on Windows I have to wait about 1 min when I start ArmoryQT (like this) untill it starts ArmoryDB itself. Could you pls watch out what makes it taking so long?
Thanks!
Advertised sites are not endorsed by the Bitcoin Forum. They may be unsafe, untrustworthy, or illegal in your jurisdiction. Advertise here.
PeZ
Sr. Member
****
Offline Offline

Activity: 241


View Profile
October 24, 2016, 02:04:44 AM
 #22


Well this just partly works, now I got this by starting ArmoryDB manually:

Quote
-INFO  - 1477273626: (..\main.cpp:22) Running on 8 threads
-INFO  - 1477273626: (..\main.cpp:23) Ram usage level: 4
-INFO  - 1477273626: (..\BlockUtils.cpp:1325) blkfile dir: C:\Users\***\AppData\Roaming/Bitcoin/blocks
-INFO  - 1477273626: (..\BlockUtils.cpp:1326) lmdb dir: C:\Users\***\AppData\Roaming/Armory/databases
-INFO  - 1477273626: (..\lmdb_wrapper.cpp:388) Opening databases...
-INFO  - 1477273627: (..\BlockUtils.cpp:1508) Executing: doInitialSyncOnLoad
-INFO  - 1477273628: (..\DatabaseBuilder.cpp:162) Reading headers from db
-ERROR - 1477273629: (..\StoredBlockObj.cpp:538) buffer is too small: 80 bytes. expected: 106
-ERROR - 1477273629: (..\BDM_mainthread.cpp:255) BDM thread failed: buffer is too small: 80 bytes. expected: 106
That was the error I got before I emptied the Armory data directory. When you empty the directory, ArmoryDB.exe will work without error, but that doesn't mean ArmoryQT will work.

[EDIT]
Looks like you got it to work with guardian.
M4rt1n
Newbie
*
Offline Offline

Activity: 14


View Profile
October 24, 2016, 02:07:14 AM
 #23


Well this just partly works, now I got this by starting ArmoryDB manually:

That was the error I got before I emptied the Armory data directory. When you empty the directory, ArmoryDB.exe will work without error, but that doesn't mean ArmoryQT will work.

I know, this happens because guardian.exe is missing in the 0.95 Windows installationfile.
Pls just watch the post above you
PeZ
Sr. Member
****
Offline Offline

Activity: 241


View Profile
October 24, 2016, 02:10:28 AM
 #24

Did you try skipping ArmoryDB and run ArmoryQT without it?

It's an annoyance to regenerate 59GB's worth of files.
M4rt1n
Newbie
*
Offline Offline

Activity: 14


View Profile
October 24, 2016, 02:13:31 AM
 #25

Did you try skipping ArmoryDB and run ArmoryQT without it?

It's an annoyance to regenerate 59GB's worth of files.

This will result in the same thing becasue ArmoryQT is starting ArmoryDB itself. At this 0.95 version there is a bug and it starts in visible (normaly it starts it in the Background) but it starts it anyway.
Btw you dont have to regenerate 59GB, it just creates 700MB DB;) (Building DB and scanning takes for me 10 min on SSD)
PeZ
Sr. Member
****
Offline Offline

Activity: 241


View Profile
October 24, 2016, 05:35:38 AM
 #26

I tried it again. ArmoryDB went fine, but when I run ArmoryQT I still get...

(DEBUG) SDM.pyc:794 - generic jsonrpc exception

Eventually ArmoryDB pops up on its own, but it uses the default path which doesn't exist.

Maybe it's because I am using Windows 10? Bitcoind does run in the background with ArmoryQT. Back to 0.93.3.
M4rt1n
Newbie
*
Offline Offline

Activity: 14


View Profile
October 24, 2016, 07:24:41 AM
 #27

I tried it again. ArmoryDB went fine, but when I run ArmoryQT I still get...

(DEBUG) SDM.pyc:794 - generic jsonrpc exception

Eventually ArmoryDB pops up on its own, but it uses the default path which doesn't exist.

Maybe it's because I am using Windows 10? Bitcoind does run in the background with ArmoryQT. Back to 0.93.3.

I'm running 0.95 on Windows 10 x64 so it's not related to Windows 10.
If you have TeamViewer I may could help you

BTW which BitCoin Version are you running? Pls update to v0.13 (as it is the minimum requirement --> https://btcarmory.com/0.95.0-release/ )

Quote
Back to 0.93.3

Why Back? You can just simply have both installed with different Installationdirectorys Wink And why 0.93.3 and not 0.94.1?
goatpig
Moderator
Legendary
*
Offline Offline

Activity: 1694

Armory Developer


View Profile
October 24, 2016, 09:04:25 AM
 #28

1) I forgot guardian.exe on the Windows package, my bad. You can still run Armory if you turn off auto bitcoind management and run BitcoinQt yourself. I'll fix the release sometimes this week.

2)

Quote
Download this File (guardian.exe 109 KB) :

Zippyshare
Mega.nz
G-Drive

if you dont trust me (this files) download 0.94.1 and install it to another directory. Then continue with your own guardian.exe

place this file in the installationdirectory (standard is C:\Program Files (x86)\Armory)

Ugh, don't post unsigned 100Kb executables online, that's a poor idea. Guardian.exe is the same accross all versions, ever since it was introduced. If you can't wait for a fix, grab the file from older packages.

3)

Quote
-ERROR - 1477273629: (..\StoredBlockObj.cpp:538) buffer is too small: 80 bytes. expected: 106
-ERROR - 1477273629: (..\BDM_mainthread.cpp:255) BDM thread failed: buffer is too small: 80 bytes. expected: 106

DB is failing to detect older versions and still reads ahead, which results in this error. I'll fix that along with guardian. The end result is the same, you need to provide the DB with another a fresh dbdir or wipe your existing one.

Quote
BTW which BitCoin Version are you running? Pls update to v0.13

This is not accurate. 0.95 is compatible with SegWit chains that Core 0.13 enabled on the testnet and 0.13.1 will eventually enable on the mainnet. The requirement is for Armory to be updated to 0.95 to run against a SegWit chain. 0.95 can run against any older version of the blockchain.

Quote
I guess there will be a 0.95.0.1 with including guardian.exe

@goatpig: on Windows I have to wait about 1 min when I start ArmoryQT (like this) untill it starts ArmoryDB itself. Could you pls watch out what makes it taking so long?
Thanks!

It will be 0.95.1. No point disturbing the versioning pattern. The slow startup I believe is related to starting bitcoind first. The client waits on bitcoind to get ready before processing any further. Test this assumption by turning off auto bitcoind, starting BitcoinQt yourself, then starting Armory. The DB should spawn right away.

This issue will go away in the next subrelease (0.95.2 now), once I'll have all the bitcoind management moved to the DB.

Quote
At this 0.95 version there is a bug and it starts in visible (normaly it starts it in the Background) but it starts it anyway.

There is no "normally" per se yet. 0.95 just introduced the DB as its own binary. It used to run within the client's virtual address space as a shared library before.

I've left the DB command line dialog visible in Windows on purpose, as I explained in the release post. This is to make debugging easier and make users aware of the architectural shift. I'll hide it in 0.95.2

PeZ
Sr. Member
****
Offline Offline

Activity: 241


View Profile
October 24, 2016, 04:48:08 PM
 #29

Why Back? You can just simply have both installed with different Installationdirectorys Wink And why 0.93.3 and not 0.94.1?
I just tried 0.94.1 and it appears to be working.
M4rt1n
Newbie
*
Offline Offline

Activity: 14


View Profile
October 25, 2016, 06:44:41 AM
 #30

Why Back? You can just simply have both installed with different Installationdirectorys Wink And why 0.93.3 and not 0.94.1?
I just tried 0.94.1 and it appears to be working.

Now pls backup the guardian.exe File from C:\Program Files (x86)\Armory and install 0.95 then copy it back. Thats all
PeZ
Sr. Member
****
Offline Offline

Activity: 241


View Profile
October 27, 2016, 10:55:13 PM
 #31

Why Back? You can just simply have both installed with different Installationdirectorys Wink And why 0.93.3 and not 0.94.1?
I just tried 0.94.1 and it appears to be working.

Now pls backup the guardian.exe File from C:\Program Files (x86)\Armory and install 0.95 then copy it back. Thats all
No such luck. I even tried reindexing my Bitcoin database and then ran ArmoryDB. ArmoryQT in debug mode spams out...
Code:
(DEBUG) SDM.pyc:794 - generic jsonrpc exception
(DEBUG) SDM.pyc:794 - generic jsonrpc exception
(DEBUG) SDM.pyc:794 - generic jsonrpc exception
(DEBUG) SDM.pyc:794 - generic jsonrpc exception
(DEBUG) SDM.pyc:794 - generic jsonrpc exception
(DEBUG) SDM.pyc:794 - generic jsonrpc exception
(DEBUG) SDM.pyc:794 - generic jsonrpc exception
(DEBUG) SDM.pyc:794 - generic jsonrpc exception
(DEBUG) SDM.pyc:794 - generic jsonrpc exception
(DEBUG) SDM.pyc:794 - generic jsonrpc exception
(DEBUG) SDM.pyc:794 - generic jsonrpc exception
(DEBUG) SDM.pyc:794 - generic jsonrpc exception
Armory 0.93.3 and 0.94.1 work fine, but not 0.95.0. Maybe it's because I'm using an old AMD 1090T processor?
achow101
Staff
Legendary
*
Offline Offline

Activity: 1246


17kKQppUsngUiByDsce4JXoZEjjpvX9bpR


View Profile WWW
October 27, 2016, 10:56:56 PM
 #32

No such luck. I even tried reindexing my Bitcoin database and then ran ArmoryDB. ArmoryQT in debug mode spams out...
Code:
(DEBUG) SDM.pyc:794 - generic jsonrpc exception
(DEBUG) SDM.pyc:794 - generic jsonrpc exception
(DEBUG) SDM.pyc:794 - generic jsonrpc exception
(DEBUG) SDM.pyc:794 - generic jsonrpc exception
(DEBUG) SDM.pyc:794 - generic jsonrpc exception
(DEBUG) SDM.pyc:794 - generic jsonrpc exception
(DEBUG) SDM.pyc:794 - generic jsonrpc exception
(DEBUG) SDM.pyc:794 - generic jsonrpc exception
(DEBUG) SDM.pyc:794 - generic jsonrpc exception
(DEBUG) SDM.pyc:794 - generic jsonrpc exception
(DEBUG) SDM.pyc:794 - generic jsonrpc exception
(DEBUG) SDM.pyc:794 - generic jsonrpc exception
Armory 0.93.3 and 0.94.1 work fine, but not 0.95.0
That error is due to it being unable to connect to Bitcoin Core's RPC server. What version of Bitcoin Core are you using? What is inside of the bitcoin.conf file?

PeZ
Sr. Member
****
Offline Offline

Activity: 241


View Profile
October 27, 2016, 11:05:13 PM
 #33

That error is due to it being unable to connect to Bitcoin Core's RPC server. What version of Bitcoin Core are you using? What is inside of the bitcoin.conf file?
Bitcoin Core (64-bit) 0.13.0
Code:
rpcuser=generated_by_armory

rpcpassword=[Removed Due to Public Posting]
achow101
Staff
Legendary
*
Offline Offline

Activity: 1246


17kKQppUsngUiByDsce4JXoZEjjpvX9bpR


View Profile WWW
October 27, 2016, 11:08:22 PM
 #34

Try commenting out (with a # in front of the lines) those lines in the bitcoin.conf and see if it will work then.

PeZ
Sr. Member
****
Offline Offline

Activity: 241


View Profile
October 27, 2016, 11:53:25 PM
 #35

Try commenting out (with a # in front of the lines) those lines in the bitcoin.conf and see if it will work then.
That caused an immediate crash. On the second attempt it started up with plenty of repeated errors...
Code:
(ERROR) SDM.pyc:790 - ValueError in bkgd req top blk
Traceback (most recent call last):
  File "SDM.pyc", line 764, in __backgroundRequestTopBlock
  File "bitcoinrpc_jsonrpc\authproxy.pyc", line 105, in __call__
  File "json\__init__.pyc", line 351, in loads
  File "json\decoder.pyc", line 366, in decode
  File "json\decoder.pyc", line 384, in raw_decode
ValueError: No JSON object could be decoded
GUI still stuck at the same spot.
M4rt1n
Newbie
*
Offline Offline

Activity: 14


View Profile
October 28, 2016, 09:51:07 AM
 #36

Why Back? You can just simply have both installed with different Installationdirectorys Wink And why 0.93.3 and not 0.94.1?
I just tried 0.94.1 and it appears to be working.

Now pls backup the guardian.exe File from C:\Program Files (x86)\Armory and install 0.95 then copy it back. Thats all
No such luck. I even tried reindexing my Bitcoin database and then ran ArmoryDB. ArmoryQT in debug mode spams out...
Code:
(DEBUG) SDM.pyc:794 - generic jsonrpc exception
(DEBUG) SDM.pyc:794 - generic jsonrpc exception
(DEBUG) SDM.pyc:794 - generic jsonrpc exception
(DEBUG) SDM.pyc:794 - generic jsonrpc exception
(DEBUG) SDM.pyc:794 - generic jsonrpc exception
(DEBUG) SDM.pyc:794 - generic jsonrpc exception
(DEBUG) SDM.pyc:794 - generic jsonrpc exception
(DEBUG) SDM.pyc:794 - generic jsonrpc exception
(DEBUG) SDM.pyc:794 - generic jsonrpc exception
(DEBUG) SDM.pyc:794 - generic jsonrpc exception
(DEBUG) SDM.pyc:794 - generic jsonrpc exception
(DEBUG) SDM.pyc:794 - generic jsonrpc exception
Armory 0.93.3 and 0.94.1 work fine, but not 0.95.0. Maybe it's because I'm using an old AMD 1090T processor?

Now I'm confused Tongue if 0.94.1 works 0.95 should also work (after pasting guardian.exe in it) but I think it is now becasue of an processor.
Have you also deleted databases in %appdata%\Armory\? if yes and it still does not work pls try BitCoin Core 0.13.1 (27.10.2016)
May with the newest Bitcoin it works for you, for me it also works with 0.13.1
PeZ
Sr. Member
****
Offline Offline

Activity: 241


View Profile
October 31, 2016, 08:15:20 PM
 #37


Now I'm confused Tongue if 0.94.1 works 0.95 should also work
Isn't 0.95 when they separated ArmoryDB from ArmoryQT? When ArmoryDB is called by ArmoryQT, it doesn't pass the proper settings, so you have to run ArmoryDB on its own.
Pages: « 1 [2]  All
  Print  
 
Jump to:  

Sponsored by , a Bitcoin-accepting VPN.
Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2006-2009, Simple Machines Valid XHTML 1.0! Valid CSS!