Bitcoin Forum
July 24, 2024, 09:41:53 PM *
News: Latest Bitcoin Core release: 27.0 [Torrent]
 
   Home   Help Search Login Register More  
Pages: « 1 2 3 [4] 5 6 7 »  All
  Print  
Author Topic: HOW TO SET UP OVERCLOCKING AND FAN CONTROL ON UBUNTU 16.04 FOR NVIDIA CARDS  (Read 54990 times)
ste1
Newbie
*
Offline Offline

Activity: 36
Merit: 0


View Profile
August 11, 2017, 04:47:39 PM
 #61

No it doesn't matter with 2 cards. Works perfectly in Windows. Just can't OC in Linux.

A couple of options:

a) try Ubuntu 17.04LTS - it has an updated kernel that may be better with your CPU and motherboard.

b) try Nvidia' newer drivers

sudo add-apt-repository ppa:graphics-drivers/ppa
sudo apt update.

Then go to additional drivers - an every Nvidia Ubuntu driver release up to the recent 384.59 will be available for install.

Sometimes, you'll need to click open Ubuntu Software and update X Server control panel for that driver.

Remember, after switching drivers and rebooting you will need to re-enter:

sudo nvidia-xconfig -a --cool-bits=28 --allow-empty-initial-configuration


I tried but still the same problem Sad

Not a lot can be done - especially, as you won't try using Gen 2 or Gen 1!
I tried this too but didn't change anything.
I noticed that oc works on a card with monitor plugged in but this not a solution for mining.
thevictimofuktyranny (OP)
Legendary
*
Offline Offline

Activity: 1092
Merit: 1004


View Profile
August 12, 2017, 11:50:37 AM
 #62

No it doesn't matter with 2 cards. Works perfectly in Windows. Just can't OC in Linux.

A couple of options:

a) try Ubuntu 17.04LTS - it has an updated kernel that may be better with your CPU and motherboard.

b) try Nvidia' newer drivers

sudo add-apt-repository ppa:graphics-drivers/ppa
sudo apt update.

Then go to additional drivers - an every Nvidia Ubuntu driver release up to the recent 384.59 will be available for install.

Sometimes, you'll need to click open Ubuntu Software and update X Server control panel for that driver.

Remember, after switching drivers and rebooting you will need to re-enter:

sudo nvidia-xconfig -a --cool-bits=28 --allow-empty-initial-configuration


I tried but still the same problem Sad

Not a lot can be done - especially, as you won't try using Gen 2 or Gen 1!
I tried this too but didn't change anything.
I noticed that oc works on a card with monitor plugged in but this not a solution for mining.

The following command is meant to allow you to allow overclocking on the additional GPUs without a dummy monitor plug.

sudo nvidia-xconfig -a --cool-bits=28 --allow-empty-initial-configuration

Sometimes, non-reference engineering on a motherboard can prevent Ubuntu from installing or commands from working - some motherboard manufacturers don't give the non-reference engineering design to Ubuntu for inclusion in a Kernel revision.

However, you can buy an HDMI dummy monitor plug from Amazon or eBay for $8.39. But, if you are willing to wait for a bit, you can get one shipped from a Chinese seller on eBay for cheaper. That will get overclocking working on the 2nd GPU.
bmartin44
Member
**
Offline Offline

Activity: 85
Merit: 100


View Profile
August 12, 2017, 01:34:43 PM
 #63

Very detailed guide. I just wondering how to select which GPU to change the configuration?

nvidia-smi -i 0 -q -d POWER

-i 0 is selection of GPU 0?

And my mining rig is ubuntu 14.04, will it work?

thevictimofuktyranny (OP)
Legendary
*
Offline Offline

Activity: 1092
Merit: 1004


View Profile
August 12, 2017, 04:23:56 PM
 #64

Very detailed guide. I just wondering how to select which GPU to change the configuration?

nvidia-smi -i 0 -q -d POWER

-i 0 is selection of GPU 0?

And my mining rig is ubuntu 14.04, will it work?

No idea, I've not done much testing on the reduced power settings. Simply, tested it will a single card.

And, I don't use legacy OS's like 14.04LTS or Windows 7, because they take to long to set up and update.

Ubuntu 16.04LTS can be installed and updated with an install of Cuda 8 in under 30 minutes. 
bmartin44
Member
**
Offline Offline

Activity: 85
Merit: 100


View Profile
August 13, 2017, 03:40:02 PM
 #65

Very detailed guide. I just wondering how to select which GPU to change the configuration?

nvidia-smi -i 0 -q -d POWER

-i 0 is selection of GPU 0?

And my mining rig is ubuntu 14.04, will it work?

No idea, I've not done much testing on the reduced power settings. Simply, tested it will a single card.

And, I don't use legacy OS's like 14.04LTS or Windows 7, because they take to long to set up and update.

Ubuntu 16.04LTS can be installed and updated with an install of Cuda 8 in under 30 minutes. 


I have googled around and yes, "-i 0" means GPU 0.

I wish I could use ubuntu 16.04 but my mining rig already built in ubuntu 14.04. I will spend some time one day to re-install it. At the meantime, I will try to overclock and will update my status here later.

Thanks for your info anyway.

thevictimofuktyranny (OP)
Legendary
*
Offline Offline

Activity: 1092
Merit: 1004


View Profile
August 17, 2017, 05:01:14 PM
 #66

No it doesn't matter with 2 cards. Works perfectly in Windows. Just can't OC in Linux.

A couple of options:

a) try Ubuntu 17.04LTS - it has an updated kernel that may be better with your CPU and motherboard.

b) try Nvidia' newer drivers

sudo add-apt-repository ppa:graphics-drivers/ppa
sudo apt update.

Then go to additional drivers - an every Nvidia Ubuntu driver release up to the recent 384.59 will be available for install.

Sometimes, you'll need to click open Ubuntu Software and update X Server control panel for that driver.

Remember, after switching drivers and rebooting you will need to re-enter:

sudo nvidia-xconfig -a --cool-bits=28 --allow-empty-initial-configuration


I tried but still the same problem Sad

Not a lot can be done - especially, as you won't try using Gen 2 or Gen 1!
I tried this too but didn't change anything.
I noticed that oc works on a card with monitor plugged in but this not a solution for mining.

Had chance to look into this problem and found a work-around that does not involve using dummy monitor plugs.

Firstly, log in and enable overclocking on one GPU:

sudo nvidia-xconfig -a --cool-bits=28

Log out and then log back in, then enable overclocking on all the other identical GPUs:

sudo nvidia-xconfig -a --cool-bits=28 --allow-empty-initial-configuration

Then log out and log back in and all the GPUs will have overclocking and fan control enabled.
jdash
Newbie
*
Offline Offline

Activity: 34
Merit: 0


View Profile
August 17, 2017, 08:26:37 PM
 #67

can i ask if it supports undervolting of cards ? thanks
thevictimofuktyranny (OP)
Legendary
*
Offline Offline

Activity: 1092
Merit: 1004


View Profile
August 17, 2017, 10:11:20 PM
 #68

can i ask if it supports undervolting of cards ? thanks

I believe "cool-bits=31" allows you to overvolt and undervolt. You'll need to google the ins and outs of undervolting an Nvidia GPU - no experience of it myself.

It is easier, to simply set the max watts you willing to let the GPUs use whilst mining.
bmartin44
Member
**
Offline Offline

Activity: 85
Merit: 100


View Profile
August 22, 2017, 11:24:49 AM
 #69

can i ask if it supports undervolting of cards ? thanks

I believe "cool-bits=31" allows you to overvolt and undervolt. You'll need to google the ins and outs of undervolting an Nvidia GPU - no experience of it myself.

It is easier, to simply set the max watts you willing to let the GPUs use whilst mining.

I don't quite understand about the cool-bits setting, that's the reason why I still haven't OC my cards yet. I googled from net and found that some cards required cool-bits=24, and some 28. What is this actually? Any detailed info about the cool-bits code?

thevictimofuktyranny (OP)
Legendary
*
Offline Offline

Activity: 1092
Merit: 1004


View Profile
August 22, 2017, 01:02:48 PM
 #70

I have Coolbits set to 31 but I don't have any uder/overvolt settings in nvidia-settings…

I've got no interest in this feature, as I said before! It is a Command Terminal feature, only.

Some websites says it allows undervolting, but most websites say it only allows overvolting up to 37500 microvolts.
ste1
Newbie
*
Offline Offline

Activity: 36
Merit: 0


View Profile
September 19, 2017, 08:08:22 PM
 #71

No it doesn't matter with 2 cards. Works perfectly in Windows. Just can't OC in Linux.

A couple of options:

a) try Ubuntu 17.04LTS - it has an updated kernel that may be better with your CPU and motherboard.

b) try Nvidia' newer drivers

sudo add-apt-repository ppa:graphics-drivers/ppa
sudo apt update.

Then go to additional drivers - an every Nvidia Ubuntu driver release up to the recent 384.59 will be available for install.

Sometimes, you'll need to click open Ubuntu Software and update X Server control panel for that driver.

Remember, after switching drivers and rebooting you will need to re-enter:

sudo nvidia-xconfig -a --cool-bits=28 --allow-empty-initial-configuration


I tried but still the same problem Sad

Not a lot can be done - especially, as you won't try using Gen 2 or Gen 1!
I tried this too but didn't change anything.
I noticed that oc works on a card with monitor plugged in but this not a solution for mining.

Had chance to look into this problem and found a work-around that does not involve using dummy monitor plugs.

Firstly, log in and enable overclocking on one GPU:

sudo nvidia-xconfig -a --cool-bits=28

Log out and then log back in, then enable overclocking on all the other identical GPUs:

sudo nvidia-xconfig -a --cool-bits=28 --allow-empty-initial-configuration

Then log out and log back in and all the GPUs will have overclocking and fan control enabled.
After logging out I got suck on the login screen. Can't login again and after reboot the xorg.conf is reset to default (no oc)
thevictimofuktyranny (OP)
Legendary
*
Offline Offline

Activity: 1092
Merit: 1004


View Profile
September 19, 2017, 08:30:58 PM
 #72

No it doesn't matter with 2 cards. Works perfectly in Windows. Just can't OC in Linux.

A couple of options:

a) try Ubuntu 17.04LTS - it has an updated kernel that may be better with your CPU and motherboard.

b) try Nvidia' newer drivers

sudo add-apt-repository ppa:graphics-drivers/ppa
sudo apt update.

Then go to additional drivers - an every Nvidia Ubuntu driver release up to the recent 384.59 will be available for install.

Sometimes, you'll need to click open Ubuntu Software and update X Server control panel for that driver.

Remember, after switching drivers and rebooting you will need to re-enter:

sudo nvidia-xconfig -a --cool-bits=28 --allow-empty-initial-configuration


I tried but still the same problem Sad

Not a lot can be done - especially, as you won't try using Gen 2 or Gen 1!
I tried this too but didn't change anything.
I noticed that oc works on a card with monitor plugged in but this not a solution for mining.

Had chance to look into this problem and found a work-around that does not involve using dummy monitor plugs.

Firstly, log in and enable overclocking on one GPU:

sudo nvidia-xconfig -a --cool-bits=28

Log out and then log back in, then enable overclocking on all the other identical GPUs:

sudo nvidia-xconfig -a --cool-bits=28 --allow-empty-initial-configuration

Then log out and log back in and all the GPUs will have overclocking and fan control enabled.
After logging out I got suck on the login screen. Can't login again and after reboot the xorg.conf is reset to default (no oc)

Try it again, it is a workaround - sometimes it takes a couple of tries.
ste1
Newbie
*
Offline Offline

Activity: 36
Merit: 0


View Profile
September 19, 2017, 08:45:33 PM
 #73

No it doesn't matter with 2 cards. Works perfectly in Windows. Just can't OC in Linux.

A couple of options:

a) try Ubuntu 17.04LTS - it has an updated kernel that may be better with your CPU and motherboard.

b) try Nvidia' newer drivers

sudo add-apt-repository ppa:graphics-drivers/ppa
sudo apt update.

Then go to additional drivers - an every Nvidia Ubuntu driver release up to the recent 384.59 will be available for install.

Sometimes, you'll need to click open Ubuntu Software and update X Server control panel for that driver.

Remember, after switching drivers and rebooting you will need to re-enter:

sudo nvidia-xconfig -a --cool-bits=28 --allow-empty-initial-configuration


I tried but still the same problem Sad

Not a lot can be done - especially, as you won't try using Gen 2 or Gen 1!
I tried this too but didn't change anything.
I noticed that oc works on a card with monitor plugged in but this not a solution for mining.

Had chance to look into this problem and found a work-around that does not involve using dummy monitor plugs.

Firstly, log in and enable overclocking on one GPU:

sudo nvidia-xconfig -a --cool-bits=28

Log out and then log back in, then enable overclocking on all the other identical GPUs:

sudo nvidia-xconfig -a --cool-bits=28 --allow-empty-initial-configuration

Then log out and log back in and all the GPUs will have overclocking and fan control enabled.
After logging out I got suck on the login screen. Can't login again and after reboot the xorg.conf is reset to default (no oc)

Try it again, it is a workaround - sometimes it takes a couple of tries.

Tried 100x, not possible.
thevictimofuktyranny (OP)
Legendary
*
Offline Offline

Activity: 1092
Merit: 1004


View Profile
September 19, 2017, 08:47:11 PM
 #74

Need to find out about the setup then!

CPU?

USB 3 Risers?

Motherboard?

Number of GPUs?

Type of GPUs?

Ubuntu Version?

Do you have one GPU acting as the display output or are you using onboard graphics?

PCI-E settings?
ste1
Newbie
*
Offline Offline

Activity: 36
Merit: 0


View Profile
September 19, 2017, 09:04:49 PM
 #75

Need to find out about the setup then!

CPU?

USB 3 Risers?

Motherboard?

Number of GPUs?

Type of GPUs?

Ubuntu Version?

Do you have one GPU acting as the display output or are you using onboard graphics?

PCI-E settings?

6600K
MSI Z170 Pro
2x 1060, 2x 1050 Ti (USB3 Risers)
Ubuntu 17.04
onboard output (tried GPU but doesn't work either)
Gen1, 4G decoding
thevictimofuktyranny (OP)
Legendary
*
Offline Offline

Activity: 1092
Merit: 1004


View Profile
September 19, 2017, 09:20:29 PM
 #76

Need to find out about the setup then!

CPU?

USB 3 Risers?

Motherboard?

Number of GPUs?

Type of GPUs?

Ubuntu Version?

Do you have one GPU acting as the display output or are you using onboard graphics?

PCI-E settings?

6600K
MSI Z170 Pro
2x 1060, 2x 1050 Ti (USB3 Risers)
Ubuntu 17.04
onboard output (tried GPU but doesn't work either)
Gen1, 4G decoding


You need to have identical models for Ubuntu e.g. all GTX 1060 or all GTX 1050 TIs.

In your situation: you will be limited to using Windows 10.

Did you get all 4 cards installed or where some missing in Nividia Xorg Server?
ste1
Newbie
*
Offline Offline

Activity: 36
Merit: 0


View Profile
September 19, 2017, 10:12:39 PM
 #77

Need to find out about the setup then!

CPU?

USB 3 Risers?

Motherboard?

Number of GPUs?

Type of GPUs?

Ubuntu Version?

Do you have one GPU acting as the display output or are you using onboard graphics?

PCI-E settings?


6600K
MSI Z170 Pro
2x 1060, 2x 1050 Ti (USB3 Risers)
Ubuntu 17.04
onboard output (tried GPU but doesn't work either)
Gen1, 4G decoding


You need to have identical models for Ubuntu e.g. all GTX 1060 or all GTX 1050 TIs.

In your situation: you will be limited to using Windows 10.

Did you get all 4 cards installed or where some missing in Nividia Xorg Server?


All cards are working without OC.
thevictimofuktyranny (OP)
Legendary
*
Offline Offline

Activity: 1092
Merit: 1004


View Profile
September 20, 2017, 12:10:55 AM
 #78

Need to find out about the setup then!

CPU?

USB 3 Risers?

Motherboard?

Number of GPUs?

Type of GPUs?

Ubuntu Version?

Do you have one GPU acting as the display output or are you using onboard graphics?

PCI-E settings?


6600K
MSI Z170 Pro
2x 1060, 2x 1050 Ti (USB3 Risers)
Ubuntu 17.04
onboard output (tried GPU but doesn't work either)
Gen1, 4G decoding


You need to have identical models for Ubuntu e.g. all GTX 1060 or all GTX 1050 TIs.

In your situation: you will be limited to using Windows 10.

Did you get all 4 cards installed or where some missing in Nividia Xorg Server?


All cards are working without OC.


OK, overclocking and fan control can only be enabled when a monitor is connected to the GPU on primary PCI-Express slot.

Set it to PEG in bios. Make sure all the PCH is set to Gen1, and check if you also have the option to set the individual slot selections to Gen1.

Try starting with a GTX 1060 on primary PCI-Express slot.

If, that does not work, then try starting with GTX 1050 TI in the primary PCI-E slot.

As soon as you get a display output from one GPU connected to a monitor - you will be able to set fan controls and overclocking.

Also, see if Disabling above 4G decode works, it sometimes causes a black screen.

ste1
Newbie
*
Offline Offline

Activity: 36
Merit: 0


View Profile
September 20, 2017, 12:44:13 PM
 #79

Need to find out about the setup then!

CPU?

USB 3 Risers?

Motherboard?

Number of GPUs?

Type of GPUs?

Ubuntu Version?

Do you have one GPU acting as the display output or are you using onboard graphics?

PCI-E settings?


6600K
MSI Z170 Pro
2x 1060, 2x 1050 Ti (USB3 Risers)
Ubuntu 17.04
onboard output (tried GPU but doesn't work either)
Gen1, 4G decoding


You need to have identical models for Ubuntu e.g. all GTX 1060 or all GTX 1050 TIs.

In your situation: you will be limited to using Windows 10.

Did you get all 4 cards installed or where some missing in Nividia Xorg Server?


All cards are working without OC.


OK, overclocking and fan control can only be enabled when a monitor is connected to the GPU on primary PCI-Express slot.

Set it to PEG in bios. Make sure all the PCH is set to Gen1, and check if you also have the option to set the individual slot selections to Gen1.

Try starting with a GTX 1060 on primary PCI-Express slot.

If, that does not work, then try starting with GTX 1050 TI in the primary PCI-E slot.

As soon as you get a display output from one GPU connected to a monitor - you will be able to set fan controls and overclocking.

Also, see if Disabling above 4G decode works, it sometimes causes a black screen.



Does it matter if I use DP or HDMI?
thevictimofuktyranny (OP)
Legendary
*
Offline Offline

Activity: 1092
Merit: 1004


View Profile
September 20, 2017, 01:36:33 PM
 #80

Need to find out about the setup then!

CPU?

USB 3 Risers?

Motherboard?

Number of GPUs?

Type of GPUs?

Ubuntu Version?

Do you have one GPU acting as the display output or are you using onboard graphics?

PCI-E settings?


6600K
MSI Z170 Pro
2x 1060, 2x 1050 Ti (USB3 Risers)
Ubuntu 17.04
onboard output (tried GPU but doesn't work either)
Gen1, 4G decoding


You need to have identical models for Ubuntu e.g. all GTX 1060 or all GTX 1050 TIs.

In your situation: you will be limited to using Windows 10.

Did you get all 4 cards installed or where some missing in Nividia Xorg Server?


All cards are working without OC.


OK, overclocking and fan control can only be enabled when a monitor is connected to the GPU on primary PCI-Express slot.

Set it to PEG in bios. Make sure all the PCH is set to Gen1, and check if you also have the option to set the individual slot selections to Gen1.

Try starting with a GTX 1060 on primary PCI-Express slot.

If, that does not work, then try starting with GTX 1050 TI in the primary PCI-E slot.

As soon as you get a display output from one GPU connected to a monitor - you will be able to set fan controls and overclocking.

Also, see if Disabling above 4G decode works, it sometimes causes a black screen.



Does it matter if I use DP or HDMI?

Try it out, but Ubuntu tends to has a few of issues with HDMI.
Pages: « 1 2 3 [4] 5 6 7 »  All
  Print  
 
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2006-2009, Simple Machines Valid XHTML 1.0! Valid CSS!