Bitcoin Forum
October 22, 2017, 05:43:44 PM *
News: Latest stable version of Bitcoin Core: 0.15.0.1  [Torrent]. (New!)
 
   Home   Help Search Donate Login Register  
Pages: [1]
  Print  
Author Topic: Inbound connections when there should be none  (Read 267 times)
RedGolpe
Full Member
***
Offline Offline

Activity: 170


View Profile
January 18, 2017, 12:52:27 PM
 #1

I have my Bitcoin Core client up and running almost constantly but from time to time, when I need more resources, I disable inbound connections by removing the relevant port mapping on my router. It may or may not be relevant that my router does not support UPnP but I have it enabled on the client.

I check if I'm actually reachable with bitnodes, and it says I'm visible or not depending on the port mapping settings so everything seems to work as expected.

However, even when I am "invisible" to the network, I receive inbound connections. I generally end up with one or two of them, always with a IPv6 address: how is that possible?
1508694224
Hero Member
*
Offline Offline

Posts: 1508694224

View Profile Personal Message (Offline)

Ignore
1508694224
Reply with quote  #2

1508694224
Report to moderator
1508694224
Hero Member
*
Offline Offline

Posts: 1508694224

View Profile Personal Message (Offline)

Ignore
1508694224
Reply with quote  #2

1508694224
Report to moderator
1508694224
Hero Member
*
Offline Offline

Posts: 1508694224

View Profile Personal Message (Offline)

Ignore
1508694224
Reply with quote  #2

1508694224
Report to moderator
Advertised sites are not endorsed by the Bitcoin Forum. They may be unsafe, untrustworthy, or illegal in your jurisdiction. Advertise here.
shorena
Legendary
*
Offline Offline

Activity: 1386


ALL escrow is signed! https://keybase.io/verify


View Profile WWW
January 18, 2017, 01:03:25 PM
 #2

I have my Bitcoin Core client up and running almost constantly but from time to time, when I need more resources, I disable inbound connections by removing the relevant port mapping on my router. It may or may not be relevant that my router does not support UPnP but I have it enabled on the client.

I check if I'm actually reachable with bitnodes, and it says I'm visible or not depending on the port mapping settings so everything seems to work as expected.

However, even when I am "invisible" to the network, I receive inbound connections. I generally end up with one or two of them, always with a IPv6 address: how is that possible?

Sounds like your router does not respect the settings for ipv6. Is there another set of rule for those connections maybe?

Foxpup
Legendary
*
Offline Offline

Activity: 1988



View Profile
January 18, 2017, 01:06:50 PM
 #3

IPv6 typically doesn't use NAT, so other nodes can connect to you directly without port mapping. Does Bitnodes say you're reachable when you enter your IPv6 address?

In any case, you can disable inbound connections on all networks by starting Bitcoin Core with the listen parameter set to 0 (either on the command line or in bitcoin.conf). You can also limit the total number of connections with the maxconnections parameter.

Will pretend to do unverifiable things (while actually eating an enchilada-style burrito) for bitcoins: 1K6d1EviQKX3SVKjPYmJGyWBb1avbmCFM4
shorena
Legendary
*
Offline Offline

Activity: 1386


ALL escrow is signed! https://keybase.io/verify


View Profile WWW
January 18, 2017, 01:08:21 PM
 #4

IPv6 typically doesn't use NAT, so other nodes can connect to you directly without port mapping.

Yeah, would be a firewall setting on the router explicitly blocking the port.

RedGolpe
Full Member
***
Offline Offline

Activity: 170


View Profile
January 18, 2017, 01:10:24 PM
 #5

Thank you for all your answers, it surely must be an IPv6 setting, I will try with my IPv6 address on Bitnodes.

Edit: confirmed.
Pages: [1]
  Print  
 
Jump to:  

Sponsored by , a Bitcoin-accepting VPN.
Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2006-2009, Simple Machines Valid XHTML 1.0! Valid CSS!