Bitcoin Forum
May 27, 2017, 08:28:24 AM *
News: Latest stable version of Bitcoin Core: 0.14.1  [Torrent]. (New!)
 
   Home   Help Search Donate Login Register  
Pages: [1]
  Print  
Author Topic: An error occurred while synchronizing with the network.  (Read 907 times)
Andrey123
Sr. Member
****
Offline Offline

Activity: 252



View Profile
March 20, 2017, 08:40:22 AM
 #1

Hey.
Installed a new version of the client, after the purse downloaded 7 GB of blocks, there was an error in the library and the purse itself was closed.
What to do? Can not download the entire transaction history.


1495873704
Hero Member
*
Offline Offline

Posts: 1495873704

View Profile Personal Message (Offline)

Ignore
1495873704
Reply with quote  #2

1495873704
Report to moderator
Advertised sites are not endorsed by the Bitcoin Forum. They may be unsafe, untrustworthy, or illegal in your jurisdiction. Advertise here.
IngerDev
Jr. Member
*
Offline Offline

Activity: 45


View Profile
March 20, 2017, 02:06:49 PM
 #2

Which Version are u using?
Have you received this Error before?
achow101
Moderator
Legendary
*
Offline Offline

Activity: 1050


16mT7jrpkjnJBD7a3TM2awyxHub58H6r6Z


View Profile WWW
March 20, 2017, 03:51:02 PM
 #3

Please post the debug.log file.

What are the specs of the machine you are using?

Andrey123
Sr. Member
****
Offline Offline

Activity: 252



View Profile
March 21, 2017, 01:40:42 AM
 #4

version of Bitcoin Core: 0.14.0, version of Bitcoin Core: 0.14.0, downloaded the link from the forum.
I use the wallet in the first place.
CPU Intel Core 2DUO E7400 2.8GHz, RAM 4Gb.

Here is some of the code from the error file (it weighs quite a lot):

2017-03-20 10:41:34 UpdateTip: new best=00000000000000a23840fbcd2619baafe06cec6f2c4a0faea58066fc2da6e4a1 height=232370 version=0x00000002 log2_work=69.827085 tx=16491353 date='2013-04-21 04:52:27' progress=0.080287 cache=518.6MiB(1953827tx)
2017-03-20 10:41:34 UpdateTip: new best=00000000000000f14c0e6ea9950459354353064796aeb3e4ddc4e807832423b2 height=232371 version=0x00000002 log2_work=69.827138 tx=16491368 date='2013-04-21 04:52:41' progress=0.080287 cache=518.6MiB(1953837tx)
2017-03-20 10:41:39 Error: Out of memory. Terminating.
2017-03-20 11:00:02 socket sending timeout: 1201s
2017-03-20 11:00:25 socket sending timeout: 1201s
2017-03-20 11:00:27 socket sending timeout: 1201s
2017-03-20 11:00:58 socket sending timeout: 1201s
2017-03-20 11:01:11 socket sending timeout: 1201s
2017-03-20 11:01:24 socket sending timeout: 1201s
achow101
Moderator
Legendary
*
Offline Offline

Activity: 1050


16mT7jrpkjnJBD7a3TM2awyxHub58H6r6Z


View Profile WWW
March 21, 2017, 02:34:57 AM
 #5

Your machine ran out of memory.

Add the following to your bitcoin.conf file. The file can be found in %appdata%/Bitcoin. If the file does not exist, make it (it's just a text file, with out the .txt extension).
Code:
dbcache=100
maxmempool=100

This should decrease the RAM usage so that it does not run out of memory.

Andrey123
Sr. Member
****
Offline Offline

Activity: 252



View Profile
March 21, 2017, 03:49:07 AM
 #6

The file was created, the extension did bitcoin.conf, since it was empty in the folder.
But how much RAM do you need?
After all, computers used to be older.
achow101
Moderator
Legendary
*
Offline Offline

Activity: 1050


16mT7jrpkjnJBD7a3TM2awyxHub58H6r6Z


View Profile WWW
March 21, 2017, 03:59:22 AM
 #7

But how much RAM do you need?
Now, I don't know. You will need greater than 4 GB to run Bitcoin Core at default settings.

Andrey123
Sr. Member
****
Offline Offline

Activity: 252



View Profile
March 21, 2017, 04:28:11 AM
 #8

The file did not help, all the same the blocks do not shake further.
More memory is not possible to put.
Maybe you can download the blocks separately and just paste them into the purse?
Andrey123
Sr. Member
****
Offline Offline

Activity: 252



View Profile
March 23, 2017, 10:05:30 AM
 #9

Really no one will help?
Pages: [1]
  Print  
 
Jump to:  

Sponsored by , a Bitcoin-accepting VPN.
Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2006-2009, Simple Machines Valid XHTML 1.0! Valid CSS!