Bitcoin Forum
December 03, 2016, 11:55:52 AM *
News: To be able to use the next phase of the beta forum software, please ensure that your email address is correct/functional.
 
   Home   Help Search Donate Login Register  
Pages: [1] 2 »  All
  Print  
Author Topic: Playing games while mining with the same GFX card  (Read 6188 times)
Auspician
Member
**
Offline Offline

Activity: 112



View Profile
June 17, 2011, 09:16:05 PM
 #1

The Goal: To play games while mining, letting the game use whatever portion of the GFX card it needs to run and leave the rest leftover for the mining client.

The Proof: This was achieved using an older Nvidia GFX card by using the -f128 flag.  The card was hashing at 40Mhash/s when not gaming and 8-10Mhash/s when gaming without any noticeable performance reduction in the game.

The Problem: Current I'm using 2x non-reference 6950's hashing at about 335Mhash/s each.  Games run fine when I turn the worker off that controls the monitor I'm gaming on.  However, the system locks whenever I attempt to also mine with that GFX card, regardless of starting the worker first or the game first.  This happens even with -f1024.

Any suggestions?
1480766152
Hero Member
*
Offline Offline

Posts: 1480766152

View Profile Personal Message (Offline)

Ignore
1480766152
Reply with quote  #2

1480766152
Report to moderator
Advertised sites are not endorsed by the Bitcoin Forum. They may be unsafe, untrustworthy, or illegal in your jurisdiction. Advertise here.
1480766152
Hero Member
*
Offline Offline

Posts: 1480766152

View Profile Personal Message (Offline)

Ignore
1480766152
Reply with quote  #2

1480766152
Report to moderator
Austinh100
Newbie
*
Offline Offline

Activity: 14


View Profile
June 18, 2011, 12:38:58 AM
 #2

windows or linux, im assuming windows, i would try setting priority to the game in task manager

Send me a tip =D
http://payb.tc/austinh100
Auspician
Member
**
Offline Offline

Activity: 112



View Profile
June 18, 2011, 01:09:07 AM
 #3

Windows 7 64-bit. 

Priority can only be set after the game is loaded and would require a complex process every time I wanted to game, even if it would work.  Any other suggestions?
milk
Jr. Member
*
Offline Offline

Activity: 48


View Profile
June 18, 2011, 10:07:50 AM
 #4

Your monitor can display 1024 frames ? Really  Shocked

-f 60 (frames) is usually the max. If it hangs your computer is unstable.
Waltibaba
Jr. Member
*
Offline Offline

Activity: 38



View Profile
June 18, 2011, 10:35:07 AM
 #5

If you want to, you can set priority permanently using a program like prifinnity; sets affinity and priority automatically.

12ZzdcQ7pyAcUJS9AGBRHTYcsu8tYLGWBK
"Money needs to be depoliticized, and the time has come for the separation of money and state to be accomplished."  Thomas Greco (2009)
*Image Removed*
Auspician
Member
**
Offline Offline

Activity: 112



View Profile
June 18, 2011, 02:49:45 PM
 #6

That might be worth looking into, Waltibaba.  I'll check it out and get back to you.

As far as how many frames my monitor can display, honestly I've ignored that detail in favor of recognizing that the Mhash/s rate drops the higher -f I go to, and other applications seem to be able to utilize that additional graphics overhead.  At -f1024 I'm still at 93% utilization of my GFX cards.
Auspician
Member
**
Offline Offline

Activity: 112



View Profile
June 18, 2011, 05:06:58 PM
 #7

No dice.  Setting GUIminer to Low priority and the game to Above Normal had no effect; the system still crashed.

Other suggestions?
frizzl
Newbie
*
Offline Offline

Activity: 28


View Profile
June 18, 2011, 07:35:06 PM
 #8

Your monitor can display 1024 frames ? Really  Shocked

-f 60 (frames) is usually the max. If it hangs your computer is unstable.

This worked for me, i was able to login to RIFT didnt do anything hardcore but it was hashing still and had decent fps in RIFT.

1NtLm3jrRK2keDBMiBbTUvNetrkNuBV8hY
Auspician
Member
**
Offline Offline

Activity: 112



View Profile
June 18, 2011, 08:41:43 PM
 #9

What GFX card are you running RIFT on, frizzl?  What OS are you using and with what version of the GFX drivers?
lacedwithkerosene
Member
**
Offline Offline

Activity: 112


View Profile WWW
June 18, 2011, 08:54:09 PM
 #10

"Consider playing Minesweeper instead of Black Ops if you must game on a computer that is actively mining"

Garrett Burgwardt
Sr. Member
****
Offline Offline

Activity: 350



View Profile
June 19, 2011, 06:04:43 AM
 #11

The 69xx series has a known problem where anything using OpenCL doesn't share resources with other programs.

Those cards will all lock.
Auspician
Member
**
Offline Offline

Activity: 112



View Profile
June 19, 2011, 05:24:08 PM
 #12

Good to know, Garrett.  Is this an ATI/AMD problem, meaning could I share feedback with them about this and ask for a software update that doesn't have that problem?
Fiyasko
Legendary
*
Offline Offline

Activity: 1428


Okey Dokey Lokey


View Profile
June 20, 2011, 04:43:55 PM
 #13

Your monitor can display 1024 frames ? Really  Shocked

-f 60 (frames) is usually the max. If it hangs your computer is unstable.

I fucking hate noobs

But Yes, If it hangs, Your system is unstable.

I have two 6870's crossfire'd in my main comp
GPU0=940core 1150mem
GPU1=1000core 1200mem

Running at -v -w128 -f250

Crysis 2+advanced graphics options=No lag
No need to stop a GPU.
When i had GPU0 at 965core, i could mine with it But games would crash while the miner was running, Turn off the miner, and games EVENTUALLY crash

If you think it's the OpenCL bug, Then try placing the core affinity on ALL gpu's to just one core, BTW if you have more than 1 GPU, OpenCL will Peg one of your cores at 100%

Even with the bug Activly Fucking my 6th core really hard Crysis 2 runs Perfect whilst mining

http://bitcoin-otc.com/viewratingdetail.php?nick=DingoRabiit&sign=ANY&type=RECV <-My Ratings
https://bitcointalk.org/index.php?topic=857670.0 GAWminers and associated things are not to be trusted, Especially the "mineral" exchange
dikidera
Full Member
***
Offline Offline

Activity: 126


View Profile
June 20, 2011, 07:09:50 PM
 #14

I also played games while mining. And although i mined slower(obviously) i had the perfect settings. The game wasn't as smooth, but it worked.
Fiyasko
Legendary
*
Offline Offline

Activity: 1428


Okey Dokey Lokey


View Profile
June 21, 2011, 04:24:50 PM
 #15

Raise the F if the game is not smooth, I can play the most BASIC of video games (Touhou 12) and i lag without the F up at 250

http://bitcoin-otc.com/viewratingdetail.php?nick=DingoRabiit&sign=ANY&type=RECV <-My Ratings
https://bitcointalk.org/index.php?topic=857670.0 GAWminers and associated things are not to be trusted, Especially the "mineral" exchange
Auspician
Member
**
Offline Offline

Activity: 112



View Profile
June 29, 2011, 02:44:47 PM
 #16

Update: This issue seems to depend upon the game.  Civilization 5 doesn't want to share resources with the miners, and results in a system crash.  However, Neverwinter Nights 2 and Fallout New Vegas work great with just the -f60 flag, even running through a GFX card on a PCIe x8 slot. 
qed
Full Member
***
Offline Offline

Activity: 196


View Profile
June 29, 2011, 11:32:20 PM
 #17

All DX11 games, on 6900 cards, will lock your PC if you start it while mining, DX9 games are working fine. I did not test DX10 games.

Mobile App (Android)

Monitor miners, exchange rates and Bitcoin network stats.
Auspician
Member
**
Offline Offline

Activity: 112



View Profile
June 30, 2011, 05:04:30 PM
 #18

Good to know!  I'll have to try running Civilization 5 in DX9.
SeriousWorm
Jr. Member
*
Offline Offline

Activity: 54



View Profile
June 30, 2011, 10:19:27 PM
 #19

I can play UrbanTerror (OpenGL game) with a miner in the background.

If I start UrT while mining, I get a crash.

*However*, if I start UrT, ALT-TAB out of the game, start the miner then just as the miner is starting ALT-TAB *back* in to the game, everything works. From then on I can ALT-TAB whenever I want, it runs perfectly for hours.

I'm running the latest Phoenix w/ Cat 10.6, MSI 6870 Hawk, Afterburner to control clocks.
I can set Aggression to about 5 without any fps loss or lag. I get minor lag on 6 and it increases at 7 and up.
I get around 150-250 MH/sec out of the 300 maximum. Much better than 0. Smiley



Additionally, Far Cry 2 (which I got with the card) seems to run fine without crashes, regardless of the above.
Fiyasko
Legendary
*
Offline Offline

Activity: 1428


Okey Dokey Lokey


View Profile
July 01, 2011, 08:09:12 AM
 #20

All DX11 games, on 6900 cards, will lock your PC if you start it while mining, DX9 games are working fine. I did not test DX10 games.

You are completely incorrect, I am loving my 6990 eyefinity, a yummy 60fps max graphics with one core and 400mhashes with the other.

When i obey this threads 'ruleset' we'll call it, (and i just tested this) i get a horrible 139mh/s per core(2) but the game still gets a solid 60fps+

Maxedout Eyefinity on Crysis2 with the Adavanced Graphics Tweaker
Notes:AA is disabled.
         All forms of PhysX are disabled
         Windows7UltimateX86
         -v -w128 -f350

http://bitcoin-otc.com/viewratingdetail.php?nick=DingoRabiit&sign=ANY&type=RECV <-My Ratings
https://bitcointalk.org/index.php?topic=857670.0 GAWminers and associated things are not to be trusted, Especially the "mineral" exchange
Pages: [1] 2 »  All
  Print  
 
Jump to:  

Sponsored by , a Bitcoin-accepting VPN.
Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2006-2009, Simple Machines Valid XHTML 1.0! Valid CSS!