Bitcoin Forum
October 23, 2017, 07:34:01 PM *
News: Latest stable version of Bitcoin Core: 0.15.0.1  [Torrent]. (New!)
 
   Home   Help Search Donate Login Register  
Pages: [1]
  Print  
Author Topic: Gitian Build of Litecoin Win32 Binaries  (Read 1793 times)
thekidcoin
Sr. Member
****
Offline Offline

Activity: 308

FlutterCoin Developer


View Profile
May 10, 2013, 03:28:45 AM
 #1

So i am having all kinds of trouble building Litecoin via gitian.

The Linux gitian builds work fine.   The windows builds however, not so much.

I can build the deps, boost, and qt via gitian, and even used these deps to build Bitcoin.exe and Bitcoin-qt.exe

Using the gitian-win32.yml from bitcoin (or from Litecoin, doesn't matter), I get nothing but errors.  Also it appears as though its not finding some of the needed deps.  But the deps definitely work, and are the gitian zip file I built for bitcoin.

Anyone ever run into this?  I found nothing on google or anything on this.  Is anyone building Litecoin windows binaries with gitian using the available src as is or do I have to re-write a lot of this to work?


Here are some of the errors in the build.log (just random snippets from hundreds of errors):

src/bignum.h:12:24: error: openssl/bn.h: No such file or directory
...
src/util.h:22:28: error: boost/thread.hpp: No such file or directory
src/util.h:23:32: error: boost/filesystem.hpp: No such file or directory
src/util.h:24:37: error: boost/filesystem/path.hpp: No such file or directory
...
src/serialize.h:289: error: expected â,â or â...â before â::â token
src/serialize.h:289: error: ISO C++ forbids declaration of âboostâ with no type
...
src/wallet.h:586: error: âBOOST_FOREACHâ was not declared in this scope
src/wallet.h:587: error: expected `;' before â{â token
src/qt/bitcoin.cpp: In function âint main(int, char**)â:
src/qt/bitcoin.cpp:124: error: âboostâ has not been declared
src/qt/bitcoin.cpp:128: error: âboostâ has not been declared
src/qt/bitcoin.cpp:128: error: expected `;' before âmqâ
src/qt/bitcoin.cpp:129: error: âmqâ was not declared in this scope
src/qt/bitcoin.cpp:136: error: expected type-specifier before âboostâ
src/qt/bitcoin.cpp:136: error: expected `)' before â::â token
src/qt/bitcoin.cpp:136: error: expected `{' before â::â token



1MYL967PR52xiNtqSP9WphRvPzKZDjBdxn
1508787241
Hero Member
*
Offline Offline

Posts: 1508787241

View Profile Personal Message (Offline)

Ignore
1508787241
Reply with quote  #2

1508787241
Report to moderator
Advertised sites are not endorsed by the Bitcoin Forum. They may be unsafe, untrustworthy, or illegal in your jurisdiction. Advertise here.
thekidcoin
Sr. Member
****
Offline Offline

Activity: 308

FlutterCoin Developer


View Profile
May 10, 2013, 03:38:34 PM
 #2

fixed by changing the deps path to the correct location - though again, it worked in the bitcoin build and the same deps are in the same exact location.

1MYL967PR52xiNtqSP9WphRvPzKZDjBdxn
Pages: [1]
  Print  
 
Jump to:  

Sponsored by , a Bitcoin-accepting VPN.
Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2006-2009, Simple Machines Valid XHTML 1.0! Valid CSS!