Bitcoin Forum
October 23, 2021, 06:49:26 PM *
News: Latest Bitcoin Core release: 22.0 [Torrent]
 
   Home   Help Search Login Register More  
Pages: « 1 2 3 [4]  All
  Print  
Author Topic: [CLOSED] 2000 YAC bounty for adapting minerd for YAC  (Read 12968 times)
Kinetic915
Full Member
***
Offline Offline

Activity: 168
Merit: 100



View Profile
May 12, 2013, 02:21:55 AM
 #61

how do you do the config fiile>?/?/ it keeps trying to connect to 127.0.0.1
create a batch pointing to the executable.

1635014966
Hero Member
*
Offline Offline

Posts: 1635014966

View Profile Personal Message (Offline)

Ignore
1635014966
Reply with quote  #2

1635014966
Report to moderator
You can see the statistics of your reports to moderators on the "Report to moderator" pages.
Advertised sites are not endorsed by the Bitcoin Forum. They may be unsafe, untrustworthy, or illegal in your jurisdiction. Advertise here.
cryptrol
Hero Member
*****
Offline Offline

Activity: 637
Merit: 500


View Profile
May 18, 2013, 05:45:54 PM
 #62

C:\Users\USERUSER\AppData\Local\Temp\cc4kfJms.s: Assembler messages:
C:\Users\USERUSER\AppData\Local\Temp\cc4kfJms.s:25: Warning: .type pseudo-op use
d outside of .def/.endef ignored.
C:\Users\USERUSER\AppData\Local\Temp\cc4kfJms.s:25: Error: junk at end of line,
first unrecognized character is `h'

See my fix:

I have to go to bed, but if anyone wants to get a step closer to compiling it on windows, replace line 173 in ./code/scrypt-jane-portable-x86.h with

Code:
#define asm_naked_fn_end(fn) ".att_syntax prefix;\n.def " #fn "; .scl 2; .type 32; .size .-" #fn "; .endef \n"  );

The new error complains about _has_cpuid@0 not being defined (in minerd-scrypt-jane.o, after compiling to asm).

EDIT: I have managed to compile it! Here is a link for all you windows users Cheesy
cpuminer-scrypt-jane-win32.zip

If this helped you and you want to donate, please send to any in my sig or YMKPwfHMR72cjw21aBJjLvq3LDfRb7AZ1b Smiley. I really appreciate it.

What did you do to solve the has_cpuid@0 error after changing the assembly line ?
I am stuck with it trying to compile the official client.
dmatthewstewart
Sr. Member
****
Offline Offline

Activity: 437
Merit: 250



View Profile
September 08, 2013, 01:30:26 AM
 #63

Can anyone walk me through getting this working on Linux like I'm 5 years old?

Getting this after ./configure CFLAGS="-O3"

Code:
./configure: line 5506: 'LIBCURL_CHECK_CONFIG(, 7.10.1, ,'

what this means?

this one got me stuck up for few mins earlier.

Basically install the libcurl dev libraries. on ubuntu :-
sudo apt-get install libcurl-ocaml-dev

and then run ./autogen.sh again to generate fresh configure script.

I think there is something in autogen which writes a bad configure script if libcurl development headers were missing.

Well, Ive tried this and now I have officially tried everything. I cant get scrypt-jane to work/install. Ive been trying for months

Pages: « 1 2 3 [4]  All
  Print  
 
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2006-2009, Simple Machines Valid XHTML 1.0! Valid CSS!