Bitcoin Forum
January 22, 2019, 01:32:25 AM *
News: Latest Bitcoin Core release: 0.17.1 [Torrent]
 
   Home   Help Search Login Register More  
Pages: [1]
  Print  
Author Topic: Armory 0.90 offline wallet issues (condensed version)  (Read 303 times)
Armory0.90issues
Newbie
*
Offline Offline

Activity: 13
Merit: 0


View Profile
August 13, 2017, 02:48:02 PM
Last edit: August 13, 2017, 04:00:37 PM by Armory0.90issues
 #1

Armory 0.90-beta running on Ubuntu 12.04 LTS on my air-gapped computer was unable to sign transactions created by Armory 0.93.2 on my Internet connected computer, so I tried to update the Armory version on the air-gapped computer to Armory 0.93.3 for Ubuntu 12.04+ (32bit) and ran into a "dependency is not satisfiable: python-qt4" error.

Now I can't get the Armory wallet on the air-gapped computer to launch anymore, and I'm unable to find where the error logs are stored in the Ubuntu file system (or else I would have them posted below) relevant error logs are available at https://pastebin.com/vcdyVCZA.  

Hoping someone here can help me get the offline wallet up and running so I can sign some transactions - thanks in advance.
Advertised sites are not endorsed by the Bitcoin Forum. They may be unsafe, untrustworthy, or illegal in your jurisdiction. Advertise here.
1548120745
Hero Member
*
Offline Offline

Posts: 1548120745

View Profile Personal Message (Offline)

Ignore
1548120745
Reply with quote  #2

1548120745
Report to moderator
1548120745
Hero Member
*
Offline Offline

Posts: 1548120745

View Profile Personal Message (Offline)

Ignore
1548120745
Reply with quote  #2

1548120745
Report to moderator
1548120745
Hero Member
*
Offline Offline

Posts: 1548120745

View Profile Personal Message (Offline)

Ignore
1548120745
Reply with quote  #2

1548120745
Report to moderator
jefferson7
Newbie
*
Offline Offline

Activity: 50
Merit: 0


View Profile
August 13, 2017, 03:36:14 PM
 #2

home/.armory

When in /home enable 'view hidden files'
jefferson7
Newbie
*
Offline Offline

Activity: 50
Merit: 0


View Profile
August 13, 2017, 03:37:49 PM
 #3

Armory wont run without those dependencies. You either download and install them all manually via usb stick, or put it online and update everything.
Armory0.90issues
Newbie
*
Offline Offline

Activity: 13
Merit: 0


View Profile
August 13, 2017, 03:55:11 PM
 #4

Thanks jefferson7 - viewing hidden files did the trick.  The error logs for yesterday are here:

https://pastebin.com/vcdyVCZA
Armory0.90issues
Newbie
*
Offline Offline

Activity: 13
Merit: 0


View Profile
August 13, 2017, 04:02:54 PM
 #5

Thanks again jefferson7 - can you elaborate on the dependency I need and, if possible, where I can find it?
achow101
Staff
Legendary
*
Offline Offline

Activity: 1652
Merit: 1982


bc1qshxkrpe4arppq89fpzm6c0tpdvx5cfkve2c8kl


View Profile WWW
August 13, 2017, 06:06:15 PM
 #6

You should install the offline bundle which you can get from https://github.com/goatpig/BitcoinArmory/releases/tag/v0.93.3. The offline bundles contain all of the packages that Armory depends on so those will be installed as well.

Armory0.90issues
Newbie
*
Offline Offline

Activity: 13
Merit: 0


View Profile
August 13, 2017, 09:07:15 PM
 #7

Thanks achow101 - I copied the .tar.gz file to my air-gapped computer via a USB key.  However, I'm unable to get it to install.  When I open the Install_DoubleClick_RunInTerminal.sh file, I get what looks like a text file with the following:

#! /bin/bash

sudo dpkg -i *.deb


I tried entering the sudo dpkg -i *.deb command into the terminal, but received the following message:

dpkg: error processing *.deb (--install):
 cannot access archive: No such file or directory
Errors were encountered while processing:
 *.deb


I apologize if this is elementary linux stuff - I've only ever worked with linux to install this offline armory wallet, and this is all very foreign to me. 

I really appreciate your time on this.
Armory0.90issues
Newbie
*
Offline Offline

Activity: 13
Merit: 0


View Profile
August 13, 2017, 09:42:46 PM
 #8

achow101 - please disregard my last post.

For those reading this in the future who are equally linux-ignorant as myself, you need to extract the tar.gz file (e.g., to your desktop), and then open the resulting OfflineBundle folder, double click on the Install_DoubleClick_RunInTerminal.sh file, and select "Run in Terminal".  That will install the 0.93.3 Armory version.  I used that version of Armory to sign a transaction created by the 0.93.2 Armory version on my Internet connected computer, and it just cleared.

achow101 and jefferson7 - if you post an address in this thread I'll buy you each a few beers.
achow101
Staff
Legendary
*
Offline Offline

Activity: 1652
Merit: 1982


bc1qshxkrpe4arppq89fpzm6c0tpdvx5cfkve2c8kl


View Profile WWW
August 14, 2017, 05:01:09 AM
 #9

achow101 and jefferson7 - if you post an address in this thread I'll buy you each a few beers.
My address is 17kKQppUsngUiByDsce4JXoZEjjpvX9bpR (it's also in my profile).

Armory0.90issues
Newbie
*
Offline Offline

Activity: 13
Merit: 0


View Profile
August 14, 2017, 10:05:49 PM
 #10

Ha - I probably should have checked that first.


tx 49f4980aa20bebf4781fdcfef59ed3ed2e36ae5ea3d2e49279aec10140468f11 coming your way.

Thanks again.

Pages: [1]
  Print  
 
Jump to:  

Bitcointalk.org is not available or authorized for sale. Do not believe any fake listings.
Sponsored by , a Bitcoin-accepting VPN.
Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2006-2009, Simple Machines Valid XHTML 1.0! Valid CSS!