Bitcoin Forum
May 27, 2024, 07:38:08 PM *
News: Latest Bitcoin Core release: 27.0 [Torrent]
 
   Home   Help Search Login Register More  
Pages: [1]
  Print  
Author Topic: Raspberry + aktive Hubs  (Read 1763 times)
dsky (OP)
Sr. Member
****
Offline Offline

Activity: 279
Merit: 250


View Profile
June 28, 2013, 10:07:50 AM
 #1

Hi Community,

ich stelle dieses WE von einem Windows Server auf einen Raspberry Pi um.

Ich habe 2x Logilink 10 Port USB2.0 Hubs mit je 3.5A NT.
Bisher habe ich beide jeweils in einem eigenen USB-Port am Server gehabt.

Angeblich sollen die Logilinks ja backpowern auf den USB-Anschluß - was passiert nun, wenn ich die Hubs stacken will?
Ich möchte quasi: Raspberry -> Hub1 -> Hub2 hintereinander betreiben, weil der Raspberry ja nur 2 USB-Ports hat.

Bretzel ich mir da den USB-Port von Raspberry durch, oder passiert nix und es läuft wie gewünscht?
Sollte ich evtl. besser einen passiven Hub als Sternverteiler dazwischen setzen: Raspberry -> passiver Hub -> Hub1 + Hub2 ? Würde dann im Zweifelsfall wohl eher der passive Hub abrauchen, bevor der Raspberry abfackelt?

Fragen über Fragen.
yxt
Legendary
*
Offline Offline

Activity: 3528
Merit: 1116



View Profile
June 28, 2013, 10:11:43 AM
 #2

Raspberry -> Hub1 -> Hub2 funktioniert

EDIT:
Quote
Angeblich sollen die Logilinks ja backpowern auf den USB-Anschluß
Habe einen anderen von Logilink, 7 Port da ist es so

BTCKano Pool██ ██
██ ██
██ ██
██ ██
██ ██
██ ██
██ ██
██ ██
██ ██
██
██
██
██
██ ██ ██
██ ██ ██
██ ██ ██
██ ██ ██
██ ██ ██
██ ██ ██
██ ██ ██
██ ██ ██
██ ██ ██
   ██
   ██
   ██
   ██
██ ██
██ ██
██ ██
██ ██
██ ██
██ ██
██ ██
██ ██
██ ██
   ██
   ██
   ██
   ██
Theradur
Full Member
***
Offline Offline

Activity: 204
Merit: 100


View Profile
June 28, 2013, 01:49:50 PM
 #3

Nutzt du den Server "richtig" oder steht er nur zum minen da? Wenn ihn richtig nutzt wirste mit dem Raspberry glaube nicht ganz glücklich werden weil der doch recht langsam ist. Ein Beaglebone Black dürfte etwas mehr Dampf haben.
Dunkelheit667
Legendary
*
Offline Offline

Activity: 1045
Merit: 1157


no degradation


View Profile
June 28, 2013, 02:01:24 PM
 #4

...Angeblich sollen die Logilinks ja backpowern auf den USB-Anschluß...
...Sollte ich evtl. besser einen passiven Hub als Sternverteiler dazwischen setzen: Raspberry -> passiver Hub -> Hub1 + Hub2 ? Würde dann im Zweifelsfall wohl eher der passive Hub abrauchen, bevor der Raspberry abfackelt?...

Also der UA0096 (Logilink, schwarz, 10-Port) backpowered. Ich bestrome damit meinen Raspberry (B, Rev. 2) problemlos, ein Netzteil ist am Raspberry dabei nicht angeschlossen.

Ein zusätzlicher passiver Hub wird im Zweifelsfall auch wenig bringen. Du weisst nicht, wie der intern aufgebaut ist, leitet ggf. auch den Strom zurück zum Raspberry.

Wenn Du gaaanz sicher gehen willst... Nimm ein altes USB-Kabel, lege die Kabel vorsichtig frei, durchtrenne das rote +5V-Kabel. Verbinde Raspberry und Hub mit diesem Kabel. So fließt kein Strom zurück. Wink

"And the machine keeps pushing time through the cogs, like paste into strings into paste again, and only the machine keeps using time to make time to make time.
And when the machine stops, time is an illusion that we created free will.
" - an unnamed Hybrid
yxt
Legendary
*
Offline Offline

Activity: 3528
Merit: 1116



View Profile
June 28, 2013, 02:15:21 PM
 #5

Viel zu aufwendig, strategisch plazierter Tesastreifen im Stecker Wink

Aber ist wie gesagt kein Problem

BTCKano Pool██ ██
██ ██
██ ██
██ ██
██ ██
██ ██
██ ██
██ ██
██ ██
██
██
██
██
██ ██ ██
██ ██ ██
██ ██ ██
██ ██ ██
██ ██ ██
██ ██ ██
██ ██ ██
██ ██ ██
██ ██ ██
   ██
   ██
   ██
   ██
██ ██
██ ██
██ ██
██ ██
██ ██
██ ██
██ ██
██ ██
██ ██
   ██
   ██
   ██
   ██
Dunkelheit667
Legendary
*
Offline Offline

Activity: 1045
Merit: 1157


no degradation


View Profile
June 28, 2013, 02:21:43 PM
 #6

Viel zu fummelig. Grin Na ne, stimmt natürlich, beide Wege führen zum Ziel.

"And the machine keeps pushing time through the cogs, like paste into strings into paste again, and only the machine keeps using time to make time to make time.
And when the machine stops, time is an illusion that we created free will.
" - an unnamed Hybrid
dsky (OP)
Sr. Member
****
Offline Offline

Activity: 279
Merit: 250


View Profile
June 29, 2013, 06:53:58 AM
 #7

Nen ARM Server mit 100Mbit NIC? Nein. Nur Mining. Für alles andere steht hier ein Windows Server mit LightsOut Addon damit der schläft, wenn kein Client an ist.

Hab 2x den UA0096. Ich klebe wohl ab. Mal sehen. Danke!
dsky (OP)
Sr. Member
****
Offline Offline

Activity: 279
Merit: 250


View Profile
June 29, 2013, 12:13:09 PM
 #8

Also der UA0096 backpowered - der Raspberry geht sofort an - auch wenn in der offiziellen Kompatibilitätsliste steht das dem nicht so sei.

Ich habe jetzt trotzdem das 1A Netzteil am Raspberry angeklemmt damit der nicht das Netzteil des Hubs belastet.

Hatte das Problem, dass nur Sticks vom ersten Hub erkannt wurden. Der zweite der an Port 10 durchgeschliffen wurde wurde nicht angesprochen. Hab den dann nochmal abgeklemmt, Sticks ab, Hub wieder dran, Sticks nacheinander dran -> Läuft. Keine Ahnung. Aber läuft so wie ich das wollte. Überlebt sogar nen Neustart.

Ich nehme Archlinux und hab damit bisher überhaupt keine Probleme. Sogar Hotplugging funzt mit dem aktuellen CGMiner. Bin sehr zufrieden.
yxt
Legendary
*
Offline Offline

Activity: 3528
Merit: 1116



View Profile
June 29, 2013, 01:25:58 PM
 #9

R-PI und usb ist etwas tricky

BTCKano Pool██ ██
██ ██
██ ██
██ ██
██ ██
██ ██
██ ██
██ ██
██ ██
██
██
██
██
██ ██ ██
██ ██ ██
██ ██ ██
██ ██ ██
██ ██ ██
██ ██ ██
██ ██ ██
██ ██ ██
██ ██ ██
   ██
   ██
   ██
   ██
██ ██
██ ██
██ ██
██ ██
██ ██
██ ██
██ ██
██ ██
██ ██
   ██
   ██
   ██
   ██
dsky (OP)
Sr. Member
****
Offline Offline

Activity: 279
Merit: 250


View Profile
June 29, 2013, 03:50:04 PM
 #10

Bei mir läufts sauber. Ich kann also den Raspberry + Logilink UA0096 10-Port USB 2.0 Hub gestackt empfehlen - auch ohne abkleben. Wobei ich nicht mehr als 6 USB Eruptoren je Hub betreiben würde wegen 3.5A Netzteil.
Menig
Legendary
*
Offline Offline

Activity: 910
Merit: 1000


View Profile
July 09, 2013, 10:48:40 AM
 #11

 
hätte gerne mal ein paar mehr Empfehlungen für USB-Hubs welche stackable sind... und genügend Power um die Ports auch entsprechend zu versorgen wenn diese
mit USB-Asic-Minern bestückt sind....

Bin von den Logilink-10-Port atm etwas angefressen da die Netzteilkabel am Hub nicht wirklich gut passen... hatte es bei meinen fünf Hubs jetzt schon mehrfach
das die Kaskade zusammengebrochen ist weil Stromstrecker auf einerm der Hubs gewackelt hat... zum kotzen !

Gibt es keine Qualitativ gute Ware mehr mit Steckern die auch fest sitzen und genügend Ampere haben um alle Ports die sie haben auch stabil mit entsprechend Strom
für die USb-Asic-Eruptor zu versorgen ?  zum kotzen ! Wink
Dunkelheit667
Legendary
*
Offline Offline

Activity: 1045
Merit: 1157


no degradation


View Profile
July 09, 2013, 12:16:21 PM
 #12

Beim Stecker soll ja eine Rasierklinge helfen, sagt Hans E. Wink

Siehe hier:
http://www.amazon.de/gp/customer-media/permalink/moUAW234WKO3FY/B003ECC702/ref=cm_ciu_images_pl_link

"And the machine keeps pushing time through the cogs, like paste into strings into paste again, and only the machine keeps using time to make time to make time.
And when the machine stops, time is an illusion that we created free will.
" - an unnamed Hybrid
h2o@7970
Sr. Member
****
Offline Offline

Activity: 280
Merit: 250


View Profile
July 09, 2013, 12:54:25 PM
 #13

Beim Stecker soll ja eine Rasierklinge helfen, sagt Hans E. Wink

Siehe hier:
http://www.amazon.de/gp/customer-media/permalink/moUAW234WKO3FY/B003ECC702/ref=cm_ciu_images_pl_link

rasierklinge ne ne dafür braucht man eine drehbank  Wink
mameise
Hero Member
*****
Offline Offline

Activity: 561
Merit: 500


View Profile
July 09, 2013, 07:55:23 PM
 #14

Also 8ch bin mit dem 4A 10 Port Hub vom Conrad mehr als zufrieden. Zum Thema stacken werde ich erst was sagen können wenn die anderen Sticks eintreffen. Denke aber wird auch kein Problem sein.
fhh
Legendary
*
Offline Offline

Activity: 1206
Merit: 1000



View Profile
July 10, 2013, 12:49:30 PM
 #15

Also 8ch bin mit dem 4A 10 Port Hub vom Conrad mehr als zufrieden. Zum Thema stacken werde ich erst was sagen können wenn die anderen Sticks eintreffen. Denke aber wird auch kein Problem sein.

Meinst du den hier?
http://www.conrad.de/ce/de/product/973666/10-Port-USB-20-Hub-mit-Netzteil?queryFromSuggest=true

nach 2 oder 3 Tagen ist das Netzteil gestorben mit 5-6 Sticks Sad

Deutsche Bitcoinbörse: https://www.bitcoin.de/r/yyfrkv
das passende Konto gibts bei der fidor Bank https://banking.fidor.de/registrierung?ibid=43076568
mameise
Hero Member
*****
Offline Offline

Activity: 561
Merit: 500


View Profile
July 10, 2013, 01:24:06 PM
 #16

Also 8ch bin mit dem 4A 10 Port Hub vom Conrad mehr als zufrieden. Zum Thema stacken werde ich erst was sagen können wenn die anderen Sticks eintreffen. Denke aber wird auch kein Problem sein.

Meinst du den hier?
http://www.conrad.de/ce/de/product/973666/10-Port-USB-20-Hub-mit-Netzteil?queryFromSuggest=true

nach 2 oder 3 Tagen ist das Netzteil gestorben mit 5-6 Sticks Sad

Ja den meine ich. Mach mir keine Angst!!! Hab bisher nur 4 dran aber die laufen seit 3 Wochen konstant! Sobald die Sticks vom GB von Mening kommen wollte ich 2 hubs mit je 6 laufen lassen... Ich hoffe ich habe mehr Glück.
gMaN1337
Full Member
***
Offline Offline

Activity: 157
Merit: 100



View Profile
July 10, 2013, 02:08:13 PM
 #17

ich habe zurzeit
1nen stick am laufen mehr sind bestellt

ich benutze folgenden usb hub :
http://www.amazon.de/gp/product/B003ID923C/ref=oh_details_o02_s00_i00?ie=UTF8&psc=1


gMaN1337
Full Member
***
Offline Offline

Activity: 157
Merit: 100



View Profile
July 10, 2013, 03:19:22 PM
 #18

habe ne frage dazu hoffe mir kann jemand helfen ^^

habe fesgestellt das wenn ich den stick mit einem lüfter kühle ich sehr viele ( fast nur noch Errors bekomme ) einer ne ahnung woran das liegen kann ?

Desweitern habe ich ne frage was die Discard bedeutet ?



hoffe mir kann jemand helfen

Pages: [1]
  Print  
 
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2006-2009, Simple Machines Valid XHTML 1.0! Valid CSS!