Bitcoin Forum
July 16, 2018, 01:45:57 AM *
News: Latest stable version of Bitcoin Core: 0.16.1  [Torrent]. (New!)
 
   Home   Help Search Donate Login Register  
Pages: [1]
  Print  
Author Topic: Antminer S9 autofreq fan speed override only working on one fan?  (Read 191 times)
myholdout
Newbie
*
Offline Offline

Activity: 2
Merit: 0


View Profile
January 03, 2018, 05:56:28 PM
 #1

As you may know, Bitmain is switching over to an auto-benchmarking/calibration model without any fan speed controls.  I just received a 14 TH/s S9 with auto-freq firmware installed (previously this speed model was fixed frequency).  I added the following to bmminer.conf:

"bitmain-fan-ctrl" : true,
"bitmain-fan-pwm" : "40",

Kernel log shows:
Set fixed fan speed=40
FAN PWM: 40

However it appears to only have affected the speed of the secondary fan (Fan6) while the primary fan (Fan3) is still on auto-speed.

Thoughts?
1531705557
Hero Member
*
Offline Offline

Posts: 1531705557

View Profile Personal Message (Offline)

Ignore
1531705557
Reply with quote  #2

1531705557
Report to moderator
1531705557
Hero Member
*
Offline Offline

Posts: 1531705557

View Profile Personal Message (Offline)

Ignore
1531705557
Reply with quote  #2

1531705557
Report to moderator
1531705557
Hero Member
*
Offline Offline

Posts: 1531705557

View Profile Personal Message (Offline)

Ignore
1531705557
Reply with quote  #2

1531705557
Report to moderator
The World's Betting Exchange

Bet with play money. Win real Bitcoin. 5BTC Prize Fund for World Cup 2018.

Advertised sites are not endorsed by the Bitcoin Forum. They may be unsafe, untrustworthy, or illegal in your jurisdiction. Advertise here.
1531705557
Hero Member
*
Offline Offline

Posts: 1531705557

View Profile Personal Message (Offline)

Ignore
1531705557
Reply with quote  #2

1531705557
Report to moderator
1531705557
Hero Member
*
Offline Offline

Posts: 1531705557

View Profile Personal Message (Offline)

Ignore
1531705557
Reply with quote  #2

1531705557
Report to moderator
1531705557
Hero Member
*
Offline Offline

Posts: 1531705557

View Profile Personal Message (Offline)

Ignore
1531705557
Reply with quote  #2

1531705557
Report to moderator
fanatic26
Hero Member
*****
Offline Offline

Activity: 756
Merit: 560


View Profile
January 03, 2018, 10:07:42 PM
 #2

The only thought is why are you screwing with the fans? The auto sensing firmware will run them as needed, you shouldnt be messing with it.

Stop buying industrial miners, running them at home, and then complaining about the noise.
fanatic26
Hero Member
*****
Offline Offline

Activity: 756
Merit: 560


View Profile
February 02, 2018, 05:59:39 PM
 #3

The auto frequency boards are different than the old fixed frequency so you cant use the old firmware.

Again I state, the software controls the fans for a reason, you should not be messing with the fan speeds.

Stop buying industrial miners, running them at home, and then complaining about the noise.
the_electronrancher
Jr. Member
*
Offline Offline

Activity: 98
Merit: 4


View Profile
February 03, 2018, 02:29:39 AM
 #4

It's not a very well built firmware - it also ignores a fixed frequency setting in the same file.  It's strange that it accepts your setting for one fan, but chalk it up to implementation issues.

Fanatic is right though, messing with the fans will not down clock the device - it will just run at the same power with poor cooling, meaning a shortened lifetime for your chips.

Take the suggestion and delete the configuration mods, let the fans run at the speed needed to properly cool the device.
Pages: [1]
  Print  
 
Jump to:  

Sponsored by , a Bitcoin-accepting VPN.
Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2006-2009, Simple Machines Valid XHTML 1.0! Valid CSS!