Bitcoin Forum
December 06, 2019, 12:10:48 AM *
News: Latest Bitcoin Core release: 0.19.0.1 [Torrent]
 
   Home   Help Search Login Register More  
Pages: [1]
  Print  
Author Topic: Need some help with c-lightning. Address is not routable...  (Read 149 times)
jimbobway
Legendary
*
Offline Offline

Activity: 1405
Merit: 1010



View Profile
January 22, 2018, 07:00:06 PM
Merited by DannyHamilton (2)
 #1

bitcoind is running and is synchonized. I am trying to run lightning with the first command and I get this error:

lightningd/lightningd --log-level=debug

    lightningd(3684): Trying to guess public addresses...

    lightningd(3684): Address 192.168.1.12:9735 is not routable

    lightningd(3684): Failed to connect 10 socket: Network is unreachable

My bitcoin.conf file has these lines:

    server=1

    rpcuser=aUser

    rpcpassword=aPassword

Any help would be appreciated.
My computer is behind a router...
Advertised sites are not endorsed by the Bitcoin Forum. They may be unsafe, untrustworthy, or illegal in your jurisdiction. Advertise here.
1575591048
Hero Member
*
Offline Offline

Posts: 1575591048

View Profile Personal Message (Offline)

Ignore
1575591048
Reply with quote  #2

1575591048
Report to moderator
1575591048
Hero Member
*
Offline Offline

Posts: 1575591048

View Profile Personal Message (Offline)

Ignore
1575591048
Reply with quote  #2

1575591048
Report to moderator
1575591048
Hero Member
*
Offline Offline

Posts: 1575591048

View Profile Personal Message (Offline)

Ignore
1575591048
Reply with quote  #2

1575591048
Report to moderator
aleksej996
Sr. Member
****
Offline Offline

Activity: 490
Merit: 328


Do not trust the government


View Profile
January 22, 2018, 11:49:40 PM
Merited by achow101 (1)
 #2

I think your node needs to be accessible from the Internet in order for lightning-c to work.
You will probably need to put your computer in DMZ as with port forwarding your node will not be aware of the IP address of the node that is connecting to it.

You will need to specify your public IP address with an argument. I think --ipaddr is the argument for this.
jimbobway
Legendary
*
Offline Offline

Activity: 1405
Merit: 1010



View Profile
January 23, 2018, 12:51:42 AM
 #3

Thanks.  Ok, here is the fix:

Just make sure to forward port 9735 to the host running lightningd and add --ipaddr <your public ip> to the lightningd command line.

If necessary add rpcport=8332 to bitcoin.conf and reboot.
aleksej996
Sr. Member
****
Offline Offline

Activity: 490
Merit: 328


Do not trust the government


View Profile
January 27, 2018, 12:10:41 AM
Merited by examplens (1)
 #4

Thanks.  Ok, here is the fix:

Just make sure to forward port 9735 to the host running lightningd and add --ipaddr <your public ip> to the lightningd command line.

If necessary add rpcport=8332 to bitcoin.conf and reboot.


Yes Smiley
But as I said, I would recommend a setting up a DMZ instead as your node will see all incoming connections coming from your routers LAN IP address.
This is why you don't port forward Bitcoin node, as eventually your node automatically blacklists some node for spamming and then you can't get any inbound connections as it bans your router.
BobLawblaw
Legendary
*
Offline Offline

Activity: 1484
Merit: 2118


Bitcointalk's Friendly Gay Negro from Outer Space


View Profile
February 08, 2018, 07:52:03 AM
 #5

But as I said, I would recommend a setting up a DMZ instead as your node will see all incoming connections coming from your routers LAN IP address.

What about WAN<->DMZ/Firewall<-port-forward->bitcoind/lnd server ?

Don't seem to have any issues with the Bitcorn node so far.

I did make sure to add the --ipaddr with my WAN IP. Not showing up on any maps yet tho Sad

Figured I've done something wrong.
Pages: [1]
  Print  
 
Jump to:  

Sponsored by , a Bitcoin-accepting VPN.
Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2006-2009, Simple Machines Valid XHTML 1.0! Valid CSS!