Bitcoin Forum
December 05, 2016, 02:49:07 AM *
News: To be able to use the next phase of the beta forum software, please ensure that your email address is correct/functional.
 
   Home   Help Search Donate Login Register  
Pages: [1]
  Print  
Author Topic: Brand new rig fails to properly utilize it's two HD6950  (Read 945 times)
sodapop
Newbie
*
Offline Offline

Activity: 6


View Profile
July 15, 2011, 09:53:17 PM
 #1

The hardware:

MB: P8P67M Pro Newest bios
CPU: I3-2100
GPU: Asus 6950 1GB Factory bios, no overclocking
SSD, 6gb ram.

The problem:

When I run any miner (hashkill, phoenix, diablominer), or any combination of miners, I either get around 50-75% utilization of both cards, OR, I get 99% utilization of one card.

Basically, I either get sub-optimal performance from both cards, or I get expected performance from one card while the other is entirely starved. This happens at random. If I do get a stable 75%/75% from both cards, it will eventually (maybe after hours) turn into either 99%/0% or 0%/99%.

I am running 64-bit ubuntu, 11.04 and Stream SDK 2.4. The two PCIe slots the cards are connected to has x8 speeds according to the motherboard manual. I have installed one crossfire bridge (otherwise I can't use the 2nd card in linux). The temperatures are fine. My CPU utilization is almost nothing. Both cards easily do more than 300MH by themselves. I do not understand where the bottleneck is.

Any help with this would be highly appreciated. I'll gladly give 0.1-1btc tips to information that makes a difference.
1480906147
Hero Member
*
Offline Offline

Posts: 1480906147

View Profile Personal Message (Offline)

Ignore
1480906147
Reply with quote  #2

1480906147
Report to moderator
Advertised sites are not endorsed by the Bitcoin Forum. They may be unsafe, untrustworthy, or illegal in your jurisdiction. Advertise here.
drawoc
Full Member
***
Offline Offline

Activity: 168

Firstbits: 175wn


View Profile
July 15, 2011, 11:28:52 PM
 #2

Could you post your Xorg.conf? You can find it at /etc/X11/xorg.conf

Donate: 175WNXmJ1WVhFgVGKUqEhYtAQGRYAvqPA
sodapop
Newbie
*
Offline Offline

Activity: 6


View Profile
July 16, 2011, 07:14:30 AM
 #3

Code:
Section "ServerLayout"
Identifier     "aticonfig Layout"
Screen      0  "aticonfig-Screen[0]-0" 0 0
EndSection

Section "Module"
Load  "glx"
EndSection

Section "Monitor"
Identifier   "aticonfig-Monitor[0]-0"
Option     "VendorName" "ATI Proprietary Driver"
Option     "ModelName" "Generic Autodetecting Monitor"
Option     "DPMS" "true"
EndSection

Section "Device"
Identifier  "aticonfig-Device[0]-0"
Driver      "fglrx"
BusID       "PCI:1:0:0"
EndSection

Section "Screen"
Identifier "Default Screen"
DefaultDepth     24
EndSection

Section "Screen"
Identifier "aticonfig-Screen[0]-0"
Device     "aticonfig-Device[0]-0"
Monitor    "aticonfig-Monitor[0]-0"
DefaultDepth     24
SubSection "Display"
Viewport   0 0
Depth     24
EndSubSection
EndSection

drawoc
Full Member
***
Offline Offline

Activity: 168

Firstbits: 175wn


View Profile
July 16, 2011, 02:51:15 PM
 #4

Looks like you only have one card set up - not 2.
Try running:
Code:
aticonfig --initial=dual-head
and restarting.

Donate: 175WNXmJ1WVhFgVGKUqEhYtAQGRYAvqPA
Sideways
Jr. Member
*
Offline Offline

Activity: 49


View Profile
July 19, 2011, 08:12:27 AM
 #5

simple things first, are you pointing your miners at different cards? ie, when you run just polcbm it will tell you that you have to give it a device, usually 0 and 1. You then have to start each miner with a -d0 and a -d1 to use the second card. I like to open a separate terminal for each miner so I can watch them, and usually have 1 or 2 more open to watch temps, etc.
Also, if it's a dedicated miner (not a part time gamer) take out the xfire bridge, it doesn't help ( maybe even hinders.. ) mining.

edit:
now that I've thought about it and come back, I'm thinkin it is the xfire setup.. I'd start there by taking it out.
Oldminer
Legendary
*
Offline Offline

Activity: 1022



View Profile
July 19, 2011, 09:00:48 AM
 #6

Check that your not running 1 of the cards @ PCI-Ex 1 x in the BIOS

If you like my post please feel free to give me some positive rep https://bitcointalk.org/index.php?action=trust;u=18639
Tip me BTC: 1FBmoYijXVizfYk25CpiN8Eds9J6YiRDaX
sodapop
Newbie
*
Offline Offline

Activity: 6


View Profile
July 20, 2011, 02:58:52 PM
 #7

I can't say what the problem was, but I am now running the exact same setup on Kubuntu, and I get 99% load on both cards and a decent 650MH with no overclocking.
Pages: [1]
  Print  
 
Jump to:  

Sponsored by , a Bitcoin-accepting VPN.
Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2006-2009, Simple Machines Valid XHTML 1.0! Valid CSS!