Bitcoin Forum
October 23, 2017, 05:21:52 PM *
News: Latest stable version of Bitcoin Core: 0.15.0.1  [Torrent]. (New!)
 
   Home   Help Search Donate Login Register  
Pages: [1]
  Print  
Author Topic: Another LiteCoin + CGMiner + 7950 mining thread.  (Read 2172 times)
skeeterskeeter
Full Member
***
Offline Offline

Activity: 160


View Profile
October 10, 2013, 09:26:07 PM
 #1

Yes, I have searched, tried, searched, and tried again to no avail.

I am trying to mine litecoins with my good ol 7950 on windows 7 with CGMiner and am having some issues.

So I first tried these arguments
Code:
F:\cgminer.exe --scrypt -o POOL -u USER -p PASS
This actually gets me up and mining but at a miserably slow rate, something along the lines of 15kHash. Also quick question before we proceed. On www.dustcoin.com it lists the Litecoin difficulty at 1014, why does CGMiner show it at 66.5M ?



So I then tried some other arguments, actually all of the arguments on https://litecoin.info/Mining_hardware_comparison none of which let me mine.
For instance this set of arguments
Code:
F:\cgminer.exe --scrypt -o POOL -u USER -p PASS --shaders 1792 -I 19 -w 256 --thread-concurrency 24000 -g 1
produces the same error I get with every other set of arguments I try



I know the shaders should be set to 1792 for a 7950 and the thread-concurrency should be 21712 or 2400. I cannot find any combination of arguments that produces above 20kHash. Am I missing an argument, do I have one set to something wrong? Could anyone suggest a simple set of arguments that work for a 7950?

In the end I want to run the GPU at a nice slow speed to keep the temp in my room down.
1508779312
Hero Member
*
Offline Offline

Posts: 1508779312

View Profile Personal Message (Offline)

Ignore
1508779312
Reply with quote  #2

1508779312
Report to moderator
1508779312
Hero Member
*
Offline Offline

Posts: 1508779312

View Profile Personal Message (Offline)

Ignore
1508779312
Reply with quote  #2

1508779312
Report to moderator
1508779312
Hero Member
*
Offline Offline

Posts: 1508779312

View Profile Personal Message (Offline)

Ignore
1508779312
Reply with quote  #2

1508779312
Report to moderator
Advertised sites are not endorsed by the Bitcoin Forum. They may be unsafe, untrustworthy, or illegal in your jurisdiction. Advertise here.
1508779312
Hero Member
*
Offline Offline

Posts: 1508779312

View Profile Personal Message (Offline)

Ignore
1508779312
Reply with quote  #2

1508779312
Report to moderator
1508779312
Hero Member
*
Offline Offline

Posts: 1508779312

View Profile Personal Message (Offline)

Ignore
1508779312
Reply with quote  #2

1508779312
Report to moderator
1508779312
Hero Member
*
Offline Offline

Posts: 1508779312

View Profile Personal Message (Offline)

Ignore
1508779312
Reply with quote  #2

1508779312
Report to moderator
Eli0t
Sr. Member
****
Offline Offline

Activity: 252


View Profile
October 10, 2013, 10:30:13 PM
 #2

what happens when you remove --thread-concurrency 24000 and change -g 1 to -g 2

LTC:  LKpJf3uk7KsHU73kxq8iFJrP1AAKN7Yni7  DGC:  DKXGvEbj3Rwgrm2QQbRyNPDDZDYoq4Y44d  XPM:  AWV5AKfLFyoBaMjg9C77rGUBhuFxz5DGGL
aa
Hero Member
*****
Offline Offline

Activity: 518


Litecoin is right coin


View Profile WWW
October 10, 2013, 10:31:31 PM
 #3

You are missing a command before you run cgminer. Run it in a command prompt and it should tell you if it's set it successfully.
Code:
setx GPU_MAX_ALLOC_PERCENT 100

After that, just use this:
Code:
cgminer --scrypt -o POOL -u USER -p PASS -I 20 --thread-concurrency 24000

Keep in mind that this will make it so that your desktop is unusable. If you want to do anything other than mining, you'll have to lower intensity (-I) to about 15 or 14.

If that works, you can tweak thread-concurrency.

balanghai
Sr. Member
****
Offline Offline

Activity: 322


View Profile
October 10, 2013, 10:32:24 PM
 #4

Drop your TC to 8192 and see what happens.

Ajinomoto
aa
Hero Member
*****
Offline Offline

Activity: 518


Litecoin is right coin


View Profile WWW
October 10, 2013, 10:35:23 PM
 #5

On www.dustcoin.com it lists the Litecoin difficulty at 1014, why does CGMiner show it at 66.5M?
cgminer difficulty = Litecoin difficulty * 65536

skeeterskeeter
Full Member
***
Offline Offline

Activity: 160


View Profile
October 10, 2013, 10:53:09 PM
 #6

You are missing a command before you run cgminer. Run it in a command prompt and it should tell you if it's set it successfully.
Code:
setx GPU_MAX_ALLOC_PERCENT 100

After that, just use this:
Code:
cgminer --scrypt -o POOL -u USER -p PASS -I 20 --thread-concurrency 24000

Keep in mind that this will make it so that your desktop is unusable. If you want to do anything other than mining, you'll have to lower intensity (-I) to about 15 or 14.

If that works, you can tweak thread-concurrency.

I took the first responses advice first and I used

Code:
F:\cgminer.exe --scrypt -o URL -u U -p P --shaders 1792 -I 12 -w 256 --thread-concurrency 8192 -g 1

Lowered the intensity and the thread-concurrency. Gets about 300kHash. Depending on the temperature over the next hour I might step up the intensity.

From the quote, what does the windows command do specifically?

Also, what is thread concurrency anyways? I'm in a CS degree and know of threads and concurrency, but what does the value mean? It doesn't really make sense in the terms I've learned.
balanghai
Sr. Member
****
Offline Offline

Activity: 322


View Profile
October 10, 2013, 11:00:19 PM
 #7

Usually the TC on the simple programs are simply instances or affinity for a certain application. But on the scrypt mining it means how much thread the cores will run in concurrency as the GPUs have lots of cores. And depending on your card, you can find a TC that will make your card run full speed but not bottlenecked just as what happened earlier with your 24k TC.

Ajinomoto
skeeterskeeter
Full Member
***
Offline Offline

Activity: 160


View Profile
October 10, 2013, 11:01:50 PM
 #8

Usually the TC on the simple programs are simply instances or affinity for a certain application. But on the scrypt mining it means how much thread the cores will run in concurrency as the GPUs have lots of cores. And depending on your card, you can find a TC that will make your card run full speed but not bottlenecked just as what happened earlier with your 24k TC.

So thread concurrency is the number of threads running on the GPU doing the scrypt algorithm?
Melfice
Jr. Member
*
Offline Offline

Activity: 38



View Profile
October 10, 2013, 11:09:50 PM
 #9

You have to install at least >3 GBs of RAM on your computer to mine with 7950. There is a bug in opencl that wont let you mine with all cards' available RAM (ie high Thread concurency >10000).
So try 4 gbs of ram in your pc and try again. Without it, try TC 8192.

BTC 1BonUhFtk4GL3rfS7nygraf6PXHBsKF2ij
LTC LfYWt79bJH22mruuuFGUjLRKGXkqzvZ7oS
skeeterskeeter
Full Member
***
Offline Offline

Activity: 160


View Profile
October 10, 2013, 11:11:15 PM
 #10

You have to install at least >3 GBs of RAM on your computer to mine with 7950. There is a bug in opencl that wont let you mine with all cards' available RAM (ie high Thread concurency >10000).
So try 4 gbs of ram in your pc and try again. Without it, try TC 8192.

I have 32GB of RAM.
skeeterskeeter
Full Member
***
Offline Offline

Activity: 160


View Profile
October 10, 2013, 11:25:27 PM
 #11

1. I set my intensity up from 12 to 14, and got 300+ HW errors very quickly.

2. I cannot change the thread concurrency at all from 8192 (64*128), I tried (64*256) and (64*192) with the same results as my first post.

3. I set -g to 2 instead of one, I got a little more speed. Nothing noticeable. In the README-scrypt in the CGMiner download, it says don't mess with it, but I did. What does it do? The readme doesn't really say much on it.
vindimy
Full Member
***
Offline Offline

Activity: 239



View Profile
October 10, 2013, 11:29:56 PM
 #12

Here's my .bat file for 7950 that's been giving me up to 650 MH/s mining Litecoin. Pretty stable.

Key difference: don't use "--shaders", use "--concurrent-threads" instead.

If this doesn't work for you, try lowering intensity and thread-concurrency until you get it right.

Code:
color 07
setx GPU_MAX_ALLOC_PERCENT 100
setx GPU_USE_SYNC_OBJECTS 1
cgminer --scrypt^
 -o stratum+tcp://stratum2.wemineltc.com:3334 -u USERNAME -p PASSWORD^
 -o stratum+tcp://us.wemineltc.com:80 -u USERNAME -p PASSWORD^
 --intensity 18^
 --worksize 256 -g 1^
 --thread-concurrency 26816^
 --auto-fan --auto-gpu^
 --temp-target 79 --temp-overheat 84 --temp-cutoff 86^
 --gpu-powertune 0^
 --device 1^
 --no-submit-stale
pause

Make sure your case has a very good airflow. In the past all problems I had were resolved by adding more fans or making the fans spin faster.

balanghai
Sr. Member
****
Offline Offline

Activity: 322


View Profile
October 10, 2013, 11:37:59 PM
 #13

Usually the TC on the simple programs are simply instances or affinity for a certain application. But on the scrypt mining it means how much thread the cores will run in concurrency as the GPUs have lots of cores. And depending on your card, you can find a TC that will make your card run full speed but not bottlenecked just as what happened earlier with your 24k TC.

So thread concurrency is the number of threads running on the GPU doing the scrypt algorithm?

Yes that's right. And sometimes if your clock settings are in tune you could get higher hash rates with just adjusting the TC from there.

Ajinomoto
aa
Hero Member
*****
Offline Offline

Activity: 518


Litecoin is right coin


View Profile WWW
October 10, 2013, 11:59:10 PM
 #14

You are missing a command before you run cgminer. Run it in a command prompt and it should tell you if it's set it successfully.
Code:
setx GPU_MAX_ALLOC_PERCENT 100

After that, just use this:
Code:
cgminer --scrypt -o POOL -u USER -p PASS -I 20 --thread-concurrency 24000

Keep in mind that this will make it so that your desktop is unusable. If you want to do anything other than mining, you'll have to lower intensity (-I) to about 15 or 14.

If that works, you can tweak thread-concurrency.
Did you bother to do any of this?

skeeterskeeter
Full Member
***
Offline Offline

Activity: 160


View Profile
October 11, 2013, 01:45:17 AM
 #15

You are missing a command before you run cgminer. Run it in a command prompt and it should tell you if it's set it successfully.
Code:
setx GPU_MAX_ALLOC_PERCENT 100

After that, just use this:
Code:
cgminer --scrypt -o POOL -u USER -p PASS -I 20 --thread-concurrency 24000

Keep in mind that this will make it so that your desktop is unusable. If you want to do anything other than mining, you'll have to lower intensity (-I) to about 15 or 14.

If that works, you can tweak thread-concurrency.
Did you bother to do any of this?

I will try it here soon and post results, I am going to try something like the .bat vindimy posted.
skeeterskeeter
Full Member
***
Offline Offline

Activity: 160


View Profile
October 11, 2013, 02:01:39 AM
 #16

Code:
setx GPU_MAX_ALLOC_PERCENT 100

Works beautifully to allow me to raise the thread concurrency to 22400 (350*64), added in auto fan and gpu just to sleep well and intensity at 13. About 300kHash and 74C temp.

Thanks everyone.
aa
Hero Member
*****
Offline Offline

Activity: 518


Litecoin is right coin


View Profile WWW
October 11, 2013, 02:42:30 AM
 #17

Code:
setx GPU_MAX_ALLOC_PERCENT 100

Works beautifully to allow me to raise the thread concurrency to 22400 (350*64), added in auto fan and gpu just to sleep well and intensity at 13. About 300kHash and 74C temp.

Thanks everyone.
Read the following: http://www.lurkmore.com/wiki/Cgminer.conf

Follow the link at the bottom of the page for more in-depth information on what the flags all do.

Pages: [1]
  Print  
 
Jump to:  

Sponsored by , a Bitcoin-accepting VPN.
Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2006-2009, Simple Machines Valid XHTML 1.0! Valid CSS!