Bitcoin Forum
August 19, 2022, 07:17:47 AM *
News: Latest Bitcoin Core release: 23.0 [Torrent]
   Home   Help Search Login Register More  
Pages: [1]
Author Topic: Binary wallet compatibility (libdb5.1++)  (Read 993 times)
Full Member
Offline Offline

Activity: 131
Merit: 108

View Profile
December 04, 2013, 01:33:27 AM

Some weeks ago I upgraded my Ubuntu system to saucy, however at that time there was still no bitcoin package for saucy available from ppa, so I decided to install bitcoin-qt (0.8.5-1) from universe (which depends on libdb5.1++) instead.

I thought that builds linked against libdb4.8 wouldn't even be able to read wallets created by builds linked against libdb5.1

Quote from:
Ubuntu precise has packages for libdb5.1-dev and libdb5.1++-dev, but using these will break binary wallet compatibility, and is not recommended.

but the bitcoin-qt (0.8.5-1) [universe] generated wallet seems to be readable by both bitcoin-qt_0.8.5-saucy1 (ppa) and official bitcoin-0.8.5-win32.

Is the above warning still true? Am I missing something?


XRP: rJkbeyRaUYDmcukEyLYVfn56QDM9VhybZG
Pages: [1]
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2006-2009, Simple Machines Valid XHTML 1.0! Valid CSS!