Bitcoin Forum
August 16, 2018, 06:21:29 AM *
News: Latest stable version of Bitcoin Core: 0.16.2  [Torrent].
 
   Home   Help Search Donate Login Register  
Pages: [1]
  Print  
Author Topic: WARNING: request rejected because http work queue depth exceeded  (Read 94 times)
ngdias
Jr. Member
*
Offline Offline

Activity: 50
Merit: 0


View Profile
May 12, 2018, 03:28:49 PM
 #1

I'm getting this error message on a VPS node that I am not using for RPC calls. It's just online and I don't do anything else than let it run.

Quote
WARNING: request rejected because http work queue depth exceeded, it can be increased with the -rpcworkqueue= setting

.conf is set to rpcallowip=127.0.0.1 so no outside RPC calls are allowed.

The node stops working when this happens and resumes normally after a reboot.

1. What could be triggering this error?
2. What can I do to avoid it? Settings recommended here fix it or just delay the problem?
3. Is there a log or a command that allows me to query and monitor the number and origin of RPC quests over time?
1534400489
Hero Member
*
Offline Offline

Posts: 1534400489

View Profile Personal Message (Offline)

Ignore
1534400489
Reply with quote  #2

1534400489
Report to moderator
1534400489
Hero Member
*
Offline Offline

Posts: 1534400489

View Profile Personal Message (Offline)

Ignore
1534400489
Reply with quote  #2

1534400489
Report to moderator
The forum strives to allow free discussion of any ideas. All policies are built around this principle. This doesn't mean you can post garbage, though: posts should actually contain ideas, and these ideas should be argued reasonably.
Advertised sites are not endorsed by the Bitcoin Forum. They may be unsafe, untrustworthy, or illegal in your jurisdiction. Advertise here.
1534400489
Hero Member
*
Offline Offline

Posts: 1534400489

View Profile Personal Message (Offline)

Ignore
1534400489
Reply with quote  #2

1534400489
Report to moderator
achow101
Moderator
Legendary
*
Offline Offline

Activity: 1498
Merit: 1526


3F1Y9yquzvY6RWvKbw2n2zeo9V5mvBhADU


View Profile WWW
May 12, 2018, 05:39:27 PM
Merited by Jet Cash (1)
 #2

1. What could be triggering this error?
RPC commands are being issued faster than they can be handled.

2. What can I do to avoid it? Settings recommended here fix it or just delay the problem?
You can set -rpcworkqueue to a number higher than 16.

3. Is there a log or a command that allows me to query and monitor the number and origin of RPC quests over time?
Start bitcoind with -debug=rpc and -debug=http. You will see information about the RPC commands and HTTP server stuff logged to the debug.log file.

ngdias
Jr. Member
*
Offline Offline

Activity: 50
Merit: 0


View Profile
May 12, 2018, 05:57:47 PM
 #3

Thanks for the reply, but there is still something I don't fully understand... the node accepts HTTP and RPC requests during regular operation, from other nodes in the network? This means anyone can spam my IP with these sort of requests to bring the node down?
achow101
Moderator
Legendary
*
Offline Offline

Activity: 1498
Merit: 1526


3F1Y9yquzvY6RWvKbw2n2zeo9V5mvBhADU


View Profile WWW
May 12, 2018, 11:53:01 PM
 #4

the node accepts HTTP and RPC requests during regular operation, from other nodes in the network?
No, it does not.

Connections from other nodes use the peer-to-peer network protocol which uses different ports and is not HTTP.

Pages: [1]
  Print  
 
Jump to:  

Sponsored by , a Bitcoin-accepting VPN.
Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2006-2009, Simple Machines Valid XHTML 1.0! Valid CSS!