Bitcoin Forum
December 16, 2017, 11:44:24 PM *
News: Latest stable version of Bitcoin Core: 0.15.1  [Torrent].
 
   Home   Help Search Donate Login Register  
Pages: [1]
  Print  
Author Topic: Radeon 7950s not recognized and failed permission to save /etc/X11/xorg.conf  (Read 1099 times)
ndunks
Newbie
*
Offline Offline

Activity: 12


View Profile
February 19, 2014, 07:27:34 PM
 #1

I have a gigabyte UD5 MB, and am running between 3-5 Sapphire, radeon 7950 GPUs off an AMD, CPU and 2 x corsair 750 RM PSUs -

I have some questions with this configuration:

1) what command is meant to be used when introducing a GPU, or multiple GPUs to Ubuntu? When I try and do this it wont recognize them, or the recognition is inconsistent.

2) After reading a variety of forums, with many results, I tried different commands.

Atconfig --adapter=all --intitial -f

Atconfig --adapter=all --intitial

Atconfig --intitial

The only command that shows the true amount of GPUs is Atconfig --adapter=all --intitial but when I do this command I get a failure message saying 'Writing to '/etc/X11/xorg.conf failed. Permission denied. However, if I run Atconfig --intitial, it recognizes only one GPU, but will update and save /etc/X11/xorg.conf correctly.

The question with regard to the above information is a) How can I delete ALL versions of /etc/X11/xorg.conf that have been written, and b) how can I rewrite /etc/X11/xorg.conf to recognize all GPUs in the machine currently?

3rd question - My rig dies if I run it through the keyboard and monitor that are connected to the CPU/MB- If I run it through SSH it stays running with suggested config settings for the 7950s, yet somewhere along the line of the changes from the cammands listed above, my SSH stopped showing the GPUS and I get the following error:

[2014-02-19 18:57:11] Started cgminer 3.7.2 [2014-02-19 18:57:11] Loaded configuration file cgminer.conf [2014-02-19 18:57:11] clDevicesNum returned error, no GPUs usable [2014-02-19 18:57:11] No devices detected! [2014-02-19 18:57:11] Waiting for USB hotplug devices or press q to quit

Does anyone have any idea how to make the GPUs visible again?  They load on the main computer in cg startup, and I see all three (even if in the suggested previous questions I have problems with recognition - I think this is because a previous '/etc/X11/xorg.conf has them configured as 3 in their respective PCIE slots) but on the SSH I get nothing - only looks as if its hunting for blocks, but no hashrates, etc.  

A friend configured the drivers, and Im totally clueless If I needed to reinstall drivers, would you recommend following this procedure - help.ubuntu.com/community/BinaryDriverHowto/AMD ?

I really, really appreciate any help possible.
Thank you!
1513467864
Hero Member
*
Offline Offline

Posts: 1513467864

View Profile Personal Message (Offline)

Ignore
1513467864
Reply with quote  #2

1513467864
Report to moderator
1513467864
Hero Member
*
Offline Offline

Posts: 1513467864

View Profile Personal Message (Offline)

Ignore
1513467864
Reply with quote  #2

1513467864
Report to moderator
Advertised sites are not endorsed by the Bitcoin Forum. They may be unsafe, untrustworthy, or illegal in your jurisdiction. Advertise here.
ndunks
Newbie
*
Offline Offline

Activity: 12


View Profile
February 19, 2014, 08:10:45 PM
 #2

So - I got info from an Ubuntu forum that allowed me to save the /etc/X11... file - which meant that none of the mentioned commands would work.  Actually what was needed was an updated command of : sudo amdconfig --adapter=all --initial every time a card is introduced.

Still, am having the same SSH issue - maybe someone has some input?  Will modify subject.

Pages: [1]
  Print  
 
Jump to:  

Sponsored by , a Bitcoin-accepting VPN.
Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2006-2009, Simple Machines Valid XHTML 1.0! Valid CSS!