Bitcoin Forum
February 29, 2020, 08:02:11 AM *
News: Latest Bitcoin Core release: 0.19.0.1 [Torrent]
 
   Home   Help Search Login Register More  
Pages: « 1 2 3 4 5 6 [7] 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 »
  Print  
Author Topic: miniZ, fast & friendly Equihash 144,5 150,5,3 125,4 192,7 210,9 150,5 96,5 miner  (Read 40716 times)
miniZ
Member
**
Offline Offline

Activity: 428
Merit: 10


View Profile WWW
December 15, 2018, 08:45:09 AM
 #121

I tried to use miniz after ewbf miner but I have this message
miniz-i -ci
************ miniZ v1.0i++ ************
Number of CUDA devices found: 0

My rig:
Win10_64bit
3-GTX1060
3-GTX1080Ti

Hi vesline,
which nvidia driver version are you using? Can you tell us the output of nvidia-smi?
Thank you!
Cheers
1582963331
Hero Member
*
Offline Offline

Posts: 1582963331

View Profile Personal Message (Offline)

Ignore
1582963331
Reply with quote  #2

1582963331
Report to moderator
1582963331
Hero Member
*
Offline Offline

Posts: 1582963331

View Profile Personal Message (Offline)

Ignore
1582963331
Reply with quote  #2

1582963331
Report to moderator
1582963331
Hero Member
*
Offline Offline

Posts: 1582963331

View Profile Personal Message (Offline)

Ignore
1582963331
Reply with quote  #2

1582963331
Report to moderator
Advertised sites are not endorsed by the Bitcoin Forum. They may be unsafe, untrustworthy, or illegal in your jurisdiction. Advertise here.
miniZ
Member
**
Offline Offline

Activity: 428
Merit: 10


View Profile WWW
December 15, 2018, 08:54:18 AM
 #122

Switched for test from Gminer and on my settings it's a bit faster.

1060 3gb pl 50%, +180 core, -502 mem
29-30sol/s with 55w/card

Is this something from the realm of fantasy .. can you confirm your words with at least screenshots?
Sure, here it is:


One of my home heaters Cheesy
hmm, I wonder .. how did you achieve such low power consumption? what voltage? My 1066 below 68vatt can not ..
Power limit max to the left and -mem is important too. It's all.
It depends on cards, some do 29-30sol at this settings some other rigs 27-28sol.
Can't check voltage atm ill post you later.

Hi stolarzz,  Yarik47
we also managed to get pretty good Sol out of 1060 3GB. We've reported here https://miniz.ch/features/
We limited pwr to 60W, and have different settings than what stolarzz reported. We may be able to try different settings soon, maybe it can get better.
Thanks for sharing this with everyone!
Cheers
Yarik47
Newbie
*
Offline Offline

Activity: 36
Merit: 0


View Profile
December 15, 2018, 10:59:16 AM
 #123

this is Photoshop? I also have 1070, but the power consumption of your cards, at the core frequency, is just fantastic .. what settings, how?
Yarik47
Newbie
*
Offline Offline

Activity: 36
Merit: 0


View Profile
December 15, 2018, 12:20:49 PM
 #124

Switched for test from Gminer and on my settings it's a bit faster.

1060 3gb pl 50%, +180 core, -502 mem
29-30sol/s with 55w/card

Is this something from the realm of fantasy .. can you confirm your words with at least screenshots?
Sure, here it is:
https://i.ibb.co/n6dD6jG/sol.jpg

One of my home heaters Cheesy
hmm, I wonder .. how did you achieve such low power consumption? what voltage? My 1066 below 68vatt can not ..
Power limit max to the left and -mem is important too. It's all.
It depends on cards, some do 29-30sol at this settings some other rigs 27-28sol.
Can't check voltage atm ill post you later.

Hi stolarzz,  Yarik47
we also managed to get pretty good Sol out of 1060 3GB. We've reported here https://miniz.ch/features/
We limited pwr to 60W, and have different settings than what stolarzz reported. We may be able to try different settings soon, maybe it can get better.
Thanks for sharing this with everyone!
Cheers
What does limited pwr to 60W mean? PL in MSI Afterburner? But PL in MSI Afterburner I have 55 to 1070, with a core frequency of 1580, but this is at least 110 watts!
topteam
Newbie
*
Offline Offline

Activity: 147
Merit: 0


View Profile
December 15, 2018, 02:15:29 PM
 #125


Hi topteam,
Thanks a lot for your feedback. We have updated miniZ to v1.0i++, we really want to solve this issue.
Let's see if this is it Smiley
it looks like the same error after fee.server
Code:
[ 0d21h40m05s] S:13944/1 740(738) [fee.server]- 69ms (98.0%) (2.0%)
0>GTX 1070       [55°C/50%]* 28.22 I/s 57.0(56.4) Sol/s 137.0W clk=1771MHz mclk=4452MHz Sol/W=0.41
1>GTX 1070       [50°C/50%]  28.70 I/s 57.4(57.4) Sol/s 137.4W clk=1797MHz mclk=4452MHz Sol/W=0.42
2>GTX 1070       [51°C/50%]  28.95 I/s 57.4(58.1) Sol/s 137.2W clk=1873MHz mclk=4452MHz Sol/W=0.42
3>GTX 1070       [47°C/50%]* 28.82 I/s 57.1(57.5) Sol/s 137.2W clk=1847MHz mclk=4452MHz Sol/W=0.42
4>GTX 1070       [51°C/50%]  28.96 I/s 59.8(58.0) Sol/s 136.3W clk=1860MHz mclk=4452MHz Sol/W=0.43
5>GTX 1070 Ti    [43°C/50%]  32.64 I/s 65.2(65.2) Sol/s 137.7W clk=1822MHz mclk=4452MHz Sol/W=0.47
6>GTX 1070 Ti    [45°C/50%]  32.55 I/s 65.4(65.3) Sol/s 137.4W clk=1835MHz mclk=4452MHz Sol/W=0.48
7>GTX 1070 Ti    [51°C/50%]  32.01 I/s 65.0(64.0) Sol/s 137.9W clk=1797MHz mclk=4452MHz Sol/W=0.46
8>GTX 1070 Ti    [48°C/50%]  32.21 I/s 64.6(64.3) Sol/s 136.8W clk=1784MHz mclk=4452MHz Sol/W=0.47
9>GTX 1070 Ti    [51°C/50%]  32.44 I/s 65.1(64.8) Sol/s 136.4W clk=1809MHz mclk=4452MHz Sol/W=0.48
10>GTX 1070 Ti    [53°C/50%]  31.50 I/s 62.3(63.0) Sol/s 136.2W clk=1708MHz mclk=4452MHz Sol/W=0.46
11>GTX 1070 Ti    [48°C/50%]* 31.88 I/s 64.9(63.8) Sol/s 137.5W clk=1784MHz mclk=4452MHz Sol/W=0.46
[ 0d21h40m15s] S:13945/1 740(738) [fee.server]- 69ms (98.0%) (2.0%)
0>GTX 1070       [55°C/50%]* 28.23 I/s 57.3(56.4) Sol/s 137.0W clk=1771MHz mclk=4452MHz Sol/W=0.41
1>GTX 1070       [50°C/50%]  28.71 I/s 57.4(57.4) Sol/s 137.4W clk=1797MHz mclk=4452MHz Sol/W=0.42
2>GTX 1070       [51°C/50%]  28.95 I/s 57.7(58.1) Sol/s 137.2W clk=1873MHz mclk=4452MHz Sol/W=0.42
3>GTX 1070       [47°C/50%]  28.83 I/s 57.1(57.5) Sol/s 137.3W clk=1847MHz mclk=4452MHz Sol/W=0.42
4>GTX 1070       [51°C/50%]  28.96 I/s 59.6(58.0) Sol/s 136.4W clk=1860MHz mclk=4452MHz Sol/W=0.43
5>GTX 1070 Ti    [44°C/50%]  32.64 I/s 65.1(65.2) Sol/s 137.7W clk=1822MHz mclk=4452MHz Sol/W=0.47
6>GTX 1070 Ti    [45°C/50%]  32.55 I/s 65.5(65.3) Sol/s 137.3W clk=1809MHz mclk=4452MHz Sol/W=0.48
7>GTX 1070 Ti    [52°C/50%]  32.02 I/s 65.0(64.0) Sol/s 138.1W clk=1797MHz mclk=4452MHz Sol/W=0.46
8>GTX 1070 Ti    [48°C/50%]  32.22 I/s 64.2(64.3) Sol/s 136.7W clk=1784MHz mclk=4452MHz Sol/W=0.47
9>GTX 1070 Ti    [51°C/50%]  32.44 I/s 64.8(64.8) Sol/s 136.4W clk=1822MHz mclk=4452MHz Sol/W=0.48
10>GTX 1070 Ti    [53°C/50%]  31.51 I/s 61.4(63.0) Sol/s 136.1W clk=1708MHz mclk=4452MHz Sol/W=0.46
11>GTX 1070 Ti    [48°C/50%]  31.88 I/s 65.4(63.8) Sol/s 137.5W clk=1771MHz mclk=4452MHz Sol/W=0.46
[ 0d21h40m25s] S:13948/1 739(738) [europe.equihash-hub.miningpoolhub.com]- 246ms (98.0%) (2.0%)
0>GTX 1070       [55°C/50%]* 28.23 I/s 57.4(56.4) Sol/s 137.0W clk=1809MHz mclk=4452MHz Sol/W=0.41
1>GTX 1070       [50°C/50%]  28.71 I/s 57.1(57.4) Sol/s 137.4W clk=1847MHz mclk=4452MHz Sol/W=0.42
2>GTX 1070       [51°C/50%]  28.96 I/s 57.5(58.1) Sol/s 137.2W clk=1860MHz mclk=4452MHz Sol/W=0.42
3>GTX 1070       [47°C/50%]* 28.83 I/s 56.7(57.5) Sol/s 137.2W clk=1847MHz mclk=4452MHz Sol/W=0.42
4>GTX 1070       [51°C/50%]  28.97 I/s 59.4(58.0) Sol/s 136.5W clk=1860MHz mclk=4452MHz Sol/W=0.42
5>GTX 1070 Ti    [43°C/50%]  32.64 I/s 64.7(65.2) Sol/s 137.6W clk=1847MHz mclk=4452MHz Sol/W=0.47
kernel: [458521.956478] miniZ[19991]: segfault at 1e8 ip 000055c4085fc638 sp 00007f361360f890 error 4 in miniZ[55c408504000+8f0000]
6>GTX 1070 Ti    [45°C/50%]  32.55 I/s 65.4(65.3) Sol/s 137.2W clk=1835MHz mclk=4452MHz So19938 Segmentation fault      (core dumped) ./miniZ --url user.rig1@europe.equihash-hub.miningpoolhub.com:20595 --pers BgoldPoW --par=144,5 --telemetry 0 --gpu-line --extra --nocolor --templimit 70C --tempunits C --latency
Main process exited, code=exited, status=139/n/a
Unit entered failed state.
Failed with result 'exit-code'.
Service hold-off time over, scheduling restart.
Stopped miner.
Started miner.
************ #033[01;31mminiZ#033[0m v1.0i++ ************
Number of CUDA devices found: 12

Hi topteam,
we've been checking all your reports and it doesn't seem to be specific to fee server.
Sometimes (like this last time) the miner is connected to your pool server.
But it can be related to communication, latency to your pool always seems a bit high but nothing too much too. Also this shouldn't be a cause to crash.

This has been a tough one. Could you run two separate instances of the miner? Each with half of your GPUs.
Maybe this could help figure out what is causing the crash.

Btw, the program freezes or crashes? We're asking this because you have the watchdog that reboots right?
Thank you for your feedback!
Cheers


Program now crash and exit (it's good for me)
I have 3 watchdogs
First for program (just restart program when it crash)
Second for GPU loads (reboot the system)
And third hardware watchdog (when system freeze)
Now I drop power to 90W per card and test the rig
vesline
Newbie
*
Offline Offline

Activity: 3
Merit: 0


View Profile
December 15, 2018, 06:05:41 PM
 #126

I tried to use miniz after ewbf miner but I have this message
miniz-i -ci
************ miniZ v1.0i++ ************
Number of CUDA devices found: 0

My rig:
Win10_64bit
3-GTX1060
3-GTX1080Ti

Hi vesline,
which nvidia driver version are you using? Can you tell us the output of nvidia-smi?
Thank you!
Cheers
C:\Program Files\NVIDIA Corporation\NVSMI>nvidia-smi
Sat Dec 15 21:02:35 2018
+-----------------------------------------------------------------------------+
| NVIDIA-SMI 391.35                 Driver Version: 391.35                    |
|-------------------------------+----------------------+----------------------+
| GPU  Name            TCC/WDDM | Bus-Id        Disp.A | Volatile Uncorr. ECC |
| Fan  Temp  Perf  Pwr:Usage/Cap|         Memory-Usage | GPU-Util  Compute M. |
|===============================+======================+======================|
|   0  GeForce GTX 108... WDDM  | 00000000:01:00.0  On |                  N/A |
| 53%   69C    P2   232W / 238W |   2560MiB / 11264MiB |    100%      Default |
+-------------------------------+----------------------+----------------------+
|   1  GeForce GTX 108... WDDM  | 00000000:03:00.0 Off |                  N/A |
| 47%   66C    P2   237W / 238W |   2477MiB / 11264MiB |    100%      Default |
+-------------------------------+----------------------+----------------------+


+-----------------------------------------------------------------------------+
| Processes:                                                       GPU Memory |
|  GPU       PID   Type   Process name                             Usage      |
|=============================================================================|
|    0      1588    C+G   Insufficient Permissions                   N/A      |
|    0      4724    C+G   C:\Windows\explorer.exe                    N/A      |
|    0      5464    C+G   ...t_cw5n1h2txyewy\ShellExperienceHost.exe N/A      |
|    0      5712    C+G   ...dows.Cortana_cw5n1h2txyewy\SearchUI.exe N/A      |
|    0      6300    C+G   ...oftEdge_8wekyb3d8bbwe\MicrosoftEdge.exe N/A      |
|    0      7288    C+G   ...36.52.0_x64__kzf8qxf38zg5c\SkypeApp.exe N/A      |
|    0      7880      C   ...Desktop\gminer_1_10_windows64\miner.exe N/A      |
|    1      7880      C   ...Desktop\gminer_1_10_windows64\miner.exe N/A      |
+-----------------------------------------------------------------------------+
miniZ
Member
**
Offline Offline

Activity: 428
Merit: 10


View Profile WWW
December 15, 2018, 07:26:33 PM
 #127

I tried to use miniz after ewbf miner but I have this message
miniz-i -ci
************ miniZ v1.0i++ ************
Number of CUDA devices found: 0

My rig:
Win10_64bit
3-GTX1060
3-GTX1080Ti

Hi vesline,
which nvidia driver version are you using? Can you tell us the output of nvidia-smi?
Thank you!
Cheers
C:\Program Files\NVIDIA Corporation\NVSMI>nvidia-smi
Sat Dec 15 21:02:35 2018
+-----------------------------------------------------------------------------+
| NVIDIA-SMI 391.35                 Driver Version: 391.35                    |
|-------------------------------+----------------------+----------------------+
| GPU  Name            TCC/WDDM | Bus-Id        Disp.A | Volatile Uncorr. ECC |
| Fan  Temp  Perf  Pwr:Usage/Cap|         Memory-Usage | GPU-Util  Compute M. |
|===============================+======================+======================|
|   0  GeForce GTX 108... WDDM  | 00000000:01:00.0  On |                  N/A |
| 53%   69C    P2   232W / 238W |   2560MiB / 11264MiB |    100%      Default |
+-------------------------------+----------------------+----------------------+
|   1  GeForce GTX 108... WDDM  | 00000000:03:00.0 Off |                  N/A |
| 47%   66C    P2   237W / 238W |   2477MiB / 11264MiB |    100%      Default |
+-------------------------------+----------------------+----------------------+

Hi vesline, for you to be able to run miniZ on Windows you need to update the NVIDIA driver to version 398.26 or later.
This is mentioned here https://miniz.ch/features/
Then it should run fine Smiley
Cheers


miniZ
Member
**
Offline Offline

Activity: 428
Merit: 10


View Profile WWW
December 15, 2018, 07:30:54 PM
 #128

Switched for test from Gminer and on my settings it's a bit faster.

1060 3gb pl 50%, +180 core, -502 mem
29-30sol/s with 55w/card

Is this something from the realm of fantasy .. can you confirm your words with at least screenshots?
Sure, here it is:


One of my home heaters Cheesy
hmm, I wonder .. how did you achieve such low power consumption? what voltage? My 1066 below 68vatt can not ..
Power limit max to the left and -mem is important too. It's all.
It depends on cards, some do 29-30sol at this settings some other rigs 27-28sol.
Can't check voltage atm ill post you later.

Hi stolarzz,  Yarik47
we also managed to get pretty good Sol out of 1060 3GB. We've reported here https://miniz.ch/features/
We limited pwr to 60W, and have different settings than what stolarzz reported. We may be able to try different settings soon, maybe it can get better.
Thanks for sharing this with everyone!
Cheers
What does limited pwr to 60W mean? PL in MSI Afterburner? But PL in MSI Afterburner I have 55 to 1070, with a core frequency of 1580, but this is at least 110 watts!
Hi Yarik47, we limited power to 60W on the 1060 3GB, this corresponds to 50% PL.
Cheers
miniZ
Member
**
Offline Offline

Activity: 428
Merit: 10


View Profile WWW
December 15, 2018, 07:36:11 PM
 #129


Program now crash and exit (it's good for me)
I have 3 watchdogs
First for program (just restart program when it crash)
Second for GPU loads (reboot the system)
And third hardware watchdog (when system freeze)
Now I drop power to 90W per card and test the rig

Hi topteam, thanks for the feedback. We'll keep working on finding a solution.
Cheers
fistsofgod
Newbie
*
Offline Offline

Activity: 153
Merit: 0


View Profile
December 15, 2018, 07:46:13 PM
 #130

this is Photoshop? I also have 1070, but the power consumption of your cards, at the core frequency, is just fantastic .. what settings, how?

undervolt cards. -502 memory. lots of different quality cards so you'd have to tinker with the settings of your own cards. the cards in that pic hitting 50sol are all evga ftw and the ones around 47 are evga sc
vesline
Newbie
*
Offline Offline

Activity: 3
Merit: 0


View Profile
December 16, 2018, 06:14:53 PM
 #131

I tried to use miniz after ewbf miner but I have this message
miniz-i -ci
************ miniZ v1.0i++ ************
Number of CUDA devices found: 0

My rig:
Win10_64bit
3-GTX1060
3-GTX1080Ti

Hi vesline,
which nvidia driver version are you using? Can you tell us the output of nvidia-smi?
Thank you!
Cheers
C:\Program Files\NVIDIA Corporation\NVSMI>nvidia-smi
Sat Dec 15 21:02:35 2018
+-----------------------------------------------------------------------------+
| NVIDIA-SMI 391.35                 Driver Version: 391.35                    |
|-------------------------------+----------------------+----------------------+
| GPU  Name            TCC/WDDM | Bus-Id        Disp.A | Volatile Uncorr. ECC |
| Fan  Temp  Perf  Pwr:Usage/Cap|         Memory-Usage | GPU-Util  Compute M. |
|===============================+======================+======================|
|   0  GeForce GTX 108... WDDM  | 00000000:01:00.0  On |                  N/A |
| 53%   69C    P2   232W / 238W |   2560MiB / 11264MiB |    100%      Default |
+-------------------------------+----------------------+----------------------+
|   1  GeForce GTX 108... WDDM  | 00000000:03:00.0 Off |                  N/A |
| 47%   66C    P2   237W / 238W |   2477MiB / 11264MiB |    100%      Default |
+-------------------------------+----------------------+----------------------+

Hi vesline, for you to be able to run miniZ on Windows you need to update the NVIDIA driver to version 398.26 or later.
This is mentioned here https://miniz.ch/features/
Then it should run fine Smiley
Cheers



Ok
Also I have NVIDIA Cards P106-100
Driver did not update since version 384.74
How can I use miniz for this type of card?
fistsofgod
Newbie
*
Offline Offline

Activity: 153
Merit: 0


View Profile
December 16, 2018, 07:14:41 PM
Last edit: December 16, 2018, 07:24:50 PM by fistsofgod
 #132

when the miner instance starts it logs x minutes of incorrect values as the card stats console output is normalized. could you add a way to delay logging for x minutes? for me it's about 5 minutes before the console output is accurate
miniZ
Member
**
Offline Offline

Activity: 428
Merit: 10


View Profile WWW
December 16, 2018, 11:18:46 PM
 #133

Ok
Also I have NVIDIA Cards P106-100
Driver did not update since version 384.74
How can I use miniz for this type of card?

Hi vesline,
at the moment you can use miniZ version for Linux (Cuda 8.0), for those cards.
Would you be able to use this version?
Cheers
miniZ
Member
**
Offline Offline

Activity: 428
Merit: 10


View Profile WWW
December 16, 2018, 11:19:44 PM
 #134

when the miner instance starts it logs x minutes of incorrect values as the card stats console output is normalized. could you add a way to delay logging for x minutes? for me it's about 5 minutes before the console output is accurate
Hi fistsofgod,
we'll add an option to specify a delay for that.
Thanks.
fistsofgod
Newbie
*
Offline Offline

Activity: 153
Merit: 0


View Profile
December 17, 2018, 01:18:31 AM
 #135

when the miner instance starts it logs x minutes of incorrect values as the card stats console output is normalized. could you add a way to delay logging for x minutes? for me it's about 5 minutes before the console output is accurate
Hi fistsofgod,
we'll add an option to specify a delay for that.
Thanks.
more importantly, could there be an option for how often stats are displayed in console? currently every 10 seconds new output is written to console/log. log files get large quickly with 15 lines every 10 seconds, 90 lines every minute written into log. I'd prefer to be able to set it to less frequent. Personally I'd set it to 60 second intervals
miniZ
Member
**
Offline Offline

Activity: 428
Merit: 10


View Profile WWW
December 17, 2018, 08:53:21 AM
 #136

Ok
Also I have NVIDIA Cards P106-100
Driver did not update since version 384.74
How can I use miniz for this type of card?

Hi vesline,
at the moment you can use miniZ version for Linux (Cuda 8.0), for those cards.
Would you be able to use this version?
Cheers
Hi vesline,
at the moment you can already use miniZ version for Windows (Cuda 8.0), for NVIDIA Cards P106-100.
Could you let us know if all went OK?
Thanks!
Cheers


when the miner instance starts it logs x minutes of incorrect values as the card stats console output is normalized. could you add a way to delay logging for x minutes? for me it's about 5 minutes before the console output is accurate
Hi fistsofgod,
we'll add an option to specify a delay for that.
Thanks.
more importantly, could there be an option for how often stats are displayed in console? currently every 10 seconds new output is written to console/log. log files get large quickly with 15 lines every 10 seconds, 90 lines every minute written into log. I'd prefer to be able to set it to less frequent. Personally I'd set it to 60 second intervals
Hi fistsofgod,
we understand. We'll work on that for the next version. Smiley
Thanks!
webgkv
Newbie
*
Offline Offline

Activity: 57
Merit: 0


View Profile
December 20, 2018, 09:37:19 PM
 #137

Hello!

You made a great miner!

Some time ago, I made this fork https://github.com/webgkv/greenTea

At the same time, I am not a programmer, but rather an advanced user. And for the most part I develop this fork as a hobby.

And so I need your help, that the miniZ would have the opportunity to work with this script.  Saw you have done something like this for hiveOS.

In more detail, it’s not a problem to launch a miniZ with a script. The problem is in obtaining data from the miner, since he does not have standard api.

So maybe you can tell me how should look the code for your miner api like this:

"Optiminer" {
                $Request = Invoke-HTTPRequest $Server $Port "" 5
                if ($Request) {
                    $Data = $Request | ConvertFrom-Json
                    $HashRate = [double]($Data.solution_rate.Total."60s" | Measure-Object -Sum).sum
                    if (-not $HashRate) { $HashRate = [double]($Data.solution_rate.Total."5s" | Measure-Object -Sum).sum }
                }
            }

This is a piece of code from a file https://github.com/yuzi-co/Forager/blob/master/Include.ps1
 
Thanks for your help!
miniZ
Member
**
Offline Offline

Activity: 428
Merit: 10


View Profile WWW
December 21, 2018, 12:10:46 AM
 #138

Hi webgkv,

Thanks for your message. We have some kind of "standard" json api.

Example (Linux):
Code:
Code:
curl --silent rig2:20000 -X '{"id":"0", "method":"getstat"}'

returns:
Code:
{"id":0, "method":"getstat", "error":null, "start_time":1544548916, "current_server":"zhash.eu.nicehash.com:3369", "server_latency":62.4, "available_servers":1, "server_status":1, "result":[{"gpuid":0, "cudaid":0, "busid":"busid", "name":"GeForce GTX 1050", "gpu_status":2, "solver":-1, "temperature":66, "gpu_fan_speed":35, "gpu_power_usage":75.0, "gpu_clock_core_max":1695, "gpu_clock_memory":3504, "speed_sps":16.1, "accepted_shares":23, "rejected_shares":0, "start_time":1544548916},{"gpuid":1, "cudaid":1, "busid":"busid", "name":"GeForce GTX 1050 Ti", "gpu_status":2, "solver":-1, "temperature":71, "gpu_fan_speed":38, "gpu_power_usage":75.0, "gpu_clock_core_max":1594, "gpu_clock_memory":3504, "speed_sps":18.6, "accepted_shares":22, "rejected_shares":0, "start_time":1544548916},{"gpuid":2, "cudaid":2, "busid":"busid", "name":"GeForce GTX 1070 Ti", "gpu_status":2, "solver":-1, "temperature":69, "gpu_fan_speed":49, "gpu_power_usage":172.1, "gpu_clock_core_max":1759, "gpu_clock_memory":3802, "speed_sps":59.0, "accepted_shares":69, "rejected_shares":0, "start_time":1544548916}]}

This API, is fully compatible with the EWBF miner, so it should be very easy to make it work with your script.
Let us know if you need further help.

Cheers!
webgkv
Newbie
*
Offline Offline

Activity: 57
Merit: 0


View Profile
December 21, 2018, 06:52:02 AM
 #139

EWBF api - this is the first option that I tried, but it doesn't work also.

 "ewbf" {
                $Message = @{id = 1; method = "getstat"} | ConvertTo-Json -Compress
                $Request = Invoke-TCPRequest $Server $port $message 5
                if ($Request) {
                    $Data = $Request | ConvertFrom-Json
                    $HashRate = [double](($Data.result.speed_sps) | Measure-Object -Sum).Sum
                }
            }

Do you have any idea what could be wrong here?

Also please write me a private message.
webgkv
Newbie
*
Offline Offline

Activity: 57
Merit: 0


View Profile
December 21, 2018, 08:14:10 AM
 #140

By the way, there is another similar development (on the powershell script). There just used http request, because it seemed to me that getstat does not work there also:

https://github.com/MaynardMiner/SWARM/blob/master/build/powershell/background.ps1

line 361 for miniz  and line 400 for ewbf
Pages: « 1 2 3 4 5 6 [7] 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 »
  Print  
 
Jump to:  

Sponsored by , a Bitcoin-accepting VPN.
Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2006-2009, Simple Machines Valid XHTML 1.0! Valid CSS!