Bitcoin Forum
July 19, 2024, 08:10:50 AM *
News: Latest Bitcoin Core release: 27.0 [Torrent]
 
   Home   Help Search Login Register More  
Pages: [1] 2 3 »  All
  Print  
Author Topic: *development stopped currently* - mkxminer  (Read 2267 times)
winmkx (OP)
Newbie
*
Offline Offline

Activity: 86
Merit: 0


View Profile
October 27, 2018, 01:27:54 AM
Last edit: June 22, 2019, 04:35:58 AM by winmkx
 #1

Please use team red miner for lyra2z and lyra2rev3 coins: https://bitcointalk.org/index.php?topic=5027811.0.

This miner is currently not being actively developed
winmkx (OP)
Newbie
*
Offline Offline

Activity: 86
Merit: 0


View Profile
October 27, 2018, 01:28:33 AM
 #2

mkxminer versions 1.0 - 3.1 were supporting only lyra2rev2 algorithm. But it is now dead for GPU miners, because ASICs completely destroyed lyra2rev2 profitability.
mkxminer version 4.0+ do not support lyra2rev2 anymore. Here is the old lyra2rev2 related thread: https://bitcointalk.org/index.php?topic=2360168
tale01
Newbie
*
Offline Offline

Activity: 121
Merit: 0


View Profile
October 27, 2018, 04:02:23 AM
 #3

Linux AMD driver 18.10 cannot work.  Cry
alucard20724
Sr. Member
****
Offline Offline

Activity: 703
Merit: 272


View Profile
October 27, 2018, 05:52:52 AM
Last edit: October 27, 2018, 06:25:27 AM by alucard20724
 #4

i'm getting a an error
Device not supported: "gfx900", only AMD GCN cards are supported.

it's a Radeon Vega56  Roll Eyes


* Note: the actual mining speed is a bit higher as some of the hashrate is used as devfee. The above values are what you (the miner) gets.
Other miners with devfee show you the total hashrate and then you have to reduce it by devfee: for example,
if you have 30MHs with 5% devfee, then effectively it is 28.5MHs for you (30 * (1.0 - 0.05)).
This miner shows you exactly the MHs that you earn, so devfee value is irrelevant.

You do not have to use this miner. For a free open-source option, please use https://miner.nicehash.com/ or https://github.com/sgminer-dev/sgminer.


so... what is the actual dev fee, for the sake of transparency.

I have no problem with using the software with a dev fee, as long as i know what the dev fee is.
TeamRedMiner has no problems with stating what their dev fee is.

a fee i can write off on taxes when the tax man comes along.
winmkx (OP)
Newbie
*
Offline Offline

Activity: 86
Merit: 0


View Profile
October 27, 2018, 07:51:42 AM
 #5

i'm getting a an error
Device not supported: "gfx900", only AMD GCN cards are supported.

it's a Radeon Vega56  Roll Eyes

Hi!

Is it on Windows or on Linux?

Thanks
winmkx (OP)
Newbie
*
Offline Offline

Activity: 86
Merit: 0


View Profile
October 27, 2018, 07:56:31 AM
 #6

Linux AMD driver 18.10 cannot work.  Cry

Thanks for testing. What's the exact error and what videocard?
mine_phun
Newbie
*
Offline Offline

Activity: 208
Merit: 0


View Profile WWW
October 27, 2018, 08:38:37 AM
 #7

Please add Nlpool.nl to your list of multipools.
tale01
Newbie
*
Offline Offline

Activity: 121
Merit: 0


View Profile
October 27, 2018, 12:07:58 PM
 #8

Linux AMD driver 18.10 cannot work.  Cry

Thanks for testing. What's the exact error and what videocard?

stuck at last lines. I use Fiji.

Code:
7efc9a069000-7efc9a071000 rw-s 1023e2000 00:06 22983                     /dev/dr
i/renderD134
7efc9a071000-7efc9a073000 rw-s 1023e0000 00:06 22983                     /dev/dr
i/renderD134
7efc9a073000-7efc9a075000 rw-s 1023de000 00:06 22983                     /dev/dr
i/renderD134
7efc9a075000-7efc9a175000 rw-s 1022de000 00:06 22983                     /dev/dr
i/renderD134
7efc9a175000-7efc9a275000 rw-s 1021de000 00:06 22983                     /dev/dr
i/renderD134
7efc9a275000-7efc9a27b000 rw-s 1021d8000 00:06 22983                     /dev/dr
i/renderD134
7efc9a27b000-7efc9a281000 rw-s 1021d2000 00:06 22983                     /dev/dr
i/renderD134
7efc9a281000-7efc9a289000 rw-s 1021ca000 00:06 22983                     /dev/dr
i/renderD134
7efc9a289000-7efc9a291000 rw-s 1021c2000 00:06 22983                     /dev/dr
i/renderD134
7efc9a291000-7efc9a311000 rw-s 102142000 00:06

Grumo
Member
**
Offline Offline

Activity: 430
Merit: 22

Professional user


View Profile WWW
October 27, 2018, 03:30:11 PM
 #9

i'm getting a an error
Device not supported: "gfx900", only AMD GCN cards are supported.

it's a Radeon Vega56  Roll Eyes

Hi!

Is it on Windows or on Linux?

Thanks
same error on windows

bTCBTCbiᴛcoinᗷTCethDOGEzecⅬTCUSDT
winmkx (OP)
Newbie
*
Offline Offline

Activity: 86
Merit: 0


View Profile
October 27, 2018, 06:29:50 PM
 #10

Please add Nlpool.nl to your list of multipools.

Thanks, added.
alucard20724
Sr. Member
****
Offline Offline

Activity: 703
Merit: 272


View Profile
October 27, 2018, 07:55:13 PM
Last edit: October 27, 2018, 08:15:06 PM by alucard20724
 #11

i'm getting a an error
Device not supported: "gfx900", only AMD GCN cards are supported.

it's a Radeon Vega56  Roll Eyes

Hi!

Is it on Windows or on Linux?

Thanks

Windows10 and 18.10.1/18.9.3 drivers.  prior release worked.. this version doesn't
winmkx (OP)
Newbie
*
Offline Offline

Activity: 86
Merit: 0


View Profile
October 27, 2018, 08:03:44 PM
 #12

Linux AMD driver 18.10 cannot work.  Cry

Thanks for testing. What's the exact error and what videocard?

stuck at last lines. I use Fiji.

Code:
7efc9a069000-7efc9a071000 rw-s 1023e2000 00:06 22983                     /dev/dr
i/renderD134
7efc9a071000-7efc9a073000 rw-s 1023e0000 00:06 22983                     /dev/dr
i/renderD134
7efc9a073000-7efc9a075000 rw-s 1023de000 00:06 22983                     /dev/dr
i/renderD134
7efc9a075000-7efc9a175000 rw-s 1022de000 00:06 22983                     /dev/dr
i/renderD134
7efc9a175000-7efc9a275000 rw-s 1021de000 00:06 22983                     /dev/dr
i/renderD134
7efc9a275000-7efc9a27b000 rw-s 1021d8000 00:06 22983                     /dev/dr
i/renderD134
7efc9a27b000-7efc9a281000 rw-s 1021d2000 00:06 22983                     /dev/dr
i/renderD134
7efc9a281000-7efc9a289000 rw-s 1021ca000 00:06 22983                     /dev/dr
i/renderD134
7efc9a289000-7efc9a291000 rw-s 1021c2000 00:06 22983                     /dev/dr
i/renderD134
7efc9a291000-7efc9a311000 rw-s 102142000 00:06



Hi!

Sorry, I'm not quite sure what your quoted text is. Definitely not output from mkxminer or error message.
Please provide more info and I'll try to investigate.

"18.10" is "Ubuntu 18.10", I guess. Server or Desktop?
Which AMD driver?

Thanks
winmkx (OP)
Newbie
*
Offline Offline

Activity: 86
Merit: 0


View Profile
October 27, 2018, 08:18:02 PM
 #13

=== Bug tracking + feature requests
https://github.com/winmkx/mkxminer/issues

I added issues that I know about, feel free to add more. Thanks
alucard20724
Sr. Member
****
Offline Offline

Activity: 703
Merit: 272


View Profile
October 27, 2018, 08:30:44 PM
 #14

=== Bug tracking + feature requests
https://github.com/winmkx/mkxminer/issues

I added issues that I know about, feel free to add more. Thanks

can you do the releases on github also?... makes it a lot easier for me to update computers.
alucard20724
Sr. Member
****
Offline Offline

Activity: 703
Merit: 272


View Profile
October 27, 2018, 09:56:35 PM
 #15

i'm getting a an error
Device not supported: "gfx900", only AMD GCN cards are supported.

it's a Radeon Vega56  Roll Eyes

Hi!

Is it on Windows or on Linux?

Thanks

additional details...

gfx900 is when HBCC is turned off   does not work when HBCC turned off
gfx901 is when HBCC is turned on.  it works with HBCC turned on

running 18.10.2 drivers now.

have you tried developing without the blockchain drivers?  the blockchain drivers are supported in the latest released drivers and they're more stable.

and have you tried developing with HBCC off.

HBCC are for the vega cards.  the 500 and 400 series card have a compute/graphic switch in AMD settings window.
winmkx (OP)
Newbie
*
Offline Offline

Activity: 86
Merit: 0


View Profile
October 27, 2018, 11:23:29 PM
 #16

i'm getting a an error
Device not supported: "gfx900", only AMD GCN cards are supported.

it's a Radeon Vega56  Roll Eyes

Hi!

Is it on Windows or on Linux?

Thanks

additional details...

gfx900 is when HBCC is turned off   does not work when HBCC turned off
gfx901 is when HBCC is turned on.  it works with HBCC turned on

running 18.10.2 drivers now.

have you tried developing without the blockchain drivers?  the blockchain drivers are supported in the latest released drivers and they're more stable.

and have you tried developing with HBCC off.

HBCC are for the vega cards.  the 500 and 400 series card have a compute/graphic switch in AMD settings window.

Sorry, this is new for me. Will have to read about HBCC, etc.
I have Windows 10 x64 and Vega64. I believe this is the best setup.

As for drivers, I'm using blockchain drivers, because they are stable. I tried with different other drivers as well, but had some issues with 4+ GPUs in one rig.
I can test on latest drivers, probably next week.
alucard20724
Sr. Member
****
Offline Offline

Activity: 703
Merit: 272


View Profile
October 28, 2018, 12:01:31 AM
 #17

i'm getting a an error
Device not supported: "gfx900", only AMD GCN cards are supported.

it's a Radeon Vega56  Roll Eyes

Hi!

Is it on Windows or on Linux?

Thanks

additional details...

gfx900 is when HBCC is turned off   does not work when HBCC turned off
gfx901 is when HBCC is turned on.  it works with HBCC turned on

running 18.10.2 drivers now.

have you tried developing without the blockchain drivers?  the blockchain drivers are supported in the latest released drivers and they're more stable.

and have you tried developing with HBCC off.

HBCC are for the vega cards.  the 500 and 400 series card have a compute/graphic switch in AMD settings window.

Sorry, this is new for me. Will have to read about HBCC, etc.
I have Windows 10 x64 and Vega64. I believe this is the best setup.

As for drivers, I'm using blockchain drivers, because they are stable. I tried with different other drivers as well, but had some issues with 4+ GPUs in one rig.
I can test on latest drivers, probably next week.

18.9.3 have been stable on my machines... i'm running windows10 x64 also.. 18.10.1 it's a crapshoot.  just starting messing with 18.10.2
GKumaran
Member
**
Offline Offline

Activity: 204
Merit: 10


View Profile
October 28, 2018, 02:47:27 AM
 #18

What are your results with the config you mentioned?
Grumo
Member
**
Offline Offline

Activity: 430
Merit: 22

Professional user


View Profile WWW
October 28, 2018, 05:37:41 AM
 #19

i'm getting a an error
Device not supported: "gfx900", only AMD GCN cards are supported.

it's a Radeon Vega56  Roll Eyes

Hi!

Is it on Windows or on Linux?

Thanks
same error on windows

+

i'm getting a an error
Device not supported: "gfx900", only AMD GCN cards are supported.

it's a Radeon Vega56  Roll Eyes

Hi!

Is it on Windows or on Linux?

Thanks

additional details...

gfx900 is when HBCC is turned off   does not work when HBCC turned off
gfx901 is when HBCC is turned on.  it works with HBCC turned on

running 18.10.2 drivers now.

have you tried developing without the blockchain drivers?  the blockchain drivers are supported in the latest released drivers and they're more stable.

and have you tried developing with HBCC off.

HBCC are for the vega cards.  the 500 and 400 series card have a compute/graphic switch in AMD settings window.

i solved issue installing blockchain drivers

bTCBTCbiᴛcoinᗷTCethDOGEzecⅬTCUSDT
alucard20724
Sr. Member
****
Offline Offline

Activity: 703
Merit: 272


View Profile
October 28, 2018, 05:42:17 AM
 #20

i'm getting a an error
Device not supported: "gfx900", only AMD GCN cards are supported.

it's a Radeon Vega56  Roll Eyes

Hi!

Is it on Windows or on Linux?

Thanks
same error on windows

+

i'm getting a an error
Device not supported: "gfx900", only AMD GCN cards are supported.

it's a Radeon Vega56  Roll Eyes

Hi!

Is it on Windows or on Linux?

Thanks

additional details...

gfx900 is when HBCC is turned off   does not work when HBCC turned off
gfx901 is when HBCC is turned on.  it works with HBCC turned on

running 18.10.2 drivers now.

have you tried developing without the blockchain drivers?  the blockchain drivers are supported in the latest released drivers and they're more stable.

and have you tried developing with HBCC off.

HBCC are for the vega cards.  the 500 and 400 series card have a compute/graphic switch in AMD settings window.

i solved issue installing blockchain drivers

I solved the issue by turning HBCC on... like it says in the post.

turning on HBCC is a lot simpler and a lot easier than reinstalling drivers.
Pages: [1] 2 3 »  All
  Print  
 
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2006-2009, Simple Machines Valid XHTML 1.0! Valid CSS!