Bitcoin Forum
June 20, 2019, 12:38:17 PM *
News: Latest Bitcoin Core release: 0.18.0 [Torrent] (New!)
 
   Home   Help Search Login Register More  
Pages: [1]
  Print  
Author Topic: Question about restoring from seed  (Read 116 times)
Awkward_Public_Stoner
Newbie
*
Offline Offline

Activity: 13
Merit: 4


View Profile
January 11, 2019, 09:56:45 PM
Merited by bones261 (1), LoyceV (1)
 #1

Might be a weird question or already answered but I created a standard wallet with segwit adresses (those starting with bc1) with Electrum 3.1.3.

Have Electrum 2.8.something on an old PC (think it's 2.8.1). Tried to restore the standard wallet with segwit addresses created with 3.1.3 from seed with Electrum 2.8.x and it won't recognize the seed. Checked multiple times, copy and pasted. No go. Is this because segwit adresses were only implemented with 3.0?

Also weird bug, when I type the seed of the wallet created with 3.1.3 to restore with 2.8.x at word 6 and half (!) of the seed suddenly the next button gets grey. When I click it it tells me I can restore a wallet with 2Fa now. When I click on this I get an error window with the possibility to send a bug report?

Thanks in advance.
NEW GAME FORMAT
JACKPOT UP TO $50000+
Guess The Symbols Of a Real Ethereum Hash
PLAY NOW
Advertised sites are not endorsed by the Bitcoin Forum. They may be unsafe, untrustworthy, or illegal in your jurisdiction. Advertise here.
1561034297
Hero Member
*
Offline Offline

Posts: 1561034297

View Profile Personal Message (Offline)

Ignore
1561034297
Reply with quote  #2

1561034297
Report to moderator
TryNinja
Legendary
*
Online Online

Activity: 1050
Merit: 1305


CS <3


View Profile
January 11, 2019, 10:05:18 PM
 #2

Is this because segwit adresses were only implemented with 3.0?
Yes. But why would you want to use an outdated version of Electrum? This version has multiple synchronization issues (besides some critical exploits and security issues).

Why don't you use the latest version? You should always keep your wallet up-to-date.

Also weird bug, when I type the seed of the wallet created with 3.1.3 to restore with 2.8.x at word 6 and half (!) of the seed suddenly the next button gets grey. When I click it it tells me I can restore a wallet with 2Fa now. When I click on this I get an error window with the possibility to send a bug report?
It probably thinks it's a 2FA wallet seed, but since it's not valid, it just crashes. Anyways, that's an old version.

Awkward_Public_Stoner
Newbie
*
Offline Offline

Activity: 13
Merit: 4


View Profile
January 11, 2019, 10:10:49 PM
 #3

Quote
Yes. But why would you want to use an outdated version of Electrum?

Thank you.

It's because I run it on Ubuntu 16.04. LTS and upgrading of Electrum did not work. I get a python error message when I try to download the newest Electrum version, something wrong with pip in Ubuntu I believe.
BitMaxz
Legendary
*
Offline Offline

Activity: 1470
Merit: 1192


Beware on fake trezor website from google ads.


View Profile WWW
January 11, 2019, 10:17:30 PM
Last edit: January 11, 2019, 10:33:38 PM by BitMaxz
Merited by bones261 (2), LoyceV (1)
 #4

Might be a weird question or already answered but I created a standard wallet with segwit adresses (those starting with bc1) with Electrum 3.1.3.

Have Electrum 2.8.something on an old PC (think it's 2.8.1). Tried to restore the standard wallet with segwit addresses created with 3.1.3 from seed with Electrum 2.8.x and it won't recognize the seed. Checked multiple times, copy and pasted. No go. Is this because segwit adresses were only implemented with 3.0?
Yes, because the segwit addresses are not implemented yet when the 2.8.1 version released.

Also weird bug, when I type the seed of the wallet created with 3.1.3 to restore with 2.8.x at word 6 and half (!) of the seed suddenly the next button gets grey. When I click it it tells me I can restore a wallet with 2Fa now. When I click on this I get an error window with the possibility to send a bug report?

Don't use the old version because the old version of electrum doesn't recognize segwit addresses and lower than 3.0 version of electrum is always stuck on synchronizing.

Always make sure that you are using a latest version to be able to restore segwit addresses and there is bad news of using an old version. If you don't know yet you can read this Vulnerability discovered in Electrum 2.6 to 3.0.4: please upgrade

So you should use the latest version to keep your wallet safe.

It's because I run it on Ubuntu 16.04. LTS and upgrading of Electrum did not work. I get a python error message when I try to download the newest Electrum version, something wrong with pip in Ubuntu I believe.

Do you have the backup seeds or private keys?
I don't have much knowledge on using linux but check this thread and maybe it might help. https://bitcointalk.org/index.php?topic=2392090.0

Awkward_Public_Stoner
Newbie
*
Offline Offline

Activity: 13
Merit: 4


View Profile
January 11, 2019, 10:29:14 PM
 #5


Do you have the backup seeds or private keys?
I don't have much knowledge on using linux but check this thread and maybe it might help. https://bitcointalk.org/index.php?topic=2392090.0

Yes, I do.

Thank you, I will check it out.
Awkward_Public_Stoner
Newbie
*
Offline Offline

Activity: 13
Merit: 4


View Profile
January 12, 2019, 02:03:28 AM
Merited by bones261 (1), HCP (1)
 #6

Update:

After upgrading from Ubuntu 16.04 LTS to Ubuntu 18.04 LTS the download of Electrum 3.3.2 and restoring from seed of my wallet went without problems.

For everyone using Ubuntu 16.04., it's using an older python version making it difficult/impossible to download the newest Electrum version. Upgrade Ubuntu if possible.

ETFbitcoin
Legendary
*
Offline Offline

Activity: 1680
Merit: 1809

Use SegWit and enjoy lower fees.


View Profile WWW
January 12, 2019, 04:49:26 AM
 #7

Glad to see your problem solved

FYI, Ubuntu LTS means there's longer support for both hardware compatibility and security vulnerability, but AFAIK no longer support for software update, so that's the source of the problem.
You could add 3rd party repository such as https://launchpad.net/~deadsnakes/+archive/ubuntu/ppa and https://launchpad.net/~jonathonf/+archive/ubuntu/python-3.6 to solve the problem, but you need to trust those repository.

Awkward_Public_Stoner
Newbie
*
Offline Offline

Activity: 13
Merit: 4


View Profile
January 12, 2019, 10:17:44 AM
 #8

Thanks, I even tried adding both of the repositories you mentioned and updating python and pip manually on Ubuntu 16.04., still didn't work. Also, as you say, you have to trust them.

Better to upgrade your Ubuntu version imo.
Pages: [1]
  Print  
 
Jump to:  

Sponsored by , a Bitcoin-accepting VPN.
Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2006-2009, Simple Machines Valid XHTML 1.0! Valid CSS!