Bitcoin Forum
January 17, 2022, 04:17:05 PM *
News: Latest Bitcoin Core release: 22.0 [Torrent]
 
   Home   Help Search Login Register More  
Poll
Question: Many said they are getting 10-100% cpu usage using pocblm to mine. I want to know which CPU they use. so this poll
Intel CPU - 58 (44.3%)
AMD CPU - 73 (55.7%)
Total Voters: 130

Pages: 1 2 3 4 [All]
  Print  
Author Topic: Using pocblm to mine causes 10-100% CPU usage  (Read 23259 times)
dishwara
Legendary
*
Offline Offline

Activity: 1854
Merit: 1016



View Profile
April 20, 2011, 06:53:35 PM
Last edit: April 21, 2011, 02:24:05 AM by dishwara
 #1

There is a long thread going on with no one can able to answer "why my CPU usage is 10-100% when i mine with GPU?"

I got a hunch that it may be CPU make.
So created this poll.
So far i rarely saw my 10-100% usage of pocblm in my pc.


Please vote which make, Intel or AMD CPU you use in your mining pc/laptop/...
Also, you can post about your complete CPU details with OS details.


EDIT

I forgot to mention one thing, i too once got 15% cpu usage after reinstall. i also installed a software the day i started mining, i think
Granola i already even made a post about it.
Its free. Please try & see if, at least granola reduces cpu usage.

http://bitcointalk.org/index.php?topic=4531.msg66422#msg66422

https://grano.la/software/index.php

May be it making 0 usage of my cpu.

ACCOUNT WAS HACKED FROM 2016-2019. NOW RECLAIMED BY ORIGINAL USER D.ISHWARA
SORRY IF ANYONE GOT CHEATED BY THE IMPOSTOR
ALL POSTS AFTER MARCH 2016 BECOMES OBSOLETE & WILL BE DELETED AFTER I READ IT.
Advertised sites are not endorsed by the Bitcoin Forum. They may be unsafe, untrustworthy, or illegal in your jurisdiction. Advertise here.
nodemaster
Full Member
***
Offline Offline

Activity: 176
Merit: 100



View Profile WWW
April 20, 2011, 07:09:49 PM
 #2

AMD Athlon 64 X2 3800+ running on Ubuntu 10.04 amd64. I'm running the CPU miner only on one core, because I end up with 100% CPU usage on the other core if I run pocblm  Cry
OVerLoRDI
Member
**
Offline Offline

Activity: 60
Merit: 10


View Profile
April 20, 2011, 07:20:36 PM
 #3

I get 100% core usage per instance of poclbm on Windows 7 64bit, My XP boxes don't have this problem.

I haven't checked my ubuntu box, I just got it up and running last night.

nodemaster
Full Member
***
Offline Offline

Activity: 176
Merit: 100



View Profile WWW
April 20, 2011, 07:41:11 PM
 #4

AMD Athlon 64 X2 3800+ running on Ubuntu 10.04 amd64. I'm running the CPU miner only on one core, because I end up with 100% CPU usage on the other core if I run pocblm  Cry

Out of curiosity I just booted Windows Vista Home 64 on the same maschine and installed pocblm. The CPU usage is between 0 and 3% Furthermore Windows outperforms Linux by the factor 10  (3.5 vs. 33 Mhash/s) Shocked

I don't like that  Angry
error
Hero Member
*****
Offline Offline

Activity: 588
Merit: 500



View Profile
April 20, 2011, 09:24:12 PM
 #5

I am seeing 100% CPU usage ever since I updated to the NVIDIA 270.26 beta drivers. Before, on 260.19, the miner only used about 3 or 4% CPU.

3KzNGwzRZ6SimWuFAgh4TnXzHpruHMZmV8
FoS
Newbie
*
Offline Offline

Activity: 22
Merit: 0


View Profile
April 20, 2011, 11:20:28 PM
 #6

AMD Athlon 64 X2 4600+ running on W7 Ultimate 32bit, I get ~60% runing poclbm gui pre in 2 graphic cards(5770 & 5850). I had 100% but after set afinity only in one core, CPU usage low to ~60%
Transisto
Donator
Legendary
*
Offline Offline

Activity: 1731
Merit: 1001



View Profile WWW
April 26, 2011, 12:07:30 AM
 #7

I tried all iteration of intel, amd, ati, win7 32/64.

For those who don't have this problem, what it your openCL / driver installation procedure ?
dishwara
Legendary
*
Offline Offline

Activity: 1854
Merit: 1016



View Profile
April 26, 2011, 02:46:51 AM
 #8

catalyst 11.4 & app 2.4 both preview of 7 march.
Win7 32, quad core intel, HD 6870

ACCOUNT WAS HACKED FROM 2016-2019. NOW RECLAIMED BY ORIGINAL USER D.ISHWARA
SORRY IF ANYONE GOT CHEATED BY THE IMPOSTOR
ALL POSTS AFTER MARCH 2016 BECOMES OBSOLETE & WILL BE DELETED AFTER I READ IT.
allinvain
Legendary
*
Offline Offline

Activity: 3080
Merit: 1068



View Profile WWW
April 26, 2011, 02:55:46 AM
 #9

Is it true that catalyst 11.4p fixes this issue?


Beremat
Full Member
***
Offline Offline

Activity: 264
Merit: 100


YGOLD is a Defi platform


View Profile
April 26, 2011, 03:42:18 AM
 #10

Is it true that catalyst 11.4p fixes this issue?


It doesn't.

allinvain
Legendary
*
Offline Offline

Activity: 3080
Merit: 1068



View Profile WWW
April 26, 2011, 04:08:20 AM
 #11

Is it true that catalyst 11.4p fixes this issue?


It doesn't.

Dang! So is there ANY fix for this? This extra CPU load is just wasted electricity.

dishwara
Legendary
*
Offline Offline

Activity: 1854
Merit: 1016



View Profile
April 26, 2011, 07:13:47 AM
 #12

Is it true that catalyst 11.4p fixes this issue?


It doesn't.

Dang! So is there ANY fix for this? This extra CPU load is just wasted electricity.

I used granola & after that i see 0 CPU usage.
But that too didn't help ~anyone

ACCOUNT WAS HACKED FROM 2016-2019. NOW RECLAIMED BY ORIGINAL USER D.ISHWARA
SORRY IF ANYONE GOT CHEATED BY THE IMPOSTOR
ALL POSTS AFTER MARCH 2016 BECOMES OBSOLETE & WILL BE DELETED AFTER I READ IT.
allinvain
Legendary
*
Offline Offline

Activity: 3080
Merit: 1068



View Profile WWW
April 26, 2011, 01:22:49 PM
 #13

Is it true that catalyst 11.4p fixes this issue?


It doesn't.

Dang! So is there ANY fix for this? This extra CPU load is just wasted electricity.

I used granola & after that i see 0 CPU usage.
But that too didn't help ~anyone

How does this "granola" program fix this problem? How does that have any relation to this high cpu usage while mining problem? I do not want to undervolt (already did that) my cpu, nor underclock it, nor disable any of the cores. I just want the damn miners to stop chewing constantly 13% of each core for a total max cores of 2. So that's 100% cpu usage for one core relative to 8 hyper-threaded cores (i7 920).


geebus
Sr. Member
****
Offline Offline

Activity: 258
Merit: 250



View Profile WWW
April 26, 2011, 01:23:31 PM
 #14

Is it true that catalyst 11.4p fixes this issue?


It doesn't.

Dang! So is there ANY fix for this? This extra CPU load is just wasted electricity.

I used granola & after that i see 0 CPU usage.
But that too didn't help ~anyone

I've explained this a few times now, in various threads... The reason poclbm takes high CPU is because there is no wait delay in between thread executions. It can be fixed with 2 new lines of code, and changing 1 line of code.

I'll be happy to explain. If you're interested, PM me.

Feel like donating to me? BTC Address: 14eUVSgBSzLpHXGAfbN9BojXTWvTb91SHJ
proudhon
Legendary
*
Offline Offline

Activity: 1890
Merit: 1195



View Profile
April 26, 2011, 01:51:55 PM
 #15

Why not just explain it out in the open?

The price of bitcoin can never be sustained over $50k
error
Hero Member
*****
Offline Offline

Activity: 588
Merit: 500



View Profile
April 26, 2011, 04:50:43 PM
 #16

Or link to one of the various posts in one of the various threads, so you don't have to explain it again?

3KzNGwzRZ6SimWuFAgh4TnXzHpruHMZmV8
proudhon
Legendary
*
Offline Offline

Activity: 1890
Merit: 1195



View Profile
April 26, 2011, 06:14:35 PM
 #17

The only thing that's made any different is setting CPU affinity for the poclbm processes to a single core.  That cuts CPU usage in half and decreases Mhahs/s by like 2-3.

The price of bitcoin can never be sustained over $50k
allinvain
Legendary
*
Offline Offline

Activity: 3080
Merit: 1068



View Profile WWW
April 27, 2011, 03:22:09 AM
 #18

Is it true that catalyst 11.4p fixes this issue?


It doesn't.

Dang! So is there ANY fix for this? This extra CPU load is just wasted electricity.

I used granola & after that i see 0 CPU usage.
But that too didn't help ~anyone

I've explained this a few times now, in various threads... The reason poclbm takes high CPU is because there is no wait delay in between thread executions. It can be fixed with 2 new lines of code, and changing 1 line of code.

I'll be happy to explain. If you're interested, PM me.

You're quite sure this is JUST a poclbm problem? I recently switched to a new miner and it does the same thing.


Also guys let me be clear. I do not get 100% cpu usage across all cores. I get a constant 13% cpu usage PER miner process (regardless if its poclbm.exe or something else)

One of the developers of the new miner I'm using said that this is caused by ATI's OpenCL implementation.

disq
Newbie
*
Offline Offline

Activity: 41
Merit: 0



View Profile
April 27, 2011, 05:52:29 PM
 #19

experiencing a similar problem (100% cpu usage in one core) with 3 different gpu miners (poclbm/phoenix/diablo) on wife's nvidia 8600gt, windows7-32bit. since only some of us have this problem (and with different architectures and different windows versions) could it be the drivers, and/or some version of win7?
Beremat
Full Member
***
Offline Offline

Activity: 264
Merit: 100


YGOLD is a Defi platform


View Profile
April 28, 2011, 01:22:13 AM
 #20

You're quite sure this is JUST a poclbm problem? I recently switched to a new miner and it does the same thing.


Also guys let me be clear. I do not get 100% cpu usage across all cores. I get a constant 13% cpu usage PER miner process (regardless if its poclbm.exe or something else)

One of the developers of the new miner I'm using said that this is caused by ATI's OpenCL implementation.
You get 13% usage because you have eight cores, and poclbm is only written to utilize one core. So, one core out of eight = around 13%. If you had a dual core CPU, for example, you'd get 50% usage per miner process.

rezin777
Full Member
***
Offline Offline

Activity: 154
Merit: 100


View Profile
April 28, 2011, 01:28:10 AM
 #21

I've explained this a few times now, in various threads... The reason poclbm takes high CPU is because there is no wait delay in between thread executions. It can be fixed with 2 new lines of code, and changing 1 line of code.

I'll be happy to explain. If you're interested, PM me.

What? It doesn't use high CPU if you are only running one miner on one GPU.
allinvain
Legendary
*
Offline Offline

Activity: 3080
Merit: 1068



View Profile WWW
April 28, 2011, 05:21:37 AM
 #22

You're quite sure this is JUST a poclbm problem? I recently switched to a new miner and it does the same thing.


Also guys let me be clear. I do not get 100% cpu usage across all cores. I get a constant 13% cpu usage PER miner process (regardless if its poclbm.exe or something else)

One of the developers of the new miner I'm using said that this is caused by ATI's OpenCL implementation.
You get 13% usage because you have eight cores, and poclbm is only written to utilize one core. So, one core out of eight = around 13%. If you had a dual core CPU, for example, you'd get 50% usage per miner process.

Yep I know that. I am surprised that if the problem is easily fixable as geebus suggested why haven't all the mining programs already implement the fix?

allinvain
Legendary
*
Offline Offline

Activity: 3080
Merit: 1068



View Profile WWW
April 28, 2011, 05:24:26 AM
 #23

I've explained this a few times now, in various threads... The reason poclbm takes high CPU is because there is no wait delay in between thread executions. It can be fixed with 2 new lines of code, and changing 1 line of code.

I'll be happy to explain. If you're interested, PM me.

What? It doesn't use high CPU if you are only running one miner on one GPU.

I doubt he meant that. Also many said that if you don't run in crossfire mode you should not have this problem, but that is not true as I recently built a new mining rig with dual 5870s in non crossfire mode with a athlon x2 5200+ and guess what each poclbm instance chewed 50% of the cpu. What I ended up doing is setting the affinity for BOTH poclbm processes to ONE core. Thus I've cut CPU usage in half.


Internet151
Full Member
***
Offline Offline

Activity: 174
Merit: 100



View Profile
May 01, 2011, 10:01:57 AM
 #24

I have two computers setup with identical miners and very similar settings on those miners. My first PC has an AMD Phenom II x4 970 with an HD 6870 and has 0-1% CPU usage by the phoenix miner. My second PC is using an AMD Semptron 140 CPU with quad HD 5870's (no crossfire) and opening even one instance of the miner triggers 100% CPU usage. My first PC is running Windows 7 SP1 64-bit, my 2nd PC is running 32-bit (same OS). Both are running Catalyst 11.3.

Hope that helps someone figure out the cause of this problem.
dishwara
Legendary
*
Offline Offline

Activity: 1854
Merit: 1016



View Profile
May 01, 2011, 10:24:36 AM
 #25

After updating to new miners with BFI_INT , now i also get 10-15% cpu usage both in pocblm & phoenix.
With HD 6870 i am getting 302-304Mhash/s , if used -f1 flag & system crashed more than 10-20 times in a single day with my normal application & showed 10-15 % cpu usaege.
Now i am forced to run with out -f1, without -f flag to avoid system crash.
Getting now 292-296 Mhash/s

ACCOUNT WAS HACKED FROM 2016-2019. NOW RECLAIMED BY ORIGINAL USER D.ISHWARA
SORRY IF ANYONE GOT CHEATED BY THE IMPOSTOR
ALL POSTS AFTER MARCH 2016 BECOMES OBSOLETE & WILL BE DELETED AFTER I READ IT.
gusta
Newbie
*
Offline Offline

Activity: 8
Merit: 0


View Profile
May 01, 2011, 08:21:33 PM
 #26

Tip for multiple gpu users - assign all proccesses to one parcticular core. This way u will have only one core loaded 100% with no loss of performance.
bernd
Newbie
*
Offline Offline

Activity: 19
Merit: 0


View Profile
May 06, 2011, 02:38:27 PM
 #27

Tip for multiple gpu users - assign all proccesses to one parcticular core. This way u will have only one core loaded 100% with no loss of performance.
would you care to elaborate how to do that? thank you in advance.
bernd
Newbie
*
Offline Offline

Activity: 19
Merit: 0


View Profile
May 06, 2011, 03:17:35 PM
 #28

would you care to elaborate how to do that? thank you in advance.

For windows

Ctrl-Alt-Del
Start task manager
Processes tab
Right click the mining program you are using
Choose set affinity
Deselect all
Choose one

worked perfectly. thank you!
wumpus
Hero Member
*****
Offline Offline

Activity: 812
Merit: 1014

No Maps for These Territories


View Profile
May 06, 2011, 05:29:45 PM
 #29

I've explained this a few times now, in various threads... The reason poclbm takes high CPU is because there is no wait delay in between thread executions. It can be fixed with 2 new lines of code, and changing 1 line of code.

I'll be happy to explain. If you're interested, PM me.
Yep. To be able to respond quickly, the CPU spin-waits when waiting for the GPU to complete. This causes 100% CPU load.

This is the default with both AMD and NVidia compute drivers, although it can be disabled with a special setting, at least with CUDA, I'm not sure OpenCL has a similar directive.

Bitcoin Core developer [PGP] Warning: For most, coin loss is a larger risk than coin theft. A disk can die any time. Regularly back up your wallet through FileBackup Wallet to an external storage or the (encrypted!) cloud. Use a separate offline wallet for storing larger amounts.
allinvain
Legendary
*
Offline Offline

Activity: 3080
Merit: 1068



View Profile WWW
May 06, 2011, 07:34:42 PM
 #30

I've explained this a few times now, in various threads... The reason poclbm takes high CPU is because there is no wait delay in between thread executions. It can be fixed with 2 new lines of code, and changing 1 line of code.

I'll be happy to explain. If you're interested, PM me.
Yep. To be able to respond quickly, the CPU spin-waits when waiting for the GPU to complete. This causes 100% CPU load.

This is the default with both AMD and NVidia compute drivers, although it can be disabled with a special setting, at least with CUDA, I'm not sure OpenCL has a similar directive.

I wish it were possible to disable it with OpenCL. If you find some way or method please share. I'd like to get the CPU to idle as it would save some watts.

Funny thing this happens only when using two or more GPUs. When mining with a single 5870 card I get little to no cpu usage...go figure.

mskwik
Full Member
***
Offline Offline

Activity: 125
Merit: 100


View Profile
May 07, 2011, 01:03:08 AM
 #31

Well I was having this problem and just found that after upgrading from kernel 2.6.36-gentoo-r5 to kernel 2.6.37-gentoo-r4 it seems to have gone away.  No hardware changes, don't think anything else major got upgraded (although the fglrx kernel module was recompiled).  HD5770 w/ AMD 64 x2 CPU running Gentoo, not sure if that helps anyone else or what the changes between those kernels are, but figured I'd post for what it's worth.

allinvain
Legendary
*
Offline Offline

Activity: 3080
Merit: 1068



View Profile WWW
May 07, 2011, 03:49:57 PM
 #32

Well I was having this problem and just found that after upgrading from kernel 2.6.36-gentoo-r5 to kernel 2.6.37-gentoo-r4 it seems to have gone away.  No hardware changes, don't think anything else major got upgraded (although the fglrx kernel module was recompiled).  HD5770 w/ AMD 64 x2 CPU running Gentoo, not sure if that helps anyone else or what the changes between those kernels are, but figured I'd post for what it's worth.

But you only have one card. This problem should occur only when running more than one GPU in the same system. I'm surprised to hear that you were having this problem. CPU usage was always at 100%?

mskwik
Full Member
***
Offline Offline

Activity: 125
Merit: 100


View Profile
May 07, 2011, 05:45:00 PM
 #33

Well I was having this problem and just found that after upgrading from kernel 2.6.36-gentoo-r5 to kernel 2.6.37-gentoo-r4 it seems to have gone away.  No hardware changes, don't think anything else major got upgraded (although the fglrx kernel module was recompiled).  HD5770 w/ AMD 64 x2 CPU running Gentoo, not sure if that helps anyone else or what the changes between those kernels are, but figured I'd post for what it's worth.

But you only have one card. This problem should occur only when running more than one GPU in the same system. I'm surprised to hear that you were having this problem. CPU usage was always at 100%?

Yeah, CPU usage was always pegged at 100% on one core when GPU mining with either pocblm or phoenix, didn't seem to matter to mining rate if I ran something else CPU-heavy that cut down on the amount it could use.  And now all of a sudden it uses less than 1%.  No idea if it's the same bug as people with multiple cards or not, just figured it might help someone else out.

allinvain
Legendary
*
Offline Offline

Activity: 3080
Merit: 1068



View Profile WWW
May 07, 2011, 07:31:12 PM
 #34

Well I was having this problem and just found that after upgrading from kernel 2.6.36-gentoo-r5 to kernel 2.6.37-gentoo-r4 it seems to have gone away.  No hardware changes, don't think anything else major got upgraded (although the fglrx kernel module was recompiled).  HD5770 w/ AMD 64 x2 CPU running Gentoo, not sure if that helps anyone else or what the changes between those kernels are, but figured I'd post for what it's worth.

But you only have one card. This problem should occur only when running more than one GPU in the same system. I'm surprised to hear that you were having this problem. CPU usage was always at 100%?

Yeah, CPU usage was always pegged at 100% on one core when GPU mining with either pocblm or phoenix, didn't seem to matter to mining rate if I ran something else CPU-heavy that cut down on the amount it could use.  And now all of a sudden it uses less than 1%.  No idea if it's the same bug as people with multiple cards or not, just figured it might help someone else out.

Damn. OK, I am officially both frustrated and confused lol

I wish I could upgrade my kernel too (win 7) Smiley Ohwell, I guess there is always mining under Linux.

mclemme
Newbie
*
Offline Offline

Activity: 1
Merit: 0



View Profile
May 10, 2011, 05:00:48 PM
 #35

AMD Athlon 64 X2 3800+ running on Ubuntu 10.04 amd64. I'm running the CPU miner only on one core, because I end up with 100% CPU usage on the other core if I run pocblm  Cry

I had the same issue, using an Intel Core 2 Duo E8400 and a Nvidia 8800GT GPU on ubuntu 10.04 64-bit.

I tried tossing a spare harddrive I had laying around in my PC and installed Ubuntu 10.10, the result when running poclbm = 0-3% CPU.

I can see that the Nvidia driver in my 10.04 is version 195.36.24 which is quite old, so I'm guessing that's the problem. Try 10.10 on a spare harddrive or an old usb key you have lying around to see if that solves your problem as well Smiley
allinvain
Legendary
*
Offline Offline

Activity: 3080
Merit: 1068



View Profile WWW
May 11, 2011, 12:36:51 AM
 #36

Hmm...yeah I think I will be moving on to linux for my dedicated miners. I managed to reduce the cpu usage to 50% by setting the affinity for both poclbm processes but still why should the cpu consume 50% more electricity than is necessary.

That new bitcoin linux distro looks mighty spiffy! Tongue I'll probably be using that on a usb drive.

maxcorrads
Newbie
*
Offline Offline

Activity: 43
Merit: 0


View Profile
May 11, 2011, 08:36:38 AM
 #37

Someone have found the way to fix the 100% CPU bug?

I have 2 5850, Windows 7, Amd64 3500+.
allinvain
Legendary
*
Offline Offline

Activity: 3080
Merit: 1068



View Profile WWW
May 11, 2011, 09:27:12 AM
 #38

Someone have found the way to fix the 100% CPU bug?

I have 2 5850, Windows 7, Amd64 3500+.

Nope. The best you can do for now is set the affinity for each miner process to one core.

maxcorrads
Newbie
*
Offline Offline

Activity: 43
Merit: 0


View Profile
May 11, 2011, 09:30:28 AM
 #39

Someone have found the way to fix the 100% CPU bug?

I have 2 5850, Windows 7, Amd64 3500+.

Nope. The best you can do for now is set the affinity for each miner process to one core.


The problem is that i've only one core Cheesy
allinvain
Legendary
*
Offline Offline

Activity: 3080
Merit: 1068



View Profile WWW
May 11, 2011, 09:34:28 AM
 #40

lool...that indeed is a problem. The only other thing I can suggest is to give linux a try and see if it does the same thing under linux. Check this out:

https://www.bitcoin.org/smf/index.php?topic=7374.0

maxcorrads
Newbie
*
Offline Offline

Activity: 43
Merit: 0


View Profile
May 13, 2011, 08:55:14 AM
Last edit: May 13, 2011, 09:16:33 AM by maxcorrads
 #41

Installed Ubuntu 11.04, now i've got 20% CPU usage.

EDIT:
For those who want to try, I followed this guide:
http://bitcointalk.org/index.php?topic=7514.0
allinvain
Legendary
*
Offline Offline

Activity: 3080
Merit: 1068



View Profile WWW
May 13, 2011, 08:57:29 AM
 #42

Installed Ubuntu 11.04, now i've got 20% CPU usage.

Thought so, so this is a windows issue with the OpelCL SDK using the CPU spinstates...in linux you can apparently disable this, but not in windows.

Carandiru
Newbie
*
Offline Offline

Activity: 40
Merit: 0


View Profile WWW
May 24, 2011, 12:52:41 AM
 #43

I've just updated my ScreenSaver that is a front-end tested with poclbm to automatically set the affinity to just one processor in hopes of lower cpu usage and lower power consumption.
allinvain
Legendary
*
Offline Offline

Activity: 3080
Merit: 1068



View Profile WWW
May 24, 2011, 07:33:39 AM
 #44

I've just updated my ScreenSaver that is a front-end tested with poclbm to automatically set the affinity to just one processor in hopes of lower cpu usage and lower power consumption.

Excellent! That is very much appreciated.


earthmeLon
Newbie
*
Offline Offline

Activity: 11
Merit: 0


View Profile
May 25, 2011, 12:25:51 AM
 #45

poclbm causes 100% usage of both my cores on my AMD Athlon 64 X2 Dual Core 6400+.
poclbm sees my GPU as
  • GeForce 8800 GTX

Ubuntu 10.10 x64
GeForce 8800 GTX (128 CUDA cores,768 MB Memory, 384-bit Memory Interface) on PCIExpress x16
NVIDIA Driver Version: 270.41.19
dishwara
Legendary
*
Offline Offline

Activity: 1854
Merit: 1016



View Profile
June 04, 2011, 05:21:22 PM
 #46

The CPU usage problem by pocblm is actually not a problem.
Its due to feature added to catalyst driver after version 10.

If you use version 10 series catalyst driver, then you will see, it uses 1-2% cpu only. & you can further reduce it using granola software.
What it does actually is, it doesn't uses CPU for any graphics work.
The catalyst driver restrict the graphics processing only to GPU.

This has been changed in version 11 series or HD 6000 card series.
In this, catalyst driver allows CPU also can process graphics.

Why this is added & what is the benefit you may ask.
They have added CPU to process graphics to give back up in case GPU usage goes OVER 100%.
I have seen many times, that with version 10, pocblm crashes, if i open some graphics related program.
With Windows 7 & Aero enabled, it can be seen very clearly.
Since Aero uses graphics which is also processed only by GPU, any additional graphics processing, crashes pocblm , so that GPU will be free to process graphics.

You have now 6 options to try.
1.Run with version 10 series catalyst driver + granola + affinity, this gives the LEAST amount of CPU usage.
2.Run with version 10 series catalyst driver + affinity.
3.Run with version 10 series catalyst driver.
4.Run with version 11.5 or latest catalyst driver + granola + affinity.
5.Run with version 11.5 or latest catalyst driver + affinity.
6.Run with version 11.5 or latest catalyst driver, this uses the MOST CPU usage.

I am now using 4 option & i see less CPU usage & temperature as all poclbm or phoenix is set to only one core using affinity.

ACCOUNT WAS HACKED FROM 2016-2019. NOW RECLAIMED BY ORIGINAL USER D.ISHWARA
SORRY IF ANYONE GOT CHEATED BY THE IMPOSTOR
ALL POSTS AFTER MARCH 2016 BECOMES OBSOLETE & WILL BE DELETED AFTER I READ IT.
mattpker
Newbie
*
Offline Offline

Activity: 28
Merit: 0



View Profile
June 05, 2011, 02:40:43 AM
 #47

Thanks for the info dishwara. I will try option 4 when I get home and update with the info.
Allenssmart
Newbie
*
Offline Offline

Activity: 23
Merit: 0


View Profile
June 05, 2011, 02:58:03 AM
 #48

13% on each instance of poclbm, running a 5970 which is 2 5870s so 26% cpu usage.
turinpt
Newbie
*
Offline Offline

Activity: 6
Merit: 0


View Profile
June 08, 2011, 05:49:45 PM
 #49

This really sucks. With 11 series CCC I get 100% CPU usage. With 10 series, guiminer doesn't recognize any OpenCL devices Sad
thundertoe
Legendary
*
Offline Offline

Activity: 938
Merit: 1000



View Profile
June 09, 2011, 01:31:01 AM
 #50

just fired up a new rig.. win 7 guiminer sempron 140... 100% cpu usage any way to slow this down? 11 drivers

trying granola... will report back
minerX
Newbie
*
Offline Offline

Activity: 56
Merit: 0


View Profile
June 09, 2011, 01:35:06 AM
 #51

2.7 amd dual core.

4x 5850 = 100% CPU (2.4, 11.5 ccc, windows 7 64 bit)

Same system on Ubuntu (11.04 ubun , 2.1 SDK)  10-15% CPU usage.
thundertoe
Legendary
*
Offline Offline

Activity: 938
Merit: 1000



View Profile
June 09, 2011, 03:34:15 AM
 #52

tried granola and with miser setting it just slowed my hash down... yah cpu was down too but hash went down same %
dishwara
Legendary
*
Offline Offline

Activity: 1854
Merit: 1016



View Profile
June 09, 2011, 05:55:10 AM
 #53

tried granola and with miser setting it just slowed my hash down... yah cpu was down too but hash went down same %
That means i am right. you using CPU to mine with version 11 catalyst drivers, besides GPU.
Use affinity & set all miners to one core, then you will see increase in performance.

ACCOUNT WAS HACKED FROM 2016-2019. NOW RECLAIMED BY ORIGINAL USER D.ISHWARA
SORRY IF ANYONE GOT CHEATED BY THE IMPOSTOR
ALL POSTS AFTER MARCH 2016 BECOMES OBSOLETE & WILL BE DELETED AFTER I READ IT.
mattpker
Newbie
*
Offline Offline

Activity: 28
Merit: 0



View Profile
June 09, 2011, 06:12:26 AM
 #54

The only thing I have found to help is setting the affinity. Until the drivers are fixed this is the only option or running Linux. I am using Phoenix Rising now because it allows you to set the affinity on start up to a random core.
thundertoe
Legendary
*
Offline Offline

Activity: 938
Merit: 1000



View Profile
June 09, 2011, 08:46:38 AM
 #55

set to one core... im running a single core sempron .... Sad
Tukotih
Member
**
Offline Offline

Activity: 70
Merit: 10


View Profile
June 09, 2011, 08:52:34 AM
 #56

AMD Athlon 64 X2 3800+ running on Ubuntu 10.04 amd64. I'm running the CPU miner only on one core, because I end up with 100% CPU usage on the other core if I run pocblm  Cry

Out of curiosity I just booted Windows Vista Home 64 on the same maschine and installed pocblm. The CPU usage is between 0 and 3% Furthermore Windows outperforms Linux by the factor 10  (3.5 vs. 33 Mhash/s) Shocked

I don't like that  Angry
If Windows outperforms Linux (especially if by a factor of 10!) you are doing it wrong!
My first guess was that you are CPU-mining, but that wouldn't make sense with 0-3% usage...
Have you installed the latest GPU & OpenCL-drivers? How high load has the card? Is there a significant increase in temperature?

Donations always appreciated: 1GkRu9rZxk5iMRzsrcZxZ3BUHV1SWNZ9RB
IMPORTANT! Switch from deepbit: http://forum.bitcoin.org/index.php?topic=8653.0
thundertoe
Legendary
*
Offline Offline

Activity: 938
Merit: 1000



View Profile
June 09, 2011, 08:54:50 AM
 #57

if i have time tomorrow ill make the new rig dual boot with vista64 and see how that goes... 100% cpu with sempron isnt horrible.. like 45 watts? power is cheap here but its annoying for me to see  that bar at 100% on the cpu meter.
fcmatt
Legendary
*
Offline Offline

Activity: 1932
Merit: 1001



View Profile
June 09, 2011, 10:50:57 PM
 #58

set to one core... im running a single core sempron .... Sad

for all the sempron 140 users.. you know, that cheapo 35-45 dollar proc.. it can be unlocked to be
a dual core chip. if your motherboard has ACC or some type of core unlock feature you can make it a dual
core.. plus it over clocks pretty well too from what i have read.

if that helps you feel free to send a tip :-)  1P4Z4eu7TxGq8qvSpzfKgWyyXCWn7ZbB9o

.
.1xBit.com  sports.
███████████████████████████
████████▀▀       ▀▀████████
█████▀  ▄▄▄▀███▀▄▄▄  ▀█████
████  ▄█████▄ ▄█████▄  ████
███  █ █████▀ ▀█████ █  ███
██  ▄██ ▀▀▀▄███▄▀▀▀ ██▄  ██
██  █▀▄██ ███████ ██▄▀█  ██
██   █████ █████ █████   ██
███  █████▀▄▄▄▄▄▀█████  ███
████  ▀▄▄▄▀█████▀▄▄▄▀  ████
█████▄  ▀▀█ ███ █▀▀  ▄█████
████████▄▄       ▄▄████████
███████████████████████████
███████████████████
▀▀       ▀▀████████
 ▄▄  ▀  ▄▄   ▀█████
 ▀    ▀█████▄  ████
   ▀█▄   ▀▀██▄  ███
 █▄  ▀██▄▄  ▀█▄  ██
  ▀█▄  ▀███▄  ▀  ██
█  ▀██▄  ▀███▄   ██
██  ▀███▄  ▀█▀  ███
███  ▀████▄    ████
 ▀▀█▄  ▀▀▀   ▄█████
▄▄       ▄▄████████
███████████████████
███████████████████
███▀▀         ▀▀███
▀   ▄▄██▄  ▀█▄  ▀██
 ▄████████▄  ▀█  ██
██████▄▀  ██▄    ██
████▄▀  ▄▀████▄  ██
██▄▀  ▄▀██████  ▄██
▄▀  ▄▀███████  ▄███
█▄▄▀███████▀  ▄████
▀████████▀  ▄██████
  ▀██▀▀   ▄████████
      ▄▄███████████
███████████████████
.
.
.
thundertoe
Legendary
*
Offline Offline

Activity: 938
Merit: 1000



View Profile
June 10, 2011, 05:43:59 PM
 #59

Thanks for the unlock tip. I tired it out and.. no luck. Mobo supports unlocking but maybe the hidden core is bad. As for overclocking.. the way the usage pegs at 100% makes me think that no matter how fast the chip its going to peg. Still nobody has an answer on how to fix.

This post suggest it may be a driver issue

 http://forum.bitcoin.org/index.php?topic=14074.0

I am only having problem on 2 card rig with windows 7. The single card rig is vista 64. I hate to have to the miners offline for awhile but i guess ill try and install vista dual boot for a test.

Anyone has ideas for a fix or found other threads that can help?
allinvain
Legendary
*
Offline Offline

Activity: 3080
Merit: 1068



View Profile WWW
June 11, 2011, 01:14:22 AM
 #60

It's definitely a driver issue. The only REAL fix would come from AMD. Let us all bug AMD about it. Seriously people write to AMD and stop whining and complaining about "how come there is no fix..." or whatever.. Smiley

hunter
Newbie
*
Offline Offline

Activity: 51
Merit: 0


View Profile
June 21, 2011, 05:01:38 AM
 #61

For you guys tweaking affinity and priorities, check out Prifinitty. http://edgemeal.110mb.com/PriFinitty/index.htm
jwzguy
Hero Member
*****
Offline Offline

Activity: 868
Merit: 1000



View Profile
June 21, 2011, 05:38:32 AM
 #62

I have this issue on both AMD and intel. Not enough poll choices.
Capitan
Member
**
Offline Offline

Activity: 112
Merit: 10


View Profile
June 21, 2011, 06:39:36 PM
 #63

You can set the CPU affinity through a command line parameter to the start.exe program. do start.exe /? to see the options, then google if you need more documentation. I used this and created a batch file that puts all the processes to belownormal priority and all assigned to a single CPU core, so it doesn't slow down my system. They still pretty much use 100% of that one core, but I have a quad core so no big deal.
jwzguy
Hero Member
*****
Offline Offline

Activity: 868
Merit: 1000



View Profile
June 22, 2011, 02:59:44 AM
 #64

On any system that dynamically adjusts core voltage with load, this -is- a big deal. Loading up one core will still bump the core voltage way up. It will cause a significant waste of power on an otherwise idle system.

I hope they fix this nonsense soon.
allinvain
Legendary
*
Offline Offline

Activity: 3080
Merit: 1068



View Profile WWW
June 22, 2011, 03:31:07 AM
 #65

On any system that dynamically adjusts core voltage with load, this -is- a big deal. Loading up one core will still bump the core voltage way up. It will cause a significant waste of power on an otherwise idle system.

I hope they fix this nonsense soon.

You are absolutely right. Those clock cycled are wasted! What sucks is that this issue has been known for a long time yet there is no fix yet. Someone clearly doesn't give a shit at AMD.

Xenomorph
Newbie
*
Offline Offline

Activity: 32
Merit: 0



View Profile
June 22, 2011, 03:58:16 AM
 #66

Core i7
Latest NVidia drivers (as of June 17th)
GeForce GT 330M
Windows 7 x64

Trying to mine with just the video card will try eat 100% CPU (well, 25%, since the CPU is multi-core/multi-threaded).
Dacm4n
Sr. Member
****
Offline Offline

Activity: 363
Merit: 250



View Profile
June 22, 2011, 05:55:47 PM
 #67

I get around 25% cpu usage using pocblm with my Intel i3 530 with Nvidia gts 250 (with latest drivers).
iopq
Hero Member
*****
Offline Offline

Activity: 658
Merit: 500


View Profile
June 22, 2011, 07:22:33 PM
 #68

I am using ATI HD 5750, with an E8400 Core™2 Duo processor under windows 7 and I do not have this issue with the latest drivers. My CPU usage is close to 0.
jwzguy
Hero Member
*****
Offline Offline

Activity: 868
Merit: 1000



View Profile
June 24, 2011, 11:48:06 PM
 #69

I am using ATI HD 5750, with an E8400 Core™2 Duo processor under windows 7 and I do not have this issue with the latest drivers. My CPU usage is close to 0.

Only one card though?
Serge
Legendary
*
Offline Offline

Activity: 1050
Merit: 1000


View Profile
June 25, 2011, 03:51:04 AM
 #70

each of the two 5830 eats 25% of i5 quad core cpu here  Angry
computerparts
Sr. Member
****
Offline Offline

Activity: 378
Merit: 250



View Profile
June 25, 2011, 07:05:32 AM
 #71

I am using ATI HD 5750, with an E8400 Core™2 Duo processor under windows 7 and I do not have this issue with the latest drivers. My CPU usage is close to 0.

There's your answer. The problem is NOT the drivers it is the Stream SDK which just so happens to be included in the Catalyst packages these days. The 5 series cards are compatible with ATI Stream SDK 2.1 which does not utilize the cpu. SDK 2.2 started utilizing the cpu to full capacity. The 6 series cards are not compatible with SDK 2.1. For those of you who have the 6 series cards, your stuck with it, at least on windows anyway.
dishwara
Legendary
*
Offline Offline

Activity: 1854
Merit: 1016



View Profile
June 25, 2011, 11:08:14 AM
 #72

All who want to avoid 10-100% CPU usage, also windows not mining with more than 4 GPU's......all problem related to windows->opencl->mining have to send/write to the below forum, coz it deals with opencl.

OpenCL is the root cause of all the problems, from windows not supporting more than 4 GPU's, 100% usage....
Instead of NO ONE asking or writing in AMD DEVELOPER forum, AMD DEVELOPER WILL NEVER know the problem.
Also, if you write to AMD, they won't care, as it MUST be addressed by developers not product division.

So, better don't mass mail, but REGISTER in the developer forum & ask them what features you want, both in Windows & Linux.
Only developer forum can solve all the Windows/Linux->OpenCL issues. No others can solve that.

http://forums.amd.com/forum/categories.cfm?catid=390

I also want to add a note, since the thread was locked i can't post there & don't want to create another thread.
http://forum.bitcoin.org/index.php?topic=19038.0

In this thread i accused mining software developers for blocking/limiting 4 GPU's only in Windows.
I was wrong. I came to learn that, its not Windows or mining programs, but its due to limitation in OpenCL.
The misunderstood is due to the reason, no one had time to explain why in Windows with more than 4 GPU's can't mine.
All i got was Windows won't mine more than 4 GPU's, if you want to go for more than 4 GPU's switch to Linux.
This is the only thing i heard. I also may not be knowledgeable/intelligent enough to read some one's post/thread which clearly said its due to OpenCL.

Actually the post of iamzill which divided the problem & cleared me to question where is the problem.
Quote
There's some misunderstanding here.

In order to you to mine on a GPU, the following statements must all be true:
1. Your GPU must be detected by your OS
2. Your GPU must be detected by the ATI openCL driver
3. Your GPU must be detected by your miner

The current problem is that ATI's Windows openCL drivers does not work with more than 4 cards. The onus is on you to prove it otherwise. I'm sure many developers would've love to overcome this limitation, but none have succeed so far.

Your screenshot shows that Windows can detect 7 GPUs for the purposes of displaying pictures, but without the help of proprietary drivers Windows cannot do any computation with them. The 4 GPU/OS limitation lies with the proprietary drivers, and not Windows or the miner developers.

From his post, i got doubt that it may be OpenCL & searched sites & found out, that it is OpenCL.

Before i try to post my findings & apologies, one miner got angry & posted & many complained to moderator, that made him to lock the thread.

I wanted to post this next day itself, but due to many problem i faced, i can't able to post.

All the miners who wrote & writing mining programs apologize me for accusing mining writers in general with out knowing the fact that it is not miners fault, but it is OpenCL & particularly AMD not developing.

I apologize to all miners that i scolded you unnecessarily without knowing the fact.
Forgive me for my no knowledge & no intelligent.

As said above, instead of keep on saying i am getting 10-100% or even 1000% CPU usage, better post to DEVELOPERS forum of AMD.

ACCOUNT WAS HACKED FROM 2016-2019. NOW RECLAIMED BY ORIGINAL USER D.ISHWARA
SORRY IF ANYONE GOT CHEATED BY THE IMPOSTOR
ALL POSTS AFTER MARCH 2016 BECOMES OBSOLETE & WILL BE DELETED AFTER I READ IT.
iopq
Hero Member
*****
Offline Offline

Activity: 658
Merit: 500


View Profile
July 14, 2011, 01:16:07 PM
 #73

I am using ATI HD 5750, with an E8400 Core™2 Duo processor under windows 7 and I do not have this issue with the latest drivers. My CPU usage is close to 0.

There's your answer. The problem is NOT the drivers it is the Stream SDK which just so happens to be included in the Catalyst packages these days. The 5 series cards are compatible with ATI Stream SDK 2.1 which does not utilize the cpu. SDK 2.2 started utilizing the cpu to full capacity. The 6 series cards are not compatible with SDK 2.1. For those of you who have the 6 series cards, your stuck with it, at least on windows anyway.
I still had no CPU usage on stream SDK 2.4, but lower hashrate so I downgraded
haydent
Full Member
***
Offline Offline

Activity: 154
Merit: 100



View Profile
July 29, 2011, 02:53:30 AM
 #74

i have started a thread at amd dev forum - opencl section about the 100% cpu usage bug with >1 gpu installed. feel free to jump over there and post your support for this issue being addressed...

http://forums.amd.com/devforum/messageview.cfm?catid=390&threadid=153211&enterthread=y

2x Gigabyte 6950 OC @ 920/450 w/ ati tray tools (1 shader modded) - 760Mhs on ozco.in 0% fee aus pool
btc: 1HS5Brzcsh7XkJn566XYbvfpa2JuBRBdss
jwzguy
Hero Member
*****
Offline Offline

Activity: 868
Merit: 1000



View Profile
July 29, 2011, 01:27:35 PM
 #75

i have started a thread at amd dev forum - opencl section about the 100% cpu usage bug with >1 gpu installed. feel free to jump over there and post your support for this issue being addressed...

http://forums.amd.com/devforum/messageview.cfm?catid=390&threadid=153211&enterthread=y

Hey. I feel like a dummy, but I can't seem to reply to your thread. I signed up and logged in but I don't see a "reply" button anywhere.
dishwara
Legendary
*
Offline Offline

Activity: 1854
Merit: 1016



View Profile
July 29, 2011, 01:34:07 PM
 #76

Its in right side bottom of EVERY post. Reply, Quote, Top, Bottom.

ACCOUNT WAS HACKED FROM 2016-2019. NOW RECLAIMED BY ORIGINAL USER D.ISHWARA
SORRY IF ANYONE GOT CHEATED BY THE IMPOSTOR
ALL POSTS AFTER MARCH 2016 BECOMES OBSOLETE & WILL BE DELETED AFTER I READ IT.
jwzguy
Hero Member
*****
Offline Offline

Activity: 868
Merit: 1000



View Profile
July 29, 2011, 04:41:04 PM
 #77

Its in right side bottom of EVERY post. Reply, Quote, Top, Bottom.
Not on my screen.
haydent
Full Member
***
Offline Offline

Activity: 154
Merit: 100



View Profile
July 30, 2011, 12:24:53 AM
 #78

i have started a thread at amd dev forum - opencl section about the 100% cpu usage bug with >1 gpu installed. feel free to jump over there and post your support for this issue being addressed...

http://forums.amd.com/devforum/messageview.cfm?catid=390&threadid=153211&enterthread=y

Hey. I feel like a dummy, but I can't seem to reply to your thread. I signed up and logged in but I don't see a "reply" button anywhere.

i had this too, you need to logout and back in and when you do it will show you a TOS that you agree to,  then you can post/reply.

thanks for posting

2x Gigabyte 6950 OC @ 920/450 w/ ati tray tools (1 shader modded) - 760Mhs on ozco.in 0% fee aus pool
btc: 1HS5Brzcsh7XkJn566XYbvfpa2JuBRBdss
Pages: 1 2 3 4 [All]
  Print  
 
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2006-2009, Simple Machines Valid XHTML 1.0! Valid CSS!