Bitcoin Forum
December 09, 2016, 09:24:30 PM *
News: Latest stable version of Bitcoin Core: 0.13.1  [Torrent].
 
   Home   Help Search Donate Login Register  
Poll
Question: Many said they are getting 10-100% cpu usage using pocblm to mine. I want to know which CPU they use. so this poll
Intel CPU - 58 (44.3%)
AMD CPU - 73 (55.7%)
Total Voters: 130

Pages: « 1 [2] 3 4 »  All
  Print  
Author Topic: Using pocblm to mine causes 10-100% CPU usage  (Read 22233 times)
rezin777
Full Member
***
Offline Offline

Activity: 154


View Profile
April 28, 2011, 01:28:10 AM
 #21

I've explained this a few times now, in various threads... The reason poclbm takes high CPU is because there is no wait delay in between thread executions. It can be fixed with 2 new lines of code, and changing 1 line of code.

I'll be happy to explain. If you're interested, PM me.

What? It doesn't use high CPU if you are only running one miner on one GPU.
1481318670
Hero Member
*
Offline Offline

Posts: 1481318670

View Profile Personal Message (Offline)

Ignore
1481318670
Reply with quote  #2

1481318670
Report to moderator
1481318670
Hero Member
*
Offline Offline

Posts: 1481318670

View Profile Personal Message (Offline)

Ignore
1481318670
Reply with quote  #2

1481318670
Report to moderator
Advertised sites are not endorsed by the Bitcoin Forum. They may be unsafe, untrustworthy, or illegal in your jurisdiction. Advertise here.
1481318670
Hero Member
*
Offline Offline

Posts: 1481318670

View Profile Personal Message (Offline)

Ignore
1481318670
Reply with quote  #2

1481318670
Report to moderator
1481318670
Hero Member
*
Offline Offline

Posts: 1481318670

View Profile Personal Message (Offline)

Ignore
1481318670
Reply with quote  #2

1481318670
Report to moderator
allinvain
Legendary
*
Offline Offline

Activity: 2002



View Profile
April 28, 2011, 05:21:37 AM
 #22

You're quite sure this is JUST a poclbm problem? I recently switched to a new miner and it does the same thing.


Also guys let me be clear. I do not get 100% cpu usage across all cores. I get a constant 13% cpu usage PER miner process (regardless if its poclbm.exe or something else)

One of the developers of the new miner I'm using said that this is caused by ATI's OpenCL implementation.
You get 13% usage because you have eight cores, and poclbm is only written to utilize one core. So, one core out of eight = around 13%. If you had a dual core CPU, for example, you'd get 50% usage per miner process.

Yep I know that. I am surprised that if the problem is easily fixable as geebus suggested why haven't all the mining programs already implement the fix?

allinvain
Legendary
*
Offline Offline

Activity: 2002



View Profile
April 28, 2011, 05:24:26 AM
 #23

I've explained this a few times now, in various threads... The reason poclbm takes high CPU is because there is no wait delay in between thread executions. It can be fixed with 2 new lines of code, and changing 1 line of code.

I'll be happy to explain. If you're interested, PM me.

What? It doesn't use high CPU if you are only running one miner on one GPU.

I doubt he meant that. Also many said that if you don't run in crossfire mode you should not have this problem, but that is not true as I recently built a new mining rig with dual 5870s in non crossfire mode with a athlon x2 5200+ and guess what each poclbm instance chewed 50% of the cpu. What I ended up doing is setting the affinity for BOTH poclbm processes to ONE core. Thus I've cut CPU usage in half.


Internet151
Full Member
***
Offline Offline

Activity: 174



View Profile
May 01, 2011, 10:01:57 AM
 #24

I have two computers setup with identical miners and very similar settings on those miners. My first PC has an AMD Phenom II x4 970 with an HD 6870 and has 0-1% CPU usage by the phoenix miner. My second PC is using an AMD Semptron 140 CPU with quad HD 5870's (no crossfire) and opening even one instance of the miner triggers 100% CPU usage. My first PC is running Windows 7 SP1 64-bit, my 2nd PC is running 32-bit (same OS). Both are running Catalyst 11.3.

Hope that helps someone figure out the cause of this problem.
dishwara
Legendary
*
Offline Offline

Activity: 1386

Truth may get delay, but NEVER fails


View Profile
May 01, 2011, 10:24:36 AM
 #25

After updating to new miners with BFI_INT , now i also get 10-15% cpu usage both in pocblm & phoenix.
With HD 6870 i am getting 302-304Mhash/s , if used -f1 flag & system crashed more than 10-20 times in a single day with my normal application & showed 10-15 % cpu usaege.
Now i am forced to run with out -f1, without -f flag to avoid system crash.
Getting now 292-296 Mhash/s
gusta
Newbie
*
Offline Offline

Activity: 8


View Profile
May 01, 2011, 08:21:33 PM
 #26

Tip for multiple gpu users - assign all proccesses to one parcticular core. This way u will have only one core loaded 100% with no loss of performance.
bernd
Newbie
*
Offline Offline

Activity: 19


View Profile
May 06, 2011, 02:38:27 PM
 #27

Tip for multiple gpu users - assign all proccesses to one parcticular core. This way u will have only one core loaded 100% with no loss of performance.
would you care to elaborate how to do that? thank you in advance.
bernd
Newbie
*
Offline Offline

Activity: 19


View Profile
May 06, 2011, 03:17:35 PM
 #28

would you care to elaborate how to do that? thank you in advance.

For windows

Ctrl-Alt-Del
Start task manager
Processes tab
Right click the mining program you are using
Choose set affinity
Deselect all
Choose one

worked perfectly. thank you!
wumpus
Hero Member
*****
Offline Offline

Activity: 798

No Maps for These Territories


View Profile
May 06, 2011, 05:29:45 PM
 #29

I've explained this a few times now, in various threads... The reason poclbm takes high CPU is because there is no wait delay in between thread executions. It can be fixed with 2 new lines of code, and changing 1 line of code.

I'll be happy to explain. If you're interested, PM me.
Yep. To be able to respond quickly, the CPU spin-waits when waiting for the GPU to complete. This causes 100% CPU load.

This is the default with both AMD and NVidia compute drivers, although it can be disabled with a special setting, at least with CUDA, I'm not sure OpenCL has a similar directive.

Bitcoin Core developer [PGP] Warning: For most, coin loss is a larger risk than coin theft. A disk can die any time. Regularly back up your wallet through FileBackup Wallet to an external storage or the (encrypted!) cloud. Use a separate offline wallet for storing larger amounts.
allinvain
Legendary
*
Offline Offline

Activity: 2002



View Profile
May 06, 2011, 07:34:42 PM
 #30

I've explained this a few times now, in various threads... The reason poclbm takes high CPU is because there is no wait delay in between thread executions. It can be fixed with 2 new lines of code, and changing 1 line of code.

I'll be happy to explain. If you're interested, PM me.
Yep. To be able to respond quickly, the CPU spin-waits when waiting for the GPU to complete. This causes 100% CPU load.

This is the default with both AMD and NVidia compute drivers, although it can be disabled with a special setting, at least with CUDA, I'm not sure OpenCL has a similar directive.

I wish it were possible to disable it with OpenCL. If you find some way or method please share. I'd like to get the CPU to idle as it would save some watts.

Funny thing this happens only when using two or more GPUs. When mining with a single 5870 card I get little to no cpu usage...go figure.

mskwik
Full Member
***
Offline Offline

Activity: 125


View Profile
May 07, 2011, 01:03:08 AM
 #31

Well I was having this problem and just found that after upgrading from kernel 2.6.36-gentoo-r5 to kernel 2.6.37-gentoo-r4 it seems to have gone away.  No hardware changes, don't think anything else major got upgraded (although the fglrx kernel module was recompiled).  HD5770 w/ AMD 64 x2 CPU running Gentoo, not sure if that helps anyone else or what the changes between those kernels are, but figured I'd post for what it's worth.

allinvain
Legendary
*
Offline Offline

Activity: 2002



View Profile
May 07, 2011, 03:49:57 PM
 #32

Well I was having this problem and just found that after upgrading from kernel 2.6.36-gentoo-r5 to kernel 2.6.37-gentoo-r4 it seems to have gone away.  No hardware changes, don't think anything else major got upgraded (although the fglrx kernel module was recompiled).  HD5770 w/ AMD 64 x2 CPU running Gentoo, not sure if that helps anyone else or what the changes between those kernels are, but figured I'd post for what it's worth.

But you only have one card. This problem should occur only when running more than one GPU in the same system. I'm surprised to hear that you were having this problem. CPU usage was always at 100%?

mskwik
Full Member
***
Offline Offline

Activity: 125


View Profile
May 07, 2011, 05:45:00 PM
 #33

Well I was having this problem and just found that after upgrading from kernel 2.6.36-gentoo-r5 to kernel 2.6.37-gentoo-r4 it seems to have gone away.  No hardware changes, don't think anything else major got upgraded (although the fglrx kernel module was recompiled).  HD5770 w/ AMD 64 x2 CPU running Gentoo, not sure if that helps anyone else or what the changes between those kernels are, but figured I'd post for what it's worth.

But you only have one card. This problem should occur only when running more than one GPU in the same system. I'm surprised to hear that you were having this problem. CPU usage was always at 100%?

Yeah, CPU usage was always pegged at 100% on one core when GPU mining with either pocblm or phoenix, didn't seem to matter to mining rate if I ran something else CPU-heavy that cut down on the amount it could use.  And now all of a sudden it uses less than 1%.  No idea if it's the same bug as people with multiple cards or not, just figured it might help someone else out.

allinvain
Legendary
*
Offline Offline

Activity: 2002



View Profile
May 07, 2011, 07:31:12 PM
 #34

Well I was having this problem and just found that after upgrading from kernel 2.6.36-gentoo-r5 to kernel 2.6.37-gentoo-r4 it seems to have gone away.  No hardware changes, don't think anything else major got upgraded (although the fglrx kernel module was recompiled).  HD5770 w/ AMD 64 x2 CPU running Gentoo, not sure if that helps anyone else or what the changes between those kernels are, but figured I'd post for what it's worth.

But you only have one card. This problem should occur only when running more than one GPU in the same system. I'm surprised to hear that you were having this problem. CPU usage was always at 100%?

Yeah, CPU usage was always pegged at 100% on one core when GPU mining with either pocblm or phoenix, didn't seem to matter to mining rate if I ran something else CPU-heavy that cut down on the amount it could use.  And now all of a sudden it uses less than 1%.  No idea if it's the same bug as people with multiple cards or not, just figured it might help someone else out.

Damn. OK, I am officially both frustrated and confused lol

I wish I could upgrade my kernel too (win 7) Smiley Ohwell, I guess there is always mining under Linux.

mclemme
Newbie
*
Offline Offline

Activity: 1



View Profile
May 10, 2011, 05:00:48 PM
 #35

AMD Athlon 64 X2 3800+ running on Ubuntu 10.04 amd64. I'm running the CPU miner only on one core, because I end up with 100% CPU usage on the other core if I run pocblm  Cry

I had the same issue, using an Intel Core 2 Duo E8400 and a Nvidia 8800GT GPU on ubuntu 10.04 64-bit.

I tried tossing a spare harddrive I had laying around in my PC and installed Ubuntu 10.10, the result when running poclbm = 0-3% CPU.

I can see that the Nvidia driver in my 10.04 is version 195.36.24 which is quite old, so I'm guessing that's the problem. Try 10.10 on a spare harddrive or an old usb key you have lying around to see if that solves your problem as well Smiley

If I deserve a donation, please use => 1Ca3LEuEEaGQakNSWgpzSKdxECYpzdt18N
allinvain
Legendary
*
Offline Offline

Activity: 2002



View Profile
May 11, 2011, 12:36:51 AM
 #36

Hmm...yeah I think I will be moving on to linux for my dedicated miners. I managed to reduce the cpu usage to 50% by setting the affinity for both poclbm processes but still why should the cpu consume 50% more electricity than is necessary.

That new bitcoin linux distro looks mighty spiffy! Tongue I'll probably be using that on a usb drive.

maxcorrads
Jr. Member
*
Offline Offline

Activity: 43


View Profile
May 11, 2011, 08:36:38 AM
 #37

Someone have found the way to fix the 100% CPU bug?

I have 2 5850, Windows 7, Amd64 3500+.
allinvain
Legendary
*
Offline Offline

Activity: 2002



View Profile
May 11, 2011, 09:27:12 AM
 #38

Someone have found the way to fix the 100% CPU bug?

I have 2 5850, Windows 7, Amd64 3500+.

Nope. The best you can do for now is set the affinity for each miner process to one core.

maxcorrads
Jr. Member
*
Offline Offline

Activity: 43


View Profile
May 11, 2011, 09:30:28 AM
 #39

Someone have found the way to fix the 100% CPU bug?

I have 2 5850, Windows 7, Amd64 3500+.

Nope. The best you can do for now is set the affinity for each miner process to one core.


The problem is that i've only one core Cheesy
allinvain
Legendary
*
Offline Offline

Activity: 2002



View Profile
May 11, 2011, 09:34:28 AM
 #40

lool...that indeed is a problem. The only other thing I can suggest is to give linux a try and see if it does the same thing under linux. Check this out:

https://www.bitcoin.org/smf/index.php?topic=7374.0

Pages: « 1 [2] 3 4 »  All
  Print  
 
Jump to:  

Sponsored by , a Bitcoin-accepting VPN.
Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2006-2009, Simple Machines Valid XHTML 1.0! Valid CSS!