Bitcoin Forum
October 20, 2017, 01:46:41 AM *
News: Latest stable version of Bitcoin Core: 0.15.0.1  [Torrent]. (New!)
 
   Home   Help Search Donate Login Register  
Pages: [1]
  Print  
Author Topic: CGMiner --Scrypt Crashing  (Read 7856 times)
QiVX
Member
**
Offline Offline

Activity: 81



View Profile
September 29, 2012, 05:24:25 AM
 #1

Hey guys,

I can't seem to run CGMiner with the --scrypt option.
I always run into the following error, followed by CGMiner disabling all GPUs and the crashing (dialog of the program is not responding comes up).

Anyone know why?
I have 3 5970s.

Advertised sites are not endorsed by the Bitcoin Forum. They may be unsafe, untrustworthy, or illegal in your jurisdiction. Advertise here.
1508464001
Hero Member
*
Offline Offline

Posts: 1508464001

View Profile Personal Message (Offline)

Ignore
1508464001
Reply with quote  #2

1508464001
Report to moderator
SAC
Sr. Member
****
Offline Offline

Activity: 322


View Profile
September 29, 2012, 04:00:16 PM
 #2

I got that when I had left over .bin files try deleting them, also you need only one of the --shaders or --thread-concurrency in there not both and the  --thread-concurrency option should be a multiple of your shaders on the card less than the 8192 I have found to be the max that works for me so try 7168 for it from your example command used above. Also just noticed 5970s in your post they have 1600 shaders per core so 8000 is a good number to go with there, my script I use to start it with in a machine with a 5830 as first card in it, 5970 is second/third card.

Code:

cat ltc.sh
export GPU_USE_SYNC_OBJECTS=1
export GPU_MAX_ALLOC_PERCENT=100
export DISPLAY=:0
~/cgminer-ltc --scrypt --worksize 256,256,256 --thread-concurrency 6720,8000,8000 --vectors 4,4,4 --gpu-threads 2 -I 18,18,18 -g 1 --auto-fan --auto-gpu  --temp-target 83

Memory speeds I have found to give me the max hashing rate for each model of card.

Code:

cat vset.sh
DISPLAY=:0 aticonfig --od-enable --adapter=all
DISPLAY=:0 aticonfig --od-setclocks=870,1170 --adapter=0
DISPLAY=:0 aticonfig --od-setclocks=750,1050 --adapter=1
DISPLAY=:0 aticonfig --od-setclocks=750,1050 --adapter=2
DISPLAY=:0 aticonfig --odgc --adapter=all
crazyates
Legendary
*
Offline Offline

Activity: 952



View Profile
September 29, 2012, 04:38:20 PM
 #3

With 3 5970s, whouldn't you use "--shaders 9600"?

Each 5870 has 1600 shaders. Each 5970 has 2 x 1600 = 3200. You have 3 x 3200 = 9600.

Tips? 1crazy8pMqgwJ7tX7ZPZmyPwFbc6xZKM9
Previous Trade History - Sale Thread
SAC
Sr. Member
****
Offline Offline

Activity: 322


View Profile
September 29, 2012, 04:44:31 PM
 #4

With 3 5970s, whouldn't you use "--shaders 9600"?

Each 5870 has 1600 shaders. Each 5970 has 2 x 1600 = 3200. You have 3 x 3200 = 9600.

No it is per core not total per card that is used by the program when making the .bin file used/loaded at runtime and I always use the --thread option as that seems to load the correct .bin every time the --shaders does not do so for me.
crazyates
Legendary
*
Offline Offline

Activity: 952



View Profile
September 29, 2012, 05:53:08 PM
 #5

With 3 5970s, whouldn't you use "--shaders 9600"?

Each 5870 has 1600 shaders. Each 5970 has 2 x 1600 = 3200. You have 3 x 3200 = 9600.
No it is per core not total per card that is used by the program when making the .bin file used/loaded at runtime and I always use the --thread option as that seems to load the correct .bin every time the --shaders does not do so for me.
Ah gotcha. I only played around with scrypt on a Single 7970, and then gave up. So I ask you this: Why is he using "--shader 1792" instead of "--shaders 1600" ?

Tips? 1crazy8pMqgwJ7tX7ZPZmyPwFbc6xZKM9
Previous Trade History - Sale Thread
vitruvio
Sr. Member
****
Offline Offline

Activity: 467



View Profile
September 29, 2012, 08:43:52 PM
 #6

cgminer documentation says you only need to set shaders and that's what I did, in my 6770 --shaders 800 and work great.

--shaders doesn't allow coma separated values, what if you have different cards? well that is not a problem here all your cards are 5970, so set only --shaders 3200, an play with -w and -g, in scrypt for me works better with -g 1, maybe 2 treaths need more ram and crash.

Regards

Pages: [1]
  Print  
 
Jump to:  

Sponsored by , a Bitcoin-accepting VPN.
Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2006-2009, Simple Machines Valid XHTML 1.0! Valid CSS!