Bitcoin Forum
December 11, 2016, 12:34:09 AM *
News: To be able to use the next phase of the beta forum software, please ensure that your email address is correct/functional.
 
   Home   Help Search Donate Login Register  
Pages: « 1 2 [3] 4 »  All
  Print  
Author Topic: [Paid] [Bounty: 10 BTC] Bitcoind build instructions for Centos x86 and x64  (Read 14086 times)
weex
Legendary
*
Offline Offline

Activity: 1062


Give me your tired, your poor, your huddled...


View Profile
August 03, 2012, 06:08:23 AM
 #41

64-bit or 32-bit?

1481416449
Hero Member
*
Offline Offline

Posts: 1481416449

View Profile Personal Message (Offline)

Ignore
1481416449
Reply with quote  #2

1481416449
Report to moderator
Advertised sites are not endorsed by the Bitcoin Forum. They may be unsafe, untrustworthy, or illegal in your jurisdiction. Advertise here.
1481416449
Hero Member
*
Offline Offline

Posts: 1481416449

View Profile Personal Message (Offline)

Ignore
1481416449
Reply with quote  #2

1481416449
Report to moderator
1481416449
Hero Member
*
Offline Offline

Posts: 1481416449

View Profile Personal Message (Offline)

Ignore
1481416449
Reply with quote  #2

1481416449
Report to moderator
1481416449
Hero Member
*
Offline Offline

Posts: 1481416449

View Profile Personal Message (Offline)

Ignore
1481416449
Reply with quote  #2

1481416449
Report to moderator
bytedisorder
Hero Member
*****
Offline Offline

Activity: 489



View Profile WWW
August 03, 2012, 06:45:45 AM
 #42

64 bit CentOS 6
weex
Legendary
*
Offline Offline

Activity: 1062


Give me your tired, your poor, your huddled...


View Profile
August 03, 2012, 07:02:18 AM
 #43

This is the latest build I have 0.6. It will show a warning that it needs to update but if it helps you here it is.

http://owneo.com/bitcoind-60003-64bit-centos5

The build process hasn't worked for me since that version.

13DQrtowGDnZUie2j9WvsKuocR8cE2XJF1

bytedisorder
Hero Member
*****
Offline Offline

Activity: 489



View Profile WWW
August 03, 2012, 07:13:01 AM
 #44

That does not run unfortunately it still throws a segmentation fault and dumps the core Sad maybe I'm missing some dependency. I think its time to move me server over to ubuntu.

Code:
user@localhost:./bitcoind
Segmentation fault (core dumped)
weex
Legendary
*
Offline Offline

Activity: 1062


Give me your tired, your poor, your huddled...


View Profile
August 03, 2012, 07:31:11 AM
 #45

Yeah, ubuntu or debian are both much easier to support. Still, it's really hard to ignore the vast number of Redhat/Centos boxes out there that need to be supported.

I'll host another bounty with a repeat of this thread if someone would like to fund it initially.

Eisenhower34
Legendary
*
Offline Offline

Activity: 898



View Profile
August 04, 2012, 11:44:02 AM
 #46

This is the latest build I have 0.6. It will show a warning that it needs to update but if it helps you here it is.

http://owneo.com/bitcoind-60003-64bit-centos5

The build process hasn't worked for me since that version.

13DQrtowGDnZUie2j9WvsKuocR8cE2XJF1


I tried your version, it works so far without error but its not loading the chain ... :/
maaku
Legendary
*
expert
Offline Offline

Activity: 905


View Profile
August 05, 2012, 07:05:00 AM
 #47

Install VirtualBox. Then:

Quote
sudo yum install rubygems
sudo gem install vagrant
git clone git://github.com/bitcoin/bitcoin
cd bitcoin
git checkout v0.6.3
curl -L https://github.com/bitcoin/bitcoin/pull/1597.patch | patch -p1
cd contrib/vagrant
make check-requirements

Download and install any requirements it complains about:

Quote
sudo yum install ...

Build:

Quote
make download
time make all

It'll take a while the first time, after than builds will be considerably faster. You'll find the zipped binaries in the 'output' directory.


can I has bounty too?

17SRxATG3LZrD7WWTCr5EfCapprShVEtP

I'm an independent developer working on bitcoin-core, making my living off community donations.
If you like my work, please consider donating yourself: 13snZ4ZyCzaL7358SmgvHGC9AxskqumNxP
Eisenhower34
Legendary
*
Offline Offline

Activity: 898



View Profile
August 05, 2012, 02:03:10 PM
 #48

Would love to test it but i get this:
Code:
sudo gem install vagrant
*** buffer overflow detected ***: /usr/bin/ruby terminated
maaku
Legendary
*
expert
Offline Offline

Activity: 905


View Profile
August 05, 2012, 05:43:51 PM
 #49

Wicked. Can you post the results of:

Quote
# gem install -V vagrant

I'm an independent developer working on bitcoin-core, making my living off community donations.
If you like my work, please consider donating yourself: 13snZ4ZyCzaL7358SmgvHGC9AxskqumNxP
Eisenhower34
Legendary
*
Offline Offline

Activity: 898



View Profile
August 05, 2012, 06:01:22 PM
 #50

Code:
gem install -V vagrant
GET 302 Found: http://gems.rubyforge.org/latest_specs.4.8.gz
GET 304 Not Modified: http://production.s3.rubygems.org/latest_specs.4.8.gz
GET 302 Found: http://gems.rubyforge.org/specs.4.8.gz
GET 304 Not Modified: http://production.s3.rubygems.org/specs.4.8.gz
Installing gem childprocess-0.3.4
*** buffer overflow detected ***: /usr/bin/ruby terminated
======= Backtrace: =========
/lib64/libc.so.6(__chk_fail+0x2f)[0x3dff2e807f]
/usr/lib64/ruby/1.8/x86_64-linux/syck.so(rb_syck_mktime+0x48e)[0x2b583925098e]
/usr/lib64/ruby/1.8/x86_64-linux/syck.so(yaml_org_handler+0x860)[0x2b58392512a0]
/usr/lib64/ruby/1.8/x86_64-linux/syck.so(syck_defaultresolver_node_import+0x39)[0x2b58392514a9]
/usr/lib64/libruby.so.1.8[0x2b5838a60a9e]
/usr/lib64/libruby.so.1.8[0x2b5838a60fb8]
/usr/lib64/libruby.so.1.8[0x2b5838a61562]
/usr/lib64/libruby.so.1.8(rb_funcall+0x85)[0x2b5838a61835]
/usr/lib64/ruby/1.8/x86_64-linux/syck.so(rb_syck_load_handler+0x47)[0x2b5839250437]
/usr/lib64/ruby/1.8/x86_64-linux/syck.so(syck_hdlr_add_node+0x39)[0x2b583924b839]
/usr/lib64/ruby/1.8/x86_64-linux/syck.so(syckparse+0xb45)[0x2b583924c605]
/usr/lib64/ruby/1.8/x86_64-linux/syck.so(syck_parse+0x19)[0x2b5839254d29]
/usr/lib64/ruby/1.8/x86_64-linux/syck.so(syck_parser_load+0xed)[0x2b58392502ad]
/usr/lib64/libruby.so.1.8[0x2b5838a60a9e]
/usr/lib64/libruby.so.1.8[0x2b5838a60fb8]
/usr/lib64/libruby.so.1.8[0x2b5838a67d36]
/usr/lib64/libruby.so.1.8[0x2b5838a67125]
/usr/lib64/libruby.so.1.8[0x2b5838a60aba]
/usr/lib64/libruby.so.1.8[0x2b5838a60fb8]
/usr/lib64/libruby.so.1.8[0x2b5838a67d36]
/usr/lib64/libruby.so.1.8[0x2b5838a67125]
/usr/lib64/libruby.so.1.8[0x2b5838a60aba]
/usr/lib64/libruby.so.1.8[0x2b5838a60fb8]
/usr/lib64/libruby.so.1.8[0x2b5838a67d36]
/usr/lib64/libruby.so.1.8[0x2b5838a69804]
/usr/lib64/libruby.so.1.8[0x2b5838a60aba]
/usr/lib64/libruby.so.1.8[0x2b5838a60fb8]
/usr/lib64/libruby.so.1.8[0x2b5838a67e69]
/usr/lib64/libruby.so.1.8[0x2b5838a67009]
/usr/lib64/libruby.so.1.8[0x2b5838a69cb5]
/usr/lib64/libruby.so.1.8[0x2b5838a6bcbf]
/usr/lib64/libruby.so.1.8[0x2b5838a68307]
/usr/lib64/libruby.so.1.8[0x2b5838a6bcbf]
/usr/lib64/libruby.so.1.8[0x2b5838a6d1c9]
/usr/lib64/libruby.so.1.8[0x2b5838a60a9e]
/usr/lib64/libruby.so.1.8[0x2b5838a60fb8]
/usr/lib64/libruby.so.1.8[0x2b5838a67e69]
/usr/lib64/libruby.so.1.8[0x2b5838a6a10d]
/usr/lib64/libruby.so.1.8[0x2b5838a60aba]
/usr/lib64/libruby.so.1.8[0x2b5838a60fb8]
/usr/lib64/libruby.so.1.8[0x2b5838a67d36]
/usr/lib64/libruby.so.1.8[0x2b5838a6a10d]
/usr/lib64/libruby.so.1.8[0x2b5838a60aba]
/usr/lib64/libruby.so.1.8[0x2b5838a60fb8]
/usr/lib64/libruby.so.1.8(rb_obj_call_init+0x54)[0x2b5838a61274]
/usr/lib64/libruby.so.1.8(rb_class_new_instance+0x32)[0x2b5838a8b782]
/usr/lib64/libruby.so.1.8[0x2b5838a60a9e]
/usr/lib64/libruby.so.1.8[0x2b5838a60fb8]
/usr/lib64/libruby.so.1.8(rb_call_super+0x8d)[0x2b5838a6201d]
/usr/lib64/libruby.so.1.8[0x2b5838a60329]
/usr/lib64/libruby.so.1.8[0x2b5838a60fb8]
/usr/lib64/libruby.so.1.8[0x2b5838a67e69]
/usr/lib64/libruby.so.1.8[0x2b5838a67125]
/usr/lib64/libruby.so.1.8[0x2b5838a69cb5]
/usr/lib64/libruby.so.1.8[0x2b5838a60aba]
/usr/lib64/libruby.so.1.8[0x2b5838a60fb8]
/usr/lib64/libruby.so.1.8[0x2b5838a67d36]
/usr/lib64/libruby.so.1.8[0x2b5838a6a96f]
/usr/lib64/libruby.so.1.8[0x2b5838a680e5]
/usr/lib64/libruby.so.1.8[0x2b5838a60aba]
/usr/lib64/libruby.so.1.8[0x2b5838a60fb8]
/usr/lib64/libruby.so.1.8[0x2b5838a67d36]
/usr/lib64/libruby.so.1.8[0x2b5838a6a10d]
======= Memory map: ========
00400000-00401000 r-xp 00000000 fd:00 33572585                           /usr/bin/ruby
00600000-00601000 rw-p 00000000 fd:00 33572585                           /usr/bin/ruby
1939a000-1e345000 rw-p 1939a000 00:00 0                                  [heap]
4180d000-4180e000 ---p 4180d000 00:00 0
4180e000-4220e000 rw-p 4180e000 00:00 0
3dfee00000-3dfee1c000 r-xp 00000000 fd:00 12582937                       /lib64/ld-2.5.so
3dff01c000-3dff01d000 r--p 0001c000 fd:00 12582937                       /lib64/ld-2.5.so
3dff01d000-3dff01e000 rw-p 0001d000 fd:00 12582937                       /lib64/ld-2.5.so
3dff200000-3dff34e000 r-xp 00000000 fd:00 12582988                       /lib64/libc-2.5.so
3dff34e000-3dff54e000 ---p 0014e000 fd:00 12582988                       /lib64/libc-2.5.so
3dff54e000-3dff552000 r--p 0014e000 fd:00 12582988                       /lib64/libc-2.5.so
3dff552000-3dff553000 rw-p 00152000 fd:00 12582988                       /lib64/libc-2.5.so
3dff553000-3dff558000 rw-p 3dff553000 00:00 0
3dff600000-3dff602000 r-xp 00000000 fd:00 12582990                       /lib64/libdl-2.5.so
3dff602000-3dff802000 ---p 00002000 fd:00 12582990                       /lib64/libdl-2.5.so
3dff802000-3dff803000 r--p 00002000 fd:00 12582990                       /lib64/libdl-2.5.so
3dff803000-3dff804000 rw-p 00003000 fd:00 12582990                       /lib64/libdl-2.5.so
3dffa00000-3dffa82000 r-xp 00000000 fd:00 12583084                       /lib64/libm-2.5.so
3dffa82000-3dffc81000 ---p 00082000 fd:00 12583084                       /lib64/libm-2.5.so
3dffc81000-3dffc82000 r--p 00081000 fd:00 12583084                       /lib64/libm-2.5.so
3dffc82000-3dffc83000 rw-p 00082000 fd:00 12583084                       /lib64/libm-2.5.so
3dffe00000-3dffe16000 r-xp 00000000 fd:00 12583266                       /lib64/libpthread-2.5.so
3dffe16000-3e00015000 ---p 00016000 fd:00 12583266                       /lib64/libpthread-2.5.so
3e00015000-3e00016000 r--p 00015000 fd:00 12583266                       /lib64/libpthread-2.5.so
3e00016000-3e00017000 rw-p 00016000 fd:00 12583266                       /lib64/libpthread-2.5.so
3e00017000-3e0001b000 rw-p 3e00017000 00:00 0
3e00200000-3e00214000 r-xp 00000000 fd:00 12583267                       /lib64/libz.so.1.2.3
3e00214000-3e00413000 ---p 00014000 fd:00 12583267                       /lib64/libz.so.1.2.3
3e00413000-3e00414000 rw-p 00013000 fd:00 12583267                       /lib64/libz.so.1.2.3
3e00600000-3e0063b000 r-xp 00000000 fd:00 12583269                       /lib64/libsepol.so.1
3e0063b000-3e0083b000 ---p 0003b000 fd:00 12583269                       /lib64/libsepol.so.1
3e0083b000-3e0083c000 rw-p 0003b000 fd:00 12583269                       /lib64/libsepol.so.1
3e0083c000-3e00846000 rw-p 3e0083c000 00:00 0
3e00a00000-3e00a15000 r-xp 00000000 fd:00 12583270                       /lib64/libselinux.so.1
3e00a15000-3e00c15000 ---p 00015000 fd:00 12583270                       /lib64/libselinux.so.1
3e00c15000-3e00c17000 rw-p 00015000 fd:00 12583270                       /lib64/libselinux.so.1
3e00c17000-3e00c18000 rw-p 3e00c17000 00:00 0
3e01600000-3e01609000 r-xp 00000000 fd:00 12583238                       /lib64/libcrypt-2.5.so
3e01609000-3e01808000 ---p 00009000 fd:00 12583238                       /lib64/libcrypt-2.5.so
3e01808000-3e01809000 r--p 00008000 fd:00 12583238                       /lib64/libcrypt-2.5.so
3e01809000-3e0180a000 rw-p 00009000 fd:00 12583238                       /lib64/libcrypt-2.5.so
3e0180a000-3e01838000 rw-p 3e0180a000 00:00 0
3e01e00000-3e01f2d000 r-xp 00000000 fd:00 12583278                       /lib64/libcrypto.so.0.9.8e
3e01f2d000-3e0212c000 ---p 0012d000 fd:00 12583278                       /lib64/libcrypto.so.0.9.8e
3e0212c000-3e0214d000 rw-p 0012c000 fd:00 12583278                       /lib64/libcrypto.so.0.9.8e
3e0214d000-3e02151000 rw-p 3e0214d000 00:00 0
3e02200000-3e0222c000 r-xp 00000000 fd:00 33570745                       /usr/lib64/libgssapi_krb5.so.2.2
3e0222c000-3e0242c000 ---p 0002c000 fd:00 33570745                       /usr/lib64/libgssapi_krb5.so.2.2
3e0242c000-3e0242e000 rw-p 0002c000 fd:00 33570745                       /usr/lib64/libgssapi_krb5.so.2.2
3e03a00000-3e03a02000 r-xp 00000000 fd:00 12582982                       /lib64/libkeyutils-1.2.so
3e03a02000-3e03c01000 ---p 00002000 fd:00 12582982                       /lib64/libkeyutils-1.2.so
3e03c01000-3e03c02000 rw-p 00001000 fd:00 12582982                       /lib64/libkeyutils-1.2.so
3e03e00000-3e03e11000 r-xp 00000000 fd:00 12583236                       /lib64/libresolv-2.5.so
3e03e11000-3e04011000 ---p 00011000 fd:00 12583236                       /lib64/libresolv-2.5.so
3e04011000-3e04012000 r--p 00011000 fd:00 12583236                       /lib64/libresolv-2.5.so
3e04012000-3e04013000 rw-p 00012000 fd:00 12583236                       /lib64/libresolv-2.5.so
3e04013000-3e04015000 rw-p 3e04013000 00:00 0
3e04200000-3e04202000 r-xp 00000000 fd:00 12583277                       /lib64/libcom_err.so.2.1
3e04202000-3e04401000 ---p 00002000 fd:00 12583277                       /lib64/libcom_err.so.2.1
3e04401000-3e04402000 rw-p 00001000 fd:00 12583277                       /lib64/libcom_err.so.2.1
3e04e00000-3e04e92000 r-xp 00000000 fd:00 33570744                       /usr/lib64/libkrb5.so.3.3
3e04e92000-3e05091000 ---p 00092000 fd:00 33570744                       /usr/lib64/libkrb5.so.3.3
3e05091000-3e05095000 rw-p 00091000 fd:00 33570744                       /usr/lib64/libkrb5.so.3.3
3e05200000-3e05224000 r-xp 00000000 fd:00 33570743                       /usr/lib64/libk5crypto.so.3.1
3e05224000-3e05423000 ---p 00024000 fd:00 33570743                       /usr/lib64/libk5crypto.so.3.1
3e05423000-3e05425000 rw-p 00023000 fd:00 33570743                       /usr/lib64/libk5crypto.so.3.1
3e05600000-3e05608000 r-xp 00000000 fd:00 33570742                       /usr/lib64/libkrb5support.so.0.1
3e05608000-3e05807000 ---p 00008000 fd:00 33570742                       /usr/lib64/libkrb5support.so.0.1
3e05807000-3e05808000 rw-p 00007000 fd:00 33570742                       /usr/lib64/libkrb5support.so.0.1
3e06600000-3e06646000 r-xp 00000000 fd:00 12583279                       /lib64/libssl.so.0.9.8e
3e06646000-3e06846000 ---p 00046000 fd:00 12583279                       /lib64/libssl.so.0.9.8e
3e06846000-3e0684c000 rw-p 00046000 fd:00 12583279                       /lib64/libssl.so.0.9.8e
2aaaaaadb000-2aaaaaade000 rw-p 2aaaaaadb000 00:00 0
2aaaaac21000-2aaaab0cb000 rw-p 2aaaaac21000 00:00 0
2aaaab0cb000-2aaaab0fe000 rw-p 2aaaaaaab000 00:00 0
2aaaab0fe000-2aaaabdf9000 rw-p 2aaaab0fe000 00:00 0
2aaaabe07000-2aaaabe14000 r-xp 00000000 fd:00 12582914                   /lib64/libgcc_s-4.1.2-20080825.so.1
2aaaabe14000-2aaaac014000 ---p 0000d000 fd:00 12582914                   /lib64/libgcc_s-4.1.2-20080825.so.1
2aaaac014000-2aaaac015000 rw-p 0000d000 fd:00 12582914                   /lib64/libgcc_s-4.1.2-20080825.so.1
2b5838a1c000-2b5838a1e000 rw-p 2b5838a1c000 00:00 0
2b5838a2c000-2b5838b05000 r-xp 00000000 fd:00 33572583                   /usr/lib64/libruby.so.1.8.5
2b5838b05000-2b5838d04000 ---p 000d9000 fd:00 33572583                   /usr/lib64/libruby.so.1.8.5
2b5838d04000-2b5838d09000 rw-p 000d8000 fd:00 33572583                   /usr/lib64/libruby.so.1.8.5
2b5838d09000-2b5838e3c000 rw-p 2b5838d09000 00:00 0
2b5838e3c000-2b5838e3e000 r-xp 00000000 fd:00 33988620                   /usr/lib64/ruby/1.8/x86_64-linux/etc.so
2b5838e3e000-2b583903e000 ---p 00002000 fd:00 33988620                   /usr/lib64/ruby/1.8/x86_64-linux/etc.so
2b583903e000-2b583903f000 rw-p 00002000 fd:00 33988620                   /usr/lib64/ruby/1.8/x86_64-linux/etc.so
2b583903f000-2b5839043000 r-xp 00000000 fd:00 33988633                   /usr/lib64/ruby/1.8/x86_64-linux/stringio.so
2b5839043000-2b5839243000 ---p 00004000 fd:00 33988633                   /usr/lib64/ruby/1.8/x86_64-linux/stringio.so
2b5839243000-2b5839244000 rw-p 00004000 fd:00 33988633                   /usr/lib64/ruby/1.8/x86_64-linux/stringio.so
2b5839244000-2b5839260000 r-xp 00000000 fd:00 33988635                   /usr/lib64/ruby/1.8/x86_64-linux/syck.so
2b5839260000-2b583945f000 ---p 0001c000 fd:00 33988635                   /usr/lib64/ruby/1.8/x86_64-linux/syck.so
2b583945f000-2b5839461000 rw-p 0001b000 fd:00 33988635                   /usr/lib64/ruby/1.8/x86_64-linux/syck.so
2b5839462000-2b583959f000 rw-p 2b5839462000 00:00 0
2b58395ad000-2b58395b7000 r-xp 00000000 fd:00 12582938                   /lib64/libnss_files-2.5.so
2b58395b7000-2b58397b6000 ---p 0000a000 fd:00 12582938                   /lib64/libnss_files-2.5.so
2b58397b6000-2b58397b7000 r--p 00009000 fd:00 12582938                   /lib64/libnss_files-2.5.so
2b58397b7000-2b58397b8000 rw-p 0000a000 fd:00 12582938                   /lib64/libnss_files-2.5.so
2b58397b8000-2b58397f2000 r-xp 00000000 fd:00 33988626                   /usr/lib64/ruby/1.8/x86_64-linux/openssl.so
2b58397f2000-2b58399f1000 ---p 0003a000 fd:00 33988626                   /usr/lib64/ruby/1.8/x86_64-linux/openssl.so
2b58399f1000-2b58399f4000 rw-p 00039000 fd:00 33988626                   /usr/lib64/ruby/1.8/x86_64-linux/openssl.so
2b58399f5000-2b5839c2f000 rw-p 2b58399f5000 00:00 0
2b5839c2f000-2b5839c30000 r-xp 00000000 fd:00 33988621                   /usr/lib64/ruby/1.8/x86_64-linux/fcntl.so
2b5839c30000-2b5839e2f000 ---p 00001000 fd:00 33988621                   /usr/lib64/ruby/1.8/x86_64-linux/fcntl.so
2b5839e2f000-2b5839e30000 rw-p 00000000 fd:00 33988621                   /usr/lib64/ruby/1.8/x86_64-linux/fcntl.so
2b5839e30000-2b5839e39000 r-xp 00000000 fd:00 33988637                   /usr/lib64/ruby/1.8/x86_64-linux/zlib.so
2b5839e39000-2b583a038000 ---p 00009000 fd:00 33988637                   /usr/lib64/ruby/1.8/x86_64-linux/zlib.so
2b583a038000-2b583a039000 rw-p 00008000 fd:00 33988637                   /usr/lib64/ruby/1.8/x86_64-linux/zlib.so
2b583a039000-2b583a03b000 r-xp 00000000 fd:00 33988614                   /usr/lib64/ruby/1.8/x86_64-linux/digest/md5.so
2b583a03b000-2b583a23a000 ---p 00002000 fd:00 33988614              Aborted
maaku
Legendary
*
expert
Offline Offline

Activity: 905


View Profile
August 05, 2012, 06:03:48 PM
 #51

Wonderful. Looks like a ruby bug.

But thankfully that shouldn't concern you as there is an alternative: download the binary RPM from here:

http://downloads.vagrantup.com/tags/v1.0.3

and install:

Quote
rpm -i vagrant_1.0.3_x86_64.rpm

I'm an independent developer working on bitcoin-core, making my living off community donations.
If you like my work, please consider donating yourself: 13snZ4ZyCzaL7358SmgvHGC9AxskqumNxP
bytedisorder
Hero Member
*****
Offline Offline

Activity: 489



View Profile WWW
August 05, 2012, 09:05:14 PM
 #52

You guys ran this binary on centOS 6? Because I keep getting a segmentation fault...
Eisenhower34
Legendary
*
Offline Offline

Activity: 898



View Profile
August 05, 2012, 09:06:58 PM
 #53

vagrant is now installed but this only leads to the next problem... my openssl dont seem to know what sha256 is but under /usr/bin/sha256 I can find a sha256hmac and sha256sum...

Code:
make check-requirements
openssl:Error: 'sha256' is an invalid command.

Standard commands
asn1parse      ca             ciphers        crl            crl2pkcs7      
dgst           dh             dhparam        dsa            dsaparam      
enc            engine         errstr         gendh          gendsa        
genrsa         nseq           ocsp           passwd         pkcs12        
pkcs7          pkcs8          prime          rand           req            
rsa            rsautl         s_client       s_server       s_time        
sess_id        smime          speed          spkac          verify        
version        x509          

Message Digest commands (see the `dgst' command for more details)
md2            md4            md5            rmd160         sha            
sha1          

Cipher commands (see the `enc' command for more details)
aes-128-cbc    aes-128-ecb    aes-192-cbc    aes-192-ecb    aes-256-cbc    
aes-256-ecb    base64         bf             bf-cbc         bf-cfb        
bf-ecb         bf-ofb         cast           cast-cbc       cast5-cbc      
cast5-cfb      cast5-ecb      cast5-ofb      des            des-cbc        
des-cfb        des-ecb        des-ede        des-ede-cbc    des-ede-cfb    
des-ede-ofb    des-ede3       des-ede3-cbc   des-ede3-cfb   des-ede3-ofb  
des-ofb        des3           desx           rc2            rc2-40-cbc    
rc2-64-cbc     rc2-cbc        rc2-cfb        rc2-ecb        rc2-ofb        
rc4            rc4-40        

openssl:Error: 'sha256' is an invalid command.

Standard commands
asn1parse      ca             ciphers        crl            crl2pkcs7      
dgst           dh             dhparam        dsa            dsaparam      
enc            engine         errstr         gendh          gendsa        
genrsa         nseq           ocsp           passwd         pkcs12        
pkcs7          pkcs8          prime          rand           req            
rsa            rsautl         s_client       s_server       s_time        
sess_id        smime          speed          spkac          verify        
version        x509          

Message Digest commands (see the `dgst' command for more details)
md2            md4            md5            rmd160         sha            
sha1          

Cipher commands (see the `enc' command for more details)
aes-128-cbc    aes-128-ecb    aes-192-cbc    aes-192-ecb    aes-256-cbc    
aes-256-ecb    base64         bf             bf-cbc         bf-cfb        
bf-ecb         bf-ofb         cast           cast-cbc       cast5-cbc      
cast5-cfb      cast5-ecb      cast5-ofb      des            des-cbc        
des-cfb        des-ecb        des-ede        des-ede-cbc    des-ede-cfb    
des-ede-ofb    des-ede3       des-ede3-cbc   des-ede3-cfb   des-ede3-ofb  
des-ofb        des3           desx           rc2            rc2-40-cbc    
rc2-64-cbc     rc2-cbc        rc2-cfb        rc2-ecb        rc2-ofb        
rc4            rc4-40        

openssl:Error: 'sha256' is an invalid command.

Standard commands
asn1parse      ca             ciphers        crl            crl2pkcs7      
dgst           dh             dhparam        dsa            dsaparam      
enc            engine         errstr         gendh          gendsa        
genrsa         nseq           ocsp           passwd         pkcs12        
pkcs7          pkcs8          prime          rand           req            
rsa            rsautl         s_client       s_server       s_time        
sess_id        smime          speed          spkac          verify        
version        x509          

Message Digest commands (see the `dgst' command for more details)
md2            md4            md5            rmd160         sha            
sha1          

Cipher commands (see the `enc' command for more details)
aes-128-cbc    aes-128-ecb    aes-192-cbc    aes-192-ecb    aes-256-cbc    
aes-256-ecb    base64         bf             bf-cbc         bf-cfb        
bf-ecb         bf-ofb         cast           cast-cbc       cast5-cbc      
cast5-cfb      cast5-ecb      cast5-ofb      des            des-cbc        
des-cfb        des-ecb        des-ede        des-ede-cbc    des-ede-cfb    
des-ede-ofb    des-ede3       des-ede3-cbc   des-ede3-cfb   des-ede3-ofb  
des-ofb        des3           desx           rc2            rc2-40-cbc    
rc2-64-cbc     rc2-cbc        rc2-cfb        rc2-ecb        rc2-ofb        
rc4            rc4-40        

[check requirements]

Missing requirement: vagrant

Please have a look at "README" to ensure
that your system meets all requirements.

make: *** [.stamp-check-requirements.h] Error 1

@bytedisorder, you should be more specific which binary do you mean? I only test this on CentOS 5.6
maaku
Legendary
*
expert
Offline Offline

Activity: 905


View Profile
August 05, 2012, 09:49:52 PM
 #54

Interesting. That is the first time I have ever encountered an openssl without built-in sha256 support...

Anyway, you can open contrib/vagrant/Makefile and do a find-replace, changing 'openssl sha256' into 'sha256sum -b'. That *should* work. I'm not near my development machine or else I would update the pull-request and test it myself.

I'm an independent developer working on bitcoin-core, making my living off community donations.
If you like my work, please consider donating yourself: 13snZ4ZyCzaL7358SmgvHGC9AxskqumNxP
weex
Legendary
*
Offline Offline

Activity: 1062


Give me your tired, your poor, your huddled...


View Profile
August 05, 2012, 10:50:57 PM
 #55

FYI, this bounty has been paid so I created the new bounty here. It's up to 4 BTC!

Eisenhower34
Legendary
*
Offline Offline

Activity: 898



View Profile
August 06, 2012, 12:08:30 AM
 #56

Interesting. That is the first time I have ever encountered an openssl without built-in sha256 support...

Anyway, you can open contrib/vagrant/Makefile and do a find-replace, changing 'openssl sha256' into 'sha256sum -b'. That *should* work. I'm not near my development machine or else I would update the pull-request and test it myself.

now this error pops out ...

Code:
make check-requirements
[check requirements]

Missing requirement: vagrant

Please have a look at "README" to ensure
that your system meets all requirements.

make: *** [.stamp-check-requirements.h] Error 1

but rpm says its installed ...

Code:
rpm -ivh vagrant_1.0.3_x86_64.rpm
Preparing...                ########################################### [100%]
        package vagrant-1.0.3-1.x86_64 is already installed

fixed it myself, added /opt/vagrant/bin to the PATH variable

now it says

Code:
make check-requirements
[check requirements]
/opt/vagrant/bin/../embedded/bin/ruby: /lib64/libc.so.6: version `GLIBC_2.6' not found (required by /opt/vagrant/embedded/bin/../lib/libruby.so.1.9)

Wrong version of requirement: vagrant

It looks like I only have GLIBC_2.5 ... and yum wont update it, as its "up to date"....
bytedisorder
Hero Member
*****
Offline Offline

Activity: 489



View Profile WWW
August 06, 2012, 12:21:06 AM
 #57

I was speaking in regards to the binary weex posted above. I looked in /var/log/messages and this is what I saw:

Code:
Aug  5 20:09:36 frost kernel: bitcoind[18680]: segfault at 0 ip 00000000007c0b90 sp 00007fff3a5e6688 error 6 in bitcoind[400000+590000]
Aug  5 20:09:36 frost abrt[18681]: Saved core dump of pid 18680 (/home/user/bitcoind) to /var/spool/abrt/ccpp-2012-08-05-20:09:36-18680 (172032 bytes)
Aug  5 20:09:36 frost abrtd: Directory 'ccpp-2012-08-05-20:09:36-18680' creation detected
Aug  5 20:09:36 frost abrtd: Executable '/home/user/bitcoind' doesn't belong to any package
Aug  5 20:09:36 frost abrtd: 'post-create' on '/var/spool/abrt/ccpp-2012-08-05-20:09:36-18680' exited with 1
Aug  5 20:09:36 frost abrtd: Corrupted or bad directory /var/spool/abrt/ccpp-2012-08-05-20:09:36-18680, deleting

Eisenhower34
Legendary
*
Offline Offline

Activity: 898



View Profile
August 08, 2012, 07:30:01 PM
 #58

This is the latest build I have 0.6. It will show a warning that it needs to update but if it helps you here it is.

http://owneo.com/bitcoind-60003-64bit-centos5

The build process hasn't worked for me since that version.

13DQrtowGDnZUie2j9WvsKuocR8cE2XJF1


I tried your version, it works so far without error but its not loading the chain ... :/

Could fix the problem with your version. CSF was blocking it Smiley

sending 4 BTC to you and another 4 BTC will go into the pool for a working build instruction of the "up to date" client.

Transaktion: 592a8aa608ba72900e1cd8838d69276b7920f8a4be1f6af43979ebd942a31a81
weex
Legendary
*
Offline Offline

Activity: 1062


Give me your tired, your poor, your huddled...


View Profile
August 08, 2012, 08:04:52 PM
 #59

This is the latest build I have 0.6. It will show a warning that it needs to update but if it helps you here it is.

http://owneo.com/bitcoind-60003-64bit-centos5

The build process hasn't worked for me since that version.

13DQrtowGDnZUie2j9WvsKuocR8cE2XJF1


I tried your version, it works so far without error but its not loading the chain ... :/

Could fix the problem with your version. CSF was blocking it Smiley

sending 4 BTC to you and another 4 BTC will go into the pool for a working build instruction of the "up to date" client.

Transaktion: 592a8aa608ba72900e1cd8838d69276b7920f8a4be1f6af43979ebd942a31a81

Thank you and I'm glad to hear it's working for you with that tweak. Updating the other thread now.

neonzeon
Newbie
*
Offline Offline

Activity: 23


View Profile
June 23, 2013, 06:31:42 PM
 #60

Weex & KJJ,

Please see my newbie dissertation https://bitcointalk.org/index.php?topic=239337

A good solution might be to define a procedure to generate an SRPM (source-RPM) package from the GIT source.
Pages: « 1 2 [3] 4 »  All
  Print  
 
Jump to:  

Sponsored by , a Bitcoin-accepting VPN.
Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2006-2009, Simple Machines Valid XHTML 1.0! Valid CSS!