Bitcoin Forum
October 17, 2019, 09:34:21 AM *
News: Latest Bitcoin Core release: 0.18.1 [Torrent]
 
   Home   Help Search Login Register More  
Pages: « 1 2 3 4 5 6 [7]  All
  Print  
Author Topic: HOW TO SET UP OVERCLOCKING AND FAN CONTROL ON UBUNTU 16.04 FOR NVIDIA CARDS  (Read 53097 times)
thevictimofuktyranny
Legendary
*
Offline Offline

Activity: 1092
Merit: 1004


View Profile
March 04, 2018, 08:28:51 PM
 #121

i reinstalled ubuntu 20 times and never could overclock nvidia cards.... in nvidia setings there is fan control but not core clock... tryed everything.. any new tutorial ?

Well, there is a new Ubuntu 16.04.04 LTS - not had time to test it as a mining platform. But, working perfectly on my test PC.

16.04.03 had a lot of bug and issues around CPUs and GPUs, so you may find the new version does work correctly.
WEEKLY BONUS Unlimited Faucet&Fastest Dice PLINKO DICE CRASH ROULETTE PLAY NOW
Advertised sites are not endorsed by the Bitcoin Forum. They may be unsafe, untrustworthy, or illegal in your jurisdiction. Advertise here.
1571304861
Hero Member
*
Offline Offline

Posts: 1571304861

View Profile Personal Message (Offline)

Ignore
1571304861
Reply with quote  #2

1571304861
Report to moderator
zloy_hulk
Newbie
*
Offline Offline

Activity: 40
Merit: 0


View Profile
April 12, 2018, 11:43:08 AM
 #122

Hello!
Please help me with one problem! I don't know how to enable OC on nvidia p106/p104 system with connected monitor to inegrated graphics.

I installed different nvidia drivers, but everytime had the same problem - adding options like coolbits doesn't work. When I restart x-server or reboot after changing xorg.conf - it resets to the default. If I make this file read-only - x-server crashes at the start.
I tried a lot of variants, but nothing is working.

Such commands like this do nothing for me
sudo nvidia-xconfig -a --allow-empty-initial-configuration --cool-bits=28 --use-display-device="DFP-0" --connected-monitor="DFP-0" --custom-edid="DFP-0:/etc/X11/dfp-edid.bin"

On other system with usual GTX 10xx cards all is working good.

My system is usual, it is for test only.

Asus H110M-k
Intel Celeron G3900
4GB DDR4
1x GPU P104-100 (on the 1st pci-e slot)

I have a connected monitor to internal graphics.

 
How can I unlock the overclocking on nvidia P104?
x001tk
Newbie
*
Offline Offline

Activity: 29
Merit: 0


View Profile
April 14, 2018, 03:08:04 AM
 #123

Hello!
Please help me with one problem! I don't know how to enable OC on nvidia p106/p104 system with connected monitor to inegrated graphics.

I installed different nvidia drivers, but everytime had the same problem - adding options like coolbits doesn't work. When I restart x-server or reboot after changing xorg.conf - it resets to the default. If I make this file read-only - x-server crashes at the start.
I tried a lot of variants, but nothing is working.

Such commands like this do nothing for me
sudo nvidia-xconfig -a --allow-empty-initial-configuration --cool-bits=28 --use-display-device="DFP-0" --connected-monitor="DFP-0" --custom-edid="DFP-0:/etc/X11/dfp-edid.bin"

On other system with usual GTX 10xx cards all is working good.

My system is usual, it is for test only.

Asus H110M-k
Intel Celeron G3900
4GB DDR4
1x GPU P104-100 (on the 1st pci-e slot)

I have a connected monitor to internal graphics.

 
How can I unlock the overclocking on nvidia P104?


https://miningclub.info/threads/majning-na-linux-mint-ubuntu-nvidia-amd-majnery-razgon-ehtakij-how-to-dlja-novichkov.19005/page-27#post-902545

Is that you Bro ?
If not, maybe it will be helpfull
ken-ray
Newbie
*
Offline Offline

Activity: 24
Merit: 0


View Profile
May 28, 2018, 05:32:07 PM
 #124

If using monitor attached to intel graphics of ssh try this command. This worked for me with Xubuntu 18.04 and nvidia 390 drivers.

sudo nvidia-xconfig -a --cool-bits=31 --allow-empty-initial-configuration
sudo systemctl restart lightdm.service
sudo DISPLAY=:0 XAUTHORITY=/var/run/lightdm/root/:0 nvidia-settings -a 'GPUFanControlState=1' -a 'GPUTargetFanSpeed=100'

This changes fan to 100% but over clock works the same way.


I found the answer here.

https://www.linuxquestions.org/questions/linux-general-1/how-to-run-nvidia-settings-remotely-4175599391/

Maxhodl
Newbie
*
Offline Offline

Activity: 6
Merit: 0


View Profile
June 26, 2018, 05:16:36 PM
 #125

Thanks to the OP, I configured my ubuntu 16.04 for overclocking and fan control, however few questions.


1. I had to connect one of the GPU to monitor in order to configure OC , however after everything done, can i go back and use Integrated Graphics? , that worked smooth for me , with Nvidia GPU to monitor , the mouse cursor lags to move (even when it is not mining)  and it is frustrating.   Has anyone come across such ? any solution

2. Is there any way to control fan curve instead of a fix % of fan speed ?

Thanks, again.
MinersRus
Member
**
Offline Offline

Activity: 188
Merit: 15


View Profile
November 21, 2018, 04:52:27 AM
Last edit: November 25, 2018, 06:05:24 AM by MinersRus
 #126

I am having great difficulty trying to overclock the memory of the GTX 750 in my rig.


After much research this is where I am at:

From a shellinabox terminal to the rig I do this command:

DISPLAY=:0 XAUTHORITY=/var/run/lightdm/root/:0 nvidia-settings -a [gpu:0]/GPUMemoryTransferRateOffset[0]=200

The result is this message: The attribute 'GPUMemoryTransferRateOffset' specified in assignment '[gpu:0]/GPUMemoryTransferRateOffset[0]=100' cannot be assigned (it is a read-only attribute).

Any ideas in how to solve this issue?

-------------------------------------------------------------------

EDIT SOLVED: the issue was I needed to use index 1 not 0 as in:

DISPLAY=:0 XAUTHORITY=/var/run/lightdm/root/:0 nvidia-settings -a [gpu:0]/GPUMemoryTransferRateOffset[1]=200

This Guide states to use 3 but if I use either 3 or 2 the command doesn't return anything but when I use 1 I get this:

Attribute 'GPUMemoryTransferRateOffset' (H110-1:0[gpu:0]) assigned value 200.

and with this command: nvidia-smi -i 0 -q -d CLOCK

I can see the memory speed has changed from 2505 to 2605 or by 100. Memory MHz is twice that so 2505 == 5010 MHz and 2605 is 5210 MHz or 200 MHz faster.

-------------------------------------------------------------------

Rig Spec's:

ASRock H110 Pro BTC+ Motherboard
Celeron G3930 CPU
4GB DDR4 Memory
180GB NVMe SSD
13x Nvidia GTX 750 GPUs

Running Ubuntu 16.04.5 LTS

Coolbits is set to 28 for all the GPU's

Nvidia Driver: Driver Version: 396.54
Rabinovitch
Legendary
*
Offline Offline

Activity: 1806
Merit: 1028



View Profile
March 06, 2019, 08:30:14 AM
Last edit: March 06, 2019, 09:02:30 AM by Rabinovitch
 #127

If using monitor attached to intel graphics of ssh try this command. This worked for me with Xubuntu 18.04 and nvidia 390 drivers.

sudo nvidia-xconfig -a --cool-bits=31 --allow-empty-initial-configuration
sudo systemctl restart lightdm.service
sudo DISPLAY=:0 XAUTHORITY=/var/run/lightdm/root/:0 nvidia-settings -a 'GPUFanControlState=1' -a 'GPUTargetFanSpeed=100'

This changes fan to 100% but over clock works the same way.


I found the answer here.

https://www.linuxquestions.org/questions/linux-general-1/how-to-run-nvidia-settings-remotely-4175599391/

Ok, but me and another guy are looking for an answer hot to set GPU fan speed to any custom value on Ubuntu 18.x Server, i.e. with no X, no GUI, no DE...

https://superuser.com/q/1398591/1004977

Could anyone please help us?

p.s. I found it, and it seems to be working solution for our case! https://bitcointalk.org/index.php?topic=2432849.msg24914477#msg24914477

From Siberia with love! Hosting by Rabinovitch!
Never do any business with Kirill Stepanenko (Volgograd, Russia)
Пpoфeccиoнaльнo зaнимaюcь paзвёpтывaниeм фepм (ASIC, GPU, BURST), oбopyдoвaниeм пoмeщeний для мaйнингa.
Pages: « 1 2 3 4 5 6 [7]  All
  Print  
 
Jump to:  

Sponsored by , a Bitcoin-accepting VPN.
Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2006-2009, Simple Machines Valid XHTML 1.0! Valid CSS!