Bitcoin Forum
November 13, 2018, 07:17:47 PM *
News: Latest Bitcoin Core release: 0.17.0 [Torrent].
 
   Home   Help Search Login Register More  
Pages: [1]
  Print  
Author Topic: Over 50% HW Errors  (Read 1832 times)
G1rr
Newbie
*
Offline Offline

Activity: 10
Merit: 0


View Profile
August 07, 2014, 02:23:40 PM
 #1

Hello everyone,

I never really payed attention to the HW errors on my miner. But while setting up my own Mining with Raspbian I noticed that I got over 70% HW Errors. Then I switched to Minera yesterday I noticed that I still got over 50% HW Errors even though I use
Code:
--icarus-options 115200:1:1 --icarus-timing 3.0=100 --rock-freq 290
on my cgminer, I tried bfgminer but I didn't even get near my max hash rate.

My Rig:
Raspberry Pi with Minera OS
2x RockMiner R-Box
4x ASICMiner Block Erupter USB
CGMiner v4.5.0

Output cgminer:
Code:
cgminer version 4.5.0 - Started: [2014-08-07 13:12:14]
----------------------------------------------------------------------------------------------------
 (5s):65.17G (1m):70.57G (5m):70.63G (15m):71.15G (avg):71.48Gh/s
 A:179138  R:3216  HW:3570  WU:998.7/m | ST: 8  SS: 0  NB: 14  LW: 194354  GF: 0  RF: 0
 Connected to stratum.bitcoin.cz diff 67 with stratum as user Fredling.Minera
 Block: c805266c...  Diff:18.7G  Started: [16:13:21]  Best share: 5.16M
----------------------------------------------------------------------------------------------------
 [U]SB management [P]ool management [S]ettings [D]isplay options [Q]uit
 0: AMU 0       :                         | 333.9M / 333.2Mh/s WU:  4.7/m A: 1037 R:   0 HW:   4
 1: AMU 1       :                         | 333.1M / 333.0Mh/s WU:  4.5/m A: 1238 R:   0 HW:   6
 2: AMU 2       :                         | 335.4M / 332.6Mh/s WU:  4.8/m A:  900 R:   0 HW:  11
 3: AMU 3       :                         | 334.6M / 333.2Mh/s WU:  4.6/m A:  804 R:   0 HW:  10
 4: LIN 0       : 290MHz  44C             | 32.87G / 35.03Gh/s WU:489.4/m A:84266 R:2680 HW:3183
 5: LIN 1       : 290MHz  42C             | 34.15G / 35.16Gh/s WU:491.2/m A:90893 R: 536 HW: 356
----------------------------------------------------------------------------------------------------

and here is a screenshot of the Minera Dashboard

http://devvsbugs.net/wp-content/uploads/2014/08/dashboard-1024x508.png

It runs fine but like you can see I got many HW Errors.

How cgminer is started:
Code:
/usr/bin/screen -dmS cgminer /var/www/minera/minera-bin/cgminer --icarus-options 115200:1:1 --icarus-timing 3.0=100 --rock-freq 290 -c /var/www/minera/conf/miner_conf.json

and my conf file:
Code:
{
    "api-listen": true,
    "api-allow": "W:127.0.0.1",
    "scan": "all",
    "log-file": "\/var\/log\/minera\/cgminer.log",
    "pools": [
        {
            "url": "stratum.bitcoin.cz:3333",
            "user": "",
            "pass": ""
        },
        {
            "url": "stratum+tcp:\/\/multi.ghash.io:3333",
            "user": "michelem.minera",
            "pass": "x"
        }
    ]
}

is there any way to fix this?
Advertised sites are not endorsed by the Bitcoin Forum. They may be unsafe, untrustworthy, or illegal in your jurisdiction. Advertise here.
1542136667
Hero Member
*
Offline Offline

Posts: 1542136667

View Profile Personal Message (Offline)

Ignore
1542136667
Reply with quote  #2

1542136667
Report to moderator
1542136667
Hero Member
*
Offline Offline

Posts: 1542136667

View Profile Personal Message (Offline)

Ignore
1542136667
Reply with quote  #2

1542136667
Report to moderator
1542136667
Hero Member
*
Offline Offline

Posts: 1542136667

View Profile Personal Message (Offline)

Ignore
1542136667
Reply with quote  #2

1542136667
Report to moderator
DumDumz
Full Member
***
Offline Offline

Activity: 126
Merit: 100

★☆★Bitin.io★☆★


View Profile
August 07, 2014, 02:28:59 PM
 #2

maybe your HW OverHeat .

G1rr
Newbie
*
Offline Offline

Activity: 10
Merit: 0


View Profile
August 07, 2014, 02:40:13 PM
 #3

maybe your HW OverHeat .

44°C max so far and I don't think this is all it needs to overheat?!
hotwired007
Hero Member
*****
Offline Offline

Activity: 537
Merit: 500


View Profile
August 07, 2014, 02:45:54 PM
 #4

Do you have a fan blowing on the block erupters? If not they will be incredibly hot...

This account was hacked & possibly sold during the period of August 1st and October 24th 2017.
Anything done or said in this period wasnt me.
Many thanks to Cyrus for his help restoring access to my account.
fire000
Member
**
Offline Offline

Activity: 98
Merit: 10


View Profile
August 07, 2014, 03:34:46 PM
 #5

just a quick look at this it the 2x RockMiner R-Box that are the problem not the asic erupters just off the sreenshots
G1rr
Newbie
*
Offline Offline

Activity: 10
Merit: 0


View Profile
August 07, 2014, 03:42:01 PM
 #6

hmm I hope it's only a display error because while monitoring the screen output on console
Code:
----------------------------------------------------------------------------------------------------
 [U]SB management [P]ool management [S]ettings [D]isplay options [Q]uit
 0: AMU 0       :                         | 334.0M / 330.0Mh/s WU:  4.4/m A:  489 R:   0 HW:   9
 1: AMU 1       :                         | 333.4M / 331.5Mh/s WU:  4.9/m A:  598 R:   0 HW:   5
 2: AMU 2       :                         | 200.6M / 330.7Mh/s WU:  4.3/m A:  301 R:   0 HW:   7
 3: AMU 3       :                         | 334.0M / 332.9Mh/s WU:  4.3/m A:   64 R:   0 HW:   0
 4: LIN 0       : 290MHz  44C             | 34.08G / 34.59Gh/s WU:483.2/m A:37865 R:1201 HW:1438
 5: LIN 1       : 290MHz  42C             | 33.28G / 35.13Gh/s WU:490.8/m A:37399 R: 454 HW: 170
----------------------------------------------------------------------------------------------------

the HW value seems pretty low in camparison to the Accepted value
fire000
Member
**
Offline Offline

Activity: 98
Merit: 10


View Profile
August 07, 2014, 03:44:37 PM
 #7

without knowing much about the RockMiner R-Box here I am guessing the "--rock-freq 290"   is some type of chip clock setting Huh?   If so maybe play with that setting and dropping it back....

Line of thinking the more ya OC the harder the unit works throwing more HW errors....    <<<<  just thinking of antminers I know with them the more ya OC them the higher the HW are
G1rr
Newbie
*
Offline Offline

Activity: 10
Merit: 0


View Profile
August 07, 2014, 04:09:41 PM
 #8

without knowing much about the RockMiner R-Box here I am guessing the "--rock-freq 290"   is some type of chip clock setting Huh?   If so maybe play with that setting and dropping it back....

Line of thinking the more ya OC the harder the unit works throwing more HW errors....    <<<<  just thinking of antminers I know with them the more ya OC them the higher the HW are

retried without --rock-freq 290 and got like half the hashrate and 47% HW errors
-ck
Moderator
Legendary
*
Offline Offline

Activity: 2702
Merit: 1145


Ruu \o/


View Profile WWW
August 11, 2014, 01:21:24 PM
 #9

Code:
--icarus-options 115200:1:1 --icarus-timing 3.0=100 --rock-freq 290


Please please please don't use icarus options, they're designed for an fpga that hasn't been used in 2 years. If you see any documentation anywhere recommending you use them on a modern device on the current official cgminer, the advice is outright wrong. Even the use of icarus timing is misguided. Just remove them.

Code:
4: LIN 0       : 290MHz  44C             | 32.87G / 35.03Gh/s WU:489.4/m A:84266 R:2680 HW:3183
 5: LIN 1       : 290MHz  42C             | 34.15G / 35.16Gh/s WU:491.2/m A:90893 R: 536 HW: 356
is there any way to fix this?
Your hardware error rate for LIN0 is 3183 / (84266 + 2680 + 3183) which is 3.5% and nothing to worry about, and much lower for LIN1. Your problem is your monitoring software is broken and reporting nonsense, not your devices or cgminer. You are overclocking them a bit though, but provided they're still producing good shares, even 5% HW errors are nothing to worry about.

Developer/maintainer for cgminer and ckpool/ckproxy.
ZERO FEE Pooled mining at ckpool.org, 1% Fee Solo mining at solo.ckpool.org
-ck
G1rr
Newbie
*
Offline Offline

Activity: 10
Merit: 0


View Profile
August 11, 2014, 07:24:51 PM
 #10

Code:
--icarus-options 115200:1:1 --icarus-timing 3.0=100 --rock-freq 290


Please please please don't use icarus options, they're designed for an fpga that hasn't been used in 2 years. If you see any documentation anywhere recommending you use them on a modern device on the current official cgminer, the advice is outright wrong. Even the use of icarus timing is misguided. Just remove them.

Code:
4: LIN 0       : 290MHz  44C             | 32.87G / 35.03Gh/s WU:489.4/m A:84266 R:2680 HW:3183
 5: LIN 1       : 290MHz  42C             | 34.15G / 35.16Gh/s WU:491.2/m A:90893 R: 536 HW: 356
is there any way to fix this?
Your hardware error rate for LIN0 is 3183 / (84266 + 2680 + 3183) which is 3.5% and nothing to worry about, and much lower for LIN1. Your problem is your monitoring software is broken and reporting nonsense, not your devices or cgminer. You are overclocking them a bit though, but provided they're still producing good shares, even 5% HW errors are nothing to worry about.

thank you, i notified the minera guys of this error ...
Pages: [1]
  Print  
 
Jump to:  

Sponsored by , a Bitcoin-accepting VPN.
Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2006-2009, Simple Machines Valid XHTML 1.0! Valid CSS!