Bitcoin Forum
December 05, 2016, 04:38:54 AM *
News: Latest stable version of Bitcoin Core: 0.13.1  [Torrent].
 
   Home   Help Search Donate Login Register  
Pages: [1]
  Print  
Author Topic: GPU's not mining with BAMT command, but do with CGMINER  (Read 3625 times)
btcnode
Jr. Member
*
Offline Offline

Activity: 39


View Profile
May 06, 2012, 03:53:30 PM
 #1

Okay, so my situation is a bit complex. I run

Code:
/etc/init.d/mine start

and I get:

Quote
..munin..GPU 0 is disabled..GPU 1..fan 1..OC 1..GPU 2..fan 2..OC 2..cgminer...

which looks good! But when I run

Code:
gpumon

I get a lot of
Quote
   Temp    Fan% (rpm)    Load  Rate     Accept/Invalid   Status
0: 58c     100% (5487-)  85%       Mhs  /                Low Mhs
1: 30.5c   50% (3330)     0%       Mhs  /                Low Temp Low Load Low Mhs
2: 30.5c   50% (3289+)    0%       Mhs  /                Low Temp Low Load Low Mhs

Total: 0 Mhash/s  0 accepted, 0 invalid

Time         Total    gpu0    gpu1    gpu2
11:49:03      0.00    0.00    0.00    0.00
11:49:05      0.00    0.00    0.00    0.00
11:49:07      0.00    0.00    0.00    0.00
11:49:09      0.00    0.00    0.00    0.00
11:49:12      0.00    0.00    0.00    0.00
11:49:14      0.00    0.00    0.00    0.00
11:49:16      0.00    0.00    0.00    0.00
11:49:18      0.00    0.00    0.00    0.00
11:49:20      0.00    0.00    0.00    0.00
11:49:23      0.00    0.00    0.00    0.00
11:49:25      0.00    0.00    0.00    0.00
11:49:27      0.00    0.00    0.00    0.00
11:49:29      0.00    0.00    0.00    0.00
11:49:31      0.00    0.00    0.00    0.00
11:49:34      0.00    0.00    0.00    0.00
11:49:36      0.00    0.00    0.00    0.00
11:49:38      0.00    0.00    0.00    0.00

So it looks like GPU's 2 and 3 (which are enabled) aren't doing anything. I've waited over 10 min watching this and waiting. So I dug around a bit and looked into the bamt.log file and here's the command that runs
Code:
May  6 11:45:50 kraken start_mining[9084]: starting cgminer with cmd: cd /opt/miners/cgminer;/usr/bin/screen -d -m -S cgminer /opt/miners/cgminer/cgminer --api-listen --api-port 4028 -o http://mymingpool.com:8332 -u myusername -p mypassword

so I figured, "hey, let me run the cgminer command myself and see what I get", so I run
Code:
/opt/miners/cgminer/cgminer --api-listen --api-port 4028 -o http://mymingpool.com:8332 -u myusername -p mypassword

and it runs and mines JUST fine, even using the first GPU (which I had disabled in my bamt.conf).

Quote
[P]ool management [G]PU management [Settings [D]isplay options [Q]uit
 GPU 0: 499.9/508.3Mh/s | A:2 R:0 HW:0 U:  4.75/m I: 5
 GPU 1: 211.3/210.4Mh/s | A:2 R:0 HW:0 U:  4.75/m I: 4
 GPU 2: 210.8/210.1Mh/s | A:2 R:0 HW:0 U:  4.75/m I: 4

So what's going on here? Why can't the bamt mine command get my GPU's to mine, but cgminer directly can.

Any help?
1480912734
Hero Member
*
Offline Offline

Posts: 1480912734

View Profile Personal Message (Offline)

Ignore
1480912734
Reply with quote  #2

1480912734
Report to moderator
Advertised sites are not endorsed by the Bitcoin Forum. They may be unsafe, untrustworthy, or illegal in your jurisdiction. Advertise here.
beta_tester
Newbie
*
Offline Offline

Activity: 6


View Profile
May 06, 2012, 05:25:09 PM
 #2

Post your bamt.conf - you say that you have GPU 0 disabled, but the gpumon output looks like GPU 0 is the only one enabled so my guess is a typo in the configuration file.
btcnode
Jr. Member
*
Offline Offline

Activity: 39


View Profile
May 06, 2012, 07:05:02 PM
 #3

Code:
settings:

  # miner_id is used to set hostname and identify this rig to munin and
  # other processes
  # IMPORTANT! miner_id must be a valid hostname: all lower case, no weird
  # characters, underscores, periods, or spaces. Dash and numbers are ok.

  miner_id: kraken

  # loc is any additional string you wish to use to identify or group this rig

  miner_loc: D.io Office

  # should we monitor the cards? 1 = yes, 0 = no

  do_monitor: 0



  cgminer: 1
  cgminer_opts: --api-listen -o http://mypoo.com:8332 -u myuser -p mypass

gpu0:

  # remove disabled: or set it to 0 to actually use this card..

  disabled: 0
  cgminer: 1

 
  # overclocking.. all are optional 

  # optional command to execute prior to overclocking
  # any valid command (or the path to a script) is fine

  # pre_oc_cmd:


  # (core/mem)_X = the value to set for this profile (0-2)
  # Profile 2 is used while mining, but setting values
  # in profile 2 that are *lower* than the values in the other
  # profiles is not allowed on some GPUs, so you have to adjust
  # the other profiles as well.
  # For instance, to get 300Mhz mem clock on my 5830s, I have
  # to set all 3 profiles to 300.


  # core_speed_0: 300
  # core_speed_1: 800
  # core_speed_2: 980
 
  # mem_speed_0: 300
  # mem_speed_1: 300
  # mem_speed_2: 300

  # core_voltage_0: 1.125
  # core_voltage_1: 1.125
  # core_voltage_2: 1.125000

  # recommend to set and forget fan, preferably at 100
 
  fan_speed: 20

  # optional command to execute after overclocking
  # post_oc_cmd:


  # Phoenix mining setup (see full example for how to use cgminer instead)
  # We strongly recommend you use phoenix at, least until you are familiar
  # with BAMT

  # kernel to use.. one of:  phatk phatk2 poclbm
  # if in doubt, use phatk2

  kernel: phatk2

  # phoenix style kernel params.  *do not* include DEVICE=x, otherwise
  # exactly same as any phoenix setup. 
  # if in doubt: BFI_INT VECTORS AGGRESSION=11
  # (though 9 on GPU0 often makes using the GUI more pleasant)

  kernel_params: BFI_INT VECTORS FASTLOOP=false AGGRESSION=9


  # Pool file

  # IMPORTANT: pool_file must contain a list of pool URLs.. one at least, more if
  # you like.  You can share the same file for all GPUs, or have one for each.
  # Miner will start with first URL in file, however if no shares are accepted
  # for any reason in (pool_timeout) seconds, the miner will move to next URL
  # in the file.  Wraps around to first URL when last one fails.
  # You can also set pool specific values, see the example pools file.
  # if in doubt: /etc/bamt/pools

  pool_file: /etc/bamt/pools

  # max time to allow phoenix to run without finding a share..
  # exceed this and we kill phoenix, start a new instance with
  # next line in pools file

  pool_timeout: 180



  # monitoring limits, used by email alerts and gpumon
  # an alert is generated if the current value goes below a 'lo'
  # or above a 'hi'.

  # GPU temp sensor reading (in C)
  monitor_temp_lo: 45
  monitor_temp_hi: 80

  # GPU load (in %)
  monitor_load_lo: 80

  # average hashrate (in mh/s)
  monitor_hash_lo: 125

  # fam rpm (in rpm)
  monitor_fan_lo: 2000

  # effective reject rate (in % of total)
  monitor_reject_hi: 2



# OK.. hopefully you get the idea.  Stubs for additional GPUs below.
# There are many additional paramters to help you deal with various
# scenarios, see /opt/bamt/examples and the docs (if we write some)


gpu1:
  disabled: 1
  cgminer: 1

  # core_speed_0: 300
  # core_speed_1: 800
  # core_speed_2: 1060
  # mem_speed_0: 300
  # mem_speed_1: 300
  # mem_speed_2: 1120
  # core_voltage_0: 1.125
  # core_voltage_1: 1.125
  # core_voltage_2: 1.125000

  fan_speed: 20

  kernel: phatk2
  kernel_params: BFI_INT VECTORS FASTLOOP=false AGGRESSION=11

  pool_file: /etc/bamt/pools
  pool_timeout: 180

  monitor_temp_lo: 45
  monitor_temp_hi: 80
  monitor_load_lo: 80
  monitor_hash_lo: 125
  monitor_fan_lo: 2000
  monitor_reject_hi: 1

gpu2:
  disabled: 1
  cgminer: 1

  # core_speed_0: 300
  # core_speed_1: 800
  # core_speed_2: 1060
  # mem_speed_0: 300
  # mem_speed_1: 300
  # mem_speed_2: 1120
  # core_voltage_0: 1.125
  # core_voltage_1: 1.125
  # core_voltage_2: 1.125000

  fan_speed: 20

  kernel: phatk2
  kernel_params: BFI_INT VECTORS FASTLOOP=false AGGRESSION=11

  pool_file: /etc/bamt/pools
  pool_timeout: 180

  monitor_temp_lo: 45
  monitor_temp_hi: 80
  monitor_load_lo: 80
  monitor_hash_lo: 125
  monitor_fan_lo: 2000
  monitor_reject_hi: 1
beta_tester
Newbie
*
Offline Offline

Activity: 6


View Profile
May 06, 2012, 07:48:19 PM
 #4

gpu1:
  disabled: 1
...
gpu2:
  disabled: 1

Turn those 1s to 0s so that they aren't disabled - unless I'm missing something?
btcnode
Jr. Member
*
Offline Offline

Activity: 39


View Profile
May 06, 2012, 08:27:03 PM
 #5

I'm trying to get any card to work with the BAMT command. I just made the change you suggested and now the first card appears to be mining via gpumon, but not the others.

Code:
   Temp    Fan% (rpm)    Load  Rate     Accept/Invalid   Status
0: 75c+    20% (1035-)   85%   226 Mhs  2/0 (0.00%)      http://pit.deepbit.net:8332
1: 41.5c   20% (1077+)    0%       Mhs  /                Low Temp Low Load Low Mhs
2: 52c     20% (1169+)    0%       Mhs  /                Low Load Low Mhs

Total: 226.81 Mhash/s  2 accepted, 0 invalid (0.00%)

Time         Total    gpu0    gpu1    gpu2
20:26:25    224.16  224.16    0.00    0.00
20:26:27    225.38  225.38    0.00    0.00
20:26:29    225.38  225.38    0.00    0.00
20:26:31    225.38  225.38    0.00    0.00
20:26:34    226.13  226.13    0.00    0.00
20:26:36    226.13  226.13    0.00    0.00
20:26:38    226.53  226.53    0.00    0.00
20:26:40    226.53  226.53    0.00    0.00
20:26:42    226.81  226.81    0.00    0.00
20:26:44    226.81  226.81    0.00    0.00
fran2k
Hero Member
*****
Offline Offline

Activity: 700


View Profile WWW
January 14, 2014, 03:18:34 AM
 #6

Same problem here... mmmm
jbass350z
Newbie
*
Offline Offline

Activity: 24


View Profile
February 11, 2014, 07:43:59 PM
 #7

I have a similar problem. Everything was mining fine then something froze up and upon reboot I get:

0 gpus configured

multiple reboots yield nothing.


screen -r actually shows some activity?? but gpumon shows no gpus whatsoever.

All GPUs are enabled in bamt.conf

How can i fix this? I can reload BAMT, but this is the second time this has happened in two days.
Pages: [1]
  Print  
 
Jump to:  

Sponsored by , a Bitcoin-accepting VPN.
Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2006-2009, Simple Machines Valid XHTML 1.0! Valid CSS!