Bitcoin Forum
December 09, 2016, 08:13:32 AM *
News: To be able to use the next phase of the beta forum software, please ensure that your email address is correct/functional.
 
   Home   Help Search Donate Login Register  
Pages: [1]
  Print  
Author Topic: Setting up pushpool errors..Can donate BTC's if helped!  (Read 364 times)
djred
Newbie
*
Offline Offline

Activity: 8


View Profile
June 10, 2012, 04:49:42 PM
 #1

Hello,

I am setting up pushpool on my Ubuntu dedicated server.
I have bitcoind running and i believe the latest blockchains have been downloaded..

When Running "pushpool -E -F"
I get the following output:

Code:
[2012-06-10 16:41:8.792411] Listening on host :: port 8342
[2012-06-10 16:41:8.792561] Listening on host :: port 8341
[2012-06-10 16:41:8.792631] Listening on host :: port 8377
[2012-06-10 16:41:8.792689] Listening on host 127.0.0.1 port 8338
[2012-06-10 16:41:8.795037] initialized
[2012-06-10 16:41:34.106168] HTTP request failed: couldn't connect to host
[2012-06-10 16:41:34.259150] HTTP request failed: couldn't connect to host
[2012-06-10 16:41:36.411524] HTTP request failed: couldn't connect to host
[2012-06-10 16:41:38.570370] HTTP request failed: couldn't connect to host
[2012-06-10 16:41:40.722174] HTTP request failed: couldn't connect to host
[2012-06-10 16:41:43.373029] HTTP request failed: couldn't connect to host
[2012-06-10 16:41:45.525255] HTTP request failed: couldn't connect to host
[2012-06-10 16:41:47.683068] HTTP request failed: couldn't connect to host
[2012-06-10 16:41:49.834699] HTTP request failed: couldn't connect to host
[2012-06-10 16:41:51.988270] HTTP request failed: couldn't connect to host
[2012-06-10 16:41:54.142395] HTTP request failed: couldn't connect to host
[2012-06-10 16:41:56.340010] HTTP request failed: couldn't connect to host
[2012-06-10 16:41:58.497226] HTTP request failed: couldn't connect to host
[2012-06-10 16:42:0.649198] HTTP request failed: couldn't connect to host
[2012-06-10 16:42:2.806000] HTTP request failed: couldn't connect to host
[2012-06-10 16:42:4.960095] HTTP request failed: couldn't connect to host
[2012-06-10 16:42:7.113470] HTTP request failed: couldn't connect to host
[2012-06-10 16:42:9.271074] HTTP request failed: couldn't connect to host
[2012-06-10 16:42:11.427321] HTTP request failed: couldn't connect to host
The "HTTP request failed: couldn't connect to host" starts to show up whenever i attempt to connect to my host via my miner like so:
"miner.exe -o http://IP:8377 -u user -p pass"

I also have mining farm for the front end.
I have created a worker on mining farm and checked that it was in the database correctly..

Here is my server.json file with important information removed of course:
Code:
{
# network ports
"listen" : [
# binary protocol (default), port 8342
{ "port" : 8342 },

# HTTP JSON-RPC protocol, port 8341
{ "port" : 8341, "protocol" : "http-json" },

# HTTP JSON-RPC protocol, port 8344,
# with trusted proxy appserver.example.com forwarding
# requests to us
{ "port" : 8377, "protocol" : "http-json",
  "proxy" : "<my server IP>" },

# binary protocol, localhost-only port 8338
{ "host" : "127.0.0.1", "port" : 8338, "protocol" : "binary" }
],

# database settings
"database" : {
"engine" : "mysql",
"host" : "localhost",
"port" : 3306,
"name" : "DB-NAME",
"username" : "DB-USER",
"password" : "BD-PASS",
"sharelog" : true,
"stmt.pwdb":"SELECT `password` FROM `pool_worker` WHERE `username` = ?",
"stmt.sharelog":"INSERT INTO shares (rem_host, username, our_result, upstream_result, reason, solution, time) VALUES (?, ?, ?, ?, ?, ?, UNIX_TIMESTAMP())"

},

# cache settings
#"memcached" : {
# "servers" : [
# { "host" : "localhost", "port" : 11211 }
# ]
#},

"pid" : "/tmp/pushpoold.pid",

# overrides local hostname detection
"forcehost" : "localhost.localdomain",

"log.requests" : "/tmp/request.log",
"log.shares" : "/tmp/shares.log",

# the server assumes longpolling (w/ SIGUSR1 called for each blk)
"longpoll.disable" : false,

# length of time to cache username/password credentials, in seconds
"auth.cred_cache.expire" : 75,

# RPC settings | Notice how this ISN'T port number 8332 this is becuase the same port number should not becuase inconjunction with the JSON RPC port other wise you'll get 500 errors
"rpc.url" : "http://127.0.0.1:8338/",
"rpc.user" : "myuser",
"rpc.pass" : "mypass",

# rewrite returned 'target' to difficulty-1?
"rpc.target.rewrite" : true
}



My bitcoin is installed under usr/lib/bitcoin/bitcoind


If i am missing some more information that you need to help please let me know.

Also I am willing to donate a few BTC's to whoever can help me fix this issue.

Thanks.
Pages: [1]
  Print  
 
Jump to:  

Sponsored by , a Bitcoin-accepting VPN.
Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2006-2009, Simple Machines Valid XHTML 1.0! Valid CSS!