Bitcoin Forum
December 02, 2016, 06:10:08 PM *
News: Latest stable version of Bitcoin Core: 0.13.1  [Torrent].
 
   Home   Help Search Donate Login Register  
Pages: [1]
  Print  
Author Topic: Ubuntu 9.10 (Karmic Koala) install: libboost-dev / libboost-all-dev Catch-22  (Read 3052 times)
watchpocket
Newbie
*
Offline Offline

Activity: 4


View Profile
May 23, 2011, 07:54:09 AM
 #1

I tried an install according to this tutorial (which originally said it was for Karmic):

<http://lickthesalt.com/2010/08/19/compiling-bitcoin-on-ubuntu-10-04-karmic/comment-page-1/#comment-266>

Everything was going beautifully until the end, when I did not have a file named “bitcoin” in the ~/src/bitcoin-patchwork directory (which I should have, according to the tutorial), and when I got this:

/usr/bin/ld: cannot find -lboost_system
collect2: ld returned 1 exit status
make: *** [bitcoin] Error 1
make -f makefile.unix bitcoin 84.83s user 4.22s system 98% cpu 1:30.26 total


I’m running Ubuntu 9.10, 64-bit. I installed libboost-dev. After seeing the error message above, I tried to install libboost-all-dev, and got this:

E: Couldn’t find package libboost-all-dev

I then tried to install libboost-dev again, got this:

libboost-dev is already the newest version.”

So: my problem appears to be that

/usr/bin/ld: cannot find -lboost_system

and I frankly have no clue what to do about that.

I did see this post on the Bitcoin forum, but I don’t really know what it means for me, or what I might do about it.

Title: Re: 0.3 almost ready
Post by: satoshi on June 24, 2010, 05:40:05 pm
Here’s RC1 for linux for testing:
(link removed, see below)

It contains both 32-bit and 64-bit binaries.

Recent changes:

build-unix.txt:
- Added instructions for building wxBase, which is needed to compile bitcoind.
- The package libboost-dev doesn’t install anything anymore, you need to get libboost-all-dev.
- Updated version numbers.

makefile.unix:
- The libboost libraries have removed the “-mt” from their filenames in 1.40. If you’re compiling with Boost 1.38 or lower, like on Ubuntu Karmic, you would need to change it back to boost_system-mt and boost_filesystem-mt.



But exactly where & how would I add the “-mt”?

Also, I did see this at the end of a bunch of stuff thrown onto my screen after running the "make -f makefile.unix bitcoin" command:

“. . . -Bstatic -l boost_system -l boost_filesystem -l boost_program_options -l boost_thread -l db_cxx -l crypto -Wl,-Bdynamic -l gthread-2.0
/usr/bin/ld: cannot find -lboost_system
collect2: ld returned 1 exit status
make: *** [bitcoin] Error 1

[The latter part being a repeat of what I quoted above.]


I get the feeling I’m an inch away from successful installation, & hoping some clues are provided for anyone who can parse them & make a suggestion.  I have a bit more info on the tutorial page comments section, but the gist of it is here.   (No problems btw compiling wxWidgets.) 

Thanks for your indugence.

[bold]"No, Mr. Bond.  I expect you to die."[/bold]
1480702208
Hero Member
*
Offline Offline

Posts: 1480702208

View Profile Personal Message (Offline)

Ignore
1480702208
Reply with quote  #2

1480702208
Report to moderator
1480702208
Hero Member
*
Offline Offline

Posts: 1480702208

View Profile Personal Message (Offline)

Ignore
1480702208
Reply with quote  #2

1480702208
Report to moderator
1480702208
Hero Member
*
Offline Offline

Posts: 1480702208

View Profile Personal Message (Offline)

Ignore
1480702208
Reply with quote  #2

1480702208
Report to moderator
Advertised sites are not endorsed by the Bitcoin Forum. They may be unsafe, untrustworthy, or illegal in your jurisdiction. Advertise here.
1480702208
Hero Member
*
Offline Offline

Posts: 1480702208

View Profile Personal Message (Offline)

Ignore
1480702208
Reply with quote  #2

1480702208
Report to moderator
1480702208
Hero Member
*
Offline Offline

Posts: 1480702208

View Profile Personal Message (Offline)

Ignore
1480702208
Reply with quote  #2

1480702208
Report to moderator
interfect
Full Member
***
Offline Offline

Activity: 139


View Profile
May 23, 2011, 08:20:08 AM
 #2

You have a good reason to still be running Karmic, right?

From what I'm seeing, it looks like libboost_system.so isn't being found by the linker. It seems like that's the new name, and on Karmic the file is called libboost_system-mt.so. In Karmic it seems like it should still be installed by libboost-dev.

You need to go into makefile.unix and follow the changelog's instructions: find/replace "boost_system" with "boost_system-mt" and "boost_filesystem" with "boost_filesystem-mt". That should make it look for the libraries under their old names.

So where it says
# for boost 1.37, add -mt to the boost libraries
LIBS= \
 -Wl,-Bstatic \
   -l boost_system \
   -l boost_filesystem \
   -l boost_program_options \
   -l boost_thread \


it should say


# for boost 1.37, add -mt to the boost libraries
LIBS= \
 -Wl,-Bstatic \
   -l boost_system-mt \
   -l boost_filesystem-mt \
   -l boost_program_options \
   -l boost_thread \


de4l
Member
**
Offline Offline

Activity: 83


View Profile
May 23, 2011, 08:24:19 AM
 #3

I experienced something similar, I don't know if you've already tried it but open your system preferences, select update manager, select settings, select the first tab and you can enable universe there, then try the install process again and libboost should install correctly.
watchpocket
Newbie
*
Offline Offline

Activity: 4


View Profile
May 24, 2011, 05:56:06 AM
 #4

Up and running.   I just went into makefile.unix and added the "-mt"s. 

Thanks for the tip, even though it was already sort of staring me in the face.

And, yeah, I know, I'm way past time to upgrade.

[bold]"No, Mr. Bond.  I expect you to die."[/bold]
watchpocket
Newbie
*
Offline Offline

Activity: 4


View Profile
May 24, 2011, 06:25:21 AM
 #5

When I exit the bitcoin gui app, I get this message:

(bitcoin:21536): GLib-GObject-CRITICAL **: g_object_ref: assertion `object->ref_count > 0' failed

That can't be normal, can it?

[bold]"No, Mr. Bond.  I expect you to die."[/bold]
interfect
Full Member
***
Offline Offline

Activity: 139


View Profile
May 26, 2011, 07:38:14 AM
 #6

When I exit the bitcoin gui app, I get this message:

(bitcoin:21536): GLib-GObject-CRITICAL **: g_object_ref: assertion `object->ref_count > 0' failed

That can't be normal, can it?


That sort of thing happens for a lot of X apps when run from the command line. You should be fine.
Pages: [1]
  Print  
 
Jump to:  

Sponsored by , a Bitcoin-accepting VPN.
Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2006-2009, Simple Machines Valid XHTML 1.0! Valid CSS!