Bitcoin Forum
December 03, 2016, 02:44:14 AM *
News: To be able to use the next phase of the beta forum software, please ensure that your email address is correct/functional.
 
   Home   Help Search Donate Login Register  
Pages: [1]
  Print  
Author Topic: Can't underclock hd6870 memory  (Read 5650 times)
Horkabork
Full Member
***
Offline Offline

Activity: 140



View Profile
May 24, 2011, 11:59:39 AM
 #1

I've got an MSI radeon HD 6870 and I can't underclock the memory for the life of me. I've tried catalyst control center, tried Trixx, tried Afterburner, and tried staring at the card angrily.

I'm using Catalyst 11.5, SDK 2.4, JFK 11.22.63. I can change the GPU speed just fine, and CCC or Trixx or afterburner will pretend to let me lower the memory clock, but it won't actually "stick".

GPU shark reports that the card is currently at 950mhz GPU, 1050mhz memory, 1.187v. However, my 3 performance states are reported as:

State 0
100.0mhz GPU
150.0mhz Mem
0.950v

State 1
775.0mhz GPU
1050mhz memory
1.100v

Performance state 2
950 mhz gpu
400mhz memory (which is what I thought I changed it to)
1.187v

It's like the card, when mining, goes "OH I'll JUST PICK THE MAXIMUM VALUES AMONG ALL 3 STATES DUM DEE DUM". It's completely ignoring my wishes, and I'm thinking getting a divorce. Does anyone have any advice?

Me: 15gbWvpLPfbLJZBsL2u5gkBdL3BUXDbTuF
A goat: http://i52.tinypic.com/34pj4v6.jpg
Advertised sites are not endorsed by the Bitcoin Forum. They may be unsafe, untrustworthy, or illegal in your jurisdiction. Advertise here.
Tally-ho
Newbie
*
Offline Offline

Activity: 19


View Profile
May 24, 2011, 12:32:36 PM
 #2

I'm afraid that if staring angrily at it is not having the desired effect, all that is left is a temporary separation.  I wouldn't jump right into divorce though, maybe you two will see through your differences.

As far as the memory issue, I've been wondering the same thing though.
zale
Member
**
Offline Offline

Activity: 69


View Profile
May 24, 2011, 01:34:15 PM
 #3

I have the same problem. Maybe it's the CCC 1.5?
zale
Member
**
Offline Offline

Activity: 69


View Profile
May 24, 2011, 04:19:59 PM
 #4

I found a solution in another thread:

Quote
Go in your MSI afterburner folder in program files (X86 for me) and edit the msiafterburner.cfg

where you see [ATIADLHAL] make sure it looks like this:
[ATIADLHAL]
EnableUnofficialOverclocking   = 1
UnofficialOverclockingEULA   = I confirm that I am aware of unofficial overclocking limitations and fully understand that MSI will not provide me any support on it
UnofficialOverclockingMode   = 2
AccessibilityCheckingPeriod   = 0

Works for me.
Horkabork
Full Member
***
Offline Offline

Activity: 140



View Profile
May 24, 2011, 05:18:15 PM
 #5

Thanks for the replies, guys, but the fix didn't work for me. I can change "performance state 2" but, as far as I can tell, the memory clock setting will be ignored if the middle performance state (state 1) has a higher memory clock. That would be fine if I could edit each performance state independently, but each tweak program seems to work in a mysterious voodoo. If I set the memory clock using one program to 750mhz, it might change the settings to that in both performance states. But if I enter 400mhz, performance state 2 might say 400mhz, but state 1 will revert to 1050mhz.

In other words, this results in 950mhz gpu, 1050mhz memory:
State 1
775.0mhz GPU
1050mhz memory
1.100v

Performance state 2
950 mhz gpu
400mhz memory
1.187v

-------------

This results in 950mhz gpu, 1001mhz clock:
State 1
775.0mhz GPU
1000mhz memory
1.100v

Performance state 2
950 mhz gpu
1001mhz memory
1.187v

If I then change the memory clock to 400mhz, performance state 2 will reflect that, but state 1 will be like "Oh no you diin't" and wag it's little finger at me, reverting to 1050mhz.

Me: 15gbWvpLPfbLJZBsL2u5gkBdL3BUXDbTuF
A goat: http://i52.tinypic.com/34pj4v6.jpg
Horkabork
Full Member
***
Offline Offline

Activity: 140



View Profile
May 24, 2011, 05:33:17 PM
 #6

Holy bojangles! It's working at 950mhz, 400mhz memory now. Through the right sequence of editing, it somehow worked. For anyone else stuck with this problem, I did the above cfg editing, then ran trixx and set it to 400mhz, closed it and ran afterburner and changed it to 402 mhz, then 400mhz. Also I danced in a circle and sacrificed a small dog.

Here's the hilarious part: I'm only seeing a tiny, 2 mhash/sec bump for all that. CURSE YOU SHOLLOLLAH, PRANKSTER GOD OF BITCOIN MINING!

Me: 15gbWvpLPfbLJZBsL2u5gkBdL3BUXDbTuF
A goat: http://i52.tinypic.com/34pj4v6.jpg
zale
Member
**
Offline Offline

Activity: 69


View Profile
May 24, 2011, 05:56:26 PM
 #7

I get 322.63 Mhash/s average now with my HD6870. I'm using phoenix with VECTORS BFI_INT FASTLOOP=false AGGRESSION=12 WORKSIZE=256 DEVICE=0

These are my exact OC settings:
Voltage: 1212mV
1050 Core clock
400 Memory
Fan Speed 46% (The exact point where it more quiet than the rest of my rig)
Which results in 70-71°C
melanarchy
Newbie
*
Offline Offline

Activity: 22


View Profile
May 26, 2011, 05:06:32 PM
 #8

So I have my miner setup on a headless box with a 6870 and I can't for the life of me figure out how to underclock the memory, AMDOverdriveCtl needs you to be in X which I am not in.  Any suggestions?

Currently I'm getting in the range of 217Mhash which seems awfully slow.

1aLV7cjRXE89KoychBaGUP8YGm5ZRVNAw - If my info is helpful donations are always welcome.
stick_theman
Sr. Member
****
Offline Offline

Activity: 372


View Profile
June 06, 2011, 02:45:31 AM
 #9

So I have my miner setup on a headless box with a 6870 and I can't for the life of me figure out how to underclock the memory, AMDOverdriveCtl needs you to be in X which I am not in.  Any suggestions?

Currently I'm getting in the range of 217Mhash which seems awfully slow.

What's up Mel, have you tried DISPLAY=:0 aticonfig --od-setclocks ??

Display =:0 is the key w/o X
Pages: [1]
  Print  
 
Jump to:  

Sponsored by , a Bitcoin-accepting VPN.
Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2006-2009, Simple Machines Valid XHTML 1.0! Valid CSS!