Bitcoin Forum
December 11, 2016, 11:59:12 AM *
News: To be able to use the next phase of the beta forum software, please ensure that your email address is correct/functional.
 
   Home   Help Search Donate Login Register  
Pages: [1]
  Print  
Author Topic: Weird error: Locale "en_dk" can not be set. Help please:)  (Read 1284 times)
Ulle69
Newbie
*
Offline Offline

Activity: 2


View Profile
May 29, 2011, 11:03:37 PM
 #1

Hi - so not totally computer illiterate, but probably not the sharpest mind in computing history neither.
Getting a weird error: Locale "en_dk" cannot be set - when I run bitcoin client on my Mac using Snow Leopard.
Not getting any blocks or connections.

Anybody encountered this before? Anybody know a fix?
Been reading a bit about fall back nodes going through some commands in the terminal- would that help?

Thanks

U.

Advertised sites are not endorsed by the Bitcoin Forum. They may be unsafe, untrustworthy, or illegal in your jurisdiction. Advertise here.
1481457552
Hero Member
*
Offline Offline

Posts: 1481457552

View Profile Personal Message (Offline)

Ignore
1481457552
Reply with quote  #2

1481457552
Report to moderator
1481457552
Hero Member
*
Offline Offline

Posts: 1481457552

View Profile Personal Message (Offline)

Ignore
1481457552
Reply with quote  #2

1481457552
Report to moderator
1481457552
Hero Member
*
Offline Offline

Posts: 1481457552

View Profile Personal Message (Offline)

Ignore
1481457552
Reply with quote  #2

1481457552
Report to moderator
Ulle69
Newbie
*
Offline Offline

Activity: 2


View Profile
May 29, 2011, 11:25:52 PM
 #2

uhm sorted - if any other super-noob comes across this - go to your formats settings in preferences and choose the right region.
Petruza
Newbie
*
Offline Offline

Activity: 1


View Profile
June 06, 2011, 04:46:14 PM
 #3

Which is the "right region"?
I have the same problem with my locale "es_AR" which is the right locale.

edit: I had a custom region instead of es_AR, is that it?
kseistrup
Hero Member
*****
Offline Offline

Activity: 565


Unselfish actions pay back better


View Profile WWW
June 06, 2011, 05:45:49 PM
 #4


Getting a weird error: Locale "en_dk" cannot be set - when I run bitcoin client on my Mac using Snow Leopard.
Not getting any blocks or connections.

Anybody encountered this before? Anybody know a fix?

Setting the locale for the client to e.g. ‘C’ or ‘POSIX’ should solve the problem.  A wrapper script could do this:

Code:
#!/bin/sh

LANG=C; export LANG
LC_ALL=C; export LC_ALL

exec bitcoin "${@}"

# eof

(If you're Danish, perhaps you'd like to join #bitcoin.dk on freenode.)

Cheers,

Klaus Alexander Seistrup
http://about.me/kseistrup
Pages: [1]
  Print  
 
Jump to:  

Sponsored by , a Bitcoin-accepting VPN.
Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2006-2009, Simple Machines Valid XHTML 1.0! Valid CSS!