Bitcoin Forum
December 11, 2016, 12:26:00 AM *
News: To be able to use the next phase of the beta forum software, please ensure that your email address is correct/functional.
 
   Home   Help Search Donate Login Register  
Pages: [1]
  Print  
Author Topic: 6870 often gets stuck in some kind of low speed mode  (Read 2435 times)
Lars
Newbie
*
Offline Offline

Activity: 27


View Profile
June 01, 2011, 03:20:40 PM
 #1

I own a gaming PC that I some times use for bitcoin mining. The system runs Win 7 and has 2x6870s installed in it. Typical hashrate with stock settings is about 260 MH/s, running poclbm with the -v flag set.

My problem is that some times (quite often actually) the first device, GPU 0, drops to about 70-80MH/s and gets stuck there. It always happens when I open a youtube video, but can probably be set off by other things as well. Once it enters this mode it stays there until I reboot the system.

Any of you GPU pros have a workaround for this? Any way to manually force it back into its normal operating speed?
1481415960
Hero Member
*
Offline Offline

Posts: 1481415960

View Profile Personal Message (Offline)

Ignore
1481415960
Reply with quote  #2

1481415960
Report to moderator
1481415960
Hero Member
*
Offline Offline

Posts: 1481415960

View Profile Personal Message (Offline)

Ignore
1481415960
Reply with quote  #2

1481415960
Report to moderator
1481415960
Hero Member
*
Offline Offline

Posts: 1481415960

View Profile Personal Message (Offline)

Ignore
1481415960
Reply with quote  #2

1481415960
Report to moderator
Advertised sites are not endorsed by the Bitcoin Forum. They may be unsafe, untrustworthy, or illegal in your jurisdiction. Advertise here.
1481415960
Hero Member
*
Offline Offline

Posts: 1481415960

View Profile Personal Message (Offline)

Ignore
1481415960
Reply with quote  #2

1481415960
Report to moderator
1481415960
Hero Member
*
Offline Offline

Posts: 1481415960

View Profile Personal Message (Offline)

Ignore
1481415960
Reply with quote  #2

1481415960
Report to moderator
1481415960
Hero Member
*
Offline Offline

Posts: 1481415960

View Profile Personal Message (Offline)

Ignore
1481415960
Reply with quote  #2

1481415960
Report to moderator
Maxxx
Member
**
Offline Offline

Activity: 70



View Profile
June 01, 2011, 03:22:56 PM
 #2

I own a gaming PC that I some times use for bitcoin mining. The system runs Win 7 and has 2x6870s installed in it. Typical hashrate with stock settings is about 260 MH/s, running poclbm with the -v flag set.

My problem is that some times (quite often actually) the first device, GPU 0, drops to about 70-80MH/s and gets stuck there. It always happens when I open a youtube video, but can probably be set off by other things as well. Once it enters this mode it stays there until I reboot the system.

Any of you GPU pros have a workaround for this? Any way to manually force it back into its normal operating speed?

You didn't mention it so I will, heat. I only experience this when the card throttles down to prevent overheating. So more fans, PCI express extender cable, and so on can all help.

If you don't already, use MSI Afterburner on Win7 to monitor temps underclock/overclock, etc.

Time is money. This means that if you have spare time, you can use it to make money.

Modular, open, and stack-able miner case.
MiningBuddy
Moderator
Legendary
*
Offline Offline

Activity: 1058


฿itcoin ฿itcoin ฿itcoin


View Profile
June 01, 2011, 03:23:25 PM
 #3

Firstly I would check your temps and make sure they are not too hot causing your card to throttle down.
Secondly I would disable hardware acceleration for flash player, (right click any flash video -> settings & un-tick enable hardware acceleration)

airdata
Sr. Member
****
Offline Offline

Activity: 406


View Profile
June 01, 2011, 03:26:11 PM
 #4

Are you using guiminer?

If so add the -f 1-10 flag.  Somebody told me to use -f #  where # is any number less than 30.  30 is the default.  I did this and it fixed this issue w\ my 6870.
LegitBit
Full Member
***
Offline Offline

Activity: 140



View Profile
June 01, 2011, 03:32:46 PM
 #5

The flash acceleration is likely the big issue there.

You can also look into disabling Ultra Low Power Settings.

http://event.msi.com/vga/afterburner/download.htm

http://www.sapphiretech.com/ssc/TriXX/

Both MSI Afterburner and TriXX have the settings to do this.
In afterburner set voltage to be constant, in trixx turn off ULPS.

Donate : 1EiAKUmTVtqXsaGLKQQVvLT9DDnHsT7jTZ (Block Explorer)
Lars
Newbie
*
Offline Offline

Activity: 27


View Profile
June 01, 2011, 03:57:06 PM
 #6

Thanks for the quick replies guys. After trying some of your ideas I think I have been able to fix the issue for now.

I'm pretty sure it isnt heat. This morning I had this issue just seconds after turning on my computer. When I have heat issues it typically just locks up my whole system. I have ordered extra fans to keep things cool, but for now I'm just running the cards at stock gpu frequencies, 100% fan speed and the memory clocked down as far as afterburner lets me (525), and this appears to be running stable. Just for reference, how high can the GPU temps go before I should start getting worried?

Hardware acceleration for flash was turned on. I have now turned it off, and it seems like my system can play youtube videos without having the performance drop. I guess this will eliminate the most common cause of this problem. The only thing that worries me is that while the hardware acceleration probably caused the drop in performance, something else must have caused it to get stuck there.

I am not using guiminer, but I guess its some kind of front end for poclbm? I'll try experimenting a bit with the -f 1-10 options and see if they make any difference. What exactly are those flags for? I tried to use "-f 1" one day, and felt like it made my system a bit unresponsive, but that could just have been a coincidence.

I'll look into the voltage setting in afterburner if I ever get the problems again. (now that the flash part is resolved) This suggestion fits with my own theory about the card entering "2D mode" and for some reason getting stuck there.
LegitBit
Full Member
***
Offline Offline

Activity: 140



View Profile
June 01, 2011, 08:57:27 PM
 #7

The -f tag is for setting process priority, setting that to 1 gave the mining process ultimate authority so that is why you experienced unresponsiveness.

30 is the default.

As for guiminer, it is just a front-end, though pretty useful and doesn't drag on resources.


Temps are a toss up, I personally make sure my card never rises above 55C even when over-clocking, though other more adventurous types let it go to 70C even 90C... which IMHO is ridiculous, within a year those cards will likely be nothing more than burnt bricks.

Technically most chips are rated to 100C as max, though often artifacts and errors occur much sooner.

Think of it this way... at 50C 24/7 you could get 1.5-2 years on average... now half that for 90C. This is of course dramatization, but I'd rather be safe than sorry.

You don't need water cooling to get low temps, just good airflow and proper fan positioning.

Donate : 1EiAKUmTVtqXsaGLKQQVvLT9DDnHsT7jTZ (Block Explorer)
itsagas
Jr. Member
*
Offline Offline

Activity: 59


View Profile
June 01, 2011, 10:09:38 PM
 #8

The -f tag is for setting process priority, setting that to 1 gave the mining process ultimate authority so that is why you experienced unresponsiveness.

30 is the default.

As for guiminer, it is just a front-end, though pretty useful and doesn't drag on resources.


Temps are a toss up, I personally make sure my card never rises above 55C even when over-clocking, though other more adventurous types let it go to 70C even 90C... which IMHO is ridiculous, within a year those cards will likely be nothing more than burnt bricks.

Technically most chips are rated to 100C as max, though often artifacts and errors occur much sooner.

Think of it this way... at 50C 24/7 you could get 1.5-2 years on average... now half that for 90C. This is of course dramatization, but I'd rather be safe than sorry.

You don't need water cooling to get low temps, just good airflow and proper fan positioning.



If you have a way to get 2 x 6990 to run at 50C while doing dedicated mining, would love to hear ideas and pics!  Mine with tons of fans are stable at 85C.  Those sucker throw off tons of heat too. 

My 6950s are running at 75C or so. 
LegitBit
Full Member
***
Offline Offline

Activity: 140



View Profile
June 01, 2011, 10:42:27 PM
 #9

I have two 5830's and a 5770 running at around 55C each, dedicated on air.

Make sure you have as much "in force" as "out force" in the case, sometimes people place a bunch of fans inward... with no exhaust, or they place fans too close to eachother with opposing air currents.

Remember that heat rises.. so if you have cards that vent out the rear, hang the machine at a 90deg angle with some bungee cords, or a wire rack. Laying it on the side may help as well. Sometimes keeping the machine out of a case helps, but alot of heat dispesal requires alot of air actually passing though the fins of the heatsink, not just above them.

Ambient temps factor in as well, gotta have a cool room.

Though you may just be out of luck with two 6990's, 4 GPU's in a cramped space are going to make tons of heat and there isn't much outside of watercooling that can help.  Smiley

Donate : 1EiAKUmTVtqXsaGLKQQVvLT9DDnHsT7jTZ (Block Explorer)
Pages: [1]
  Print  
 
Jump to:  

Sponsored by , a Bitcoin-accepting VPN.
Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2006-2009, Simple Machines Valid XHTML 1.0! Valid CSS!