Bitcoin Forum
December 10, 2016, 08:55:57 PM *
News: Latest stable version of Bitcoin Core: 0.13.1  [Torrent].
 
   Home   Help Search Donate Login Register  
Pages: [1]
  Print  
Author Topic: Cant get HD5850's to overclock and set fan speed in ubuntu  (Read 2952 times)
CubedRoot
Sr. Member
****
Offline Offline

Activity: 295


View Profile
June 03, 2011, 02:19:13 PM
 #1

I have 3 Sapphire HD5850's running.  I have tried to overclock them but I am not getting very stable numbers. Each card is identical, and i cannot get them to clock to the same speeds. I can barely even overclock one of them Sad

Heres my setup:
Ubuntu 11.04 64 bit running headless, GDM is set to not start on boot, and I have a script in /etc/init to start X
Catalyst 11.5
AMD SDK 2.4

On GPU 0 I can only get it to stay stable at 800 gpu 300 mem. If I go any higher, I get a system lock and have to reboot to free it.  This is the GPU that I used to install Ubuntu, but I am currently running it headless.  Also I cannot get the damn speed to set on boot using my start script. I will post the script below:


Code:
#!/bin/bash
# ${1} is used as a variable for the username, password and for the gpu device number.  Ex. mineruser0, minerpass0, Device=0 or mineruser1, minerpass1, Device=1
      HOMEDIR=/home/bitcoin
      MINERSERV=btcguild.com:8332
      MINERUSER=MYMINER${1}
      MINERPASS=MINERPASS

      export AMDAPPSDKROOT=${HOMEDIR}/AMD-APP-SDK-v2.4-lnx64/
      export AMDAPPSDKSAMPLESROOT=${HOMEDIR}/AMD-APP-SDK-v2.4-lnx64/
      export LD_LIBRARY_PATH=${AMDAPPSDKROOT}lib/x86_64:${LD_LIBRARY_PATH}

      #Overclock GPU0 to 800 Mhz and set fan seepd
      DISPLAY=:0 aticonfig --pplib-cmd "set fanspeed 0 75"
      DISPLAY=:0 aticonfig --od-enable --adapter=all
      DISPLAY=:0 aticonfig --od-setclocks=800,300 --adapter=${1}
      cd ${HOMEDIR}/phoenix-1.48
      echo "Starting Miner: ${1}"
      ${HOMEDIR}/phoenix-1.48/phoenix.py -u http://${MINERUSER}:${MINERPASS}@${MINERSERV} -k phatk VECTORS BFI_INT AGGRESSION=10 FASTLOOP=false WORKSIZE=128 DEVICE=${1}


I dont understand why the fan speed will not set with this script, since I can run this same exact command: DISPLAY=:0 aticonfig --pplib-cmd "set fanspeed 0 75"  and it will set the fan with no problems from a normal terminal session.


GPU 1 will only overclock to around 900,300 and be stable. 
GPU 2 will only overclock to around 930,350 and be stable.


Here is the script I am using for these 2 GPU's:

Code:
#!/bin/bash
# ${1} is used as a variable for the username, password and for the gpu device number.  Ex. mineruser0, minerpass0, Device=0 or mineruser1, minerpass1, Device=1
      HOMEDIR=/home/bitcoin
      MINERSERV=btcguild.com:8332
      MINERUSER=MYMINER${1}
      MINERPASS=MINERPASS

      export AMDAPPSDKROOT=${HOMEDIR}/AMD-APP-SDK-v2.4-lnx64/
      export AMDAPPSDKSAMPLESROOT=${HOMEDIR}/AMD-APP-SDK-v2.4-lnx64/
      export LD_LIBRARY_PATH=${AMDAPPSDKROOT}lib/x86_64:${LD_LIBRARY_PATH}

      #Overclock GPU to 875Mhz
      DISPLAY=:0.1 aticonfig --pplib-cmd "set fanspeed 0 75"
      DISPLAY=:0.2 aticonfig --pplib-cmd "set fanspeed 0 75"
      DISPLAY=:0 aticonfig --od-enable --adapter=all
      DISPLAY=:0 aticonfig --od-setclocks=900,300 --adapter=1
      DISPLAY=:0 aticonfig --od-setclocks=930,350 --adapter=2
      cd ${HOMEDIR}/phoenix-1.48
      echo "Starting Miner: ${1}"
      ${HOMEDIR}/phoenix-1.48/phoenix.py -u http://${MINERUSER}:${MINERPASS}@${MINERSERV} -k phatk VECTORS BFI_INT FASTLOOP=false AGGRESSION=13 WORKSIZE=128 DEVICE=${1}


These cards will run at low temps for hours on end. The highest temp Ive seen has been around 65c.

I  have seen alot of folks running this same setup and are able to get 950,325 out of their Sapphire HD5850's with no stability problems. What are some things I can try to get these cards stable and higher clock speeds?  Do I need to export any display settings?
Advertised sites are not endorsed by the Bitcoin Forum. They may be unsafe, untrustworthy, or illegal in your jurisdiction. Advertise here.
1481403357
Hero Member
*
Offline Offline

Posts: 1481403357

View Profile Personal Message (Offline)

Ignore
1481403357
Reply with quote  #2

1481403357
Report to moderator
1481403357
Hero Member
*
Offline Offline

Posts: 1481403357

View Profile Personal Message (Offline)

Ignore
1481403357
Reply with quote  #2

1481403357
Report to moderator
Mapatti
Newbie
*
Offline Offline

Activity: 14



View Profile
June 03, 2011, 02:21:30 PM
 #2

Which PSU do you use?
CubedRoot
Sr. Member
****
Offline Offline

Activity: 295


View Profile
June 03, 2011, 02:24:27 PM
 #3

I have a 600W PSU that is running the system plus GP0, and then I have a 425 ePower JuiceBox that is running the other 2 cards GPU1 and GPU2.

Total power draw from both PSU's is showing to be about 600w from my Kill-a-watt meter

What is strange is that I can overclock all three cards in Win7 to around 940 with no problems.
Mapatti
Newbie
*
Offline Offline

Activity: 14



View Profile
June 03, 2011, 02:47:01 PM
 #4

Im not very good with *NIX OSs but i give a try:
Quote
     DISPLAY=:0 aticonfig --od-enable --adapter=all
      DISPLAY=:0 aticonfig --od-setclocks=800,300 --adapter=${1}
Why is there adapter=all if you only clock ${1}? And shouldnt there be --odcc (confirm clock)
CubedRoot
Sr. Member
****
Offline Offline

Activity: 295


View Profile
June 03, 2011, 02:51:07 PM
 #5

the line with adapter=all is just for safety. All it does is apply the aticonfig --od-enable to all 3 of the adapters.
The second line: DISPLAY=:0 aticonfig --od-setclocks=800,300 --adapter=${1}   applyes the clock settings to the variable ${1} which in this case would be GPU0 since I run the command like this:  startminer.sh 0
exahash
Sr. Member
****
Offline Offline

Activity: 276



View Profile
June 03, 2011, 04:44:00 PM
 #6

Which Sapphire 5850's are you using?  I have a whole bunch of the xtreme's and can't get aticonfig to apply memory settings outside of the overdrive range.  The lowest I can get the memclocks to is 900 with aticonfig.

Did you flash your cards' bios?

On my Sapphire 5850's most will do at least 880,900 yielding 330-340 MH/s  Some will only take 850,900 and a few lousier ones will only take 820,900

In windows I can use trixx to get around 370 MH/s with 960,300 @1.25 volts.  I can't get over 900 gpu clock without upping the voltages.

I'm experimenting with the latest version of AMDOverdriveCtl to get the memclocks lowered in ubuntu.

Also, there's another thread about oc'ing the 5850's you might be interested in.
Mapatti
Newbie
*
Offline Offline

Activity: 14



View Profile
June 03, 2011, 05:30:11 PM
 #7

Try install older catalyst 10.4 for example.
CubedRoot
Sr. Member
****
Offline Offline

Activity: 295


View Profile
June 03, 2011, 05:57:41 PM
 #8

I am running the Sapphire Xtreme 1 gig HD5850's.  These are not reference cards, so I dont think I can adjust the voltages in the bios.  Will AMDovrdrvctrl allow me to adjust the voltages?

I have modified the BIOS on all 3 cards. The only thing I done to the bios was set it so I could run low clock speeds on ram, and allow higher upper GPU limits.  The cards are set to run stock clocks on boot, and I use my scripts to overclock them.
Pages: [1]
  Print  
 
Jump to:  

Sponsored by , a Bitcoin-accepting VPN.
Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2006-2009, Simple Machines Valid XHTML 1.0! Valid CSS!