Bitcoin Forum
December 03, 2016, 06:00:00 PM *
News: To be able to use the next phase of the beta forum software, please ensure that your email address is correct/functional.
 
   Home   Help Search Donate Login Register  
Pages: [1]
  Print  
Author Topic: Not getting max Hash rate with HD6850?  (Read 8564 times)
wachtwoord
Legendary
*
Offline Offline

Activity: 1484



View Profile WWW
June 04, 2011, 03:01:50 PM
 #1

Hi,

I own a HD6850 video card (Club 3D CGAX-68524 Radeon HD6850 16xPCIE 256-bit 1GB GDDR5) and am mining with my GPU only. I use poclbm_py2exe_20110428 to mine and have bene ming at ~153Mhash. In this source however (https://en.bitcoin.it/wiki/Mining_hardware_comparison) hash rates between 170Mhash and 244mHash are reported. Since this is significantly more I am curious if I am doing something wrong?

Thanks in advance

1480788000
Hero Member
*
Offline Offline

Posts: 1480788000

View Profile Personal Message (Offline)

Ignore
1480788000
Reply with quote  #2

1480788000
Report to moderator
1480788000
Hero Member
*
Offline Offline

Posts: 1480788000

View Profile Personal Message (Offline)

Ignore
1480788000
Reply with quote  #2

1480788000
Report to moderator
Advertised sites are not endorsed by the Bitcoin Forum. They may be unsafe, untrustworthy, or illegal in your jurisdiction. Advertise here.
1480788000
Hero Member
*
Offline Offline

Posts: 1480788000

View Profile Personal Message (Offline)

Ignore
1480788000
Reply with quote  #2

1480788000
Report to moderator
grue
Global Moderator
Legendary
*
Offline Offline

Activity: 1932



View Profile
June 04, 2011, 03:31:35 PM
 #2

you have to overclock?

It is pitch black. You are likely to be eaten by a grue.

Tired of annoying signature ads? Ad block for signatures
wachtwoord
Legendary
*
Offline Offline

Activity: 1484



View Profile WWW
June 04, 2011, 03:34:32 PM
 #3

Ah, those are overclocked numbers.  Grin

By pure chance I did find a way to boost it without overclocking to 184MHash by adding a -v argument to poclbm. Does anyone know what that means and are there more of such arguments? Thats 20% more!

enmaku
Hero Member
*****
Offline Offline

Activity: 742



View Profile WWW
June 04, 2011, 03:35:23 PM
 #4

Play with your parameters and try over/under clocking.
On my 5830 I get ~192 MH/s just running the miner with no flags and stock settings
Adding -v -w128 agression=11 gets me ~226 MH/s
Using MSI Afterburner to up the core clock to 975 MHz and knock the memory clock down to 675 MHz gets me ~277 MH/s

Atroxes
Full Member
***
Offline Offline

Activity: 120



View Profile
June 04, 2011, 03:36:52 PM
 #5

Ah, those are overclocked numbers.  Grin

By pure chance I did find a way to boost it without overclocking to 184MHash by adding a -v argument to poclbm. Does anyone know what that means and are there more of such arguments? Thats 20% more!

Use Phoenix miner.

And use this: -k phatk VECTORS BFI_INT AGGRESSION=8 FASTLOOP WORKSIZE=256 (128 can be better depending on your configuration)

And downclock your memory (I think that works on 6xxx series atleast).
enmaku
Hero Member
*****
Offline Offline

Activity: 742



View Profile WWW
June 04, 2011, 03:39:12 PM
 #6

Ah, those are overclocked numbers.  Grin

By pure chance I did find a way to boost it without overclocking to 184MHash by adding a -v argument to poclbm. Does anyone know what that means and are there more of such arguments? Thats 20% more!

-v tells the miner to work in vectors, which is more efficient on some cards.
-w128 specifies the work size, there will be a "sweet spot" for your card, try adjusting the number (must be a power of two, so w64, w128, w256 are all valid while w99 is not)
agression is... well it's pretty much what it sounds like Smiley

I only managed to pull about 18% more with flags alone, the big boost came with overclocking the core clock and underclocking the memory clock, that's what took me from 192 to 277 MH/s Smiley

wachtwoord
Legendary
*
Offline Offline

Activity: 1484



View Profile WWW
June 04, 2011, 04:21:10 PM
 #7

Okay thanks a lot for the input.

Without overclocking:

Poclbm got to ~190 Mhash max (after removing the -f 60)

Phoenix got ~202 Mhas max

I made two Phoenix configs (this post: http://forum.bitcoin.org/?topic=6458.0 explains the flags quite nicely) :

1 dedicated: -k phatk VECTORS BFI_INT AGGRESSION=11 FASTLOOP=false WORKSIZE=128  @ ~202 Mhash
1 non-dedicated (for normal use): -k phatk VECTORS BFI_INT AGGRESSION=7 FASTLOOP WORKSIZE=128  @ 196 Mhash

I'll try overclocking another time but again thanks for the tips Smiley

BTW: The GPU is already @ 72 Celcius without overclocking so I might not be able to overclock a lot/at all

wachtwoord
Legendary
*
Offline Offline

Activity: 1484



View Profile WWW
June 04, 2011, 07:48:07 PM
 #8

I decided to try overclocking the casrd now and downloaded MSI afterburner.

1. I could only up the core frequency to 850 (from 775) and doing so boosted the has rate to 221 Mhash (~10%).
2. Lowering the memory frequency did not have any effect on the hash rate. Default is 1000 and I tried all the way down to 500. Ik also tried upping it to 1200 but this resulted in artifacts being created and some safety measure kicked in automatically resetting it.

So, how have you overclocked the core to 975? And how come me lowering the memory frequency has no effect (should I reset the computer for this to work?)

Also why is lowering the memory frequency supposed to have a positive effect anyway?

wachtwoord
Legendary
*
Offline Offline

Activity: 1484



View Profile WWW
June 04, 2011, 08:02:55 PM
 #9

The lowest possible memory frequency is 500Mhz, just as the highest possible core frequency is 850 instead of the 975 that was recommended by enmaku.

I am running at a 500Mhz memory frequency now and the hash rate does not change as does the core temperature in comparison with 1000 Mhz.

murasha
Member
**
Offline Offline

Activity: 105


PHP developer


View Profile
June 04, 2011, 08:26:15 PM
 #10

I got the same situation when I added a .reg file to windows registry that allowed to increase GPU clock limits in CCC.
If you done it too  - delete those keys from your registry and re-install the driver.

wachtwoord
Legendary
*
Offline Offline

Activity: 1484



View Profile WWW
June 04, 2011, 09:43:17 PM
 #11

I found out how to do it. This: http://forum.bitcoin.org/index.php?topic=4292.0 post explains it.

The lower freqency however seems to have no effect a all on has rate. I am now running at 250 hz even but any value between 250-1000 seems to result in the same hash rate ..... Anyone know if I am doing something wrong?

I tried upping the core frequency to 975 but the system crashed. Now I tried 950 (with the 250 memory frequency) and it seems to be stable. How can I be sure? Should I leave it at this? Will this has negative effects on the video card?


At the moment I am running at 950/250 with 241 Mhash.

I reckon I should put the memory frequency  back @ when gaming? And also lower the core frequency back a  bit right?

Edit:

950 crashed so at 925 and 241 mhash now

LegitBit
Full Member
***
Offline Offline

Activity: 140



View Profile
June 04, 2011, 09:45:47 PM
 #12

Definitely put the mem back before gaming, had a card that crapped out because I forgot the card was downclocked when I launched an intensive game, took a long time to get it back to working condition.

Donate : 1EiAKUmTVtqXsaGLKQQVvLT9DDnHsT7jTZ (Block Explorer)
wachtwoord
Legendary
*
Offline Offline

Activity: 1484



View Profile WWW
June 04, 2011, 09:50:24 PM
 #13

What? It actually breaks the card?

bbulker
Full Member
***
Offline Offline

Activity: 127


View Profile
June 04, 2011, 10:14:46 PM
 #14

Definitely put the mem back before gaming, had a card that crapped out because I forgot the card was downclocked when I launched an intensive game, took a long time to get it back to working condition.

Are you sure that was because of the downclocked memory? I've played games just fine while mining with downclocked memory.
LegitBit
Full Member
***
Offline Offline

Activity: 140



View Profile
June 05, 2011, 12:12:39 AM
 #15

Didn't break the card, but screwed up the driver in a hard crash.

Definitely was the down-clocking. Was also an intensive game. I didn't notice because I had played a less intensive game before that and nothing bad happened.

Had to remove the driver in safe mode and reinstall several times before I got it working again.

Donate : 1EiAKUmTVtqXsaGLKQQVvLT9DDnHsT7jTZ (Block Explorer)
Pages: [1]
  Print  
 
Jump to:  

Sponsored by , a Bitcoin-accepting VPN.
Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2006-2009, Simple Machines Valid XHTML 1.0! Valid CSS!