Bitcoin Forum
October 19, 2018, 01:52:42 AM *
News: Make sure you are not using versions of Bitcoin Core other than 0.17.0 [Torrent], 0.16.3, 0.15.2, or 0.14.3. More info.
 
   Home   Help Search Donate Login Register  
Pages: [1]
  Print  
Author Topic: Cgminer schmiert ab  (Read 1788 times)
mrright
Newbie
*
Offline Offline

Activity: 10
Merit: 0


View Profile
November 10, 2015, 06:13:18 PM
 #1

hi leute,
hab das problem das mein cgminer immer wieder abstürzt.

angeschlossen an einen pi2 sind 3 antminer u3 an einem aktiven usb stick.

kurz bevor er abstürzt komm die meldung:"[2015-11-10 18:10:12] AMU 1 GetResults usb read err:(-1) LIBUSB_ERROR_IO
 [2015-11-10 18:10:13] AMU 1 attempted reset got err:(0) LIBUSB_SUCCESS"

und dann kommt nach kurzer zeit:"[screen is terminating]"

und nix geht mehr.

hat jemand eine idee warum das passiert?

1539913962
Hero Member
*
Offline Offline

Posts: 1539913962

View Profile Personal Message (Offline)

Ignore
1539913962
Reply with quote  #2

1539913962
Report to moderator
1539913962
Hero Member
*
Offline Offline

Posts: 1539913962

View Profile Personal Message (Offline)

Ignore
1539913962
Reply with quote  #2

1539913962
Report to moderator
The trust scores you see are subjective; they will change depending on who you have in your trust list.
Advertised sites are not endorsed by the Bitcoin Forum. They may be unsafe, untrustworthy, or illegal in your jurisdiction. Advertise here.
1539913962
Hero Member
*
Offline Offline

Posts: 1539913962

View Profile Personal Message (Offline)

Ignore
1539913962
Reply with quote  #2

1539913962
Report to moderator
1539913962
Hero Member
*
Offline Offline

Posts: 1539913962

View Profile Personal Message (Offline)

Ignore
1539913962
Reply with quote  #2

1539913962
Report to moderator
1539913962
Hero Member
*
Offline Offline

Posts: 1539913962

View Profile Personal Message (Offline)

Ignore
1539913962
Reply with quote  #2

1539913962
Report to moderator
flikflak
Sr. Member
****
Offline Offline

Activity: 368
Merit: 250


View Profile
November 10, 2015, 09:42:42 PM
 #2

Hmm... hast du schon mal eine andere build versucht?

Ansonsten wende dich mal an -ck, er ist Moderator im englischen Teil und der Entwickler vom cgminer.

Edit: Link zum Thread
o_solo_miner
Legendary
*
Offline Offline

Activity: 977
Merit: 1003


-> morgen, ist heute, schon gestern <-


View Profile
November 12, 2015, 08:22:28 AM
 #3

hi leute,
hab das problem das mein cgminer immer wieder abstürzt.

angeschlossen an einen pi2 sind 3 antminer u3 an einem aktiven usb stick.

kurz bevor er abstürzt komm die meldung:"[2015-11-10 18:10:12] AMU 1 GetResults usb read err:(-1) LIBUSB_ERROR_IO
 [2015-11-10 18:10:13] AMU 1 attempted reset got err:(0) LIBUSB_SUCCESS"

und dann kommt nach kurzer zeit:"[screen is terminating]"

und nix geht mehr.

hat jemand eine idee warum das passiert?



1. Prüfe ob du einen USB Hub verwendest der genug Strom liefern kann (1A pro Port).

2. Was für einen USB Hub verwendest du? Ist der USB3 fähig?
    Wenn ja, dann :

A: RPis and Windows have incomplete or non-standard USB3 support so they may
never work. It may be possible to get a USB3 hub to work by plugging it into
a USB2 hub. When choosing a hub, USB2 hubs are preferable whenever possible
due to better support all round.

Oder auf Deutsch, verwende besser einen USB Hub 1.1 / 2 und keinen 3.

Wichtig beim compilieren ist die USBLIB, das hängt nun von der verwendeten Distribution ab.
Welche verwendest du?

 

http://ckpool.org "THE Pool" from the creator of CGMiner & CKPool / Payout System:SPLNS / ZERO FEE!
------------------------------------------- join now -----------------------------------------------
http://solo.ckpool.org for Solominers with the best block notify system
mrright
Newbie
*
Offline Offline

Activity: 10
Merit: 0


View Profile
November 12, 2015, 04:26:33 PM
 #4

Als hub verwende ich: D-Link DUB-H7 (USB2.0)
flikflak
Sr. Member
****
Offline Offline

Activity: 368
Merit: 250


View Profile
November 12, 2015, 04:42:41 PM
 #5

Hast du mal in den Thread geschaut? Eine Seite vorher hat jemand das gleiche Problem mit einem U3 und dem RaspberryPi2, wie du. Es wird dann ein vollständiger dump empfohlen. Sollten die dumpfiles unterschiedliche Ursachen haben, dann liegt es nicht an der Software -> -ck vermutet eher eine schlechte sd Karte ("dodgy sd card"), da wohl viele den cgminer 4.9.2 mit dem Raspberry Pi 2 problemlos nutzen. Wie man den dump richtig ausführt, erklärt kano weiter unten.

Viel Glück!
mrright
Newbie
*
Offline Offline

Activity: 10
Merit: 0


View Profile
November 12, 2015, 06:54:55 PM
 #6

man muss dazu sagen, nachdem ich auf der hersteller seite auf's datenblatt geguckt habe , ist mir aufgefallen dass nur 2 ports 1,2 A liefer und die anderen 5 nur 0,5A, ich gehe davon aus dass es daran liegt.

könnt ihr einen anständigen usb hub empfehlen?
mrright
Newbie
*
Offline Offline

Activity: 10
Merit: 0


View Profile
November 12, 2015, 08:54:43 PM
 #7

is ne transcend sd karte, bringt es was das image mit win32 image writer einfach auf ne neue zu kopieren? das mit der dump file kapier ich nich ganz, bin noch recht neu in der materie. Aber Danke schon mal, etz bin ich schon ein wenig schlauer
mrright
Newbie
*
Offline Offline

Activity: 10
Merit: 0


View Profile
November 13, 2015, 04:34:01 PM
 #8

nach der vermutung dass es an der usb karte liegt hab ich jetzt ales auf eine andere sandisk per image geschrieben aber das problem bleibt und kommt immer noch.

ich raff das nich ganz wie das mit der dump file funktioniert, kann mir das jemand auf deutsch erklären?

gruß
flikflak
Sr. Member
****
Offline Offline

Activity: 368
Merit: 250


View Profile
November 13, 2015, 06:18:48 PM
 #9

Besorge dir den debugger gdb als Source und kompiliere es auf dem Pi mit den flags  -g -O0. Dann startest du gdb vor dem cgminer und du bekommst ein dumpfile. 
mrright
Newbie
*
Offline Offline

Activity: 10
Merit: 0


View Profile
November 15, 2015, 03:43:44 PM
 #10

hab jetzt mal einen anderen powered usb hub von nem kumpel probiert, hier geht es halbwegs , nur kommt hier ein neuer fehler und zwar:  [2015-11-15 15:42:33] AMU 3 GetResults usb read err:(-9) LIBUSB_ERROR_PIPE
 [2015-11-15 15:42:33] AMU 3 attempted reset got err:(0) LIBUSB_SUCCESS

Buchi-88
Legendary
*
Offline Offline

Activity: 1764
Merit: 1038


Changing Car Ownership forever


View Profile
November 17, 2015, 09:41:44 AM
 #11

Bitte poste die Fehler hier:

https://bitcointalk.org/index.php?topic=28402.0

Ich hatte auch immer wieder Probleme mit Cgminer, versuche einmal BfgMiner...

★★★★★
▄▄██████▄▄
▄█████▀  ▀█████▄
▄████▀        ▀████▄
▄███▀              ▀███▄
▄██▀                    ▀██▄
▄██▀                        ▀██▄
██        ▒▓▓▓▓▓▒▒            ██
██      ▒▓▓▒▓█▓ ▒▓▓▓          ██
██   ▒▒▓█▓▒ ▒▓▓  ▒▓█▓▒▒▒      ██
██  ▒███▓▓▓█▓▓▓▓▓▓▓▓▓████▓▒   ██
██  ▒█▓▓▒▒▒▓▓▓▓▓▓▓▓▓▓▒▒▓▓██▒  ██
██  ▒██▓▓▓▓▓▓▓▓▓▓▓▓▓▒▓▓▓▒▓█▒  ██
██   ▒▒▓█▒▓▓▒▓▓▓▓▓▓▓██▒█▓▒█   ██
██      ▓█▓▒         ▓▓▓      ██
██                            ██
▀██▄                        ▄██▀
▀██▄                    ▄██▀
▀███▄              ▄███▀
▀████▄        ▄████▀
▀█████▄  ▄█████▀
▀▀██████▀▀
▀▀
TrustedCars
Flex




























Changing Car Ownership Forever
√ Commitment free               √ Transparent
√ Affordable for everybody  √ Paperless














Whitepaper
Lightpaper
ANN Thread
Facebook
Twitter
Telegram
▄▄██████▄▄
▄█████▀  ▀█████▄
▄████▀        ▀████▄
▄███▀              ▀███▄
▄██▀                    ▀██▄
▄██▀                        ▀██▄
██        ▒▓▓▓▓▓▒▒            ██
██      ▒▓▓▒▓█▓ ▒▓▓▓          ██
██   ▒▒▓█▓▒ ▒▓▓  ▒▓█▓▒▒▒      ██
██  ▒███▓▓▓█▓▓▓▓▓▓▓▓▓████▓▒   ██
██  ▒█▓▓▒▒▒▓▓▓▓▓▓▓▓▓▓▒▒▓▓██▒  ██
██  ▒██▓▓▓▓▓▓▓▓▓▓▓▓▓▒▓▓▓▒▓█▒  ██
██   ▒▒▓█▒▓▓▒▓▓▓▓▓▓▓██▒█▓▒█   ██
██      ▓█▓▒         ▓▓▓      ██
██                            ██
▀██▄                        ▄██▀
▀██▄                    ▄██▀
▀███▄              ▄███▀
▀████▄        ▄████▀
▀█████▄  ▄█████▀
▀▀██████▀▀
▀▀
★★★★★
Buchi-88
Legendary
*
Offline Offline

Activity: 1764
Merit: 1038


Changing Car Ownership forever


View Profile
January 18, 2016, 11:03:35 AM
 #12

Seit einiger Zeit habe ich immer wieder "Hänger" einfrieren des Pis mit Cgminer (Watchdog und jeweilige Neustarts sind für mich keine Option), hat da schon jemand etwas gefunden das Cgminer auf dem Pi sauber 24/7 läuft???

Stromversorgung der USB Miner ist kein Problem habe einen 20A HUB...

Früher hat bei mir das geholfen...

Quote
Raspberry Pi is locking up when running CGMiner

If your RPi is freezing randomly after some time (could be minutes, could be hours or days) with error like Oops: PREEMPT ARM, CPU0 Not tainted printed out over HDMI, and with locked up ethernet and USB interfaces, you have to add following option to the /boot/cmdline.txt file on SD card:

slub_debug=FP

Make sure you do not add that option to the new line if some other options are already present in that file. Always paste it behind all other options delimited with space. Also, before editing, make sure your /boot partition is mounted by issuing this command:

leider jetzt auch irgendwie nicht mehr... eventuell jemand die gleichen Probleme?


★★★★★
▄▄██████▄▄
▄█████▀  ▀█████▄
▄████▀        ▀████▄
▄███▀              ▀███▄
▄██▀                    ▀██▄
▄██▀                        ▀██▄
██        ▒▓▓▓▓▓▒▒            ██
██      ▒▓▓▒▓█▓ ▒▓▓▓          ██
██   ▒▒▓█▓▒ ▒▓▓  ▒▓█▓▒▒▒      ██
██  ▒███▓▓▓█▓▓▓▓▓▓▓▓▓████▓▒   ██
██  ▒█▓▓▒▒▒▓▓▓▓▓▓▓▓▓▓▒▒▓▓██▒  ██
██  ▒██▓▓▓▓▓▓▓▓▓▓▓▓▓▒▓▓▓▒▓█▒  ██
██   ▒▒▓█▒▓▓▒▓▓▓▓▓▓▓██▒█▓▒█   ██
██      ▓█▓▒         ▓▓▓      ██
██                            ██
▀██▄                        ▄██▀
▀██▄                    ▄██▀
▀███▄              ▄███▀
▀████▄        ▄████▀
▀█████▄  ▄█████▀
▀▀██████▀▀
▀▀
TrustedCars
Flex




























Changing Car Ownership Forever
√ Commitment free               √ Transparent
√ Affordable for everybody  √ Paperless














Whitepaper
Lightpaper
ANN Thread
Facebook
Twitter
Telegram
▄▄██████▄▄
▄█████▀  ▀█████▄
▄████▀        ▀████▄
▄███▀              ▀███▄
▄██▀                    ▀██▄
▄██▀                        ▀██▄
██        ▒▓▓▓▓▓▒▒            ██
██      ▒▓▓▒▓█▓ ▒▓▓▓          ██
██   ▒▒▓█▓▒ ▒▓▓  ▒▓█▓▒▒▒      ██
██  ▒███▓▓▓█▓▓▓▓▓▓▓▓▓████▓▒   ██
██  ▒█▓▓▒▒▒▓▓▓▓▓▓▓▓▓▓▒▒▓▓██▒  ██
██  ▒██▓▓▓▓▓▓▓▓▓▓▓▓▓▒▓▓▓▒▓█▒  ██
██   ▒▒▓█▒▓▓▒▓▓▓▓▓▓▓██▒█▓▒█   ██
██      ▓█▓▒         ▓▓▓      ██
██                            ██
▀██▄                        ▄██▀
▀██▄                    ▄██▀
▀███▄              ▄███▀
▀████▄        ▄████▀
▀█████▄  ▄█████▀
▀▀██████▀▀
▀▀
★★★★★
o_solo_miner
Legendary
*
Offline Offline

Activity: 977
Merit: 1003


-> morgen, ist heute, schon gestern <-


View Profile
January 18, 2016, 12:17:33 PM
 #13

Hallo,
ich habe den Firmware upgrade gemacht und die usblib-dev installiert und es läuft nun seit Monaten.
Allerdings mit einem U2.

Außerdem sollte man unter /boot noch die config.txt um diesen Eintrag erweitern:
max_usb_current=1
einfach am Ende Eintragen und den Pi mit reboot neu starten!

Getestet mit cgminer 4.9.2 und Raspi B+ sowie Raspi2 B.

viel Erfolg


EDIT: Mein Raspi B ohne Plus erkennt jedoch einige U1/2 nicht, bzw. einen als Ux und den nächsten als
U3 !! Dann meldet cgminer natürlich Fehler und zeigt an das er einen "U3" auf 225 MHz der mit 770 mV läuft
erkannt hat.
Das habe ich auch nicht lösen können!

http://ckpool.org "THE Pool" from the creator of CGMiner & CKPool / Payout System:SPLNS / ZERO FEE!
------------------------------------------- join now -----------------------------------------------
http://solo.ckpool.org for Solominers with the best block notify system
Buchi-88
Legendary
*
Offline Offline

Activity: 1764
Merit: 1038


Changing Car Ownership forever


View Profile
January 18, 2016, 12:37:26 PM
 #14

Hallo,
ich habe den Firmware upgrade gemacht und die usblib-dev installiert und es läuft nun seit Monaten.
Allerdings mit einem U2.

Außerdem sollte man unter /boot noch die config.txt um diesen Eintrag erweitern:
max_usb_current=1
einfach am Ende Eintragen und den Pi mit reboot neu starten!

Getestet mit cgminer 4.9.2 und Raspi B+ sowie Raspi2 B.

viel Erfolg


EDIT: Mein Raspi B ohne Plus erkennt jedoch einige U1/2 nicht, bzw. einen als Ux und den nächsten als
U3 !! Dann meldet cgminer natürlich Fehler und zeigt an das er einen "U3" auf 225 MHz der mit 770 mV läuft
erkannt hat.
Das habe ich auch nicht lösen können!

Danke ich werde versuchen die "usblib-dev" zu deinstallieren und noch einmal neu zu installieren, DANKE

★★★★★
▄▄██████▄▄
▄█████▀  ▀█████▄
▄████▀        ▀████▄
▄███▀              ▀███▄
▄██▀                    ▀██▄
▄██▀                        ▀██▄
██        ▒▓▓▓▓▓▒▒            ██
██      ▒▓▓▒▓█▓ ▒▓▓▓          ██
██   ▒▒▓█▓▒ ▒▓▓  ▒▓█▓▒▒▒      ██
██  ▒███▓▓▓█▓▓▓▓▓▓▓▓▓████▓▒   ██
██  ▒█▓▓▒▒▒▓▓▓▓▓▓▓▓▓▓▒▒▓▓██▒  ██
██  ▒██▓▓▓▓▓▓▓▓▓▓▓▓▓▒▓▓▓▒▓█▒  ██
██   ▒▒▓█▒▓▓▒▓▓▓▓▓▓▓██▒█▓▒█   ██
██      ▓█▓▒         ▓▓▓      ██
██                            ██
▀██▄                        ▄██▀
▀██▄                    ▄██▀
▀███▄              ▄███▀
▀████▄        ▄████▀
▀█████▄  ▄█████▀
▀▀██████▀▀
▀▀
TrustedCars
Flex




























Changing Car Ownership Forever
√ Commitment free               √ Transparent
√ Affordable for everybody  √ Paperless














Whitepaper
Lightpaper
ANN Thread
Facebook
Twitter
Telegram
▄▄██████▄▄
▄█████▀  ▀█████▄
▄████▀        ▀████▄
▄███▀              ▀███▄
▄██▀                    ▀██▄
▄██▀                        ▀██▄
██        ▒▓▓▓▓▓▒▒            ██
██      ▒▓▓▒▓█▓ ▒▓▓▓          ██
██   ▒▒▓█▓▒ ▒▓▓  ▒▓█▓▒▒▒      ██
██  ▒███▓▓▓█▓▓▓▓▓▓▓▓▓████▓▒   ██
██  ▒█▓▓▒▒▒▓▓▓▓▓▓▓▓▓▓▒▒▓▓██▒  ██
██  ▒██▓▓▓▓▓▓▓▓▓▓▓▓▓▒▓▓▓▒▓█▒  ██
██   ▒▒▓█▒▓▓▒▓▓▓▓▓▓▓██▒█▓▒█   ██
██      ▓█▓▒         ▓▓▓      ██
██                            ██
▀██▄                        ▄██▀
▀██▄                    ▄██▀
▀███▄              ▄███▀
▀████▄        ▄████▀
▀█████▄  ▄█████▀
▀▀██████▀▀
▀▀
★★★★★
Buchi-88
Legendary
*
Offline Offline

Activity: 1764
Merit: 1038


Changing Car Ownership forever


View Profile
January 18, 2016, 07:15:57 PM
 #15

Hat leider überhaupt ncihts gebracht der Pi hat sich innerhalb kürzester Zeit auf-gehangen...  Angry Angry Angry

★★★★★
▄▄██████▄▄
▄█████▀  ▀█████▄
▄████▀        ▀████▄
▄███▀              ▀███▄
▄██▀                    ▀██▄
▄██▀                        ▀██▄
██        ▒▓▓▓▓▓▒▒            ██
██      ▒▓▓▒▓█▓ ▒▓▓▓          ██
██   ▒▒▓█▓▒ ▒▓▓  ▒▓█▓▒▒▒      ██
██  ▒███▓▓▓█▓▓▓▓▓▓▓▓▓████▓▒   ██
██  ▒█▓▓▒▒▒▓▓▓▓▓▓▓▓▓▓▒▒▓▓██▒  ██
██  ▒██▓▓▓▓▓▓▓▓▓▓▓▓▓▒▓▓▓▒▓█▒  ██
██   ▒▒▓█▒▓▓▒▓▓▓▓▓▓▓██▒█▓▒█   ██
██      ▓█▓▒         ▓▓▓      ██
██                            ██
▀██▄                        ▄██▀
▀██▄                    ▄██▀
▀███▄              ▄███▀
▀████▄        ▄████▀
▀█████▄  ▄█████▀
▀▀██████▀▀
▀▀
TrustedCars
Flex




























Changing Car Ownership Forever
√ Commitment free               √ Transparent
√ Affordable for everybody  √ Paperless














Whitepaper
Lightpaper
ANN Thread
Facebook
Twitter
Telegram
▄▄██████▄▄
▄█████▀  ▀█████▄
▄████▀        ▀████▄
▄███▀              ▀███▄
▄██▀                    ▀██▄
▄██▀                        ▀██▄
██        ▒▓▓▓▓▓▒▒            ██
██      ▒▓▓▒▓█▓ ▒▓▓▓          ██
██   ▒▒▓█▓▒ ▒▓▓  ▒▓█▓▒▒▒      ██
██  ▒███▓▓▓█▓▓▓▓▓▓▓▓▓████▓▒   ██
██  ▒█▓▓▒▒▒▓▓▓▓▓▓▓▓▓▓▒▒▓▓██▒  ██
██  ▒██▓▓▓▓▓▓▓▓▓▓▓▓▓▒▓▓▓▒▓█▒  ██
██   ▒▒▓█▒▓▓▒▓▓▓▓▓▓▓██▒█▓▒█   ██
██      ▓█▓▒         ▓▓▓      ██
██                            ██
▀██▄                        ▄██▀
▀██▄                    ▄██▀
▀███▄              ▄███▀
▀████▄        ▄████▀
▀█████▄  ▄█████▀
▀▀██████▀▀
▀▀
★★★★★
o_solo_miner
Legendary
*
Offline Offline

Activity: 977
Merit: 1003


-> morgen, ist heute, schon gestern <-


View Profile
January 19, 2016, 04:02:26 PM
 #16

startest du mit --usb x.x?

EDIT:
Mein Problem mit dem alten Raspi (RaspiB) ist nun gelöst!
Ich habe einen neuen USB-Hub verwendet, es scheint so zu sein das obwohl der
Raspi den Strom bringen kann (max-current=1) es wohl nicht so gut läuft!
Mit dem Hub funktioniert es nun Fehlerfrei!

http://ckpool.org "THE Pool" from the creator of CGMiner & CKPool / Payout System:SPLNS / ZERO FEE!
------------------------------------------- join now -----------------------------------------------
http://solo.ckpool.org for Solominers with the best block notify system
Buchi-88
Legendary
*
Offline Offline

Activity: 1764
Merit: 1038


Changing Car Ownership forever


View Profile
January 19, 2016, 04:54:26 PM
 #17

startest du mit --usb x.x?

EDIT:
Mein Problem mit dem alten Raspi (RaspiB) ist nun gelöst!
Ich habe einen neuen USB-Hub verwendet, es scheint so zu sein das obwohl der
Raspi den Strom bringen kann (max-current=1) es wohl nicht so gut läuft!
Mit dem Hub funktioniert es nun Fehlerfrei!

Ich starte mit diesem Befehl in der Config,

"usb" : ":9"

aber ich bin jetzt wieder auf den bfgminer zurück da der einfach funktioniert  Cool am HUB sollte es nicht liegen da der 20A hat...

Irgendetwas verträgt sich da nciht mit dem cgminer... Oscam mit der Easymouse oder Sunwatch mit dem Bluetoothstick...

★★★★★
▄▄██████▄▄
▄█████▀  ▀█████▄
▄████▀        ▀████▄
▄███▀              ▀███▄
▄██▀                    ▀██▄
▄██▀                        ▀██▄
██        ▒▓▓▓▓▓▒▒            ██
██      ▒▓▓▒▓█▓ ▒▓▓▓          ██
██   ▒▒▓█▓▒ ▒▓▓  ▒▓█▓▒▒▒      ██
██  ▒███▓▓▓█▓▓▓▓▓▓▓▓▓████▓▒   ██
██  ▒█▓▓▒▒▒▓▓▓▓▓▓▓▓▓▓▒▒▓▓██▒  ██
██  ▒██▓▓▓▓▓▓▓▓▓▓▓▓▓▒▓▓▓▒▓█▒  ██
██   ▒▒▓█▒▓▓▒▓▓▓▓▓▓▓██▒█▓▒█   ██
██      ▓█▓▒         ▓▓▓      ██
██                            ██
▀██▄                        ▄██▀
▀██▄                    ▄██▀
▀███▄              ▄███▀
▀████▄        ▄████▀
▀█████▄  ▄█████▀
▀▀██████▀▀
▀▀
TrustedCars
Flex




























Changing Car Ownership Forever
√ Commitment free               √ Transparent
√ Affordable for everybody  √ Paperless














Whitepaper
Lightpaper
ANN Thread
Facebook
Twitter
Telegram
▄▄██████▄▄
▄█████▀  ▀█████▄
▄████▀        ▀████▄
▄███▀              ▀███▄
▄██▀                    ▀██▄
▄██▀                        ▀██▄
██        ▒▓▓▓▓▓▒▒            ██
██      ▒▓▓▒▓█▓ ▒▓▓▓          ██
██   ▒▒▓█▓▒ ▒▓▓  ▒▓█▓▒▒▒      ██
██  ▒███▓▓▓█▓▓▓▓▓▓▓▓▓████▓▒   ██
██  ▒█▓▓▒▒▒▓▓▓▓▓▓▓▓▓▓▒▒▓▓██▒  ██
██  ▒██▓▓▓▓▓▓▓▓▓▓▓▓▓▒▓▓▓▒▓█▒  ██
██   ▒▒▓█▒▓▓▒▓▓▓▓▓▓▓██▒█▓▒█   ██
██      ▓█▓▒         ▓▓▓      ██
██                            ██
▀██▄                        ▄██▀
▀██▄                    ▄██▀
▀███▄              ▄███▀
▀████▄        ▄████▀
▀█████▄  ▄█████▀
▀▀██████▀▀
▀▀
★★★★★
Pages: [1]
  Print  
 
Jump to:  

Sponsored by , a Bitcoin-accepting VPN.
Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2006-2009, Simple Machines Valid XHTML 1.0! Valid CSS!