Bitcoin Forum
May 24, 2019, 12:15:30 PM *
News: Latest Bitcoin Core release: 0.18.0 [Torrent] (New!)
 
   Home   Help Search Login Register More  
Pages: [1]
  Print  
Author Topic: Armory issue on Ubuntu  (Read 3350 times)
davidspitzer
Hero Member
*****
Offline Offline

Activity: 615
Merit: 500


View Profile
February 11, 2013, 11:28:21 PM
 #1

Any help would be appreciatted - I installed Swig and Python and compiled all of the armory files when i try to run it I get this : (im not sure what package to install to get the CppBlockUtils module)

python BitcoinArmory/ArmoryQt.py

Traceback (most recent call last):
  File "ArmoryQt.py", line 34, in <module>
    from armoryengine import *
  File "/home/david/BitcoinArmory/armoryengine.py", line 728, in <module>
    import CppBlockUtils as Cpp
ImportError: No module named CppBlockUtils

Error in sys.excepthook:
Traceback (most recent call last):
  File "/home/david/BitcoinArmory/armoryengine.py", line 559, in logexcept_override
    sys.__excepthook__(type, value, tback)
AttributeError: 'NoneType' object has no attribute '__excepthook__'

Original exception was:
Traceback (most recent call last):
  File "ArmoryQt.py", line 34, in <module>
    from armoryengine import *
  File "/home/david/BitcoinArmory/armoryengine.py", line 728, in <module>
    import CppBlockUtils as Cpp
ImportError: No module named CppBlockUtils



1558700130
Hero Member
*
Offline Offline

Posts: 1558700130

View Profile Personal Message (Offline)

Ignore
1558700130
Reply with quote  #2

1558700130
Report to moderator
PLAY OVER 3000 GAMES
LIGHTNING FAST WITHDRAWALS
PLAY NOW
Advertised sites are not endorsed by the Bitcoin Forum. They may be unsafe, untrustworthy, or illegal in your jurisdiction. Advertise here.
1558700130
Hero Member
*
Offline Offline

Posts: 1558700130

View Profile Personal Message (Offline)

Ignore
1558700130
Reply with quote  #2

1558700130
Report to moderator
1558700130
Hero Member
*
Offline Offline

Posts: 1558700130

View Profile Personal Message (Offline)

Ignore
1558700130
Reply with quote  #2

1558700130
Report to moderator
davidspitzer
Hero Member
*****
Offline Offline

Activity: 615
Merit: 500


View Profile
February 11, 2013, 11:34:05 PM
 #2

Any help would be appreciatted - I installed Swig and Python and compiled all of the armory files when i try to run it I get this : (im not sure what package to install to get the CppBlockUtils module)

python BitcoinArmory/ArmoryQt.py

Traceback (most recent call last):
  File "ArmoryQt.py", line 34, in <module>
    from armoryengine import *
  File "/home/david/BitcoinArmory/armoryengine.py", line 728, in <module>
    import CppBlockUtils as Cpp
ImportError: No module named CppBlockUtils

Error in sys.excepthook:
Traceback (most recent call last):
  File "/home/david/BitcoinArmory/armoryengine.py", line 559, in logexcept_override
    sys.__excepthook__(type, value, tback)
AttributeError: 'NoneType' object has no attribute '__excepthook__'

Original exception was:
Traceback (most recent call last):
  File "ArmoryQt.py", line 34, in <module>
    from armoryengine import *
  File "/home/david/BitcoinArmory/armoryengine.py", line 728, in <module>
    import CppBlockUtils as Cpp
ImportError: No module named CppBlockUtils






there is a cppForSwig folder under the armory folder with these files in it

/home/david/BitcoinArmory/cppForSwig/cryptopp
/home/david/BitcoinArmory/cppForSwig/reorgTest
/home/david/BitcoinArmory/cppForSwig/ArmoryEngine_MSVS2005.sln
/home/david/BitcoinArmory/cppForSwig/ArmoryEngine_MSVS2005.vcproj
/home/david/BitcoinArmory/cppForSwig/BinaryData.cpp
/home/david/BitcoinArmory/cppForSwig/BinaryData.h
/home/david/BitcoinArmory/cppForSwig/BinaryData.o
/home/david/BitcoinArmory/cppForSwig/BlockObj.cpp
/home/david/BitcoinArmory/cppForSwig/BlockObj.h
/home/david/BitcoinArmory/cppForSwig/BlockObj.o
/home/david/BitcoinArmory/cppForSwig/BlockUtils.cpp
/home/david/BitcoinArmory/cppForSwig/BlockUtils.h
/home/david/BitcoinArmory/cppForSwig/BlockUtils.o
/home/david/BitcoinArmory/cppForSwig/BlockUtilsTest.cpp
/home/david/BitcoinArmory/cppForSwig/BtcUtils.cpp
/home/david/BitcoinArmory/cppForSwig/BtcUtils.h
/home/david/BitcoinArmory/cppForSwig/BtcUtils.o
/home/david/BitcoinArmory/cppForSwig/CppBlockUtils.i
/home/david/BitcoinArmory/cppForSwig/EncryptionUtils.cpp
/home/david/BitcoinArmory/cppForSwig/EncryptionUtils.h
/home/david/BitcoinArmory/cppForSwig/EncryptionUtils.o
/home/david/BitcoinArmory/cppForSwig/FileDataPtr.cpp
/home/david/BitcoinArmory/cppForSwig/FileDataPtr.h
/home/david/BitcoinArmory/cppForSwig/FileDataPtr.o
/home/david/BitcoinArmory/cppForSwig/Makefile
/home/david/BitcoinArmory/cppForSwig/SWIG_compile_dll_MSVS2005.vcproj
/home/david/BitcoinArmory/cppForSwig/UniversalTimer.cpp
/home/david/BitcoinArmory/cppForSwig/UniversalTimer.h
/home/david/BitcoinArmory/cppForSwig/UniversalTimer.o
/home/david/BitcoinArmory/cppForSwig/testswig.py
etotheipi
Legendary
*
Offline Offline

Activity: 1428
Merit: 1005


Core Armory Developer


View Profile WWW
February 12, 2013, 06:34:45 AM
 #3

By the way, there's an Armory subforum, so that is a good place for this.

The problem is that the C++ utilities weren't compiled, or failed to compile.  That's why you get that error.  If you type "make" from the base BitcoinArmory directory and you have all the correct dependencies, then it will compile and put CppBlockUtils.py and _CppBlockUtils.so into the correct place to run "python ArmoryQt.py.

However, two things:

(1)  If you just want to run Armory (as opposed to modifying it, etc), you can just download the .deb posted on the Get Armory page.  Just double-click it after you download it, and it will find all the correct dependencies for you and put everything in the correct place.  This is the best option for using it, since it guarantees it will register itself to handle "bitcoin:" URLs.  No guarantee when you compile it yourself.  If you are concerned about authenticity, you can follow the directions at the bottom of the Get Armory page to verify it is signed by my offline signing key.
(2) If you do want to compile it yourself you should follow the directions on building Armory from source page.  Again, you can downlaod the GPG key from any keyserver and verify the signature on the latest Armory tag (v0.87-beta or v0.87.2-beta).  There's very few steps on that page, and they've worked very reliably on debian-based systems.


Founder and CEO of Armory Technologies, Inc.
Armory Bitcoin Wallet: Bringing cold storage to the average user!
Only use Armory software signed by the Armory Offline Signing Key (0x98832223)

Please donate to the Armory project by clicking here!    (or donate directly via 1QBDLYTDFHHZAABYSKGKPWKLSXZWCCJQBX -- yes, it's a real address!)
davidspitzer
Hero Member
*****
Offline Offline

Activity: 615
Merit: 500


View Profile
February 12, 2013, 06:39:26 AM
 #4

By the way, there's an Armory subforum, so that is a good place for this.

The problem is that the C++ utilities weren't compiled, or failed to compile.  That's why you get that error.  If you type "make" from the base BitcoinArmory directory and you have all the correct dependencies, then it will compile and put CppBlockUtils.py and _CppBlockUtils.so into the correct place to run "python ArmoryQt.py.

However, two things:

(1)  If you just want to run Armory (as opposed to modifying it, etc), you can just download the .deb posted on the Get Armory page.  Just double-click it after you download it, and it will find all the correct dependencies for you and put everything in the correct place.  This is the best option for using it, since it guarantees it will register itself to handle "bitcoin:" URLs.  No guarantee when you compile it yourself.  If you are concerned about authenticity, you can follow the directions at the bottom of the Get Armory page to verify it is signed by my offline signing key.
(2) If you do want to compile it yourself you should follow the directions on building Armory from source page.  Again, you can downlaod the GPG key from any keyserver and verify the signature on the latest Armory tag (v0.87-beta or v0.87.2-beta).  There's very few steps on that page, and they've worked very reliably on debian-based systems.



Im not sure that the precompiled distribution will work on an arm cpu laptop (samsung chromebook) if it will i will just try that. I did follow the directions on the page to download and compile my own version - I ran make in the armory directory  - all seemed to complete ok - Ill try it again if you think it would help though
etotheipi
Legendary
*
Offline Offline

Activity: 1428
Merit: 1005


Core Armory Developer


View Profile WWW
February 12, 2013, 09:07:13 AM
 #5

Im not sure that the precompiled distribution will work on an arm cpu laptop (samsung chromebook) if it will i will just try that. I did follow the directions on the page to download and compile my own version - I ran make in the armory directory  - all seemed to complete ok - Ill try it again if you think it would help though

Oh yeah.  The precompiled version probably won't work on ARM. 

But if it complains about no CppBlockUtils module, it means compliation didn't complete.  Next time you run "make", observe if it spits out any errors (there will be some warnings, but there shouldnt' be any errors).  If it finishes, check to see that you have a CppBlockUtils.py and _CppBlockUtils.so in the base BitcoinArmory directory.  My guess is that it just doesn't finish compiling and you didn't notice the error.

Founder and CEO of Armory Technologies, Inc.
Armory Bitcoin Wallet: Bringing cold storage to the average user!
Only use Armory software signed by the Armory Offline Signing Key (0x98832223)

Please donate to the Armory project by clicking here!    (or donate directly via 1QBDLYTDFHHZAABYSKGKPWKLSXZWCCJQBX -- yes, it's a real address!)
nnimmo
Newbie
*
Offline Offline

Activity: 21
Merit: 0



View Profile
December 22, 2013, 01:45:10 PM
 #6

i tried version 0.90-beta for ubuntu 12.04 and 0.90-beta for ubuntu 10.04. but it show "dependencies don't meet" python-twisted. my system is  ubuntu 12.10  32-bit  . are there any version fit for my system?
AussieHash
Hero Member
*****
Offline Offline

Activity: 688
Merit: 500



View Profile
December 23, 2014, 02:50:09 PM
 #7

Im not sure that the precompiled distribution will work on an arm cpu laptop (samsung chromebook) if it will i will just try that. I did follow the directions on the page to download and compile my own version - I ran make in the armory directory  - all seemed to complete ok - Ill try it again if you think it would help though

Oh yeah.  The precompiled version probably won't work on ARM.  

But if it complains about no CppBlockUtils module, it means compliation didn't complete.  Next time you run "make", observe if it spits out any errors (there will be some warnings, but there shouldnt' be any errors).  If it finishes, check to see that you have a CppBlockUtils.py and _CppBlockUtils.so in the base BitcoinArmory directory.  My guess is that it just doesn't finish compiling and you didn't notice the error.

I have the same issue on Raspian.

After

Code:
sudo apt-get install git-core build-essential pyqt4-dev-tools swig libqtcore4 libqt4-dev python-qt4 python-dev python-twisted python-psutil
git clone git://github.com/etotheipi/BitcoinArmory.git
cd BitcoinArmory
Code:
pi@raspberrypi ~/armory $ sudo apt-get install git-core build-essential pyqt4-dev-tools swig libqtcore4 libqt4-dev python-qt4 python-dev python-twisted python-psutil
Reading package lists... Done
Building dependency tree        
Reading state information... Done
build-essential is already the newest version.
git-core is already the newest version.
libqtcore4 is already the newest version.
libqtcore4 set to manually installed.
pyqt4-dev-tools is already the newest version.
python-dev is already the newest version.
python-qt4 is already the newest version.
The following extra packages will be installed:
  libgl1-mesa-dev libglu1-mesa-dev libpthread-stubs0 libpthread-stubs0-dev libqt4-dev-bin libqt4-opengl libqt4-opengl-dev libqt4-qt3support libqtwebkit-dev libx11-dev libx11-doc libxau-dev libxcb1-dev libxdmcp-dev libxext-dev
  mesa-common-dev python-crypto python-openssl python-pam python-pyasn1 python-twisted-bin python-twisted-conch python-twisted-core python-twisted-lore python-twisted-mail python-twisted-names python-twisted-news
  python-twisted-runner python-twisted-web python-twisted-words python-zope.interface qt4-linguist-tools qt4-qmake swig2.0 x11proto-core-dev x11proto-input-dev x11proto-kb-dev x11proto-xext-dev xorg-sgml-doctools xtrans-dev
Suggested packages:
  firebird-dev libmysqlclient-dev libpq-dev libsqlite0-dev libsqlite3-dev qt4-dev-tools qt4-doc unixodbc-dev libxcb-doc libxext-doc python-crypto-dbg python-crypto-doc python-openssl-doc python-openssl-dbg doc-base
  python-twisted-bin-dbg python-gtk2 python-glade2 python-qt3 python-wxgtk2.8 python-twisted-runner-dbg swig-doc swig-examples swig2.0-examples swig2.0-doc
The following NEW packages will be installed:
  libgl1-mesa-dev libglu1-mesa-dev libpthread-stubs0 libpthread-stubs0-dev libqt4-dev libqt4-dev-bin libqt4-opengl libqt4-opengl-dev libqt4-qt3support libqtwebkit-dev libx11-dev libx11-doc libxau-dev libxcb1-dev libxdmcp-dev
  libxext-dev mesa-common-dev python-crypto python-openssl python-pam python-psutil python-pyasn1 python-twisted python-twisted-bin python-twisted-conch python-twisted-core python-twisted-lore python-twisted-mail
  python-twisted-names python-twisted-news python-twisted-runner python-twisted-web python-twisted-words python-zope.interface qt4-linguist-tools qt4-qmake swig swig2.0 x11proto-core-dev x11proto-input-dev x11proto-kb-dev
  x11proto-xext-dev xorg-sgml-doctools xtrans-dev
0 upgraded, 44 newly installed, 0 to remove and 0 not upgraded.
Need to get 17.3 MB of archives.
After this operation, 72.0 MB of additional disk space will be used.
Do you want to continue [Y/n]? y
Get:1 http://mirrordirector.raspbian.org/raspbian/ wheezy/main libqt4-opengl armhf 4:4.8.2+dfsg-11+rpi1 [280 kB]
Get:2 http://mirrordirector.raspbian.org/raspbian/ wheezy/main libqt4-qt3support armhf 4:4.8.2+dfsg-11+rpi1 [882 kB]
Get:3 http://mirrordirector.raspbian.org/raspbian/ wheezy/main xorg-sgml-doctools all 1:1.10-1 [24.1 kB]
Get:4 http://mirrordirector.raspbian.org/raspbian/ wheezy/main x11proto-core-dev all 7.0.23-1 [774 kB]
Get:5 http://mirrordirector.raspbian.org/raspbian/ wheezy/main libxau-dev armhf 1:1.0.7-1 [21.0 kB]
Get:6 http://mirrordirector.raspbian.org/raspbian/ wheezy/main libxdmcp-dev armhf 1:1.1.1-1 [40.8 kB]
Get:7 http://mirrordirector.raspbian.org/raspbian/ wheezy/main x11proto-input-dev all 2.2-1 [172 kB]
Get:8 http://mirrordirector.raspbian.org/raspbian/ wheezy/main x11proto-kb-dev all 1.0.6-2 [269 kB]
Get:9 http://mirrordirector.raspbian.org/raspbian/ wheezy/main xtrans-dev all 1.2.7-1 [112 kB]
Get:10 http://mirrordirector.raspbian.org/raspbian/ wheezy/main libpthread-stubs0 armhf 0.3-3 [3,230 B]
Get:11 http://mirrordirector.raspbian.org/raspbian/ wheezy/main libpthread-stubs0-dev armhf 0.3-3 [3,996 B]                                                                                                                          
Get:12 http://mirrordirector.raspbian.org/raspbian/ wheezy/main libxcb1-dev armhf 1.8.1-2+deb7u1 [81.6 kB]                                                                                                                            
Get:13 http://mirrordirector.raspbian.org/raspbian/ wheezy/main libx11-dev armhf 2:1.5.0-1+deb7u1+wheezy [957 kB]                                                                                                                    
Get:14 http://mirrordirector.raspbian.org/raspbian/ wheezy/main mesa-common-dev armhf 8.0.5-4+deb7u2+rpi1 [278 kB]                                                                                                                    
Get:15 http://mirrordirector.raspbian.org/raspbian/ wheezy/main x11proto-xext-dev all 7.2.1-1 [273 kB]                                                                                                                                
Get:16 http://mirrordirector.raspbian.org/raspbian/ wheezy/main libxext-dev armhf 2:1.3.1-2+deb7u1 [108 kB]                                                                                                                          
Get:17 http://mirrordirector.raspbian.org/raspbian/ wheezy/main libgl1-mesa-dev armhf 8.0.5-4+deb7u2+rpi1 [32.8 kB]                                                                                                                  
Get:18 http://mirrordirector.raspbian.org/raspbian/ wheezy/main libglu1-mesa-dev armhf 8.0.5-4+deb7u2+rpi1 [193 kB]                                                                                                                  
Get:19 http://mirrordirector.raspbian.org/raspbian/ wheezy/main libqt4-dev-bin armhf 4:4.8.2+dfsg-11+rpi1 [1,382 kB]                                                                                                                  
Get:20 http://mirrordirector.raspbian.org/raspbian/ wheezy/main qt4-linguist-tools armhf 4:4.8.2+dfsg-11+rpi1 [721 kB]                                                                                                                
Get:21 http://mirrordirector.raspbian.org/raspbian/ wheezy/main qt4-qmake armhf 4:4.8.2+dfsg-11+rpi1 [1,111 kB]                                                                                                                      
Get:22 http://mirrordirector.raspbian.org/raspbian/ wheezy/main libqt4-dev armhf 4:4.8.2+dfsg-11+rpi1 [868 kB]                                                                                                                        
Get:23 http://mirrordirector.raspbian.org/raspbian/ wheezy/main libqt4-opengl-dev armhf 4:4.8.2+dfsg-11+rpi1 [62.6 kB]                                                                                                                
Get:24 http://mirrordirector.raspbian.org/raspbian/ wheezy/main libqtwebkit-dev armhf 2.2.1-5 [165 kB]                                                                                                                                
Get:25 http://mirrordirector.raspbian.org/raspbian/ wheezy/main libx11-doc all 2:1.5.0-1+deb7u1+wheezy [3,227 kB]                                                                                                                    
Get:26 http://mirrordirector.raspbian.org/raspbian/ wheezy/main python-crypto armhf 2.6-4+deb7u3 [522 kB]                                                                                                                            
Get:27 http://mirrordirector.raspbian.org/raspbian/ wheezy/main python-openssl armhf 0.13-2+rpi1+deb7u1 [152 kB]                                                                                                                      
Get:28 http://mirrordirector.raspbian.org/raspbian/ wheezy/main python-pam armhf 0.4.2-13 [12.3 kB]                                                                                                                                  
Get:29 http://mirrordirector.raspbian.org/raspbian/ wheezy/main python-psutil armhf 0.5.1-1 [54.4 kB]                                                                                                                                
Get:30 http://mirrordirector.raspbian.org/raspbian/ wheezy/main python-pyasn1 all 0.1.3-1 [51.4 kB]                                                                                                                                  
Get:31 http://mirrordirector.raspbian.org/raspbian/ wheezy/main python-twisted-bin armhf 12.0.0-1 [40.9 kB]                                                                                                                          
Get:32 http://mirrordirector.raspbian.org/raspbian/ wheezy/main python-zope.interface armhf 3.6.1-3 [139 kB]                                                                                                                          
Get:33 http://mirrordirector.raspbian.org/raspbian/ wheezy/main python-twisted-core all 12.0.0-1 [1,226 kB]                                                                                                                          
Get:34 http://mirrordirector.raspbian.org/raspbian/ wheezy/main python-twisted-web all 12.0.0-1 [459 kB]                                                                                                                              
Get:35 http://mirrordirector.raspbian.org/raspbian/ wheezy/main python-twisted-lore all 12.0.0-1 [107 kB]                                                                                                                            
Get:36 http://mirrordirector.raspbian.org/raspbian/ wheezy/main python-twisted-mail all 12.0.0-1 [199 kB]                                                                                                                            
Get:37 http://mirrordirector.raspbian.org/raspbian/ wheezy/main python-twisted-names all 12.0.0-1 [77.0 kB]                                                                                                                          
Get:38 http://mirrordirector.raspbian.org/raspbian/ wheezy/main python-twisted-news all 12.0.0-1 [28.9 kB]                                                                                                                            
Get:39 http://mirrordirector.raspbian.org/raspbian/ wheezy/main python-twisted-runner armhf 12.0.0-1 [25.4 kB]                                                                                                                        
Get:40 http://mirrordirector.raspbian.org/raspbian/ wheezy/main python-twisted-words all 12.0.0-1 [219 kB]                                                                                                                            
Get:41 http://mirrordirector.raspbian.org/raspbian/ wheezy/main swig2.0 armhf 2.0.7-3 [1,378 kB]                                                                                                                                      
Get:42 http://mirrordirector.raspbian.org/raspbian/ wheezy/main swig armhf 2.0.7-3 [277 kB]                                                                                                                                          
Get:43 http://mirrordirector.raspbian.org/raspbian/ wheezy/main python-twisted-conch all 1:12.0.0-1 [279 kB]                                                                                                                          
Get:44 http://mirrordirector.raspbian.org/raspbian/ wheezy/main python-twisted all 12.0.0-1 [10.9 kB]                                                                                                                                
Fetched 17.3 MB in 31s (552 kB/s)                                                                                                                                                                                                    
Extracting templates from packages: 100%
Selecting previously unselected package libqt4-opengl:armhf.
(Reading database ... 77836 files and directories currently installed.)
Unpacking libqt4-opengl:armhf (from .../libqt4-opengl_4%3a4.8.2+dfsg-11+rpi1_armhf.deb) ...
Selecting previously unselected package libqt4-qt3support:armhf.
Unpacking libqt4-qt3support:armhf (from .../libqt4-qt3support_4%3a4.8.2+dfsg-11+rpi1_armhf.deb) ...
Selecting previously unselected package xorg-sgml-doctools.
Unpacking xorg-sgml-doctools (from .../xorg-sgml-doctools_1%3a1.10-1_all.deb) ...
Selecting previously unselected package x11proto-core-dev.
Unpacking x11proto-core-dev (from .../x11proto-core-dev_7.0.23-1_all.deb) ...
Selecting previously unselected package libxau-dev:armhf.
Unpacking libxau-dev:armhf (from .../libxau-dev_1%3a1.0.7-1_armhf.deb) ...
Selecting previously unselected package libxdmcp-dev:armhf.
Unpacking libxdmcp-dev:armhf (from .../libxdmcp-dev_1%3a1.1.1-1_armhf.deb) ...
Selecting previously unselected package x11proto-input-dev.
Unpacking x11proto-input-dev (from .../x11proto-input-dev_2.2-1_all.deb) ...
Selecting previously unselected package x11proto-kb-dev.
Unpacking x11proto-kb-dev (from .../x11proto-kb-dev_1.0.6-2_all.deb) ...
Selecting previously unselected package xtrans-dev.
Unpacking xtrans-dev (from .../xtrans-dev_1.2.7-1_all.deb) ...
Selecting previously unselected package libpthread-stubs0:armhf.
Unpacking libpthread-stubs0:armhf (from .../libpthread-stubs0_0.3-3_armhf.deb) ...
Selecting previously unselected package libpthread-stubs0-dev:armhf.
Unpacking libpthread-stubs0-dev:armhf (from .../libpthread-stubs0-dev_0.3-3_armhf.deb) ...
Selecting previously unselected package libxcb1-dev:armhf.
Unpacking libxcb1-dev:armhf (from .../libxcb1-dev_1.8.1-2+deb7u1_armhf.deb) ...
Selecting previously unselected package libx11-dev:armhf.
Unpacking libx11-dev:armhf (from .../libx11-dev_2%3a1.5.0-1+deb7u1+wheezy_armhf.deb) ...
Selecting previously unselected package mesa-common-dev.
Unpacking mesa-common-dev (from .../mesa-common-dev_8.0.5-4+deb7u2+rpi1_armhf.deb) ...
Selecting previously unselected package x11proto-xext-dev.
Unpacking x11proto-xext-dev (from .../x11proto-xext-dev_7.2.1-1_all.deb) ...
Selecting previously unselected package libxext-dev:armhf.
Unpacking libxext-dev:armhf (from .../libxext-dev_2%3a1.3.1-2+deb7u1_armhf.deb) ...
Selecting previously unselected package libgl1-mesa-dev.
Unpacking libgl1-mesa-dev (from .../libgl1-mesa-dev_8.0.5-4+deb7u2+rpi1_armhf.deb) ...
Selecting previously unselected package libglu1-mesa-dev.
Unpacking libglu1-mesa-dev (from .../libglu1-mesa-dev_8.0.5-4+deb7u2+rpi1_armhf.deb) ...
Selecting previously unselected package libqt4-dev-bin.
Unpacking libqt4-dev-bin (from .../libqt4-dev-bin_4%3a4.8.2+dfsg-11+rpi1_armhf.deb) ...
Selecting previously unselected package qt4-linguist-tools.
Unpacking qt4-linguist-tools (from .../qt4-linguist-tools_4%3a4.8.2+dfsg-11+rpi1_armhf.deb) ...
Selecting previously unselected package qt4-qmake.
Unpacking qt4-qmake (from .../qt4-qmake_4%3a4.8.2+dfsg-11+rpi1_armhf.deb) ...
Selecting previously unselected package libqt4-dev.
Unpacking libqt4-dev (from .../libqt4-dev_4%3a4.8.2+dfsg-11+rpi1_armhf.deb) ...
Selecting previously unselected package libqt4-opengl-dev.
Unpacking libqt4-opengl-dev (from .../libqt4-opengl-dev_4%3a4.8.2+dfsg-11+rpi1_armhf.deb) ...
Selecting previously unselected package libqtwebkit-dev.
Unpacking libqtwebkit-dev (from .../libqtwebkit-dev_2.2.1-5_armhf.deb) ...
Selecting previously unselected package libx11-doc.
Unpacking libx11-doc (from .../libx11-doc_2%3a1.5.0-1+deb7u1+wheezy_all.deb) ...
Selecting previously unselected package python-crypto.
Unpacking python-crypto (from .../python-crypto_2.6-4+deb7u3_armhf.deb) ...
Selecting previously unselected package python-openssl.
Unpacking python-openssl (from .../python-openssl_0.13-2+rpi1+deb7u1_armhf.deb) ...
Selecting previously unselected package python-pam.
Unpacking python-pam (from .../python-pam_0.4.2-13_armhf.deb) ...
Selecting previously unselected package python-psutil.
Unpacking python-psutil (from .../python-psutil_0.5.1-1_armhf.deb) ...
Selecting previously unselected package python-pyasn1.
Unpacking python-pyasn1 (from .../python-pyasn1_0.1.3-1_all.deb) ...
Selecting previously unselected package python-twisted-bin.
Unpacking python-twisted-bin (from .../python-twisted-bin_12.0.0-1_armhf.deb) ...
Selecting previously unselected package python-zope.interface.
Unpacking python-zope.interface (from .../python-zope.interface_3.6.1-3_armhf.deb) ...
Selecting previously unselected package python-twisted-core.
Unpacking python-twisted-core (from .../python-twisted-core_12.0.0-1_all.deb) ...
Selecting previously unselected package python-twisted-web.
Unpacking python-twisted-web (from .../python-twisted-web_12.0.0-1_all.deb) ...
Selecting previously unselected package python-twisted-lore.
Unpacking python-twisted-lore (from .../python-twisted-lore_12.0.0-1_all.deb) ...
Selecting previously unselected package python-twisted-mail.
Unpacking python-twisted-mail (from .../python-twisted-mail_12.0.0-1_all.deb) ...
Selecting previously unselected package python-twisted-names.
Unpacking python-twisted-names (from .../python-twisted-names_12.0.0-1_all.deb) ...
Selecting previously unselected package python-twisted-news.
Unpacking python-twisted-news (from .../python-twisted-news_12.0.0-1_all.deb) ...
Selecting previously unselected package python-twisted-runner.
Unpacking python-twisted-runner (from .../python-twisted-runner_12.0.0-1_armhf.deb) ...
Selecting previously unselected package python-twisted-words.
Unpacking python-twisted-words (from .../python-twisted-words_12.0.0-1_all.deb) ...
Selecting previously unselected package swig2.0.
Unpacking swig2.0 (from .../swig2.0_2.0.7-3_armhf.deb) ...
Selecting previously unselected package swig.
Unpacking swig (from .../swig_2.0.7-3_armhf.deb) ...
Selecting previously unselected package python-twisted-conch.
Unpacking python-twisted-conch (from .../python-twisted-conch_1%3a12.0.0-1_all.deb) ...
Selecting previously unselected package python-twisted.
Unpacking python-twisted (from .../python-twisted_12.0.0-1_all.deb) ...
Processing triggers for man-db ...
Processing triggers for menu ...
Setting up libqt4-opengl:armhf (4:4.8.2+dfsg-11+rpi1) ...
Setting up libqt4-qt3support:armhf (4:4.8.2+dfsg-11+rpi1) ...
Setting up xorg-sgml-doctools (1:1.10-1) ...
Setting up x11proto-core-dev (7.0.23-1) ...
Setting up libxau-dev:armhf (1:1.0.7-1) ...
Setting up libxdmcp-dev:armhf (1:1.1.1-1) ...
Setting up x11proto-input-dev (2.2-1) ...
Setting up x11proto-kb-dev (1.0.6-2) ...
Setting up xtrans-dev (1.2.7-1) ...
Setting up libpthread-stubs0:armhf (0.3-3) ...
Setting up libpthread-stubs0-dev:armhf (0.3-3) ...
Setting up libxcb1-dev:armhf (1.8.1-2+deb7u1) ...
Setting up libx11-dev:armhf (2:1.5.0-1+deb7u1+wheezy) ...
Setting up mesa-common-dev (8.0.5-4+deb7u2+rpi1) ...
Setting up x11proto-xext-dev (7.2.1-1) ...
Setting up libxext-dev:armhf (2:1.3.1-2+deb7u1) ...
Setting up libgl1-mesa-dev (8.0.5-4+deb7u2+rpi1) ...
Setting up libglu1-mesa-dev (8.0.5-4+deb7u2+rpi1) ...
Setting up libqt4-dev-bin (4:4.8.2+dfsg-11+rpi1) ...
update-alternatives: using /usr/bin/moc-qt4 to provide /usr/bin/moc (moc) in auto mode
update-alternatives: using /usr/bin/uic-qt4 to provide /usr/bin/uic (uic) in auto mode
update-alternatives: warning: skip creation of /usr/share/man/man1/uic.1.gz because associated file /usr/share/man/man1/uic-qt4.1.gz (of link group uic) doesn't exist
Setting up qt4-linguist-tools (4:4.8.2+dfsg-11+rpi1) ...
update-alternatives: using /usr/bin/lupdate-qt4 to provide /usr/bin/lupdate (lupdate) in auto mode
update-alternatives: using /usr/bin/lrelease-qt4 to provide /usr/bin/lrelease (lrelease) in auto mode
Setting up qt4-qmake (4:4.8.2+dfsg-11+rpi1) ...
update-alternatives: using /usr/bin/qmake-qt4 to provide /usr/bin/qmake (qmake) in auto mode
Setting up libqt4-dev (4:4.8.2+dfsg-11+rpi1) ...
Setting up libqt4-opengl-dev (4:4.8.2+dfsg-11+rpi1) ...
Setting up libqtwebkit-dev (2.2.1-5) ...
Setting up libx11-doc (2:1.5.0-1+deb7u1+wheezy) ...
Setting up python-crypto (2.6-4+deb7u3) ...
Setting up python-openssl (0.13-2+rpi1+deb7u1) ...
Setting up python-pam (0.4.2-13) ...
Setting up python-psutil (0.5.1-1) ...
Setting up python-pyasn1 (0.1.3-1) ...
Setting up python-twisted-bin (12.0.0-1) ...
Setting up python-zope.interface (3.6.1-3) ...
Setting up python-twisted-core (12.0.0-1) ...
Setting up python-twisted-web (12.0.0-1) ...
Setting up python-twisted-lore (12.0.0-1) ...
Setting up python-twisted-mail (12.0.0-1) ...
Setting up python-twisted-names (12.0.0-1) ...
Setting up python-twisted-news (12.0.0-1) ...
Setting up python-twisted-runner (12.0.0-1) ...
Setting up python-twisted-words (12.0.0-1) ...
Setting up swig2.0 (2.0.7-3) ...
Setting up swig (2.0.7-3) ...
Setting up python-twisted-conch (1:12.0.0-1) ...
Processing triggers for python-twisted-core ...
Setting up python-twisted (12.0.0-1) ...
Processing triggers for python-support ...
Processing triggers for menu ...
pi@raspberrypi ~/armory $ ls -l
total 21692
-rw-r--r-- 1 pi pi 22205388 Oct  4 03:41 armory_0.92.3_rpi_bundle.tar.gz
drwxr-xr-x 2 pi pi     4096 Dec 23 08:50 OfflineBundle
pi@raspberrypi ~/armory $ git clone git://github.com/etotheipi/BitcoinArmory.git
Cloning into 'BitcoinArmory'...
remote: Counting objects: 20113, done.
remote: Compressing objects: 100% (44/44), done.
remote: Total 20113 (delta 12), reused 0 (delta 0)
Receiving objects: 100% (20113/20113), 68.76 MiB | 1.14 MiB/s, done.
Resolving deltas: 100% (14879/14879), done.
Checking out files: 100% (884/884), done.
pi@raspberrypi ~/armory $ cd BitcoinArmory

I reached the make step

Code:
pi@raspberrypi ~/armory/BitcoinArmory $ make
make -C cppForSwig
make[1]: Entering directory '/home/pi/armory/BitcoinArmory/cppForSwig'
g++  -Icryptopp -Ileveldb/include -DUSE_CRYPTOPP -D__STDC_LIMIT_MACROS -O2 -pipe -fPIC -c UniversalTimer.cpp
g++  -Icryptopp -Ileveldb/include -DUSE_CRYPTOPP -D__STDC_LIMIT_MACROS -O2 -pipe -fPIC -c BinaryData.cpp
g++  -Icryptopp -Ileveldb/include -DUSE_CRYPTOPP -D__STDC_LIMIT_MACROS -O2 -pipe -fPIC -c leveldb_wrapper.cpp
g++  -Icryptopp -Ileveldb/include -DUSE_CRYPTOPP -D__STDC_LIMIT_MACROS -O2 -pipe -fPIC -c StoredBlockObj.cpp
g++  -Icryptopp -Ileveldb/include -DUSE_CRYPTOPP -D__STDC_LIMIT_MACROS -O2 -pipe -fPIC -c BtcUtils.cpp
g++  -Icryptopp -Ileveldb/include -DUSE_CRYPTOPP -D__STDC_LIMIT_MACROS -O2 -pipe -fPIC -c BlockObj.cpp
g++  -Icryptopp -Ileveldb/include -DUSE_CRYPTOPP -D__STDC_LIMIT_MACROS -O2 -pipe -fPIC -c BlockUtils.cpp
g++  -Icryptopp -Ileveldb/include -DUSE_CRYPTOPP -D__STDC_LIMIT_MACROS -O2 -pipe -fPIC -c EncryptionUtils.cpp
make -C cryptopp libcryptopp.a
make[2]: Entering directory '/home/pi/armory/BitcoinArmory/cppForSwig/cryptopp'
g++ -DNDEBUG -O -g0 -native -template=no%extdef  -c rc6.cpp
g++: error: unrecognized option ‘-native’
g++: error: unrecognized option ‘-template=no%extdef’
Makefile:197: recipe for target 'rc6.o' failed
make[2]: *** [rc6.o] Error 1
make[2]: Leaving directory '/home/pi/armory/BitcoinArmory/cppForSwig/cryptopp'
Makefile:53: recipe for target 'libcryptopp.a' failed
make[1]: *** [libcryptopp.a] Error 2
make[1]: Leaving directory '/home/pi/armory/BitcoinArmory/cppForSwig'
Makefile:8: recipe for target 'all' failed
make: *** [all] Error 2

I then followed this with installing libcrypto++-dev

Code:
pi@raspberrypi ~/armory/BitcoinArmory $ python ArmoryQt.py
Traceback (most recent call last):
  File "ArmoryQt.py", line 34, in <module>
    import CppBlockUtils as Cpp
ImportError: No module named CppBlockUtils
pi@raspberrypi ~/armory/BitcoinArmory $ sudo apt-get install libcrypto++-dev
Reading package lists... Done
Building dependency tree      
Reading state information... Done
The following extra packages will be installed:
  libcrypto++9
The following NEW packages will be installed:
  libcrypto++-dev libcrypto++9
0 upgraded, 2 newly installed, 0 to remove and 0 not upgraded.
Need to get 4,514 kB of archives.
After this operation, 22.3 MB of additional disk space will be used.
Do you want to continue [Y/n]? y
Get:1 http://mirrordirector.raspbian.org/raspbian/ wheezy/main libcrypto++9 armhf 5.6.1-6 [1,203 kB]
Get:2 http://mirrordirector.raspbian.org/raspbian/ wheezy/main libcrypto++-dev armhf 5.6.1-6 [3,311 kB]
Fetched 4,514 kB in 8s (558 kB/s)                                                                                                                                                                                                    
Selecting previously unselected package libcrypto++9.
(Reading database ... 87606 files and directories currently installed.)
Unpacking libcrypto++9 (from .../libcrypto++9_5.6.1-6_armhf.deb) ...
Selecting previously unselected package libcrypto++-dev.
Unpacking libcrypto++-dev (from .../libcrypto++-dev_5.6.1-6_armhf.deb) ...
Setting up libcrypto++9 (5.6.1-6) ...
Setting up libcrypto++-dev (5.6.1-6) ...
pi@raspberrypi ~/armory/BitcoinArmory $ make
make -C cppForSwig
make[1]: Entering directory '/home/pi/armory/BitcoinArmory/cppForSwig'
make -C cryptopp libcryptopp.a
make[2]: Entering directory '/home/pi/armory/BitcoinArmory/cppForSwig/cryptopp'
g++ -DNDEBUG -O -g0 -native -template=no%extdef  -c rc6.cpp
g++: error: unrecognized option ‘-native’
g++: error: unrecognized option ‘-template=no%extdef’
Makefile:197: recipe for target 'rc6.o' failed
make[2]: *** [rc6.o] Error 1
make[2]: Leaving directory '/home/pi/armory/BitcoinArmory/cppForSwig/cryptopp'
Makefile:53: recipe for target 'libcryptopp.a' failed
make[1]: *** [libcryptopp.a] Error 2
make[1]: Leaving directory '/home/pi/armory/BitcoinArmory/cppForSwig'
Makefile:8: recipe for target 'all' failed
make: *** [all] Error 2
pi@raspberrypi ~/armory/BitcoinArmory $ python ArmoryQt.py
Traceback (most recent call last):
  File "ArmoryQt.py", line 34, in <module>
    import CppBlockUtils as Cpp
ImportError: No module named CppBlockUtils

Prior to all the above steps, I installed the Pi offline bundle armory_0.92.3_rpi_bundle.tar.gz which appeared to install correctly, but would not run.  After running the installation above, the downloaded binary works fine, even though the make failed.  I don't know if the binary just needed libcrypto++ to work
Pages: [1]
  Print  
 
Jump to:  

Sponsored by , a Bitcoin-accepting VPN.
Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2006-2009, Simple Machines Valid XHTML 1.0! Valid CSS!